netifd: update to the latest version, reverts a commit causing MTU issues (fixes #18869)

Signed-off-by: Felix Fietkau <nbd@openwrt.org>

SVN-Revision: 44461
This commit is contained in:
Felix Fietkau 2015-02-16 09:07:19 +00:00
parent dd41c1927c
commit 00d422fc60
2 changed files with 2 additions and 13 deletions

View File

@ -1,13 +1,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=netifd
PKG_VERSION:=2015-02-09
PKG_VERSION:=2015-02-16
PKG_RELEASE=$(PKG_SOURCE_VERSION)
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=http://git.openwrt.org/project/netifd.git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE_VERSION:=2dae3867c8730e194c036a7827b0322726adf81a
PKG_SOURCE_VERSION:=2d09cca0e90127d33eed43b8790f5778ba3b943f
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
# PKG_MIRROR_MD5SUM:=

View File

@ -1,11 +0,0 @@
diff -urN netifd-2012-10-29/utils.c netifd-2012-10-29.new/utils.c
--- netifd-2012-10-29/utils.c 2012-11-23 17:15:39.000000000 +0100
+++ netifd-2012-10-29.new/utils.c 2012-11-23 17:16:53.409244361 +0100
@@ -17,6 +17,7 @@
#include <arpa/inet.h>
#include <netinet/in.h>
+#include <sys/socket.h>
void
__vlist_simple_init(struct vlist_simple_tree *tree, int offset)