ar71xx: Add Support for the Bitmain Antminer S3
This patch adds support for the Bitmain Antminer S3 Cryptocurrency Miner http://wiki.openwrt.org/toh/bitmain/s3 Signed-off-by: L. D. Pinney <ldpinney@gmail.com> SVN-Revision: 46236
This commit is contained in:
parent
9f2b8b3902
commit
055663201b
@ -12,7 +12,8 @@ get_status_led() {
|
||||
all0305)
|
||||
status_led="eap7660d:green:ds4"
|
||||
;;
|
||||
antminer-s1)
|
||||
antminer-s1|\
|
||||
antminer-s3)
|
||||
status_led="bitmain:green:system"
|
||||
;;
|
||||
ap132)
|
||||
|
@ -36,6 +36,12 @@ antminer-s1)
|
||||
ucidef_set_led_wlan "wlan" "WLAN" "bitmain:green:wlan" "phy0tpt"
|
||||
;;
|
||||
|
||||
antminer-s3)
|
||||
ucidef_set_led_wlan "wlan" "WLAN" "bitmain:green:wlan" "phy0tpt"
|
||||
ucidef_set_led_default "sys" "SYS" "bitmain:green:sys" "0"
|
||||
ucidef_set_led_default "lan" "LAN" "bitmain:yellow:lan" "0"
|
||||
;;
|
||||
|
||||
ap113)
|
||||
ucidef_set_led_usbdev "usb" "USB" "ap113:green:usb" "1-1"
|
||||
;;
|
||||
|
@ -346,6 +346,7 @@ wp543)
|
||||
;;
|
||||
|
||||
antminer-s1 |\
|
||||
antminer-s3 |\
|
||||
dir-505-a1)
|
||||
ucidef_set_interface_lan "eth1"
|
||||
;;
|
||||
|
@ -110,6 +110,9 @@ tplink_board_detect() {
|
||||
"04440001"*)
|
||||
model="BITMAIN ANTMINER S1"
|
||||
;;
|
||||
"04440003"*)
|
||||
model="BITMAIN ANTMINER S3"
|
||||
;;
|
||||
"120000"*)
|
||||
model="MERCURY MAC1200R"
|
||||
;;
|
||||
|
@ -302,6 +302,7 @@ platform_check_image() {
|
||||
;;
|
||||
|
||||
antminer-s1 | \
|
||||
antminer-s3 | \
|
||||
archer-c5 | \
|
||||
archer-c7 | \
|
||||
el-m150 | \
|
||||
|
@ -42,6 +42,7 @@ CONFIG_ATH79_MACH_AP96=y
|
||||
CONFIG_ATH79_MACH_ARCHER_C7=y
|
||||
CONFIG_ATH79_MACH_AW_NR580=y
|
||||
CONFIG_ATH79_MACH_ANTMINER_S1=y
|
||||
CONFIG_ATH79_MACH_ANTMINER_S3=y
|
||||
CONFIG_ATH79_MACH_BHU_BXU2000N2_A=y
|
||||
CONFIG_ATH79_MACH_CAP4200AG=y
|
||||
CONFIG_ATH79_MACH_CARAMBOLA2=y
|
||||
|
98
target/linux/ar71xx/files/arch/mips/ath79/mach-antminer-s3.c
Normal file
98
target/linux/ar71xx/files/arch/mips/ath79/mach-antminer-s3.c
Normal file
@ -0,0 +1,98 @@
|
||||
/*
|
||||
* Bitmain Antminer S3 board support
|
||||
*
|
||||
* Copyright (C) 2015 L. D. Pinney <ldpinney@gmail.com>
|
||||
*
|
||||
* This program is free software; you can redistribute it and/or modify it
|
||||
* under the terms of the GNU General Public License version 2 as published
|
||||
* by the Free Software Foundation.
|
||||
*/
|
||||
|
||||
#include <linux/gpio.h>
|
||||
|
||||
#include <asm/mach-ath79/ath79.h>
|
||||
#include <asm/mach-ath79/ar71xx_regs.h>
|
||||
|
||||
#include "common.h"
|
||||
#include "dev-eth.h"
|
||||
#include "dev-gpio-buttons.h"
|
||||
#include "dev-leds-gpio.h"
|
||||
#include "dev-m25p80.h"
|
||||
#include "dev-wmac.h"
|
||||
#include "machtypes.h"
|
||||
#include "dev-usb.h"
|
||||
|
||||
#define ANTMINER_S3_GPIO_LED_WLAN 0
|
||||
#define ANTMINER_S3_GPIO_LED_SYSTEM 17
|
||||
#define ANTMINER_S3_GPIO_LED_LAN 22
|
||||
|
||||
#define ANTMINER_S3_GPIO_BTN_RESET 11
|
||||
|
||||
#define ANTMINER_S3_KEYSPOLL_INTERVAL 88 /* msecs */
|
||||
#define ANTMINER_S3_KEYSDEBOUNCE_INTERVAL (3 * ANTMINER_S3_KEYSPOLL_INTERVAL)
|
||||
|
||||
static const char *ANTMINER_S3_part_probes[] = {
|
||||
"tp-link",
|
||||
NULL,
|
||||
};
|
||||
|
||||
static struct flash_platform_data ANTMINER_S3_flash_data = {
|
||||
.part_probes = ANTMINER_S3_part_probes,
|
||||
};
|
||||
|
||||
static struct gpio_led ANTMINER_S3_leds_gpio[] __initdata = {
|
||||
{
|
||||
.name = "bitmain:green:wlan",
|
||||
.gpio = ANTMINER_S3_GPIO_LED_WLAN,
|
||||
.active_low = 0,
|
||||
},{
|
||||
.name = "bitmain:green:system",
|
||||
.gpio = ANTMINER_S3_GPIO_LED_SYSTEM,
|
||||
.active_low = 0,
|
||||
},{
|
||||
.name = "bitmain:yellow:lan",
|
||||
.gpio = ANTMINER_S3_GPIO_LED_LAN,
|
||||
.active_low = 0,
|
||||
},
|
||||
};
|
||||
|
||||
static struct gpio_keys_button ANTMINER_S3_GPIO_keys[] __initdata = {
|
||||
{
|
||||
.desc = "reset",
|
||||
.type = EV_KEY,
|
||||
.code = KEY_RESTART,
|
||||
.debounce_interval = ANTMINER_S3_KEYSDEBOUNCE_INTERVAL,
|
||||
.gpio = ANTMINER_S3_GPIO_BTN_RESET,
|
||||
.active_low = 0,
|
||||
},
|
||||
};
|
||||
|
||||
static void __init antminer_s3_setup(void)
|
||||
{
|
||||
u8 *mac = (u8 *) KSEG1ADDR(0x1f01fc00);
|
||||
u8 *ee = (u8 *) KSEG1ADDR(0x1fff1000);
|
||||
|
||||
/* disable PHY_SWAP and PHY_ADDR_SWAP bits */
|
||||
ath79_setup_ar933x_phy4_switch(false, false);
|
||||
|
||||
ath79_register_leds_gpio(-1, ARRAY_SIZE(ANTMINER_S3_leds_gpio),
|
||||
ANTMINER_S3_leds_gpio);
|
||||
|
||||
ath79_register_gpio_keys_polled(-1, ANTMINER_S3_KEYSPOLL_INTERVAL,
|
||||
ARRAY_SIZE(ANTMINER_S3_GPIO_keys),
|
||||
ANTMINER_S3_GPIO_keys);
|
||||
ath79_register_usb();
|
||||
|
||||
ath79_register_m25p80(&ANTMINER_S3_flash_data);
|
||||
ath79_init_mac(ath79_eth0_data.mac_addr, mac, 1);
|
||||
ath79_init_mac(ath79_eth1_data.mac_addr, mac, -1);
|
||||
|
||||
ath79_register_mdio(0, 0x0);
|
||||
ath79_register_eth(0);
|
||||
ath79_register_eth(1);
|
||||
|
||||
ath79_register_wmac(ee, mac);
|
||||
}
|
||||
|
||||
MIPS_MACHINE(ATH79_MACH_ANTMINER_S3, "ANTMINER-S3",
|
||||
"Bitmain Antminer S3", antminer_s3_setup);
|
@ -15,3 +15,14 @@ define Profile/ANTMINER_S1/Description
|
||||
Package set optimized for the Bitmain Antminer S1.
|
||||
endef
|
||||
$(eval $(call Profile,ANTMINER_S1))
|
||||
|
||||
define Profile/ANTMINER_S3
|
||||
NAME:=Antminer S3
|
||||
PACKAGES:=kmod-usb-core kmod-usb2 kmod-crypto-manager kmod-i2c-gpio-custom kmod-usb-hid
|
||||
endef
|
||||
|
||||
|
||||
define Profile/ANTMINER_S1/Description
|
||||
Package set optimized for the Bitmain Antminer S3.
|
||||
endef
|
||||
$(eval $(call Profile,ANTMINER_S3))
|
||||
|
@ -338,6 +338,14 @@ define Device/antminer-s1
|
||||
CONSOLE := ttyATH0,115200
|
||||
endef
|
||||
|
||||
define Device/antminer-s3
|
||||
$(Device/tplink-8mlzma)
|
||||
BOARDNAME := ANTMINER-S3
|
||||
DEVICE_PROFILE := ANTMINER_S3
|
||||
TPLINK_HWID := 0x04440003
|
||||
CONSOLE := ttyATH0,115200
|
||||
endef
|
||||
|
||||
define Device/el-m150
|
||||
$(Device/tplink-8mlzma)
|
||||
BOARDNAME := EL-M150
|
||||
@ -353,7 +361,7 @@ define Device/el-mini
|
||||
TPLINK_HWID := 0x01530001
|
||||
CONSOLE := ttyATH0,115200
|
||||
endef
|
||||
TARGET_DEVICES += antminer-s1 el-m150 el-mini
|
||||
TARGET_DEVICES += antminer-s1 antminer-s3 el-m150 el-mini
|
||||
|
||||
define Device/gl-inet-6408A-v1
|
||||
$(Device/tplink-8mlzma)
|
||||
|
@ -0,0 +1,39 @@
|
||||
--- a/arch/mips/ath79/machtypes.h
|
||||
+++ b/arch/mips/ath79/machtypes.h
|
||||
@@ -22,6 +21,7 @@
|
||||
ATH79_MACH_ALL0305, /* Allnet ALL0305 */
|
||||
ATH79_MACH_ALL0315N, /* Allnet ALL0315N */
|
||||
ATH79_MACH_ANTMINER_S1, /* Bitmain Antminer S1 */
|
||||
+ ATH79_MACH_ANTMINER_S3, /* Bitmain Antminer S3 */
|
||||
ATH79_MACH_AP113, /* Atheros AP113 reference board */
|
||||
ATH79_MACH_AP121, /* Atheros AP121 reference board */
|
||||
ATH79_MACH_AP121_MINI, /* Atheros AP121-MINI reference board */
|
||||
--- a/arch/mips/ath79/Kconfig
|
||||
+++ b/arch/mips/ath79/Kconfig
|
||||
@@ -66,6 +66,16 @@
|
||||
select ATH79_DEV_USB
|
||||
select ATH79_DEV_WMAC
|
||||
|
||||
+config ATH79_MACH_ANTMINER_S3
|
||||
+ bool "Bitmain Antminer S3 support"
|
||||
+ select SOC_AR933X
|
||||
+ select ATH79_DEV_ETH
|
||||
+ select ATH79_DEV_GPIO_BUTTONS
|
||||
+ select ATH79_DEV_LEDS_GPIO
|
||||
+ select ATH79_DEV_M25P80
|
||||
+ select ATH79_DEV_USB
|
||||
+ select ATH79_DEV_WMAC
|
||||
+
|
||||
config ATH79_MACH_AP113
|
||||
bool "Atheros AP113 board support"
|
||||
select SOC_AR724X
|
||||
--- a/arch/mips/ath79/Makefile
|
||||
+++ b/arch/mips/ath79/Makefile
|
||||
@@ -43,6 +43,7 @@
|
||||
obj-$(CONFIG_ATH79_MACH_ALL0258N) += mach-all0258n.o
|
||||
obj-$(CONFIG_ATH79_MACH_ALL0315N) += mach-all0315n.o
|
||||
obj-$(CONFIG_ATH79_MACH_ANTMINER_S1)+= mach-antminer-s1.o
|
||||
+obj-$(CONFIG_ATH79_MACH_ANTMINER_S3)+= mach-antminer-s3.o
|
||||
obj-$(CONFIG_ATH79_MACH_AP113) += mach-ap113.o
|
||||
obj-$(CONFIG_ATH79_MACH_AP121) += mach-ap121.o
|
||||
obj-$(CONFIG_ATH79_MACH_AP132) += mach-ap132.o
|
@ -31,6 +31,7 @@
|
||||
|
||||
#define HEADER_VERSION_V1 0x01000000
|
||||
#define HWID_ANTMINER_S1 0x04440001
|
||||
#define HWID_ANTMINER_S3 0x04440003
|
||||
#define HWID_GL_INET_V1 0x08000001
|
||||
#define HWID_GS_OOLITE_V1 0x3C000101
|
||||
#define HWID_TL_MR10U_V1 0x00100101
|
||||
|
Loading…
Reference in New Issue
Block a user