Update compat-wireless to 2009-06-25
SVN-Revision: 16561
This commit is contained in:
parent
6cebdff1cd
commit
098c284c6b
@ -17,12 +17,12 @@ ifneq ($(CONFIG_LINUX_2_6_21)$(CONFIG_LINUX_2_6_23)$(CONFIG_LINUX_2_6_24)$(CONFI
|
||||
PKG_MD5SUM:=9563ceeed86bca0859ad5f010623277c
|
||||
PATCH_DIR:=./patches-old
|
||||
else
|
||||
PKG_VERSION:=2009-06-02
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=2009-06-25
|
||||
PKG_RELEASE:=1
|
||||
PKG_SOURCE_URL:= \
|
||||
http://www.orbit-lab.org/kernel/compat-wireless-2.6/2009/06 \
|
||||
http://wireless.kernel.org/download/compat-wireless-2.6
|
||||
PKG_MD5SUM:=2209c48613e69c08436cfd7dd3b10893
|
||||
PKG_MD5SUM:=e76d2580436069e2b44f0f57db790bfe
|
||||
endif
|
||||
|
||||
PKG_SOURCE:=compat-wireless-$(PKG_VERSION).tar.bz2
|
||||
|
@ -1,7 +1,7 @@
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -20,8 +20,7 @@ NOSTDINC_FLAGS := -I$(M)/include/ -inclu
|
||||
obj-y := net/wireless/ net/mac80211/
|
||||
obj-y := net/wireless/ net/mac80211/ net/rfkill/
|
||||
ifeq ($(ONLY_CORE),)
|
||||
obj-$(CONFIG_B44) += drivers/net/b44.o
|
||||
-obj-y += drivers/ssb/ \
|
||||
|
@ -15,16 +15,23 @@
|
||||
# CONFIG_LIB80211_DEBUG=y
|
||||
|
||||
CONFIG_WIRELESS_OLD_REGULATORY=n
|
||||
@@ -127,56 +127,56 @@ CONFIG_ATH9K=m
|
||||
@@ -123,61 +123,61 @@ ifneq ($(CONFIG_PCI),)
|
||||
|
||||
CONFIG_ATH5K=m
|
||||
# CONFIG_ATH5K_DEBUG=y
|
||||
-CONFIG_ATH5K_RFKILL=y
|
||||
+# CONFIG_ATH5K_RFKILL=y
|
||||
CONFIG_ATH9K=m
|
||||
# CONFIG_ATH9K_DEBUG=y
|
||||
|
||||
|
||||
-CONFIG_IWLWIFI=m
|
||||
-CONFIG_IWLWIFI_LEDS=y
|
||||
-CONFIG_IWLWIFI_RFKILL=y
|
||||
-CONFIG_IWLWIFI_SPECTRUM_MEASUREMENT=y
|
||||
+# CONFIG_IWLWIFI=m
|
||||
+# CONFIG_IWLWIFI_LEDS=y
|
||||
# CONFIG_IWLWIFI_RFKILL=y
|
||||
-CONFIG_IWLWIFI_SPECTRUM_MEASUREMENT=y
|
||||
+# CONFIG_IWLWIFI_RFKILL=y
|
||||
+# CONFIG_IWLWIFI_SPECTRUM_MEASUREMENT=y
|
||||
# CONFIG_IWLWIFI_DEBUG=y
|
||||
# CONFIG_IWLWIFI_DEBUGFS=y
|
||||
@ -47,6 +54,7 @@
|
||||
-CONFIG_B43_PCMCIA=y
|
||||
-CONFIG_B43_PIO=y
|
||||
-CONFIG_B43_LEDS=y
|
||||
-CONFIG_B43_RFKILL=y
|
||||
+# CONFIG_B43=m
|
||||
+# CONFIG_B43_HWRNG=y
|
||||
+# CONFIG_B43_PCI_AUTOSELECT=y
|
||||
@ -54,7 +62,7 @@
|
||||
+# CONFIG_B43_PCMCIA=y
|
||||
+# CONFIG_B43_PIO=y
|
||||
+# CONFIG_B43_LEDS=y
|
||||
# CONFIG_B43_RFKILL=y
|
||||
+# CONFIG_B43_RFKILL=y
|
||||
# CONFIG_B43_DEBUG=y
|
||||
# CONFIG_B43_FORCE_PIO=y
|
||||
|
||||
@ -63,12 +71,13 @@
|
||||
-CONFIG_B43LEGACY_PCI_AUTOSELECT=y
|
||||
-CONFIG_B43LEGACY_PCICORE_AUTOSELECT=y
|
||||
-CONFIG_B43LEGACY_LEDS=y
|
||||
-CONFIG_B43LEGACY_RFKILL=y
|
||||
+# CONFIG_B43LEGACY=m
|
||||
+# CONFIG_B43LEGACY_HWRNG=y
|
||||
+# CONFIG_B43LEGACY_PCI_AUTOSELECT=y
|
||||
+# CONFIG_B43LEGACY_PCICORE_AUTOSELECT=y
|
||||
+# CONFIG_B43LEGACY_LEDS=y
|
||||
# CONFIG_B43LEGACY_RFKILL=y
|
||||
+# CONFIG_B43LEGACY_RFKILL=y
|
||||
# CONFIG_B43LEGACY_DEBUG=y
|
||||
CONFIG_B43LEGACY_DMA=y
|
||||
-CONFIG_B43LEGACY_PIO=y
|
||||
@ -103,7 +112,7 @@
|
||||
# CONFIG_IPW2200_DEBUG=y
|
||||
# The above enables use a second interface prefixed 'rtap'.
|
||||
# Example usage:
|
||||
@@ -191,27 +191,27 @@ CONFIG_IPW2200_QOS=y
|
||||
@@ -192,27 +192,27 @@ CONFIG_IPW2200_QOS=y
|
||||
#
|
||||
# % echo 1 > /sys/bus/pci/drivers/ipw2200/*/rtap_iface
|
||||
|
||||
@ -145,7 +154,7 @@
|
||||
|
||||
CONFIG_RT2X00_LIB_PCI=m
|
||||
CONFIG_RT2400PCI=m
|
||||
@@ -227,24 +227,24 @@ CONFIG_RT61PCI=m
|
||||
@@ -228,24 +228,24 @@ CONFIG_RT61PCI=m
|
||||
NEED_RT2X00_FIRMWARE=y
|
||||
endif
|
||||
|
||||
@ -176,7 +185,7 @@
|
||||
|
||||
# USB Drivers
|
||||
ifneq ($(CONFIG_USB),)
|
||||
@@ -258,21 +258,21 @@ CONFIG_ZD1211RW=m
|
||||
@@ -259,21 +259,21 @@ CONFIG_ZD1211RW=m
|
||||
# is only wireless RNDIS chip known to date.
|
||||
# Note: this depends on CONFIG_USB_NET_RNDIS_HOST and CONFIG_USB_NET_CDCETHER
|
||||
# it also requires new RNDIS_HOST and CDC_ETHER modules which we add
|
||||
@ -204,7 +213,7 @@
|
||||
endif
|
||||
|
||||
# RT2500USB does not require firmware
|
||||
@@ -286,24 +286,24 @@ CONFIG_RT73USB=m
|
||||
@@ -287,30 +287,30 @@ CONFIG_RT73USB=m
|
||||
NEED_RT2X00_FIRMWARE=y
|
||||
endif
|
||||
|
||||
@ -219,10 +228,12 @@
|
||||
|
||||
ifneq ($(CONFIG_SPI_MASTER),)
|
||||
|
||||
-CONFIG_WL12XX=m
|
||||
-CONFIG_WL1251=m
|
||||
-CONFIG_P54_SPI=m
|
||||
-CONFIG_LIBERTAS_SPI=m
|
||||
-NEED_LIBERTAS=y
|
||||
+# CONFIG_WL12XX=m
|
||||
+# CONFIG_WL1251=m
|
||||
+# CONFIG_P54_SPI=m
|
||||
+# CONFIG_LIBERTAS_SPI=m
|
||||
+# NEED_LIBERTAS=y
|
||||
|
||||
@ -235,10 +246,29 @@
|
||||
+# CONFIG_LIBERTAS_SDIO=m
|
||||
+# NEED_LIBERTAS=y
|
||||
|
||||
endif # end of SDIO driver list
|
||||
# Activate iwmc3200wifi support only on kernel >= 2.6.29.
|
||||
# iwmc3200wifi uses new netdev_ops api no supported by old kernel.
|
||||
ifeq ($(shell test $(KERNEL_SUBLEVEL) -ge 29 && echo yes),yes)
|
||||
-CONFIG_IWM=m
|
||||
+# CONFIG_IWM=m
|
||||
# CONFIG_IWM_DEBUG=y
|
||||
endif
|
||||
|
||||
@@ -333,13 +333,13 @@ CONFIG_ATH_COMMON=m
|
||||
@@ -323,7 +323,7 @@ CONFIG_RT2X00_LIB=m
|
||||
CONFIG_RT2X00_LIB_HT=y
|
||||
CONFIG_RT2X00_LIB_FIRMWARE=y
|
||||
CONFIG_RT2X00_LIB_CRYPTO=y
|
||||
-CONFIG_RT2X00_LIB_RFKILL=y
|
||||
+# CONFIG_RT2X00_LIB_RFKILL=y
|
||||
CONFIG_RT2X00_LIB_LEDS=y
|
||||
# CONFIG_RT2X00_LIB_DEBUGFS=y
|
||||
# CONFIG_RT2X00_DEBUG=y
|
||||
@@ -340,25 +340,25 @@ CONFIG_P54_LEDS=y
|
||||
# Atheros
|
||||
CONFIG_ATH_COMMON=m
|
||||
|
||||
-CONFIG_WL12XX=y
|
||||
+# CONFIG_WL12XX=y
|
||||
|
||||
# Sonics Silicon Backplane
|
||||
-CONFIG_SSB_POSSIBLE=y
|
||||
@ -251,7 +281,20 @@
|
||||
|
||||
ifeq ($(NEED_LIBERTAS),y)
|
||||
-CONFIG_LIBERTAS_THINFIRM=m
|
||||
-CONFIG_LIBERTAS=m
|
||||
+# CONFIG_LIBERTAS_THINFIRM=m
|
||||
CONFIG_LIBERTAS=m
|
||||
+# CONFIG_LIBERTAS=m
|
||||
# CONFIG_LIBERTAS_DEBUG=y
|
||||
endif
|
||||
|
||||
# We need the backported rfkill module on kernel < 2.6.31.
|
||||
# In more recent kernel versions use the in kernel rfkill module.
|
||||
ifeq ($(shell test $(KERNEL_SUBLEVEL) -le 30 && echo yes),yes)
|
||||
-CONFIG_RFKILL_BACKPORT=m
|
||||
-CONFIG_RFKILL_BACKPORT_LEDS=y
|
||||
-CONFIG_RFKILL_BACKPORT_INPUT=y
|
||||
+# CONFIG_RFKILL_BACKPORT=m
|
||||
+# CONFIG_RFKILL_BACKPORT_LEDS=y
|
||||
+# CONFIG_RFKILL_BACKPORT_INPUT=y
|
||||
endif
|
||||
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- a/drivers/net/wireless/ath/ath5k/reset.c
|
||||
+++ b/drivers/net/wireless/ath/ath5k/reset.c
|
||||
@@ -1297,8 +1297,14 @@ int ath5k_hw_reset(struct ath5k_hw *ah,
|
||||
@@ -1296,8 +1296,14 @@ int ath5k_hw_reset(struct ath5k_hw *ah,
|
||||
if (ah->ah_version != AR5K_AR5210) {
|
||||
AR5K_REG_WRITE_BITS(ah, AR5K_TXCFG,
|
||||
AR5K_TXCFG_SDMAMR, AR5K_DMASIZE_128B);
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- a/drivers/net/wireless/ath/ath9k/main.c
|
||||
+++ b/drivers/net/wireless/ath/ath9k/main.c
|
||||
@@ -1041,6 +1041,9 @@ static void ath_unregister_led(struct at
|
||||
@@ -1057,6 +1057,9 @@ static void ath_unregister_led(struct at
|
||||
|
||||
static void ath_deinit_leds(struct ath_softc *sc)
|
||||
{
|
||||
@ -10,7 +10,7 @@
|
||||
cancel_delayed_work_sync(&sc->ath_led_blink_work);
|
||||
ath_unregister_led(&sc->assoc_led);
|
||||
sc->sc_flags &= ~SC_OP_LED_ASSOCIATED;
|
||||
@@ -1055,6 +1058,9 @@ static void ath_init_leds(struct ath_sof
|
||||
@@ -1071,6 +1074,9 @@ static void ath_init_leds(struct ath_sof
|
||||
char *trigger;
|
||||
int ret;
|
||||
|
||||
|
@ -1,8 +1,8 @@
|
||||
--- a/config.mk
|
||||
+++ b/config.mk
|
||||
@@ -124,7 +124,7 @@ ifneq ($(CONFIG_PCI),)
|
||||
CONFIG_ATH5K=m
|
||||
@@ -125,7 +125,7 @@ CONFIG_ATH5K=m
|
||||
# CONFIG_ATH5K_DEBUG=y
|
||||
# CONFIG_ATH5K_RFKILL=y
|
||||
CONFIG_ATH9K=m
|
||||
-# CONFIG_ATH9K_DEBUG=y
|
||||
+CONFIG_ATH9K_DEBUG=y
|
||||
|
@ -1,198 +0,0 @@
|
||||
Completely untested patch to implement firmware capabilities
|
||||
and automagic QoS-disabling.
|
||||
|
||||
|
||||
--- a/drivers/net/wireless/b43/b43.h
|
||||
+++ b/drivers/net/wireless/b43/b43.h
|
||||
@@ -163,6 +163,7 @@ enum {
|
||||
#define B43_SHM_SH_WLCOREREV 0x0016 /* 802.11 core revision */
|
||||
#define B43_SHM_SH_PCTLWDPOS 0x0008
|
||||
#define B43_SHM_SH_RXPADOFF 0x0034 /* RX Padding data offset (PIO only) */
|
||||
+#define B43_SHM_SH_FWCAPA 0x0042 /* Firmware capabilities (Opensource firmware only) */
|
||||
#define B43_SHM_SH_PHYVER 0x0050 /* PHY version */
|
||||
#define B43_SHM_SH_PHYTYPE 0x0052 /* PHY type */
|
||||
#define B43_SHM_SH_ANTSWAP 0x005C /* Antenna swap threshold */
|
||||
@@ -297,6 +298,10 @@ enum {
|
||||
#define B43_HF_MLADVW 0x001000000000ULL /* N PHY ML ADV workaround (rev >= 13 only) */
|
||||
#define B43_HF_PR45960W 0x080000000000ULL /* PR 45960 workaround (rev >= 13 only) */
|
||||
|
||||
+/* Firmware capabilities field in SHM (Opensource firmware only) */
|
||||
+#define B43_FWCAPA_HWCRYPTO 0x0001
|
||||
+#define B43_FWCAPA_QOS 0x0002
|
||||
+
|
||||
/* MacFilter offsets. */
|
||||
#define B43_MACFILTER_SELF 0x0000
|
||||
#define B43_MACFILTER_BSSID 0x0003
|
||||
@@ -596,6 +601,13 @@ struct b43_wl {
|
||||
/* Pointer to the ieee80211 hardware data structure */
|
||||
struct ieee80211_hw *hw;
|
||||
|
||||
+ /* The number of queues that were registered with the mac80211 subsystem
|
||||
+ * initially. This is a backup copy of hw->queues in case hw->queues has
|
||||
+ * to be dynamically lowered at runtime (Firmware does not support QoS).
|
||||
+ * hw->queues has to be restored to the original value before unregistering
|
||||
+ * from the mac80211 subsystem. */
|
||||
+ u16 mac80211_initially_registered_queues;
|
||||
+
|
||||
struct mutex mutex;
|
||||
spinlock_t irq_lock;
|
||||
/* R/W lock for data transmission.
|
||||
@@ -752,6 +764,8 @@ struct b43_wldev {
|
||||
bool dfq_valid; /* Directed frame queue valid (IBSS PS mode, ATIM) */
|
||||
bool radio_hw_enable; /* saved state of radio hardware enabled state */
|
||||
bool suspend_in_progress; /* TRUE, if we are in a suspend/resume cycle */
|
||||
+ bool qos_enabled; /* TRUE, if QoS is used. */
|
||||
+ bool hwcrypto_enabled; /* TRUE, if HW crypto acceleration is enabled. */
|
||||
|
||||
/* PHY/Radio device. */
|
||||
struct b43_phy phy;
|
||||
--- a/drivers/net/wireless/b43/dma.c
|
||||
+++ b/drivers/net/wireless/b43/dma.c
|
||||
@@ -1285,7 +1285,7 @@ static struct b43_dmaring *select_ring_b
|
||||
{
|
||||
struct b43_dmaring *ring;
|
||||
|
||||
- if (b43_modparam_qos) {
|
||||
+ if (dev->qos_enabled) {
|
||||
/* 0 = highest priority */
|
||||
switch (queue_prio) {
|
||||
default:
|
||||
--- a/drivers/net/wireless/b43/main.c
|
||||
+++ b/drivers/net/wireless/b43/main.c
|
||||
@@ -80,8 +80,8 @@ static int modparam_nohwcrypt;
|
||||
module_param_named(nohwcrypt, modparam_nohwcrypt, int, 0444);
|
||||
MODULE_PARM_DESC(nohwcrypt, "Disable hardware encryption.");
|
||||
|
||||
-int b43_modparam_qos = 1;
|
||||
-module_param_named(qos, b43_modparam_qos, int, 0444);
|
||||
+static int modparam_qos = 1;
|
||||
+module_param_named(qos, modparam_qos, int, 0444);
|
||||
MODULE_PARM_DESC(qos, "Enable QOS support (default on)");
|
||||
|
||||
static int modparam_btcoex = 1;
|
||||
@@ -538,6 +538,13 @@ void b43_hf_write(struct b43_wldev *dev,
|
||||
b43_shm_write16(dev, B43_SHM_SHARED, B43_SHM_SH_HOSTFHI, hi);
|
||||
}
|
||||
|
||||
+/* Read the firmware capabilities bitmask (Opensource firmware only) */
|
||||
+static u16 b43_fwcapa_read(struct b43_wldev *dev)
|
||||
+{
|
||||
+ B43_WARN_ON(!dev->fw.opensource);
|
||||
+ return b43_shm_read16(dev, B43_SHM_SHARED, B43_SHM_SH_FWCAPA);
|
||||
+}
|
||||
+
|
||||
void b43_tsf_read(struct b43_wldev *dev, u64 *tsf)
|
||||
{
|
||||
u32 low, high;
|
||||
@@ -2307,12 +2314,34 @@ static int b43_upload_microcode(struct b
|
||||
dev->fw.patch = fwpatch;
|
||||
dev->fw.opensource = (fwdate == 0xFFFF);
|
||||
|
||||
+ /* Default to use-all-queues. */
|
||||
+ dev->wl->hw->queues = dev->wl->mac80211_initially_registered_queues;
|
||||
+ dev->qos_enabled = !!modparam_qos;
|
||||
+ /* Default to firmware/hardware crypto acceleration. */
|
||||
+ dev->hwcrypto_enabled = 1;
|
||||
+
|
||||
if (dev->fw.opensource) {
|
||||
+ u16 fwcapa;
|
||||
+
|
||||
/* Patchlevel info is encoded in the "time" field. */
|
||||
dev->fw.patch = fwtime;
|
||||
- b43info(dev->wl, "Loading OpenSource firmware version %u.%u%s\n",
|
||||
- dev->fw.rev, dev->fw.patch,
|
||||
- dev->fw.pcm_request_failed ? " (Hardware crypto not supported)" : "");
|
||||
+ b43info(dev->wl, "Loading OpenSource firmware version %u.%u\n",
|
||||
+ dev->fw.rev, dev->fw.patch);
|
||||
+
|
||||
+ fwcapa = b43_fwcapa_read(dev);
|
||||
+ if (!(fwcapa & B43_FWCAPA_HWCRYPTO) || dev->fw.pcm_request_failed) {
|
||||
+ b43info(dev->wl, "Hardware crypto acceleration not supported by firmware\n");
|
||||
+ /* Disable hardware crypto and fall back to software crypto. */
|
||||
+ dev->hwcrypto_enabled = 0;
|
||||
+ }
|
||||
+ if (!(fwcapa & B43_FWCAPA_QOS)) {
|
||||
+ b43info(dev->wl, "QoS not supported by firmware\n");
|
||||
+ /* Disable QoS. Tweak hw->queues to 1. It will be restored before
|
||||
+ * ieee80211_unregister to make sure the networking core can
|
||||
+ * properly free possible resources. */
|
||||
+ dev->wl->hw->queues = 1;
|
||||
+ dev->qos_enabled = 0;
|
||||
+ }
|
||||
} else {
|
||||
b43info(dev->wl, "Loading firmware version %u.%u "
|
||||
"(20%.2i-%.2i-%.2i %.2i:%.2i:%.2i)\n",
|
||||
@@ -3627,7 +3656,7 @@ static int b43_op_set_key(struct ieee802
|
||||
if (!dev || b43_status(dev) < B43_STAT_INITIALIZED)
|
||||
goto out_unlock;
|
||||
|
||||
- if (dev->fw.pcm_request_failed) {
|
||||
+ if (dev->fw.pcm_request_failed || !dev->hwcrypto_enabled) {
|
||||
/* We don't have firmware for the crypto engine.
|
||||
* Must use software-crypto. */
|
||||
err = -EOPNOTSUPP;
|
||||
@@ -4735,6 +4764,7 @@ static int b43_wireless_init(struct ssb_
|
||||
b43err(NULL, "Could not allocate ieee80211 device\n");
|
||||
goto out;
|
||||
}
|
||||
+ wl = hw_to_b43_wl(hw);
|
||||
|
||||
/* fill hw info */
|
||||
hw->flags = IEEE80211_HW_RX_INCLUDES_FCS |
|
||||
@@ -4748,7 +4778,8 @@ static int b43_wireless_init(struct ssb_
|
||||
BIT(NL80211_IFTYPE_WDS) |
|
||||
BIT(NL80211_IFTYPE_ADHOC);
|
||||
|
||||
- hw->queues = b43_modparam_qos ? 4 : 1;
|
||||
+ hw->queues = modparam_qos ? 4 : 1;
|
||||
+ wl->mac80211_initially_registered_queues = hw->queues;
|
||||
hw->max_rates = 2;
|
||||
SET_IEEE80211_DEV(hw, dev->dev);
|
||||
if (is_valid_ether_addr(sprom->et1mac))
|
||||
@@ -4756,9 +4787,7 @@ static int b43_wireless_init(struct ssb_
|
||||
else
|
||||
SET_IEEE80211_PERM_ADDR(hw, sprom->il0mac);
|
||||
|
||||
- /* Get and initialize struct b43_wl */
|
||||
- wl = hw_to_b43_wl(hw);
|
||||
- memset(wl, 0, sizeof(*wl));
|
||||
+ /* Initialize struct b43_wl */
|
||||
wl->hw = hw;
|
||||
spin_lock_init(&wl->irq_lock);
|
||||
rwlock_init(&wl->tx_lock);
|
||||
@@ -4824,8 +4853,13 @@ static void b43_remove(struct ssb_device
|
||||
cancel_work_sync(&wldev->restart_work);
|
||||
|
||||
B43_WARN_ON(!wl);
|
||||
- if (wl->current_dev == wldev)
|
||||
+ if (wl->current_dev == wldev) {
|
||||
+ /* Restore the queues count before unregistering, because firmware detect
|
||||
+ * might have modified it. Restoring is important, so the networking
|
||||
+ * stack can properly free resources. */
|
||||
+ wl->hw->queues = wl->mac80211_initially_registered_queues;
|
||||
ieee80211_unregister_hw(wl->hw);
|
||||
+ }
|
||||
|
||||
b43_one_core_detach(dev);
|
||||
|
||||
--- a/drivers/net/wireless/b43/main.h
|
||||
+++ b/drivers/net/wireless/b43/main.h
|
||||
@@ -39,7 +39,6 @@
|
||||
#define PAD_BYTES(nr_bytes) P4D_BYTES( __LINE__ , (nr_bytes))
|
||||
|
||||
|
||||
-extern int b43_modparam_qos;
|
||||
extern int b43_modparam_verbose;
|
||||
|
||||
/* Logmessage verbosity levels. Update the b43_modparam_verbose helptext, if
|
||||
--- a/drivers/net/wireless/b43/pio.c
|
||||
+++ b/drivers/net/wireless/b43/pio.c
|
||||
@@ -313,7 +313,7 @@ static struct b43_pio_txqueue *select_qu
|
||||
{
|
||||
struct b43_pio_txqueue *q;
|
||||
|
||||
- if (b43_modparam_qos) {
|
||||
+ if (dev->qos_enabled) {
|
||||
/* 0 = highest priority */
|
||||
switch (queue_prio) {
|
||||
default:
|
@ -1,52 +0,0 @@
|
||||
From: Matthieu CASTET <castet.matthieu@free.fr>
|
||||
|
||||
Fix possible unaligned u32 access in b43_generate_plcp_hdr().
|
||||
Unaligned data is read/write with a u32 pointer instead of using the
|
||||
packed structure. Some versions of gcc ignore the "packed" attribute, if the
|
||||
structure element is accessed through a local pointer.
|
||||
|
||||
Signed-off-by: Matthieu CASTET <castet.matthieu@free.fr>
|
||||
Signed-off-by: Michael Buesch <mb@bu3sch.de>
|
||||
|
||||
---
|
||||
|
||||
Please queue this bugfix.
|
||||
|
||||
|
||||
diff --git a/drivers/net/wireless/b43/xmit.c b/drivers/net/wireless/b43/xmit.c
|
||||
index a63d888..55f36a7 100644
|
||||
--- a/drivers/net/wireless/b43/xmit.c
|
||||
+++ b/drivers/net/wireless/b43/xmit.c
|
||||
@@ -118,7 +118,6 @@ u8 b43_plcp_get_ratecode_ofdm(const u8 bitrate)
|
||||
void b43_generate_plcp_hdr(struct b43_plcp_hdr4 *plcp,
|
||||
const u16 octets, const u8 bitrate)
|
||||
{
|
||||
- __le32 *data = &(plcp->data);
|
||||
__u8 *raw = plcp->raw;
|
||||
|
||||
if (b43_is_ofdm_rate(bitrate)) {
|
||||
@@ -127,7 +126,7 @@ void b43_generate_plcp_hdr(struct b43_plcp_hdr4 *plcp,
|
||||
d = b43_plcp_get_ratecode_ofdm(bitrate);
|
||||
B43_WARN_ON(octets & 0xF000);
|
||||
d |= (octets << 5);
|
||||
- *data = cpu_to_le32(d);
|
||||
+ plcp->data = cpu_to_le32(d);
|
||||
} else {
|
||||
u32 plen;
|
||||
|
||||
@@ -141,7 +140,7 @@ void b43_generate_plcp_hdr(struct b43_plcp_hdr4 *plcp,
|
||||
raw[1] = 0x04;
|
||||
} else
|
||||
raw[1] = 0x04;
|
||||
- *data |= cpu_to_le32(plen << 16);
|
||||
+ plcp->data |= cpu_to_le32(plen << 16);
|
||||
raw[0] = b43_plcp_get_ratecode_cck(bitrate);
|
||||
}
|
||||
}
|
||||
|
||||
--
|
||||
Greetings, Michael.
|
||||
--
|
||||
To unsubscribe from this list: send the line "unsubscribe linux-wireless" in
|
||||
the body of a message to majordomo@vger.kernel.org
|
||||
More majordomo info at http://vger.kernel.org/majordomo-info.html
|
Loading…
Reference in New Issue
Block a user