fuse24: introduce fuse package for brcm-2.4 (#5186)
SVN-Revision: 16411
This commit is contained in:
parent
99e23d2144
commit
0dc50344f0
123
package/fuse24/Makefile
Normal file
123
package/fuse24/Makefile
Normal file
@ -0,0 +1,123 @@
|
||||
#
|
||||
# Copyright (C) 2008 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
include $(INCLUDE_DIR)/kernel.mk
|
||||
|
||||
PKG_NAME:=fuse
|
||||
|
||||
PKG_VERSION:=2.5.3
|
||||
PKG_RELEASE:=1
|
||||
PKG_MD5SUM:=9c7e8b6606b9f158ae20b8521ba2867c
|
||||
|
||||
PKG_SOURCE_URL:=@SF/$(PKG_NAME)
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_CAT:=zcat
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/fuse24/Default
|
||||
TITLE:=FUSE for kernel 2.4
|
||||
DEPENDS:=@LINUX_2_4
|
||||
URL:=http://fuse.sourceforge.net/
|
||||
endef
|
||||
|
||||
define Package/fuse24/Default/description
|
||||
FUSE for kernel 2.4 (Filesystem in UserSpacE) contains only the kernel module.
|
||||
The libraries and utilities can be compiled from a recent FUSE version (package fuse).
|
||||
For details see:
|
||||
http://apps.sourceforge.net/mediawiki/fuse/index.php?title=FAQ#What_version_of_FUSE_do_I_need_to_use_FUSE_with_Linux_2.4.3F
|
||||
endef
|
||||
|
||||
define KernelPackage/fuse24
|
||||
$(call Package/fuse24/Default)
|
||||
SUBMENU:=Filesystems
|
||||
DEPENDS:=@LINUX_2_4
|
||||
TITLE+= (kernel module)
|
||||
FILES:=$(PKG_INSTALL_DIR)/lib/modules/$(LINUX_VERSION)/kernel/fs/fuse/fuse.$(LINUX_KMOD_SUFFIX)
|
||||
AUTOLOAD:=$(call AutoLoad,80,fuse)
|
||||
endef
|
||||
|
||||
define KernelPackage/fuse24/description
|
||||
$(call Package/fuse24/Default/description)
|
||||
This package contains the FUSE kernel 2.4 module.
|
||||
endef
|
||||
|
||||
define KernelPackage/fuse24/install
|
||||
$(call $(Package/kmod-fuse24/install))
|
||||
echo mknod /dev/fuse -m 0666 c 10 229 >> $(1)/CONTROL/postinst
|
||||
endef
|
||||
|
||||
define Build/Configure
|
||||
(cd $(PKG_BUILD_DIR); \
|
||||
rm -rf config.{cache,status} ; \
|
||||
touch configure.in ; \
|
||||
touch aclocal.m4 ; \
|
||||
touch Makefile.in ; \
|
||||
touch include/config.h.in ; \
|
||||
touch configure ; \
|
||||
$(TARGET_CONFIGURE_OPTS) \
|
||||
CFLAGS="$(TARGET_CFLAGS)" \
|
||||
./configure \
|
||||
--target=$(GNU_TARGET_NAME) \
|
||||
--host=$(GNU_TARGET_NAME) \
|
||||
--build=$(GNU_HOST_NAME) \
|
||||
--program-prefix="" \
|
||||
--program-suffix="" \
|
||||
--prefix=/usr \
|
||||
--exec-prefix=/usr \
|
||||
--bindir=/usr/bin \
|
||||
--datadir=/usr/share \
|
||||
--includedir=/usr/include \
|
||||
--infodir=/usr/share/info \
|
||||
--libdir=/usr/lib \
|
||||
--libexecdir=/usr/lib \
|
||||
--localstatedir=/var \
|
||||
--mandir=/usr/share/man \
|
||||
--sbindir=/usr/sbin \
|
||||
--sysconfdir=/etc \
|
||||
$(DISABLE_LARGEFILE) \
|
||||
$(DISABLE_NLS) \
|
||||
--enable-shared \
|
||||
--enable-static \
|
||||
--disable-rpath \
|
||||
--enable-kernel-module \
|
||||
--disable-example \
|
||||
--disable-auto-modprobe \
|
||||
--with-kernel=$(LINUX_DIR) \
|
||||
--disable-mtab \
|
||||
--disable-lib \
|
||||
--disable-util \
|
||||
);
|
||||
endef
|
||||
|
||||
define Build/Compile
|
||||
rm -rf $(PKG_INSTALL_DIR)
|
||||
mkdir -p $(PKG_INSTALL_DIR)
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||
ARCH="$(LINUX_KARCH)" \
|
||||
CROSS_COMPILE="$(TARGET_CROSS)" \
|
||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||
all install
|
||||
endef
|
||||
|
||||
define Build/InstallDev
|
||||
mkdir -p $(1)/usr/include
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/include/fuse{,.h} $(1)/usr/include/
|
||||
# mkdir -p $(1)/usr/lib
|
||||
# $(CP) $(PKG_INSTALL_DIR)/usr/lib/libfuse.{a,so*} $(1)/usr/lib/
|
||||
mkdir -p $(1)/usr/lib/pkgconfig
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/fuse.pc $(1)/usr/lib/pkgconfig/
|
||||
$(SED) 's,-I$$$${includedir}/fuse,,g' $(1)/usr/lib/pkgconfig/fuse.pc
|
||||
$(SED) 's,-L$$$${libdir},,g' $(1)/usr/lib/pkgconfig/fuse.pc
|
||||
#echo mknod /dev/fuse -m 0666 c 10 229 >> $(PKG_BUILD_DIR)/ipkg/kmod-fuse24/CONTROL/postinst
|
||||
endef
|
||||
|
||||
$(eval $(call KernelPackage,fuse24))
|
46
package/fuse24/patches/101-kmod_build.patch
Normal file
46
package/fuse24/patches/101-kmod_build.patch
Normal file
@ -0,0 +1,46 @@
|
||||
diff -Nur fuse-2.5.2/kernel/Makefile.in fuse-2.5.2.patched/kernel/Makefile.in
|
||||
--- fuse-2.5.2/kernel/Makefile.in 2006-02-02 18:04:52.000000000 +0100
|
||||
+++ fuse-2.5.2.patched/kernel/Makefile.in 2006-03-28 20:17:13.000000000 +0200
|
||||
@@ -54,23 +54,8 @@
|
||||
|
||||
ifeq ($(majver), 2.4)
|
||||
|
||||
-CC = gcc
|
||||
-LD = ld
|
||||
-CFLAGS = -O2 -Wall -Wstrict-prototypes -fno-strict-aliasing -pipe @KERNELCFLAGS@
|
||||
-CPPFLAGS = -I@kernelsrc@/include -I. -D__KERNEL__ -DMODULE -D_LOOSE_KERNEL_NAMES -DFUSE_VERSION=\"$(VERSION)\" @KERNELCPPFLAGS@
|
||||
-
|
||||
fuse_objs = dev.o dir.o file.o inode.o compat/parser.o
|
||||
|
||||
-SUFFIXES = .c .o .s
|
||||
-
|
||||
-all-spec: fuse.o
|
||||
-
|
||||
-.c.o:
|
||||
- $(CC) $(CFLAGS) $(CPPFLAGS) -c $< -o $@
|
||||
-
|
||||
-fuse.o: $(fuse_objs)
|
||||
- $(LD) -r -o fuse.o $(fuse_objs)
|
||||
-
|
||||
fuse_headers = fuse_i.h fuse_kernel.h
|
||||
|
||||
dev.o: $(fuse_headers)
|
||||
@@ -78,6 +63,18 @@
|
||||
file.o: $(fuse_headers)
|
||||
inode.o: $(fuse_headers)
|
||||
|
||||
+EXTRA_CFLAGS += -DFUSE_VERSION=\"$(VERSION)\"
|
||||
+
|
||||
+O_TARGET := fuse.o
|
||||
+
|
||||
+obj-y := $(fuse_objs)
|
||||
+obj-m := $(O_TARGET)
|
||||
+
|
||||
+-include $(TOPDIR)/Rules.make
|
||||
+
|
||||
+all-spec:
|
||||
+ $(MAKE) -C @kernelsrc@ TOPDIR=@kernelsrc@ SUBDIRS=$(PWD) modules
|
||||
+
|
||||
else
|
||||
|
||||
EXTRA_CFLAGS += -DFUSE_VERSION=\"$(VERSION)\"
|
15
package/fuse24/patches/102-no_depmod.patch
Normal file
15
package/fuse24/patches/102-no_depmod.patch
Normal file
@ -0,0 +1,15 @@
|
||||
diff -ruN fuse-2.5.3-old/kernel/Makefile.in fuse-2.5.3-new/kernel/Makefile.in
|
||||
--- fuse-2.5.3-old/kernel/Makefile.in 2006-06-17 00:04:06.000000000 +0200
|
||||
+++ fuse-2.5.3-new/kernel/Makefile.in 2006-06-17 00:08:44.000000000 +0200
|
||||
@@ -31,11 +31,9 @@
|
||||
install-y: all
|
||||
$(mkdir_p) $(DESTDIR)$(fusemoduledir)
|
||||
$(INSTALL) -m 644 $(fusemodule) $(DESTDIR)$(fusemoduledir)/$(fusemodule)
|
||||
- -/sbin/depmod -a
|
||||
|
||||
uninstall-y:
|
||||
rm -f $(DESTDIR)$(fusemoduledir)/$(fusemodule)
|
||||
- -/sbin/depmod -a
|
||||
|
||||
clean:
|
||||
-rm -f $(fusemodule) *.o .*.cmd *.mod.c *.ko *.s */*.o
|
16
package/fuse24/patches/111-uclibc_changes.patch
Normal file
16
package/fuse24/patches/111-uclibc_changes.patch
Normal file
@ -0,0 +1,16 @@
|
||||
diff -ruw fuse-2.4.0/util/fusermount.c.org fuse-2.4.0/util/fusermount.c
|
||||
--- fuse-2.4.0/util/fusermount.c.org 2005-10-14 11:34:06.000000000 +0200
|
||||
+++ fuse-2.4.0/util/fusermount.c 2005-10-14 11:56:26.000000000 +0200
|
||||
@@ -42,7 +42,12 @@
|
||||
#define FUSE_COMMFD_ENV "_FUSE_COMMFD"
|
||||
|
||||
#define FUSE_DEV_OLD "/proc/fs/fuse/dev"
|
||||
+#ifdef __UCLIBC__
|
||||
+/* /dev is mounted as devfs in OpenWRT, and device is created here */
|
||||
+#define FUSE_DEV_NEW "/dev/misc/fuse"
|
||||
+#else
|
||||
#define FUSE_DEV_NEW "/dev/fuse"
|
||||
+#endif
|
||||
#define FUSE_VERSION_FILE_OLD "/proc/fs/fuse/version"
|
||||
#define FUSE_CONF "/etc/fuse.conf"
|
||||
|
12
package/fuse24/patches/112-no_break_on_mknod.patch
Normal file
12
package/fuse24/patches/112-no_break_on_mknod.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -ruN fuse-2.4.1-old/util/Makefile.in fuse-2.4.1-new/util/Makefile.in
|
||||
--- fuse-2.4.1-old/util/Makefile.in 2005-10-17 12:29:20.000000000 +0200
|
||||
+++ fuse-2.4.1-new/util/Makefile.in 2005-10-19 17:11:13.000000000 +0200
|
||||
@@ -445,7 +445,7 @@
|
||||
install-exec-hook:
|
||||
-chown root $(DESTDIR)$(bindir)/fusermount
|
||||
-chmod u+s $(DESTDIR)$(bindir)/fusermount
|
||||
- @if test ! -e $(DESTDIR)/dev/fuse; then \
|
||||
+ -@if test ! -e $(DESTDIR)/dev/fuse; then \
|
||||
$(mkdir_p) $(DESTDIR)/dev; \
|
||||
echo "mknod $(DESTDIR)/dev/fuse -m 0666 c 10 229"; \
|
||||
mknod $(DESTDIR)/dev/fuse -m 0666 c 10 229; \
|
63
package/fuse24/patches/113-DCACHE_BUG.patch
Normal file
63
package/fuse24/patches/113-DCACHE_BUG.patch
Normal file
@ -0,0 +1,63 @@
|
||||
diff -ruN fuse-2.5.3.orig/kernel/dev.c fuse-2.5.3/kernel/dev.c
|
||||
--- fuse-2.5.3.orig/kernel/dev.c 2006-02-02 19:04:52.000000000 +0200
|
||||
+++ fuse-2.5.3/kernel/dev.c 2008-10-23 10:27:53.000000000 +0300
|
||||
@@ -512,6 +512,9 @@
|
||||
{
|
||||
unsigned long offset;
|
||||
int err;
|
||||
+#ifdef DCACHE_BUG
|
||||
+ struct vm_area_struct *vma;
|
||||
+#endif
|
||||
|
||||
unlock_request(cs->req);
|
||||
fuse_copy_finish(cs);
|
||||
@@ -523,14 +526,22 @@
|
||||
cs->nr_segs --;
|
||||
}
|
||||
down_read(¤t->mm->mmap_sem);
|
||||
+#ifndef DCACHE_BUG
|
||||
err = get_user_pages(current, current->mm, cs->addr, 1, cs->write, 0,
|
||||
&cs->pg, NULL);
|
||||
+#else
|
||||
+ err = get_user_pages(current, current->mm, cs->addr, 1, cs->write, 0,
|
||||
+ &cs->pg, &vma);
|
||||
+#endif
|
||||
up_read(¤t->mm->mmap_sem);
|
||||
if (err < 0)
|
||||
return err;
|
||||
BUG_ON(err != 1);
|
||||
offset = cs->addr % PAGE_SIZE;
|
||||
cs->mapaddr = kmap_atomic(cs->pg, KM_USER0);
|
||||
+#ifdef DCACHE_BUG
|
||||
+ r4k_flush_cache_page(vma, cs->addr);
|
||||
+#endif
|
||||
cs->buf = cs->mapaddr + offset;
|
||||
cs->len = min(PAGE_SIZE - offset, cs->seglen);
|
||||
cs->seglen -= cs->len;
|
||||
@@ -545,6 +556,11 @@
|
||||
{
|
||||
unsigned ncpy = min(*size, cs->len);
|
||||
if (val) {
|
||||
+#ifdef DCACHE_BUG
|
||||
+ // patch from mailing list, it is very important, otherwise,
|
||||
+ // can't mount, or ls mount point will hang
|
||||
+ flush_cache_all();
|
||||
+#endif
|
||||
if (cs->write)
|
||||
memcpy(cs->buf, *val, ncpy);
|
||||
else
|
||||
diff -ruN fuse-2.5.3.orig/kernel/fuse_i.h fuse-2.5.3/kernel/fuse_i.h
|
||||
--- fuse-2.5.3.orig/kernel/fuse_i.h 2006-02-02 19:04:52.000000000 +0200
|
||||
+++ fuse-2.5.3/kernel/fuse_i.h 2008-10-22 18:03:50.000000000 +0300
|
||||
@@ -45,6 +45,10 @@
|
||||
# endif
|
||||
#endif
|
||||
|
||||
+//#if defined(__arm__) && LINUX_VERSION_CODE < KERNEL_VERSION(2,6,20)
|
||||
+#define DCACHE_BUG
|
||||
+//#endif
|
||||
+
|
||||
#include "config.h"
|
||||
#ifndef KERNEL_2_6
|
||||
# include <linux/config.h>
|
||||
|
Loading…
Reference in New Issue
Block a user