opkg: Fix handling of sha256sums for conffiles
MD5s are shorter than SHA256, so reading buffer has to be bigger to read the whole hash. Signed-off-by: Michal Hrusecky <michal.hrusecky@nic.cz> SVN-Revision: 48917
This commit is contained in:
parent
fbb2449953
commit
1268b2e899
@ -12,7 +12,7 @@ include $(INCLUDE_DIR)/feeds.mk
|
||||
PKG_NAME:=opkg
|
||||
PKG_REV:=9c97d5ecd795709c8584e972bfdf3aee3a5b846d
|
||||
PKG_VERSION:=$(PKG_REV)
|
||||
PKG_RELEASE:=11
|
||||
PKG_RELEASE:=12
|
||||
|
||||
PKG_SOURCE_PROTO:=git
|
||||
PKG_SOURCE_VERSION:=$(PKG_REV)
|
||||
|
@ -176,3 +176,17 @@
|
||||
|
||||
# check for openssl
|
||||
AC_ARG_ENABLE(openssl,
|
||||
--- a/libopkg/pkg_parse.c
|
||||
+++ b/libopkg/pkg_parse.c
|
||||
@@ -49,9 +49,9 @@ parse_status(pkg_t *pkg, const char *sst
|
||||
static void
|
||||
parse_conffiles(pkg_t *pkg, const char *cstr)
|
||||
{
|
||||
- char file_name[1024], md5sum[35];
|
||||
+ char file_name[1024], md5sum[85];
|
||||
|
||||
- if (sscanf(cstr, "%1023s %34s", file_name, md5sum) != 2) {
|
||||
+ if (sscanf(cstr, "%1023s %84s", file_name, md5sum) != 2) {
|
||||
opkg_msg(ERROR, "Failed to parse Conffiles line for %s\n",
|
||||
pkg->name);
|
||||
return;
|
||||
|
Loading…
Reference in New Issue
Block a user