Makefile change to compile modules, minor change in patch
SVN-Revision: 1775
This commit is contained in:
parent
3d74d80e5d
commit
2fc4ce6b61
@ -198,8 +198,8 @@ $(LINUX_KERNEL): $(LINUX_DIR)/vmlinux
|
|||||||
|
|
||||||
$(LINUX_DIR)/.modules_done: $(LINUX_KERNEL) $(LINUX_IMAGE)
|
$(LINUX_DIR)/.modules_done: $(LINUX_KERNEL) $(LINUX_IMAGE)
|
||||||
rm -rf $(LINUX_BUILD_DIR)/modules
|
rm -rf $(LINUX_BUILD_DIR)/modules
|
||||||
$(MAKE) -C $(LINUX_DIR) ARCH=$(LINUX_KARCH) PATH=$(TARGET_PATH) modules
|
$(MAKE) -C $(LINUX_DIR) CROSS_COMPILE=$(TARGET_CROSS) ARCH=$(LINUX_KARCH) PATH=$(TARGET_PATH) modules
|
||||||
$(MAKE) -C $(LINUX_DIR) DEPMOD=true INSTALL_MOD_PATH=$(LINUX_BUILD_DIR)/modules modules_install
|
$(MAKE) -C $(LINUX_DIR) CROSS_COMPILE=$(TARGET_CROSS) DEPMOD=true INSTALL_MOD_PATH=$(LINUX_BUILD_DIR)/modules modules_install
|
||||||
touch $(LINUX_DIR)/.modules_done
|
touch $(LINUX_DIR)/.modules_done
|
||||||
|
|
||||||
$(STAGING_DIR)/include/linux/version.h: $(LINUX_DIR)/.configured
|
$(STAGING_DIR)/include/linux/version.h: $(LINUX_DIR)/.configured
|
||||||
|
@ -1,9 +1,12 @@
|
|||||||
#
|
#
|
||||||
# Automatically generated make config: don't edit
|
# Automatically generated make config: don't edit
|
||||||
# Linux kernel version: 2.6.12-rc5
|
# Linux kernel version: 2.6.12.5
|
||||||
# Sat Aug 27 21:25:27 2005
|
# Sun Aug 28 11:20:38 2005
|
||||||
#
|
#
|
||||||
CONFIG_MIPS=y
|
CONFIG_MIPS=y
|
||||||
|
# CONFIG_MIPS64 is not set
|
||||||
|
# CONFIG_64BIT is not set
|
||||||
|
CONFIG_MIPS32=y
|
||||||
|
|
||||||
#
|
#
|
||||||
# Code maturity level options
|
# Code maturity level options
|
||||||
@ -56,64 +59,43 @@ CONFIG_OBSOLETE_MODPARM=y
|
|||||||
#
|
#
|
||||||
# Machine selection
|
# Machine selection
|
||||||
#
|
#
|
||||||
|
# CONFIG_MACH_JAZZ is not set
|
||||||
CONFIG_BCM47XX=y
|
CONFIG_BCM47XX=y
|
||||||
# CONFIG_MIPS_MTX1 is not set
|
# CONFIG_MACH_VR41XX is not set
|
||||||
# CONFIG_MIPS_BOSPORUS is not set
|
# CONFIG_TOSHIBA_JMR3927 is not set
|
||||||
# CONFIG_MIPS_PB1000 is not set
|
|
||||||
# CONFIG_MIPS_PB1100 is not set
|
|
||||||
# CONFIG_MIPS_PB1500 is not set
|
|
||||||
# CONFIG_MIPS_PB1550 is not set
|
|
||||||
# CONFIG_MIPS_PB1200 is not set
|
|
||||||
# CONFIG_MIPS_DB1000 is not set
|
|
||||||
# CONFIG_MIPS_DB1100 is not set
|
|
||||||
# CONFIG_MIPS_DB1500 is not set
|
|
||||||
# CONFIG_MIPS_DB1550 is not set
|
|
||||||
# CONFIG_MIPS_DB1200 is not set
|
|
||||||
# CONFIG_MIPS_MIRAGE is not set
|
|
||||||
# CONFIG_MIPS_COBALT is not set
|
# CONFIG_MIPS_COBALT is not set
|
||||||
# CONFIG_MACH_DECSTATION is not set
|
# CONFIG_MACH_DECSTATION is not set
|
||||||
# CONFIG_MIPS_EV64120 is not set
|
# CONFIG_MIPS_EV64120 is not set
|
||||||
# CONFIG_MIPS_EV96100 is not set
|
# CONFIG_MIPS_EV96100 is not set
|
||||||
# CONFIG_MIPS_IVR is not set
|
# CONFIG_MIPS_IVR is not set
|
||||||
# CONFIG_MIPS_ITE8172 is not set
|
|
||||||
# CONFIG_MACH_JAZZ is not set
|
|
||||||
# CONFIG_LASAT is not set
|
# CONFIG_LASAT is not set
|
||||||
|
# CONFIG_MIPS_ITE8172 is not set
|
||||||
# CONFIG_MIPS_ATLAS is not set
|
# CONFIG_MIPS_ATLAS is not set
|
||||||
# CONFIG_MIPS_MALTA is not set
|
# CONFIG_MIPS_MALTA is not set
|
||||||
# CONFIG_MIPS_SEAD is not set
|
# CONFIG_MIPS_SEAD is not set
|
||||||
# CONFIG_MOMENCO_JAGUAR_ATX is not set
|
|
||||||
# CONFIG_MOMENCO_OCELOT is not set
|
# CONFIG_MOMENCO_OCELOT is not set
|
||||||
# CONFIG_MOMENCO_OCELOT_3 is not set
|
|
||||||
# CONFIG_MOMENCO_OCELOT_C is not set
|
|
||||||
# CONFIG_MOMENCO_OCELOT_G is not set
|
# CONFIG_MOMENCO_OCELOT_G is not set
|
||||||
# CONFIG_MIPS_XXS1500 is not set
|
# CONFIG_MOMENCO_OCELOT_C is not set
|
||||||
|
# CONFIG_MOMENCO_OCELOT_3 is not set
|
||||||
|
# CONFIG_MOMENCO_JAGUAR_ATX is not set
|
||||||
|
# CONFIG_PMC_YOSEMITE is not set
|
||||||
# CONFIG_DDB5074 is not set
|
# CONFIG_DDB5074 is not set
|
||||||
# CONFIG_DDB5476 is not set
|
# CONFIG_DDB5476 is not set
|
||||||
# CONFIG_DDB5477 is not set
|
# CONFIG_DDB5477 is not set
|
||||||
# CONFIG_MACH_VR41XX is not set
|
# CONFIG_NEC_OSPREY is not set
|
||||||
# CONFIG_PMC_YOSEMITE is not set
|
|
||||||
# CONFIG_SGI_IP22 is not set
|
# CONFIG_SGI_IP22 is not set
|
||||||
# CONFIG_SGI_IP27 is not set
|
# CONFIG_SOC_AU1X00 is not set
|
||||||
# CONFIG_SGI_IP32 is not set
|
# CONFIG_SIBYTE_SB1xxx_SOC is not set
|
||||||
# CONFIG_SIBYTE_SWARM is not set
|
|
||||||
# CONFIG_SIBYTE_SENTOSA is not set
|
|
||||||
# CONFIG_SIBYTE_RHONE is not set
|
|
||||||
# CONFIG_SIBYTE_CARMEL is not set
|
|
||||||
# CONFIG_SIBYTE_PTSWARM is not set
|
|
||||||
# CONFIG_SIBYTE_LITTLESUR is not set
|
|
||||||
# CONFIG_SIBYTE_CRHINE is not set
|
|
||||||
# CONFIG_SIBYTE_CRHONE is not set
|
|
||||||
# CONFIG_SNI_RM200_PCI is not set
|
# CONFIG_SNI_RM200_PCI is not set
|
||||||
# CONFIG_TOSHIBA_JMR3927 is not set
|
|
||||||
# CONFIG_TOSHIBA_RBTX4927 is not set
|
# CONFIG_TOSHIBA_RBTX4927 is not set
|
||||||
CONFIG_RWSEM_GENERIC_SPINLOCK=y
|
CONFIG_RWSEM_GENERIC_SPINLOCK=y
|
||||||
CONFIG_GENERIC_CALIBRATE_DELAY=y
|
CONFIG_GENERIC_CALIBRATE_DELAY=y
|
||||||
CONFIG_HAVE_DEC_LOCK=y
|
CONFIG_HAVE_DEC_LOCK=y
|
||||||
CONFIG_DMA_NONCOHERENT=y
|
CONFIG_DMA_NONCOHERENT=y
|
||||||
# CONFIG_CPU_BIG_ENDIAN is not set
|
CONFIG_CPU_LITTLE_ENDIAN=y
|
||||||
# CONFIG_CPU_LITTLE_ENDIAN is not set
|
|
||||||
CONFIG_IRQ_CPU=y
|
CONFIG_IRQ_CPU=y
|
||||||
CONFIG_MIPS_L1_CACHE_SHIFT=5
|
CONFIG_MIPS_L1_CACHE_SHIFT=5
|
||||||
|
# CONFIG_FB is not set
|
||||||
|
|
||||||
#
|
#
|
||||||
# CPU selection
|
# CPU selection
|
||||||
@ -135,19 +117,14 @@ CONFIG_CPU_MIPS32=y
|
|||||||
# CONFIG_CPU_RM7000 is not set
|
# CONFIG_CPU_RM7000 is not set
|
||||||
# CONFIG_CPU_RM9000 is not set
|
# CONFIG_CPU_RM9000 is not set
|
||||||
# CONFIG_CPU_SB1 is not set
|
# CONFIG_CPU_SB1 is not set
|
||||||
CONFIG_CPU_SUPPORTS_32BIT_KERNEL=y
|
|
||||||
|
|
||||||
#
|
|
||||||
# Kernel type
|
|
||||||
#
|
|
||||||
# CONFIG_MIPS32 is not set
|
|
||||||
# CONFIG_MIPS64 is not set
|
|
||||||
# CONFIG_64BIT is not set
|
|
||||||
CONFIG_PAGE_SIZE_4KB=y
|
CONFIG_PAGE_SIZE_4KB=y
|
||||||
# CONFIG_PAGE_SIZE_8KB is not set
|
# CONFIG_PAGE_SIZE_8KB is not set
|
||||||
# CONFIG_PAGE_SIZE_16KB is not set
|
# CONFIG_PAGE_SIZE_16KB is not set
|
||||||
# CONFIG_PAGE_SIZE_64KB is not set
|
# CONFIG_PAGE_SIZE_64KB is not set
|
||||||
CONFIG_CPU_HAS_PREFETCH=y
|
CONFIG_CPU_HAS_PREFETCH=y
|
||||||
|
# CONFIG_VTAG_ICACHE is not set
|
||||||
|
# CONFIG_64BIT_PHYS_ADDR is not set
|
||||||
|
# CONFIG_CPU_ADVANCED is not set
|
||||||
CONFIG_CPU_HAS_LLSC=y
|
CONFIG_CPU_HAS_LLSC=y
|
||||||
CONFIG_CPU_HAS_SYNC=y
|
CONFIG_CPU_HAS_SYNC=y
|
||||||
# CONFIG_PREEMPT is not set
|
# CONFIG_PREEMPT is not set
|
||||||
@ -173,6 +150,7 @@ CONFIG_MMU=y
|
|||||||
#
|
#
|
||||||
CONFIG_BINFMT_ELF=y
|
CONFIG_BINFMT_ELF=y
|
||||||
# CONFIG_BINFMT_MISC is not set
|
# CONFIG_BINFMT_MISC is not set
|
||||||
|
CONFIG_TRAD_SIGNALS=y
|
||||||
|
|
||||||
#
|
#
|
||||||
# Device Drivers
|
# Device Drivers
|
||||||
@ -279,6 +257,7 @@ CONFIG_BLK_DEV_NBD=m
|
|||||||
# CONFIG_BLK_DEV_RAM is not set
|
# CONFIG_BLK_DEV_RAM is not set
|
||||||
CONFIG_BLK_DEV_RAM_COUNT=16
|
CONFIG_BLK_DEV_RAM_COUNT=16
|
||||||
CONFIG_INITRAMFS_SOURCE=""
|
CONFIG_INITRAMFS_SOURCE=""
|
||||||
|
# CONFIG_LBD is not set
|
||||||
# CONFIG_CDROM_PKTCDVD is not set
|
# CONFIG_CDROM_PKTCDVD is not set
|
||||||
|
|
||||||
#
|
#
|
||||||
@ -621,7 +600,6 @@ CONFIG_SERIO_SERPORT=y
|
|||||||
CONFIG_SERIO_LIBPS2=m
|
CONFIG_SERIO_LIBPS2=m
|
||||||
# CONFIG_SERIO_RAW is not set
|
# CONFIG_SERIO_RAW is not set
|
||||||
# CONFIG_GAMEPORT is not set
|
# CONFIG_GAMEPORT is not set
|
||||||
CONFIG_SOUND_GAMEPORT=y
|
|
||||||
|
|
||||||
#
|
#
|
||||||
# Character devices
|
# Character devices
|
||||||
@ -702,7 +680,6 @@ CONFIG_RTC=y
|
|||||||
#
|
#
|
||||||
# Graphics support
|
# Graphics support
|
||||||
#
|
#
|
||||||
# CONFIG_FB is not set
|
|
||||||
|
|
||||||
#
|
#
|
||||||
# Sound
|
# Sound
|
||||||
@ -878,11 +855,6 @@ CONFIG_NLS_DEFAULT="iso8859-1"
|
|||||||
# CONFIG_NLS_KOI8_U is not set
|
# CONFIG_NLS_KOI8_U is not set
|
||||||
# CONFIG_NLS_UTF8 is not set
|
# CONFIG_NLS_UTF8 is not set
|
||||||
|
|
||||||
#
|
|
||||||
# Profiling support
|
|
||||||
#
|
|
||||||
# CONFIG_PROFILING is not set
|
|
||||||
|
|
||||||
#
|
#
|
||||||
# Kernel hacking
|
# Kernel hacking
|
||||||
#
|
#
|
||||||
@ -941,3 +913,4 @@ CONFIG_ZLIB_INFLATE=y
|
|||||||
CONFIG_ZLIB_DEFLATE=y
|
CONFIG_ZLIB_DEFLATE=y
|
||||||
CONFIG_GENERIC_HARDIRQS=y
|
CONFIG_GENERIC_HARDIRQS=y
|
||||||
CONFIG_GENERIC_IRQ_PROBE=y
|
CONFIG_GENERIC_IRQ_PROBE=y
|
||||||
|
CONFIG_ISA_DMA_API=y
|
||||||
|
@ -1695,7 +1695,7 @@ diff -Nur linux-2.6.12.5/arch/mips/Kconfig.orig linux-2.6.12.5-brcm/arch/mips/Kc
|
|||||||
+ default y
|
+ default y
|
||||||
diff -Nur linux-2.6.12.5/arch/mips/Makefile linux-2.6.12.5-brcm/arch/mips/Makefile
|
diff -Nur linux-2.6.12.5/arch/mips/Makefile linux-2.6.12.5-brcm/arch/mips/Makefile
|
||||||
--- linux-2.6.12.5/arch/mips/Makefile 2005-08-15 02:20:18.000000000 +0200
|
--- linux-2.6.12.5/arch/mips/Makefile 2005-08-15 02:20:18.000000000 +0200
|
||||||
+++ linux-2.6.12.5-brcm/arch/mips/Makefile 2005-08-28 11:12:20.406862800 +0200
|
+++ linux-2.6.12.5-brcm/arch/mips/Makefile 2005-08-28 11:35:08.381898984 +0200
|
||||||
@@ -79,7 +79,7 @@
|
@@ -79,7 +79,7 @@
|
||||||
cflags-y += -I $(TOPDIR)/include/asm/gcc
|
cflags-y += -I $(TOPDIR)/include/asm/gcc
|
||||||
cflags-y += -G 0 -mno-abicalls -fno-pic -pipe
|
cflags-y += -G 0 -mno-abicalls -fno-pic -pipe
|
||||||
@ -1727,7 +1727,7 @@ diff -Nur linux-2.6.12.5/arch/mips/Makefile linux-2.6.12.5-brcm/arch/mips/Makefi
|
|||||||
+#
|
+#
|
||||||
+core-$(CONFIG_BCM47XX) += arch/mips/bcm47xx/ arch/mips/bcm47xx/broadcom/
|
+core-$(CONFIG_BCM47XX) += arch/mips/bcm47xx/ arch/mips/bcm47xx/broadcom/
|
||||||
+cflags-$(CONFIG_BCM47XX) += -Iarch/mips/bcm47xx/broadcom/include
|
+cflags-$(CONFIG_BCM47XX) += -Iarch/mips/bcm47xx/broadcom/include
|
||||||
+load-$(CONFIG_BCM47XX) := 0x80001000
|
+load-$(CONFIG_BCM47XX) := 0xffffffff80001000
|
||||||
+
|
+
|
||||||
+
|
+
|
||||||
+#
|
+#
|
||||||
@ -1742,7 +1742,7 @@ diff -Nur linux-2.6.12.5/arch/mips/Makefile linux-2.6.12.5-brcm/arch/mips/Makefi
|
|||||||
+all: bzImage
|
+all: bzImage
|
||||||
+
|
+
|
||||||
+zImage bzImage: vmlinux
|
+zImage bzImage: vmlinux
|
||||||
+ $(Q)$(MAKE) -C arch/mips/bcm47xx/compressed vmlinux
|
+ @$(MAKE) -C arch/mips/bcm47xx/compressed vmlinux
|
||||||
+
|
+
|
||||||
+endif
|
+endif
|
||||||
+
|
+
|
||||||
|
Loading…
Reference in New Issue
Block a user