libusb: update to version 1.0.19
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 43930
This commit is contained in:
parent
b78cddafcc
commit
2ff6a5f618
@ -8,12 +8,12 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=libusb
|
||||
PKG_VERSION:=1.0.9
|
||||
PKG_VERSION:=1.0.19
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=@SF/$(PKG_NAME)
|
||||
PKG_MD5SUM:=7f5a02375ad960d4e33a6dae7d63cfcb
|
||||
PKG_MD5SUM:=f9e2bb5879968467e5ca756cb4e1fa7e
|
||||
|
||||
PKG_INSTALL:=1
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
@ -37,6 +37,9 @@ define Package/libusb-1.0/description
|
||||
endef
|
||||
|
||||
TARGET_CFLAGS += $(FPIC)
|
||||
CONFIGURE_ARGS += \
|
||||
--disable-udev \
|
||||
--disable-log
|
||||
|
||||
define Build/InstallDev
|
||||
$(CP) $(PKG_INSTALL_DIR)/* $(1)/
|
||||
|
@ -14,15 +14,15 @@ Date: Thu Jan 27 06:39:16 2011 +0300
|
||||
|
||||
--- a/libusb/io.c
|
||||
+++ b/libusb/io.c
|
||||
@@ -20,6 +20,7 @@
|
||||
|
||||
#include <config.h>
|
||||
#include <errno.h>
|
||||
@@ -32,6 +32,7 @@
|
||||
#include <sys/time.h>
|
||||
#endif
|
||||
#ifdef USBI_TIMERFD_AVAILABLE
|
||||
+#include <fcntl.h>
|
||||
#include <signal.h>
|
||||
#include <stdint.h>
|
||||
#include <stdlib.h>
|
||||
@@ -1072,7 +1073,7 @@ int usbi_io_init(struct libusb_context *
|
||||
#include <sys/timerfd.h>
|
||||
#endif
|
||||
|
||||
@@ -1141,7 +1142,7 @@ int usbi_io_init(struct libusb_context *
|
||||
|
||||
#ifdef USBI_TIMERFD_AVAILABLE
|
||||
ctx->timerfd = timerfd_create(usbi_backend->get_timerfd_clockid(),
|
||||
|
Loading…
Reference in New Issue
Block a user