toolchain/gcc: add support for gcc-4.3.5
SVN-Revision: 21599
This commit is contained in:
parent
09df0523fd
commit
32098a5faf
@ -33,6 +33,9 @@ if !LINUX_2_4
|
||||
config GCC_VERSION_4_3_4
|
||||
bool "gcc 4.3.4"
|
||||
|
||||
config GCC_VERSION_4_3_5
|
||||
bool "gcc 4.3.5"
|
||||
|
||||
config GCC_VERSION_4_4_1
|
||||
bool "gcc 4.4.1"
|
||||
|
||||
|
@ -6,6 +6,7 @@ config GCC_VERSION
|
||||
default "4.3.3" if GCC_VERSION_4_3_3
|
||||
default "4.3.3+cs" if GCC_VERSION_4_3_3_CS
|
||||
default "4.3.4" if GCC_VERSION_4_3_4
|
||||
default "4.3.5" if GCC_VERSION_4_3_5
|
||||
default "4.4.1" if GCC_VERSION_4_4_1
|
||||
default "4.4.1+cs" if GCC_VERSION_4_4_1_CS
|
||||
default "4.4.2" if GCC_VERSION_4_4_2
|
||||
@ -47,6 +48,7 @@ config GCC_VERSION_4_3
|
||||
default y if GCC_VERSION_4_3_3
|
||||
default y if GCC_VERSION_4_3_3_CS
|
||||
default y if GCC_VERSION_4_3_4
|
||||
default y if GCC_VERSION_4_3_5
|
||||
|
||||
config GCC_VERSION_4_4
|
||||
bool
|
||||
|
@ -54,6 +54,9 @@ else
|
||||
ifeq ($(PKG_VERSION),4.3.4)
|
||||
PKG_MD5SUM:=60df63222dbffd53ca11492a2545044f
|
||||
endif
|
||||
ifeq ($(PKG_VERSION),4.3.5)
|
||||
PKG_MD5SUM:=e588cfde3bf323f82918589b94f14a15
|
||||
endif
|
||||
ifeq ($(PKG_VERSION),4,4,1)
|
||||
PKG_MD5SUM:=927eaac3d44b22f31f9c83df82f26436
|
||||
endif
|
||||
|
33
toolchain/gcc/patches/4.3.5/100-uclibc-conf.patch
Normal file
33
toolchain/gcc/patches/4.3.5/100-uclibc-conf.patch
Normal file
@ -0,0 +1,33 @@
|
||||
--- a/contrib/regression/objs-gcc.sh
|
||||
+++ b/contrib/regression/objs-gcc.sh
|
||||
@@ -105,6 +105,10 @@ if [ $H_REAL_TARGET = $H_REAL_HOST -a $H
|
||||
then
|
||||
make all-gdb all-dejagnu all-ld || exit 1
|
||||
make install-gdb install-dejagnu install-ld || exit 1
|
||||
+elif [ $H_REAL_TARGET = $H_REAL_HOST -a $H_REAL_TARGET = i686-pc-linux-uclibc ]
|
||||
+ then
|
||||
+ make all-gdb all-dejagnu all-ld || exit 1
|
||||
+ make install-gdb install-dejagnu install-ld || exit 1
|
||||
elif [ $H_REAL_TARGET = $H_REAL_HOST ] ; then
|
||||
make bootstrap || exit 1
|
||||
make install || exit 1
|
||||
--- a/libjava/classpath/ltconfig
|
||||
+++ b/libjava/classpath/ltconfig
|
||||
@@ -603,7 +603,7 @@ host_os=`echo $host | sed 's/^\([^-]*\)-
|
||||
|
||||
# Transform linux* to *-*-linux-gnu*, to support old configure scripts.
|
||||
case $host_os in
|
||||
-linux-gnu*) ;;
|
||||
+linux-gnu*|linux-uclibc*) ;;
|
||||
linux*) host=`echo $host | sed 's/^\(.*-.*-linux\)\(.*\)$/\1-gnu\2/'`
|
||||
esac
|
||||
|
||||
@@ -1251,7 +1251,7 @@ linux-gnuoldld* | linux-gnuaout* | linux
|
||||
;;
|
||||
|
||||
# This must be Linux ELF.
|
||||
-linux-gnu*)
|
||||
+linux*)
|
||||
version_type=linux
|
||||
need_lib_prefix=no
|
||||
need_version=no
|
12
toolchain/gcc/patches/4.3.5/104-gnuhurd-uclibc-conf.patch
Normal file
12
toolchain/gcc/patches/4.3.5/104-gnuhurd-uclibc-conf.patch
Normal file
@ -0,0 +1,12 @@
|
||||
--- a/gcc/config.gcc
|
||||
+++ b/gcc/config.gcc
|
||||
@@ -529,6 +529,9 @@ case ${target} in
|
||||
alpha*)
|
||||
tm_file="${cpu_type}/${cpu_type}.h alpha/elf.h alpha/linux.h alpha/linux-elf.h gnu.h ${tm_file}"
|
||||
;;
|
||||
+ i[34567]86-*hurd*-*)
|
||||
+ tm_file="${cpu_type}/${cpu_type}.h i386/unix.h i386/att.h dbxelf.h elfos.h svr4.h i386/gnu.h gnu.h ${tm_file}"
|
||||
+ ;;
|
||||
i[34567]86-*-*)
|
||||
tm_file="${cpu_type}/${cpu_type}.h i386/unix.h i386/att.h dbxelf.h elfos.h svr4.h linux.h i386/linux.h gnu.h ${tm_file}"
|
||||
;;
|
79
toolchain/gcc/patches/4.3.5/105-libtool.patch
Normal file
79
toolchain/gcc/patches/4.3.5/105-libtool.patch
Normal file
@ -0,0 +1,79 @@
|
||||
2008-03-02 Ralf Wildenhues <Ralf.Wildenhues@gmx.de>
|
||||
|
||||
Backport from upstream Libtool:
|
||||
|
||||
2007-10-12 Eric Blake <ebb9@byu.net>
|
||||
|
||||
Deal with Autoconf 2.62's semantic change in m4_append.
|
||||
* ltsugar.m4 (lt_append): Replace broken versions of
|
||||
m4_append.
|
||||
(lt_if_append_uniq): Don't require separator to be overquoted, and
|
||||
avoid broken m4_append.
|
||||
(lt_dict_add): Fix typo.
|
||||
* libtool.m4 (_LT_DECL): Don't overquote separator.
|
||||
|
||||
--- a/libtool.m4
|
||||
+++ b/libtool.m4
|
||||
@@ -319,7 +319,7 @@ m4_bpatsubst([m4_bpatsubst([$1], [^ *],
|
||||
# VALUE may be 0, 1 or 2 for a computed quote escaped value based on
|
||||
# VARNAME. Any other value will be used directly.
|
||||
m4_define([_LT_DECL],
|
||||
-[lt_if_append_uniq([lt_decl_varnames], [$2], [[, ]],
|
||||
+[lt_if_append_uniq([lt_decl_varnames], [$2], [, ],
|
||||
[lt_dict_add_subkey([lt_decl_dict], [$2], [libtool_name],
|
||||
[m4_ifval([$1], [$1], [$2])])
|
||||
lt_dict_add_subkey([lt_decl_dict], [$2], [value], [$3])
|
||||
--- a/ltsugar.m4
|
||||
+++ b/ltsugar.m4
|
||||
@@ -1,13 +1,13 @@
|
||||
# ltsugar.m4 -- libtool m4 base layer. -*-Autoconf-*-
|
||||
#
|
||||
-# Copyright (C) 2004, 2005 Free Software Foundation, Inc.
|
||||
+# Copyright (C) 2004, 2005, 2007 Free Software Foundation, Inc.
|
||||
# Written by Gary V. Vaughan.
|
||||
#
|
||||
# This file is free software; the Free Software Foundation gives
|
||||
# unlimited permission to copy and/or distribute it, with or without
|
||||
# modifications, as long as this notice is preserved.
|
||||
|
||||
-# serial 3 ltsugar.m4
|
||||
+# serial 4 ltsugar.m4
|
||||
|
||||
# This is to help aclocal find these macros, as it can't see m4_define.
|
||||
AC_DEFUN([LTSUGAR_VERSION], [m4_if([0.1])])
|
||||
@@ -46,6 +46,20 @@ m4_define([lt_cdr],
|
||||
m4_define([lt_unquote], $1)
|
||||
|
||||
|
||||
+# lt_append(MACRO-NAME, STRING, [SEPARATOR])
|
||||
+# ------------------------------------------
|
||||
+# Redefine MACRO-NAME to hold its former content plus `SEPARATOR'`STRING'.
|
||||
+# Note that neither SEPARATOR nor STRING are expanded. No SEPARATOR is
|
||||
+# output if MACRO-NAME was previously undefined (different than defined
|
||||
+# and empty).
|
||||
+# This macro is needed until we can rely on Autoconf 2.62, since earlier
|
||||
+# versions of m4 mistakenly expanded SEPARATOR.
|
||||
+m4_define([lt_append],
|
||||
+[m4_define([$1],
|
||||
+ m4_ifdef([$1], [m4_defn([$1])[$3]])[$2])])
|
||||
+
|
||||
+
|
||||
+
|
||||
# lt_combine(SEP, PREFIX-LIST, INFIX, SUFFIX1, [SUFFIX2...])
|
||||
# ----------------------------------------------------------
|
||||
# Produce a SEP delimited list of all paired combinations of elements of
|
||||
@@ -67,10 +81,10 @@ m4_define([lt_combine],
|
||||
# by SEPARATOR if supplied) and expand UNIQ, else NOT-UNIQ.
|
||||
m4_define([lt_if_append_uniq],
|
||||
[m4_ifdef([$1],
|
||||
- [m4_bmatch($3[]m4_defn([$1])$3, $3[]m4_re_escape([$2])$3,
|
||||
- [$5],
|
||||
- [m4_append([$1], [$2], [$3])$4])],
|
||||
- [m4_append([$1], [$2], [$3])$4])])
|
||||
+ [m4_if(m4_index([$3]m4_defn([$1])[$3], [$3$2$3]), [-1],
|
||||
+ [lt_append([$1], [$2], [$3])$4],
|
||||
+ [$5])],
|
||||
+ [lt_append([$1], [$2], [$3])$4])])
|
||||
|
||||
|
||||
# lt_dict_add(DICT, KEY, VALUE)
|
11
toolchain/gcc/patches/4.3.5/106-fix_linker_error.patch
Normal file
11
toolchain/gcc/patches/4.3.5/106-fix_linker_error.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- a/gcc/cp/Make-lang.in
|
||||
+++ b/gcc/cp/Make-lang.in
|
||||
@@ -73,7 +73,7 @@ g++-cross$(exeext): g++$(exeext)
|
||||
CXX_C_OBJS = attribs.o c-common.o c-format.o c-pragma.o c-semantics.o c-lex.o \
|
||||
c-dump.o $(CXX_TARGET_OBJS) c-pretty-print.o c-opts.o c-pch.o \
|
||||
c-incpath.o cppdefault.o c-ppoutput.o c-cppbuiltin.o prefix.o \
|
||||
- c-gimplify.o c-omp.o tree-inline.o
|
||||
+ c-gimplify.o c-omp.o
|
||||
|
||||
# Language-specific object files for C++ and Objective C++.
|
||||
CXX_AND_OBJCXX_OBJS = cp/call.o cp/decl.o cp/expr.o cp/pt.o cp/typeck2.o \
|
11
toolchain/gcc/patches/4.3.5/301-missing-execinfo_h.patch
Normal file
11
toolchain/gcc/patches/4.3.5/301-missing-execinfo_h.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- a/boehm-gc/include/gc.h
|
||||
+++ b/boehm-gc/include/gc.h
|
||||
@@ -503,7 +503,7 @@ GC_API GC_PTR GC_malloc_atomic_ignore_of
|
||||
#if defined(__linux__) || defined(__GLIBC__)
|
||||
# include <features.h>
|
||||
# if (__GLIBC__ == 2 && __GLIBC_MINOR__ >= 1 || __GLIBC__ > 2) \
|
||||
- && !defined(__ia64__)
|
||||
+ && !defined(__ia64__) && !defined(__UCLIBC__)
|
||||
# ifndef GC_HAVE_BUILTIN_BACKTRACE
|
||||
# define GC_HAVE_BUILTIN_BACKTRACE
|
||||
# endif
|
11
toolchain/gcc/patches/4.3.5/302-c99-snprintf.patch
Normal file
11
toolchain/gcc/patches/4.3.5/302-c99-snprintf.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- a/libstdc++-v3/include/c_global/cstdio
|
||||
+++ b/libstdc++-v3/include/c_global/cstdio
|
||||
@@ -144,7 +144,7 @@ _GLIBCXX_BEGIN_NAMESPACE(std)
|
||||
|
||||
_GLIBCXX_END_NAMESPACE
|
||||
|
||||
-#if _GLIBCXX_USE_C99
|
||||
+#if _GLIBCXX_USE_C99 || defined __UCLIBC__
|
||||
|
||||
#undef snprintf
|
||||
#undef vfscanf
|
@ -0,0 +1,47 @@
|
||||
--- a/libmudflap/mf-hooks2.c
|
||||
+++ b/libmudflap/mf-hooks2.c
|
||||
@@ -427,7 +427,7 @@ WRAPPER2(void, bzero, void *s, size_t n)
|
||||
{
|
||||
TRACE ("%s\n", __PRETTY_FUNCTION__);
|
||||
MF_VALIDATE_EXTENT(s, n, __MF_CHECK_WRITE, "bzero region");
|
||||
- bzero (s, n);
|
||||
+ memset (s, 0, n);
|
||||
}
|
||||
|
||||
|
||||
@@ -437,7 +437,7 @@ WRAPPER2(void, bcopy, const void *src, v
|
||||
TRACE ("%s\n", __PRETTY_FUNCTION__);
|
||||
MF_VALIDATE_EXTENT(src, n, __MF_CHECK_READ, "bcopy src");
|
||||
MF_VALIDATE_EXTENT(dest, n, __MF_CHECK_WRITE, "bcopy dest");
|
||||
- bcopy (src, dest, n);
|
||||
+ memmove (dest, src, n);
|
||||
}
|
||||
|
||||
|
||||
@@ -447,7 +447,7 @@ WRAPPER2(int, bcmp, const void *s1, cons
|
||||
TRACE ("%s\n", __PRETTY_FUNCTION__);
|
||||
MF_VALIDATE_EXTENT(s1, n, __MF_CHECK_READ, "bcmp 1st arg");
|
||||
MF_VALIDATE_EXTENT(s2, n, __MF_CHECK_READ, "bcmp 2nd arg");
|
||||
- return bcmp (s1, s2, n);
|
||||
+ return n == 0 ? 0 : memcmp (s1, s2, n);
|
||||
}
|
||||
|
||||
|
||||
@@ -456,7 +456,7 @@ WRAPPER2(char *, index, const char *s, i
|
||||
size_t n = strlen (s);
|
||||
TRACE ("%s\n", __PRETTY_FUNCTION__);
|
||||
MF_VALIDATE_EXTENT(s, CLAMPADD(n, 1), __MF_CHECK_READ, "index region");
|
||||
- return index (s, c);
|
||||
+ return strchr (s, c);
|
||||
}
|
||||
|
||||
|
||||
@@ -465,7 +465,7 @@ WRAPPER2(char *, rindex, const char *s,
|
||||
size_t n = strlen (s);
|
||||
TRACE ("%s\n", __PRETTY_FUNCTION__);
|
||||
MF_VALIDATE_EXTENT(s, CLAMPADD(n, 1), __MF_CHECK_READ, "rindex region");
|
||||
- return rindex (s, c);
|
||||
+ return strrchr (s, c);
|
||||
}
|
||||
|
||||
/* XXX: stpcpy, memccpy */
|
71
toolchain/gcc/patches/4.3.5/410-fix_pr37436.patch
Normal file
71
toolchain/gcc/patches/4.3.5/410-fix_pr37436.patch
Normal file
@ -0,0 +1,71 @@
|
||||
--- a/gcc/config/arm/arm.c
|
||||
+++ b/gcc/config/arm/arm.c
|
||||
@@ -3769,6 +3769,7 @@ arm_legitimate_address_p (enum machine_m
|
||||
rtx xop1 = XEXP (x, 1);
|
||||
|
||||
return ((arm_address_register_rtx_p (xop0, strict_p)
|
||||
+ && GET_CODE(xop1) == CONST_INT
|
||||
&& arm_legitimate_index_p (mode, xop1, outer, strict_p))
|
||||
|| (arm_address_register_rtx_p (xop1, strict_p)
|
||||
&& arm_legitimate_index_p (mode, xop0, outer, strict_p)));
|
||||
--- a/gcc/config/arm/arm.md
|
||||
+++ b/gcc/config/arm/arm.md
|
||||
@@ -4199,7 +4199,7 @@
|
||||
|
||||
(define_expand "extendqihi2"
|
||||
[(set (match_dup 2)
|
||||
- (ashift:SI (match_operand:QI 1 "general_operand" "")
|
||||
+ (ashift:SI (match_operand:QI 1 "arm_reg_or_extendqisi_mem_op" "")
|
||||
(const_int 24)))
|
||||
(set (match_operand:HI 0 "s_register_operand" "")
|
||||
(ashiftrt:SI (match_dup 2)
|
||||
@@ -4224,7 +4224,7 @@
|
||||
|
||||
(define_insn "*arm_extendqihi_insn"
|
||||
[(set (match_operand:HI 0 "s_register_operand" "=r")
|
||||
- (sign_extend:HI (match_operand:QI 1 "memory_operand" "Uq")))]
|
||||
+ (sign_extend:HI (match_operand:QI 1 "arm_extendqisi_mem_op" "Uq")))]
|
||||
"TARGET_ARM && arm_arch4"
|
||||
"ldr%(sb%)\\t%0, %1"
|
||||
[(set_attr "type" "load_byte")
|
||||
@@ -4235,7 +4235,7 @@
|
||||
|
||||
(define_expand "extendqisi2"
|
||||
[(set (match_dup 2)
|
||||
- (ashift:SI (match_operand:QI 1 "general_operand" "")
|
||||
+ (ashift:SI (match_operand:QI 1 "arm_reg_or_extendqisi_mem_op" "")
|
||||
(const_int 24)))
|
||||
(set (match_operand:SI 0 "s_register_operand" "")
|
||||
(ashiftrt:SI (match_dup 2)
|
||||
@@ -4267,7 +4267,7 @@
|
||||
|
||||
(define_insn "*arm_extendqisi"
|
||||
[(set (match_operand:SI 0 "s_register_operand" "=r")
|
||||
- (sign_extend:SI (match_operand:QI 1 "memory_operand" "Uq")))]
|
||||
+ (sign_extend:SI (match_operand:QI 1 "arm_extendqisi_mem_op" "Uq")))]
|
||||
"TARGET_ARM && arm_arch4 && !arm_arch6"
|
||||
"ldr%(sb%)\\t%0, %1"
|
||||
[(set_attr "type" "load_byte")
|
||||
@@ -4278,7 +4278,8 @@
|
||||
|
||||
(define_insn "*arm_extendqisi_v6"
|
||||
[(set (match_operand:SI 0 "s_register_operand" "=r,r")
|
||||
- (sign_extend:SI (match_operand:QI 1 "nonimmediate_operand" "r,Uq")))]
|
||||
+ (sign_extend:SI
|
||||
+ (match_operand:QI 1 "arm_reg_or_extendqisi_mem_op" "r,Uq")))]
|
||||
"TARGET_ARM && arm_arch6"
|
||||
"@
|
||||
sxtb%?\\t%0, %1
|
||||
--- a/gcc/config/arm/predicates.md
|
||||
+++ b/gcc/config/arm/predicates.md
|
||||
@@ -234,6 +234,10 @@
|
||||
(match_test "arm_legitimate_address_p (mode, XEXP (op, 0), SIGN_EXTEND,
|
||||
0)")))
|
||||
|
||||
+(define_special_predicate "arm_reg_or_extendqisi_mem_op"
|
||||
+ (ior (match_operand 0 "arm_extendqisi_mem_op")
|
||||
+ (match_operand 0 "s_register_operand")))
|
||||
+
|
||||
(define_predicate "power_of_two_operand"
|
||||
(match_code "const_int")
|
||||
{
|
25
toolchain/gcc/patches/4.3.5/810-arm-softfloat-libgcc.patch
Normal file
25
toolchain/gcc/patches/4.3.5/810-arm-softfloat-libgcc.patch
Normal file
@ -0,0 +1,25 @@
|
||||
--- a/gcc/config/arm/t-linux
|
||||
+++ b/gcc/config/arm/t-linux
|
||||
@@ -3,7 +3,10 @@
|
||||
TARGET_LIBGCC2_CFLAGS = -fomit-frame-pointer -fPIC
|
||||
|
||||
LIB1ASMSRC = arm/lib1funcs.asm
|
||||
-LIB1ASMFUNCS = _udivsi3 _divsi3 _umodsi3 _modsi3 _dvmd_lnx
|
||||
+LIB1ASMFUNCS = _udivsi3 _divsi3 _umodsi3 _modsi3 _dvmd_lnx \
|
||||
+ _negdf2 _addsubdf3 _muldivdf3 _cmpdf2 _unorddf2 _fixdfsi _fixunsdfsi \
|
||||
+ _truncdfsf2 _negsf2 _addsubsf3 _muldivsf3 _cmpsf2 _unordsf2 \
|
||||
+ _fixsfsi _fixunssfsi _floatdidf _floatundidf _floatdisf _floatundisf
|
||||
|
||||
# MULTILIB_OPTIONS = mhard-float/msoft-float
|
||||
# MULTILIB_DIRNAMES = hard-float soft-float
|
||||
--- a/gcc/config/arm/linux-elf.h
|
||||
+++ b/gcc/config/arm/linux-elf.h
|
||||
@@ -60,7 +60,7 @@
|
||||
%{shared:-lc} \
|
||||
%{!shared:%{profile:-lc_p}%{!profile:-lc}}"
|
||||
|
||||
-#define LIBGCC_SPEC "%{msoft-float:-lfloat} %{mfloat-abi=soft*:-lfloat} -lgcc"
|
||||
+#define LIBGCC_SPEC "-lgcc"
|
||||
|
||||
#define GLIBC_DYNAMIC_LINKER "/lib/ld-linux.so.2"
|
||||
|
36
toolchain/gcc/patches/4.3.5/820-libgcc_pic.patch
Normal file
36
toolchain/gcc/patches/4.3.5/820-libgcc_pic.patch
Normal file
@ -0,0 +1,36 @@
|
||||
--- a/libgcc/Makefile.in
|
||||
+++ b/libgcc/Makefile.in
|
||||
@@ -680,11 +680,12 @@ $(libgcov-objects): %$(objext): $(gcc_sr
|
||||
|
||||
# Static libraries.
|
||||
libgcc.a: $(libgcc-objects)
|
||||
+libgcc_pic.a: $(libgcc-s-objects)
|
||||
libgcov.a: $(libgcov-objects)
|
||||
libunwind.a: $(libunwind-objects)
|
||||
libgcc_eh.a: $(libgcc-eh-objects)
|
||||
|
||||
-libgcc.a libgcov.a libunwind.a libgcc_eh.a:
|
||||
+libgcc.a libgcov.a libunwind.a libgcc_eh.a libgcc_pic.a:
|
||||
-rm -f $@
|
||||
|
||||
objects="$(objects)"; \
|
||||
@@ -706,7 +707,7 @@ libgcc_s$(SHLIB_EXT): libunwind$(SHLIB_E
|
||||
endif
|
||||
|
||||
ifeq ($(enable_shared),yes)
|
||||
-all: libgcc_eh.a libgcc_s$(SHLIB_EXT)
|
||||
+all: libgcc_eh.a libgcc_pic.a libgcc_s$(SHLIB_EXT)
|
||||
ifneq ($(LIBUNWIND),)
|
||||
all: libunwind$(SHLIB_EXT)
|
||||
endif
|
||||
@@ -879,6 +880,10 @@ install-shared:
|
||||
chmod 644 $(DESTDIR)$(inst_libdir)/libgcc_eh.a
|
||||
$(RANLIB) $(DESTDIR)$(inst_libdir)/libgcc_eh.a
|
||||
|
||||
+ $(INSTALL_DATA) libgcc_pic.a $(mapfile) $(DESTDIR)$(inst_libdir)/
|
||||
+ chmod 644 $(DESTDIR)$(inst_libdir)/libgcc_pic.a
|
||||
+ $(RANLIB) $(DESTDIR)$(inst_libdir)/libgcc_pic.a
|
||||
+
|
||||
$(subst @multilib_dir@,$(MULTIDIR),$(subst \
|
||||
@shlib_base_name@,libgcc_s,$(subst \
|
||||
@shlib_slibdir_qual@,$(MULTIOSSUBDIR),$(SHLIB_INSTALL))))
|
270
toolchain/gcc/patches/4.3.5/910-mbsd_multi.patch
Normal file
270
toolchain/gcc/patches/4.3.5/910-mbsd_multi.patch
Normal file
@ -0,0 +1,270 @@
|
||||
|
||||
This patch brings over a few features from MirBSD:
|
||||
* -fhonour-copts
|
||||
If this option is not given, it's warned (depending
|
||||
on environment variables). This is to catch errors
|
||||
of misbuilt packages which override CFLAGS themselves.
|
||||
* -Werror-maybe-reset
|
||||
Has the effect of -Wno-error if GCC_NO_WERROR is
|
||||
set and not '0', a no-operation otherwise. This is
|
||||
to be able to use -Werror in "make" but prevent
|
||||
GNU autoconf generated configure scripts from
|
||||
freaking out.
|
||||
* Make -fno-strict-aliasing and -fno-delete-null-pointer-checks
|
||||
the default for -O2/-Os, because they trigger gcc bugs
|
||||
and can delete code with security implications.
|
||||
|
||||
This patch was authored by Thorsten Glaser <tg at mirbsd.de>
|
||||
with copyright assignment to the FSF in effect.
|
||||
|
||||
--- a/gcc/c-opts.c
|
||||
+++ b/gcc/c-opts.c
|
||||
@@ -108,6 +108,9 @@ static size_t deferred_count;
|
||||
/* Number of deferred options scanned for -include. */
|
||||
static size_t include_cursor;
|
||||
|
||||
+/* Check if a port honours COPTS. */
|
||||
+static int honour_copts = 0;
|
||||
+
|
||||
static void set_Wimplicit (int);
|
||||
static void handle_OPT_d (const char *);
|
||||
static void set_std_cxx98 (int);
|
||||
@@ -462,6 +465,14 @@ c_common_handle_option (size_t scode, co
|
||||
enable_warning_as_error ("implicit-function-declaration", value, CL_C | CL_ObjC);
|
||||
break;
|
||||
|
||||
+ case OPT_Werror_maybe_reset:
|
||||
+ {
|
||||
+ char *ev = getenv ("GCC_NO_WERROR");
|
||||
+ if ((ev != NULL) && (*ev != '0'))
|
||||
+ cpp_opts->warnings_are_errors = 0;
|
||||
+ }
|
||||
+ break;
|
||||
+
|
||||
case OPT_Wformat:
|
||||
set_Wformat (value);
|
||||
break;
|
||||
@@ -708,6 +719,12 @@ c_common_handle_option (size_t scode, co
|
||||
flag_exceptions = value;
|
||||
break;
|
||||
|
||||
+ case OPT_fhonour_copts:
|
||||
+ if (c_language == clk_c) {
|
||||
+ honour_copts++;
|
||||
+ }
|
||||
+ break;
|
||||
+
|
||||
case OPT_fimplement_inlines:
|
||||
flag_implement_inlines = value;
|
||||
break;
|
||||
@@ -1248,6 +1265,47 @@ c_common_init (void)
|
||||
/* Has to wait until now so that cpplib has its hash table. */
|
||||
init_pragma ();
|
||||
|
||||
+ if (c_language == clk_c) {
|
||||
+ char *ev = getenv ("GCC_HONOUR_COPTS");
|
||||
+ int evv;
|
||||
+ if (ev == NULL)
|
||||
+ evv = -1;
|
||||
+ else if ((*ev == '0') || (*ev == '\0'))
|
||||
+ evv = 0;
|
||||
+ else if (*ev == '1')
|
||||
+ evv = 1;
|
||||
+ else if (*ev == '2')
|
||||
+ evv = 2;
|
||||
+ else if (*ev == 's')
|
||||
+ evv = -1;
|
||||
+ else {
|
||||
+ warning (0, "unknown GCC_HONOUR_COPTS value, assuming 1");
|
||||
+ evv = 1; /* maybe depend this on something like MIRBSD_NATIVE? */
|
||||
+ }
|
||||
+ if (evv == 1) {
|
||||
+ if (honour_copts == 0) {
|
||||
+ error ("someone does not honour COPTS at all in lenient mode");
|
||||
+ return false;
|
||||
+ } else if (honour_copts != 1) {
|
||||
+ warning (0, "someone does not honour COPTS correctly, passed %d times",
|
||||
+ honour_copts);
|
||||
+ }
|
||||
+ } else if (evv == 2) {
|
||||
+ if (honour_copts == 0) {
|
||||
+ error ("someone does not honour COPTS at all in strict mode");
|
||||
+ return false;
|
||||
+ } else if (honour_copts != 1) {
|
||||
+ error ("someone does not honour COPTS correctly, passed %d times",
|
||||
+ honour_copts);
|
||||
+ return false;
|
||||
+ }
|
||||
+ } else if (evv == 0) {
|
||||
+ if (honour_copts != 1)
|
||||
+ inform ("someone does not honour COPTS correctly, passed %d times",
|
||||
+ honour_copts);
|
||||
+ }
|
||||
+ }
|
||||
+
|
||||
return true;
|
||||
}
|
||||
|
||||
--- a/gcc/c.opt
|
||||
+++ b/gcc/c.opt
|
||||
@@ -207,6 +207,10 @@ Werror-implicit-function-declaration
|
||||
C ObjC RejectNegative Warning
|
||||
This switch is deprecated; use -Werror=implicit-function-declaration instead
|
||||
|
||||
+Werror-maybe-reset
|
||||
+C ObjC C++ ObjC++
|
||||
+; Documented in common.opt
|
||||
+
|
||||
Wfloat-equal
|
||||
C ObjC C++ ObjC++ Var(warn_float_equal) Warning
|
||||
Warn if testing floating point numbers for equality
|
||||
@@ -590,6 +594,9 @@ C++ ObjC++ Optimization
|
||||
fhonor-std
|
||||
C++ ObjC++
|
||||
|
||||
+fhonour-copts
|
||||
+C ObjC C++ ObjC++ RejectNegative
|
||||
+
|
||||
fhosted
|
||||
C ObjC
|
||||
Assume normal C execution environment
|
||||
--- a/gcc/common.opt
|
||||
+++ b/gcc/common.opt
|
||||
@@ -102,6 +102,10 @@ Werror=
|
||||
Common Joined
|
||||
Treat specified warning as error
|
||||
|
||||
+Werror-maybe-reset
|
||||
+Common
|
||||
+If environment variable GCC_NO_WERROR is set, act as -Wno-error
|
||||
+
|
||||
Wextra
|
||||
Common Warning
|
||||
Print extra (possibly unwanted) warnings
|
||||
@@ -528,6 +532,9 @@ fguess-branch-probability
|
||||
Common Report Var(flag_guess_branch_prob) Optimization
|
||||
Enable guessing of branch probabilities
|
||||
|
||||
+fhonour-copts
|
||||
+Common RejectNegative
|
||||
+
|
||||
; Nonzero means ignore `#ident' directives. 0 means handle them.
|
||||
; Generate position-independent code for executables if possible
|
||||
; On SVR4 targets, it also controls whether or not to emit a
|
||||
--- a/gcc/opts.c
|
||||
+++ b/gcc/opts.c
|
||||
@@ -830,9 +830,6 @@ decode_options (unsigned int argc, const
|
||||
flag_schedule_insns_after_reload = 1;
|
||||
#endif
|
||||
flag_regmove = 1;
|
||||
- flag_strict_aliasing = 1;
|
||||
- flag_strict_overflow = 1;
|
||||
- flag_delete_null_pointer_checks = 1;
|
||||
flag_reorder_blocks = 1;
|
||||
flag_reorder_functions = 1;
|
||||
flag_tree_store_ccp = 1;
|
||||
@@ -853,6 +850,10 @@ decode_options (unsigned int argc, const
|
||||
|
||||
if (optimize >= 3)
|
||||
{
|
||||
+ flag_strict_aliasing = 1;
|
||||
+ flag_strict_overflow = 1;
|
||||
+ flag_delete_null_pointer_checks = 1;
|
||||
+
|
||||
flag_predictive_commoning = 1;
|
||||
flag_inline_functions = 1;
|
||||
flag_unswitch_loops = 1;
|
||||
@@ -1444,6 +1445,17 @@ common_handle_option (size_t scode, cons
|
||||
enable_warning_as_error (arg, value, lang_mask);
|
||||
break;
|
||||
|
||||
+ case OPT_Werror_maybe_reset:
|
||||
+ {
|
||||
+ char *ev = getenv ("GCC_NO_WERROR");
|
||||
+ if ((ev != NULL) && (*ev != '0'))
|
||||
+ warnings_are_errors = 0;
|
||||
+ }
|
||||
+ break;
|
||||
+
|
||||
+ case OPT_fhonour_copts:
|
||||
+ break;
|
||||
+
|
||||
case OPT_Wextra:
|
||||
set_Wextra (value);
|
||||
break;
|
||||
--- a/gcc/doc/cppopts.texi
|
||||
+++ b/gcc/doc/cppopts.texi
|
||||
@@ -168,6 +168,11 @@ in older programs. This warning is on b
|
||||
Make all warnings into hard errors. Source code which triggers warnings
|
||||
will be rejected.
|
||||
|
||||
+ at item -Werror-maybe-reset
|
||||
+ at opindex Werror-maybe-reset
|
||||
+Act like @samp{-Wno-error} if the @env{GCC_NO_WERROR} environment
|
||||
+variable is set to anything other than 0 or empty.
|
||||
+
|
||||
@item -Wsystem-headers
|
||||
@opindex Wsystem-headers
|
||||
Issue warnings for code in system headers. These are normally unhelpful
|
||||
--- a/gcc/doc/invoke.texi
|
||||
+++ b/gcc/doc/invoke.texi
|
||||
@@ -233,7 +233,7 @@ Objective-C and Objective-C++ Dialects}.
|
||||
-Wconversion -Wcoverage-mismatch -Wno-deprecated-declarations @gol
|
||||
-Wdisabled-optimization -Wno-div-by-zero @gol
|
||||
-Wempty-body -Wno-endif-labels @gol
|
||||
--Werror -Werror=* @gol
|
||||
+-Werror -Werror=* -Werror-maybe-reset @gol
|
||||
-Wfatal-errors -Wfloat-equal -Wformat -Wformat=2 @gol
|
||||
-Wno-format-extra-args -Wformat-nonliteral @gol
|
||||
-Wformat-security -Wformat-y2k -Wignored-qualifiers @gol
|
||||
@@ -4031,6 +4031,22 @@ This option is only supported for C and
|
||||
@option{-Wall} and by @option{-pedantic}, which can be disabled with
|
||||
@option{-Wno-pointer-sign}.
|
||||
|
||||
+ at item -Werror-maybe-reset
|
||||
+ at opindex Werror-maybe-reset
|
||||
+Act like @samp{-Wno-error} if the @env{GCC_NO_WERROR} environment
|
||||
+variable is set to anything other than 0 or empty.
|
||||
+
|
||||
+ at item -fhonour-copts
|
||||
+ at opindex fhonour-copts
|
||||
+If @env{GCC_HONOUR_COPTS} is set to 1, abort if this option is not
|
||||
+given at least once, and warn if it is given more than once.
|
||||
+If @env{GCC_HONOUR_COPTS} is set to 2, abort if this option is not
|
||||
+given exactly once.
|
||||
+If @env{GCC_HONOUR_COPTS} is set to 0 or unset, warn if this option
|
||||
+is not given exactly once.
|
||||
+The warning is quelled if @env{GCC_HONOUR_COPTS} is set to @samp{s}.
|
||||
+This flag and environment variable only affect the C language.
|
||||
+
|
||||
@item -Wstack-protector
|
||||
@opindex Wstack-protector
|
||||
@opindex Wno-stack-protector
|
||||
@@ -5493,7 +5509,7 @@ so, the first branch is redirected to ei
|
||||
second branch or a point immediately following it, depending on whether
|
||||
the condition is known to be true or false.
|
||||
|
||||
-Enabled at levels @option{-O2}, @option{-O3}, @option{-Os}.
|
||||
+Enabled at levels @option{-O3}.
|
||||
|
||||
@item -fsplit-wide-types
|
||||
@opindex fsplit-wide-types
|
||||
@@ -5638,7 +5654,7 @@ safely dereference null pointers. Use
|
||||
@option{-fno-delete-null-pointer-checks} to disable this optimization
|
||||
for programs which depend on that behavior.
|
||||
|
||||
-Enabled at levels @option{-O2}, @option{-O3}, @option{-Os}.
|
||||
+Enabled at levels @option{-O3}.
|
||||
|
||||
@item -fexpensive-optimizations
|
||||
@opindex fexpensive-optimizations
|
||||
--- a/gcc/java/jvspec.c
|
||||
+++ b/gcc/java/jvspec.c
|
||||
@@ -670,6 +670,7 @@ lang_specific_pre_link (void)
|
||||
class name. Append dummy `.c' that can be stripped by set_input so %b
|
||||
is correct. */
|
||||
set_input (concat (main_class_name, "main.c", NULL));
|
||||
+ putenv ("GCC_HONOUR_COPTS=s"); /* XXX hack! */
|
||||
err = do_spec (jvgenmain_spec);
|
||||
if (err == 0)
|
||||
{
|
@ -0,0 +1,37 @@
|
||||
gcc/ChangeLog
|
||||
2007-11-27 Bernhard Fischer <>
|
||||
|
||||
* config/arm/arm-protos.h (arm_vector_mode_supported_p,
|
||||
arm_hard_regno_mode_ok, const_ok_for_arm): Do not hide non-rtx related
|
||||
function prototypes in RTX_CODE.
|
||||
* genopinit.c: Include tm_p.h.
|
||||
|
||||
--- a/gcc/config/arm/arm-protos.h
|
||||
+++ b/gcc/config/arm/arm-protos.h
|
||||
@@ -40,15 +40,14 @@ extern HOST_WIDE_INT thumb_compute_initi
|
||||
unsigned int);
|
||||
extern unsigned int arm_dbx_register_number (unsigned int);
|
||||
extern void arm_output_fn_unwind (FILE *, bool);
|
||||
-
|
||||
|
||||
#ifdef TREE_CODE
|
||||
extern int arm_return_in_memory (const_tree);
|
||||
#endif
|
||||
-#ifdef RTX_CODE
|
||||
extern bool arm_vector_mode_supported_p (enum machine_mode);
|
||||
extern int arm_hard_regno_mode_ok (unsigned int, enum machine_mode);
|
||||
extern int const_ok_for_arm (HOST_WIDE_INT);
|
||||
+#ifdef RTX_CODE
|
||||
extern int arm_split_constant (RTX_CODE, enum machine_mode, rtx,
|
||||
HOST_WIDE_INT, rtx, rtx, int);
|
||||
extern RTX_CODE arm_canonicalize_comparison (RTX_CODE, enum machine_mode,
|
||||
--- a/gcc/genopinit.c
|
||||
+++ b/gcc/genopinit.c
|
||||
@@ -487,6 +487,7 @@ from the machine description file `md'.
|
||||
printf ("#include \"expr.h\"\n");
|
||||
printf ("#include \"optabs.h\"\n");
|
||||
printf ("#include \"reload.h\"\n\n");
|
||||
+ printf ("#include \"tm_p.h\"\n\n");
|
||||
|
||||
printf ("void\ninit_all_optabs (void)\n{\n");
|
||||
|
42
toolchain/gcc/patches/4.3.5/995-short-enums.diff
Normal file
42
toolchain/gcc/patches/4.3.5/995-short-enums.diff
Normal file
@ -0,0 +1,42 @@
|
||||
see gcc PR34205
|
||||
Index: gcc-4.3.0/gcc/tree.h
|
||||
===================================================================
|
||||
--- gcc-4.3.0/gcc/tree.h (revision 130511)
|
||||
+++ gcc-4.3.0/gcc/tree.h (working copy)
|
||||
@@ -38,6 +38,7 @@
|
||||
|
||||
LAST_AND_UNUSED_TREE_CODE /* A convenient way to get a value for
|
||||
NUM_TREE_CODES. */
|
||||
+ ,__LAST_AND_UNUSED_TREE_CODE=32767 /* Force 16bit width. */
|
||||
};
|
||||
|
||||
#undef DEFTREECODE
|
||||
Index: gcc-4.3.0/gcc/rtl.h
|
||||
===================================================================
|
||||
--- gcc-4.3.0/gcc/rtl.h (revision 130511)
|
||||
+++ gcc-4.3.0/gcc/rtl.h (working copy)
|
||||
@@ -48,9 +48,11 @@
|
||||
#include "rtl.def" /* rtl expressions are documented here */
|
||||
#undef DEF_RTL_EXPR
|
||||
|
||||
- LAST_AND_UNUSED_RTX_CODE}; /* A convenient way to get a value for
|
||||
+ LAST_AND_UNUSED_RTX_CODE /* A convenient way to get a value for
|
||||
NUM_RTX_CODE.
|
||||
Assumes default enum value assignment. */
|
||||
+ ,__LAST_AND_UNUSED_RTX_CODE=32767 /* Force 16bit width. */
|
||||
+};
|
||||
|
||||
#define NUM_RTX_CODE ((int) LAST_AND_UNUSED_RTX_CODE)
|
||||
/* The cast here, saves many elsewhere. */
|
||||
Index: gcc-4.3.0/gcc/c-common.h
|
||||
===================================================================
|
||||
--- gcc-4.3.0/gcc/c-common.h (revision 130511)
|
||||
+++ gcc-4.3.0/gcc/c-common.h (working copy)
|
||||
@@ -125,6 +125,7 @@
|
||||
RID_LAST_AT = RID_AT_IMPLEMENTATION,
|
||||
RID_FIRST_PQ = RID_IN,
|
||||
RID_LAST_PQ = RID_ONEWAY
|
||||
+ ,__LAST_AND_UNUSED_RID=32767 /* Force 16bit width. */
|
||||
};
|
||||
|
||||
#define OBJC_IS_AT_KEYWORD(rid) \
|
@ -0,0 +1,13 @@
|
||||
\\\\
|
||||
\\ gcc PR33200
|
||||
--- a/gcc/config.gcc
|
||||
+++ b/gcc/config.gcc
|
||||
@@ -2314,7 +2314,7 @@ sh-*-symbianelf* | sh[12346l]*-*-symbian
|
||||
if test x${enable_incomplete_targets} = xyes ; then
|
||||
tm_defines="$tm_defines SUPPORT_SH1=1 SUPPORT_SH2E=1 SUPPORT_SH4=1 SUPPORT_SH4_SINGLE=1 SUPPORT_SH2A=1 SUPPORT_SH2A_SINGLE=1 SUPPORT_SH5_32MEDIA=1 SUPPORT_SH5_32MEDIA_NOFPU=1 SUPPORT_SH5_64MEDIA=1 SUPPORT_SH5_64MEDIA_NOFPU=1"
|
||||
fi
|
||||
- use_fixproto=yes
|
||||
+ # XXX: why? use_fixproto=yes
|
||||
;;
|
||||
sh-*-rtems*)
|
||||
tmake_file="sh/t-sh sh/t-elf t-rtems sh/t-rtems"
|
10
toolchain/gcc/patches/4.3.5/999-coldfire.patch
Normal file
10
toolchain/gcc/patches/4.3.5/999-coldfire.patch
Normal file
@ -0,0 +1,10 @@
|
||||
--- a/gcc/config.gcc
|
||||
+++ b/gcc/config.gcc
|
||||
@@ -1627,6 +1627,7 @@ m68k-*-linux*) # Motorola m68k's runnin
|
||||
if test x$sjlj != x1; then
|
||||
tmake_file="$tmake_file m68k/t-slibgcc-elf-ver"
|
||||
fi
|
||||
+ tmake_file="m68k/t-floatlib m68k/t-m68kbare m68k/t-m68kelf"
|
||||
;;
|
||||
m68k-*-rtems*)
|
||||
default_m68k_cpu=68020
|
Loading…
Reference in New Issue
Block a user