add xsupplicant package (thanks to Florian Fainelli)
SVN-Revision: 2188
This commit is contained in:
parent
daec54c846
commit
3881fcbbe0
@ -123,16 +123,17 @@ source "package/ulogd/Config.in"
|
||||
source "package/updatedd/Config.in"
|
||||
source "package/vsftpd/Config.in"
|
||||
source "package/vtun/Config.in"
|
||||
source "package/wireless-tools/Config.in"
|
||||
source "package/wol/Config.in"
|
||||
source "package/wpa_supplicant/Config.in"
|
||||
source "package/wput/Config.in"
|
||||
source "package/xinetd/Config.in"
|
||||
source "package/wificonf/Config.in"
|
||||
source "package/wifidog/Config.in"
|
||||
source "package/wireless-tools/Config.in"
|
||||
source "package/wiviz/Config.in"
|
||||
source "package/wol/Config.in"
|
||||
source "package/wondershaper/Config.in"
|
||||
source "package/wpa_supplicant/Config.in"
|
||||
source "package/wput/Config.in"
|
||||
source "package/wrt-radauth/Config.in"
|
||||
source "package/xinetd/Config.in"
|
||||
source "package/xsupplicant/Config.in"
|
||||
|
||||
comment "Libraries"
|
||||
source "package/cgilib/Config.in"
|
||||
|
@ -202,6 +202,7 @@ package-$(BR2_PACKAGE_WPA_SUPPLICANT) += wpa_supplicant
|
||||
package-$(BR2_PACKAGE_WPUT) += wput
|
||||
package-$(BR2_PACKAGE_WRT_RADAUTH) += wrt-radauth
|
||||
package-$(BR2_PACKAGE_XINETD) += xinetd
|
||||
package-$(BR2_PACKAGE_XSUPPLICANT) += xsupplicant
|
||||
package-$(BR2_PACKAGE_ZLIB) += zlib
|
||||
|
||||
DEV_LIBS:=tcp_wrappers glib ncurses openssl pcre popt zlib libnet libpcap mysql postgresql iptables matrixssl lzo gmp fuse portmap libelf uclibc++ speex libpng libgd wireless-tools nvram linux-atm
|
||||
@ -293,6 +294,7 @@ usbutils-compile: libusb-compile
|
||||
vtun-compile: zlib-compile openssl-compile lzo-compile
|
||||
wificonf-compile: wireless-tools-compile nvram-compile
|
||||
wpa_supplicant-compile: openssl-compile
|
||||
xsupplicant-compile: openssl-compile
|
||||
|
||||
asterisk-compile: bluez-libs-compile ncurses-compile openssl-compile
|
||||
ifneq ($(BR2_PACKAGE_ASTERISK_CODEC_SPEEX),)
|
||||
|
11
openwrt/package/xsupplicant/Config.in
Normal file
11
openwrt/package/xsupplicant/Config.in
Normal file
@ -0,0 +1,11 @@
|
||||
config BR2_PACKAGE_XSUPPLICANT
|
||||
tristate "xsupplicant - a fully compliant 802.1x authenticator"
|
||||
default m if CONFIG_DEVEL
|
||||
select BR2_PACKAGE_LIBOPENSSL
|
||||
select BR2_PACKAGE_WIRELESS_TOOLS
|
||||
help
|
||||
This software allows a GNU/Linux or BSD workstation to authenticate with
|
||||
a RADIUS server using 802.1x and various EAP protocols.
|
||||
|
||||
http://open1x.sourceforge.net/
|
||||
|
70
openwrt/package/xsupplicant/Makefile
Normal file
70
openwrt/package/xsupplicant/Makefile
Normal file
@ -0,0 +1,70 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=xsupplicant
|
||||
PKG_VERSION:=1.2.2
|
||||
PKG_RELEASE:=1
|
||||
PKG_MD5SUM:=0e9aaf83a11f8eaff7c6564a53c25d8e
|
||||
|
||||
PKG_SOURCE_URL:=@SF/open1x
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_CAT:=zcat
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
|
||||
|
||||
include $(TOPDIR)/package/rules.mk
|
||||
|
||||
$(eval $(call PKG_template,XSUPPLICANT,xsupplicant,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
|
||||
|
||||
$(PKG_BUILD_DIR)/.configured:
|
||||
(cd $(PKG_BUILD_DIR); rm -rf config.{cache,status}; \
|
||||
touch configure.in; \
|
||||
touch aclocal.m4; \
|
||||
touch Makefile.in; \
|
||||
touch configure; \
|
||||
$(TARGET_CONFIGURE_OPTS) \
|
||||
CFLAGS="$(TARGET_CFLAGS)" \
|
||||
CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
|
||||
LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
|
||||
./configure \
|
||||
--target=$(GNU_TARGET_NAME) \
|
||||
--host=$(GNU_TARGET_NAME) \
|
||||
--build=$(GNU_HOST_NAME) \
|
||||
--program-prefix="" \
|
||||
--program-suffix="" \
|
||||
--prefix=/usr \
|
||||
--exec-prefix=/usr \
|
||||
--bindir=/usr/bin \
|
||||
--datadir=/usr/share \
|
||||
--includedir=/usr/include \
|
||||
--infodir=/usr/share/info \
|
||||
--libdir=/usr/lib \
|
||||
--libexecdir=/usr/lib \
|
||||
--localstatedir=/var \
|
||||
--mandir=/usr/share/man \
|
||||
--sbindir=/usr/sbin \
|
||||
--sysconfdir=/etc \
|
||||
$(DISABLE_LARGEFILE) \
|
||||
$(DISABLE_NLS) \
|
||||
--with-openssl="$(STAGING_DIR)/usr" \
|
||||
--with-madwifi-path="$(STAGING_DIR)/usr/include/madwifi" \
|
||||
);
|
||||
touch $@
|
||||
|
||||
$(PKG_BUILD_DIR)/.built:
|
||||
rm -rf $(PKG_INSTALL_DIR)
|
||||
mkdir -p $(PKG_INSTALL_DIR)
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||
DESTDIR=$(PKG_INSTALL_DIR) \
|
||||
all install
|
||||
touch $@
|
||||
|
||||
$(IPKG_XSUPPLICANT):
|
||||
install -d -m0755 $(IDIR_XSUPPLICANT)/etc
|
||||
install -m0644 $(PKG_BUILD_DIR)/etc/xsupplicant.conf $(IDIR_XSUPPLICANT)/etc/
|
||||
install -d -m0755 $(IDIR_XSUPPLICANT)/usr/bin
|
||||
cp -fpR $(PKG_INSTALL_DIR)/usr/bin/xsup_* $(IDIR_XSUPPLICANT)/usr/bin/
|
||||
install -d -m0755 $(IDIR_XSUPPLICANT)/usr/sbin
|
||||
cp -fpR $(PKG_INSTALL_DIR)/usr/sbin/xsupplicant $(IDIR_XSUPPLICANT)/usr/sbin/
|
||||
$(RSTRIP) $(IDIR_XSUPPLICANT)
|
||||
$(IPKG_BUILD) $(IDIR_XSUPPLICANT) $(PACKAGE_DIR)
|
8
openwrt/package/xsupplicant/ipkg/xsupplicant.control
Normal file
8
openwrt/package/xsupplicant/ipkg/xsupplicant.control
Normal file
@ -0,0 +1,8 @@
|
||||
Package: xsupplicant
|
||||
Priority: optional
|
||||
Section: net
|
||||
Maintainer: OpenWrt Developers Team <openwrt-devel@openwrt.org>, Florian Fainelli <florian@alphacore.net>
|
||||
Source: buildroot internal
|
||||
Depends: libopenssl, wireless-tools
|
||||
Description: A fully compliant 802.1x authenticator
|
||||
|
24
openwrt/package/xsupplicant/patches/001-no-lfl.patch
Normal file
24
openwrt/package/xsupplicant/patches/001-no-lfl.patch
Normal file
@ -0,0 +1,24 @@
|
||||
diff -ruN xsupplicant-1.2.2-old/configure xsupplicant-1.2.2-new/configure
|
||||
--- xsupplicant-1.2.2-old/configure 2005-09-14 05:34:54.000000000 +0200
|
||||
+++ xsupplicant-1.2.2-new/configure 2005-10-20 06:24:23.000000000 +0200
|
||||
@@ -3316,7 +3316,7 @@
|
||||
fi
|
||||
if test -n "$LEX"; then
|
||||
LFLAGS="$LFLAGS -i"
|
||||
- MORELIBS="${MORELIBS} -lfl"
|
||||
+
|
||||
fi
|
||||
|
||||
echo "$as_me:$LINENO: checking whether byte ordering is bigendian" >&5
|
||||
diff -ruN xsupplicant-1.2.2-old/configure.in xsupplicant-1.2.2-new/configure.in
|
||||
--- xsupplicant-1.2.2-old/configure.in 2005-09-14 05:34:54.000000000 +0200
|
||||
+++ xsupplicant-1.2.2-new/configure.in 2005-10-20 06:23:38.000000000 +0200
|
||||
@@ -17,7 +17,7 @@
|
||||
AM_PROG_LEX
|
||||
if test -n "$LEX"; then
|
||||
LFLAGS="$LFLAGS -i"
|
||||
- MORELIBS="${MORELIBS} -lfl"
|
||||
+
|
||||
fi
|
||||
|
||||
AC_C_BIGENDIAN([big_endian=true;AC_DEFINE(BIGENDIAN)],[big_endian=false;AC_DEFINE(LILENDIAN)])
|
@ -0,0 +1,11 @@
|
||||
diff -ruN xsupplicant-1.2.2-old/src/cardif/linux/cardif_madwifi_driver.h xsupplicant-1.2.2-new/src/cardif/linux/cardif_madwifi_driver.h
|
||||
--- xsupplicant-1.2.2-old/src/cardif/linux/cardif_madwifi_driver.h 2005-04-06 04:21:53.000000000 +0200
|
||||
+++ xsupplicant-1.2.2-new/src/cardif/linux/cardif_madwifi_driver.h 2005-10-17 22:03:19.000000000 +0200
|
||||
@@ -21,6 +21,7 @@
|
||||
int cardif_madwifi_driver_set_key(char *, int, unsigned char *, int, int,
|
||||
char *, int, char *, int);
|
||||
int cardif_madwifi_driver_wpa_state(struct interface_data *, char);
|
||||
+void cardif_madwifi_driver_associate(struct interface_data *, char *);
|
||||
int cardif_madwifi_driver_disassociate(struct interface_data *, int);
|
||||
|
||||
#endif // _CARDIF_MADWIFI_DRIVER_H_
|
Loading…
Reference in New Issue
Block a user