remove pcmcia and sdio
This fixes #6701 Remove the pcmcia and sdio interface from b43 driver to not depend on these modules. SVN-Revision: 19756
This commit is contained in:
parent
8a1f7817d1
commit
3889c76a6e
@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
|
||||
PKG_NAME:=mac80211
|
||||
|
||||
PKG_VERSION:=2010-02-16
|
||||
PKG_RELEASE:=2
|
||||
PKG_RELEASE:=3
|
||||
PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources
|
||||
# http://www.orbit-lab.org/kernel/compat-wireless-2.6/2010/11 \
|
||||
# http://wireless.kernel.org/download/compat-wireless-2.6
|
||||
|
@ -5,7 +5,25 @@
|
||||
CONFIG_PCI=y
|
||||
CONFIG_USB=y
|
||||
- CONFIG_PCMCIA=y
|
||||
+ # CONFIG_PCMCIA=y
|
||||
+# CONFIG_PCMCIA=y
|
||||
CONFIG_SSB=m
|
||||
else
|
||||
include $(KLIB_BUILD)/.config
|
||||
@@ -197,7 +197,7 @@ CONFIG_B43=m
|
||||
CONFIG_B43_HWRNG=y
|
||||
CONFIG_B43_PCI_AUTOSELECT=y
|
||||
ifneq ($(CONFIG_PCMCIA),)
|
||||
-CONFIG_B43_PCMCIA=y
|
||||
+# CONFIG_B43_PCMCIA=y
|
||||
endif
|
||||
CONFIG_B43_LEDS=y
|
||||
CONFIG_B43_PHY_LP=y
|
||||
@@ -248,7 +248,7 @@ CONFIG_SSB_BLOCKIO=y
|
||||
CONFIG_SSB_PCIHOST=y
|
||||
CONFIG_SSB_B43_PCI_BRIDGE=y
|
||||
ifneq ($(CONFIG_PCMCIA),)
|
||||
-CONFIG_SSB_PCMCIAHOST=y
|
||||
+# CONFIG_SSB_PCMCIAHOST=y
|
||||
endif
|
||||
# CONFIG_SSB_DEBUG=y
|
||||
CONFIG_SSB_DRIVER_PCICORE=y
|
||||
|
13
package/mac80211/patches/011-no_sdio.patch
Normal file
13
package/mac80211/patches/011-no_sdio.patch
Normal file
@ -0,0 +1,13 @@
|
||||
--- a/config.mk
|
||||
+++ b/config.mk
|
||||
@@ -382,8 +382,8 @@ endif # end of SPI driver list
|
||||
|
||||
ifneq ($(CONFIG_MMC),)
|
||||
|
||||
-CONFIG_SSB_SDIOHOST=y
|
||||
-CONFIG_B43_SDIO=y
|
||||
+# CONFIG_SSB_SDIOHOST=y
|
||||
+# CONFIG_B43_SDIO=y
|
||||
CONFIG_WL1251_SDIO=m
|
||||
|
||||
ifdef CONFIG_COMPAT_KERNEL_27
|
@ -1,6 +1,6 @@
|
||||
--- a/net/wireless/nl80211.c
|
||||
+++ b/net/wireless/nl80211.c
|
||||
@@ -5667,7 +5667,11 @@
|
||||
@@ -5662,7 +5662,11 @@ int nl80211_send_action(struct cfg80211_
|
||||
return err;
|
||||
}
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user