Upgrade rt2500 to a CVS snapshot, builds again on 2.6

SVN-Revision: 7576
This commit is contained in:
Florian Fainelli 2007-06-11 21:35:51 +00:00
parent b187a7e887
commit 3a22d8eb29
2 changed files with 13 additions and 24 deletions

View File

@ -10,19 +10,19 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=rt2500 PKG_NAME:=rt2500
PKG_VERSION:=1.1.0-b4 PKG_VERSION:=cvs-2007061115
PKG_RELEASE:=1 PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/rt2400 PKG_SOURCE_URL:=@openwrt/
PKG_MD5SUM:=83b8b9a091705c08d99268479f3b3b6a PKG_MD5SUM:=67a158b24ec46e37edc4545f51338bb9
include $(INCLUDE_DIR)/package.mk include $(INCLUDE_DIR)/package.mk
define KernelPackage/rt2500 define KernelPackage/rt2500
SUBMENU:=Wireless Drivers SUBMENU:=Wireless Drivers
TITLE:=Driver for ralink pci wireless chipsets TITLE:=Driver for ralink pci wireless chipsets
DEPENDS:=@LINUX_2_4 @USB_SUPPORT +wireless-tools DEPENDS:=@USB_SUPPORT +wireless-tools
DESCRIPTION:=\ DESCRIPTION:=\
This package contains a driver for ralink rt2500 pci chipsets. This package contains a driver for ralink rt2500 pci chipsets.
URL:=http://rt2x00.serialmonkey.com/ URL:=http://rt2x00.serialmonkey.com/

View File

@ -1,29 +1,18 @@
Index: rt2500-1.1.0-b4/Module/rt_config.h diff -urN rt2500-cvs-2007061115.new/Module/rt_config.h rt2500-cvs-2007061115/Module/rt_config.h
=================================================================== --- rt2500-cvs-2007061115.new/Module/rt_config.h 2007-06-11 22:35:28.000000000 +0200
--- rt2500-1.1.0-b4.orig/Module/rt_config.h 2007-06-04 13:22:53.001797784 +0200 +++ rt2500-cvs-2007061115/Module/rt_config.h 2007-06-11 22:57:31.000000000 +0200
+++ rt2500-1.1.0-b4/Module/rt_config.h 2007-06-04 13:22:53.074786688 +0200 @@ -153,6 +153,7 @@
@@ -55,7 +55,7 @@
#error You must compile this driver with "-O".
#endif
-#include <linux/config.h> //can delete
+#include <linux/autoconf.h> //can delete
#include <linux/module.h>
#include <linux/version.h>
#include <linux/kernel.h>
@@ -154,6 +154,7 @@
enum rt2560_chips { enum rt2560_chips {
RT2560A = 0, RT2560A = 0,
+ RT2561T = 0, + RT2561T = 0,
}; };
#ifdef RTMP_EMBEDDED #if 1 //#ifdef RTMP_EMBEDDED
Index: rt2500-1.1.0-b4/Module/rtmp_main.c diff -urN rt2500-cvs-2007061115.new/Module/rtmp_main.c rt2500-cvs-2007061115/Module/rtmp_main.c
=================================================================== --- rt2500-cvs-2007061115.new/Module/rtmp_main.c 2007-05-29 05:49:17.000000000 +0200
--- rt2500-1.1.0-b4.orig/Module/rtmp_main.c 2007-06-04 13:22:53.008796720 +0200 +++ rt2500-cvs-2007061115/Module/rtmp_main.c 2007-06-11 22:57:13.000000000 +0200
+++ rt2500-1.1.0-b4/Module/rtmp_main.c 2007-06-04 13:22:53.074786688 +0200 @@ -1041,6 +1041,7 @@
@@ -975,6 +975,7 @@
static struct pci_device_id rt2500_pci_tbl[] __devinitdata = static struct pci_device_id rt2500_pci_tbl[] __devinitdata =
{ {
{0x1814, 0x0201, PCI_ANY_ID, PCI_ANY_ID, 0, 0, RT2560A}, {0x1814, 0x0201, PCI_ANY_ID, PCI_ANY_ID, 0, 0, RT2560A},