upgrade to linux 2.4.33.4
SVN-Revision: 5634
This commit is contained in:
parent
cf921b2f28
commit
3b9654520c
@ -16,10 +16,9 @@ define Target/Description
|
||||
(e.g. Netgear WGT624, Linksys WRT55AG)
|
||||
endef
|
||||
|
||||
|
||||
LINUX_VERSION:=2.4.32
|
||||
LINUX_VERSION:=2.4.33.4
|
||||
LINUX_RELEASE:=1
|
||||
LINUX_KERNEL_MD5SUM:=38f4d0830e95a20f4bfed17622d5557c
|
||||
LINUX_KERNEL_MD5SUM:=aca0257549c385a227088ad8853a72a2
|
||||
|
||||
include $(INCLUDE_DIR)/kernel-build.mk
|
||||
$(eval $(call BuildKernel))
|
||||
|
@ -755,6 +755,7 @@ CONFIG_MKISS=m
|
||||
#
|
||||
# CONFIG_INPUT is not set
|
||||
# CONFIG_INPUT_KEYBDEV is not set
|
||||
# CONFIG_DUMMY_KEYB is not set
|
||||
# CONFIG_INPUT_MOUSEDEV is not set
|
||||
# CONFIG_INPUT_JOYDEV is not set
|
||||
# CONFIG_INPUT_EVDEV is not set
|
||||
|
@ -15,9 +15,9 @@ define Target/Description
|
||||
Build firmware images for TI AR7 based routers (w.g. Linksys WAG54G v2)
|
||||
endef
|
||||
|
||||
LINUX_VERSION:=2.4.32
|
||||
LINUX_VERSION:=2.4.33.4
|
||||
LINUX_RELEASE:=1
|
||||
LINUX_KERNEL_MD5SUM:=38f4d0830e95a20f4bfed17622d5557c
|
||||
LINUX_KERNEL_MD5SUM:=aca0257549c385a227088ad8853a72a2
|
||||
|
||||
include $(INCLUDE_DIR)/kernel-build.mk
|
||||
DEFAULT_PACKAGES += kmod-avalanche-cpmac
|
||||
|
@ -736,6 +736,7 @@ CONFIG_SHAPER=m
|
||||
#
|
||||
# CONFIG_INPUT is not set
|
||||
# CONFIG_INPUT_KEYBDEV is not set
|
||||
# CONFIG_DUMMY_KEYB is not set
|
||||
# CONFIG_INPUT_MOUSEDEV is not set
|
||||
# CONFIG_INPUT_JOYDEV is not set
|
||||
# CONFIG_INPUT_EVDEV is not set
|
||||
|
@ -20,9 +20,9 @@ define Target/Description
|
||||
with TFTP client too.
|
||||
endef
|
||||
|
||||
LINUX_VERSION:=2.4.32
|
||||
LINUX_VERSION:=2.4.33.4
|
||||
LINUX_RELEASE:=1
|
||||
LINUX_KERNEL_MD5SUM:=38f4d0830e95a20f4bfed17622d5557c
|
||||
LINUX_KERNEL_MD5SUM:=aca0257549c385a227088ad8853a72a2
|
||||
|
||||
include $(INCLUDE_DIR)/kernel-build.mk
|
||||
DEFAULT_PACKAGES += kmod-switch nvram
|
||||
|
@ -947,6 +947,7 @@ CONFIG_MKISS=m
|
||||
#
|
||||
# CONFIG_INPUT is not set
|
||||
# CONFIG_INPUT_KEYBDEV is not set
|
||||
# CONFIG_DUMMY_KEYB is not set
|
||||
# CONFIG_INPUT_MOUSEDEV is not set
|
||||
# CONFIG_INPUT_JOYDEV is not set
|
||||
# CONFIG_INPUT_EVDEV is not set
|
||||
|
@ -184,18 +184,6 @@ diff -rupN linux-2.4.32/drivers/sound/sound_firmware.c linux-2.4.32.gcc4-fixes-v
|
||||
static int do_mod_firmware_load(const char *fn, char **fp)
|
||||
{
|
||||
int fd;
|
||||
diff -rupN linux-2.4.32/drivers/usb/host/ehci-q.c linux-2.4.32.gcc4-fixes-v12/drivers/usb/host/ehci-q.c
|
||||
--- linux-2.4.32/drivers/usb/host/ehci-q.c 2005-01-19 18:00:53.000000000 +0100
|
||||
+++ linux-2.4.32.gcc4-fixes-v12/drivers/usb/host/ehci-q.c 2005-11-17 13:32:13.000000000 +0100
|
||||
@@ -199,8 +199,6 @@ ehci_urb_done (struct ehci_hcd *ehci, st
|
||||
#ifdef INTR_AUTOMAGIC
|
||||
struct urb *resubmit = 0;
|
||||
struct usb_device *dev = 0;
|
||||
-
|
||||
- static int ehci_urb_enqueue (struct usb_hcd *, struct urb *, int);
|
||||
#endif
|
||||
|
||||
if (likely (urb->hcpriv != 0)) {
|
||||
diff -rupN linux-2.4.32/drivers/usb/inode.c linux-2.4.32.gcc4-fixes-v12/drivers/usb/inode.c
|
||||
--- linux-2.4.32/drivers/usb/inode.c 2004-02-18 15:16:23.000000000 +0100
|
||||
+++ linux-2.4.32.gcc4-fixes-v12/drivers/usb/inode.c 2005-11-17 13:32:13.000000000 +0100
|
||||
|
@ -753,28 +753,6 @@ diff -rupN linux-2.4.32/drivers/net/arlan.h linux-2.4.32.more-gcc4-fixes-v1/driv
|
||||
extern int arlan_entry_debug;
|
||||
extern int arlan_exit_debug;
|
||||
extern int testMemory;
|
||||
diff -rupN linux-2.4.32/drivers/net/bonding/bond_alb.c linux-2.4.32.more-gcc4-fixes-v1/drivers/net/bonding/bond_alb.c
|
||||
--- linux-2.4.32/drivers/net/bonding/bond_alb.c 2004-04-14 20:22:20.000000000 +0200
|
||||
+++ linux-2.4.32.more-gcc4-fixes-v1/drivers/net/bonding/bond_alb.c 2005-11-17 13:31:16.000000000 +0100
|
||||
@@ -1275,7 +1275,7 @@ void bond_alb_deinitialize(struct bondin
|
||||
int bond_alb_xmit(struct sk_buff *skb, struct net_device *bond_dev)
|
||||
{
|
||||
struct bonding *bond = bond_dev->priv;
|
||||
- struct ethhdr *eth_data = (struct ethhdr *)skb->mac.raw = skb->data;
|
||||
+ struct ethhdr *eth_data;
|
||||
struct alb_bond_info *bond_info = &(BOND_ALB_INFO(bond));
|
||||
struct slave *tx_slave = NULL;
|
||||
static u32 ip_bcast = 0xffffffff;
|
||||
@@ -1285,6 +1285,9 @@ int bond_alb_xmit(struct sk_buff *skb, s
|
||||
u8 *hash_start = NULL;
|
||||
int res = 1;
|
||||
|
||||
+ skb->mac.raw = (unsigned char *)skb->data;
|
||||
+ eth_data = (struct ethhdr *)skb->mac.raw;
|
||||
+
|
||||
/* make sure that the curr_active_slave and the slaves list do
|
||||
* not change during tx
|
||||
*/
|
||||
diff -rupN linux-2.4.32/drivers/net/de4x5.c linux-2.4.32.more-gcc4-fixes-v1/drivers/net/de4x5.c
|
||||
--- linux-2.4.32/drivers/net/de4x5.c 2004-02-18 15:16:23.000000000 +0100
|
||||
+++ linux-2.4.32.more-gcc4-fixes-v1/drivers/net/de4x5.c 2005-11-17 13:31:16.000000000 +0100
|
||||
|
@ -1,39 +0,0 @@
|
||||
diff -u linux-2.4.30/drivers/mtd/chips/cfi_cmdset_0002.c.orig linux-2.4.30/drivers/mtd/chips/cfi_cmdset_0002.c
|
||||
--- linux-2.4.30/drivers/mtd/chips/cfi_cmdset_0002.c.orig 2004-11-17 12:54:21.000000000 +0100
|
||||
+++ linux-2.4.30/drivers/mtd/chips/cfi_cmdset_0002.c 2006-10-21 17:55:25.000000000 +0200
|
||||
@@ -510,7 +510,7 @@
|
||||
or tells us why it failed. */
|
||||
dq6 = CMD(1<<6);
|
||||
dq5 = CMD(1<<5);
|
||||
- timeo = jiffies + (HZ/1000); /* setting timeout to 1ms for now */
|
||||
+ timeo = jiffies + (HZ/1000) + 1; /* setting timeout to 1ms for now */
|
||||
|
||||
oldstatus = cfi_read(map, adr);
|
||||
status = cfi_read(map, adr);
|
||||
@@ -547,7 +547,7 @@
|
||||
printk(KERN_WARNING "Internal flash device timeout occurred or write operation was performed while flash was programming.\n" );
|
||||
}
|
||||
} else {
|
||||
- printk(KERN_WARNING "Waiting for write to complete timed out in do_write_oneword.");
|
||||
+ printk(KERN_WARNING "Waiting for write to complete timed out in do_write_oneword.\n");
|
||||
|
||||
chip->state = FL_READY;
|
||||
wake_up(&chip->wq);
|
||||
@@ -825,7 +825,7 @@
|
||||
chip->state = FL_READY;
|
||||
wake_up(&chip->wq);
|
||||
cfi_spin_unlock(chip->mutex);
|
||||
- printk("waiting for erase to complete timed out.");
|
||||
+ printk("waiting for erase to complete timed out.\n");
|
||||
DISABLE_VPP(map);
|
||||
return -EIO;
|
||||
}
|
||||
@@ -963,7 +963,7 @@
|
||||
}
|
||||
else
|
||||
{
|
||||
- printk( "Waiting for erase to complete timed out in do_erase_oneblock.");
|
||||
+ printk( "Waiting for erase to complete timed out in do_erase_oneblock.\n");
|
||||
|
||||
chip->state = FL_READY;
|
||||
wake_up(&chip->wq);
|
@ -93,15 +93,6 @@ diff -ur linux.old/drivers/usb/host/ehci-q.c linux.dev/drivers/usb/host/ehci-q.c
|
||||
diff -ur linux.old/drivers/usb/host/usb-uhci.c linux.dev/drivers/usb/host/usb-uhci.c
|
||||
--- linux.old/drivers/usb/host/usb-uhci.c 2004-11-17 12:54:21.000000000 +0100
|
||||
+++ linux.dev/drivers/usb/host/usb-uhci.c 2006-07-30 12:10:16.000000000 +0200
|
||||
@@ -2491,7 +2491,7 @@
|
||||
((urb_priv_t*)urb->hcpriv)->flags=0;
|
||||
}
|
||||
|
||||
- if ((urb->status != -ECONNABORTED) && (urb->status != ECONNRESET) &&
|
||||
+ if ((urb->status != -ECONNABORTED) && (urb->status != -ECONNRESET) &&
|
||||
(urb->status != -ENOENT)) {
|
||||
|
||||
urb->status = -EINPROGRESS;
|
||||
@@ -3034,6 +3034,21 @@
|
||||
|
||||
pci_set_master(dev);
|
||||
|
@ -1,12 +0,0 @@
|
||||
--- linux-2.4.30/drivers/net/pppoe.c.old 2006-10-10 13:49:12.000000000 +0200
|
||||
+++ linux-2.4.30/drivers/net/pppoe.c 2006-10-10 13:50:02.000000000 +0200
|
||||
@@ -639,6 +639,9 @@
|
||||
po->chan.hdrlen = (sizeof(struct pppoe_hdr) +
|
||||
dev->hard_header_len);
|
||||
|
||||
+ if (po->chan.mtu > dev->mtu - sizeof(struct pppoe_hdr))
|
||||
+ po->chan.mtu = dev->mtu - sizeof(struct pppoe_hdr);
|
||||
+
|
||||
po->chan.private = sk;
|
||||
po->chan.ops = &pppoe_chan_ops;
|
||||
|
Loading…
Reference in New Issue
Block a user