toolchain: remove ppl/cloog, disable graphite for gcc 4.8
graphite is disabled by default and it's not worth carrying ppl and cloog for supporting this feature on the old gcc 4.8, which is only used for ARC Signed-off-by: Felix Fietkau <nbd@nbd.name>
This commit is contained in:
parent
8bf69ee78c
commit
3f55e5aeb5
@ -23,15 +23,10 @@ choice
|
||||
endchoice
|
||||
|
||||
config GCC_USE_GRAPHITE
|
||||
depends on !GCC_VERSION_4_8_ARC
|
||||
bool
|
||||
prompt "Compile in support for the new Graphite framework in GCC 4.4+" if TOOLCHAINOPTS
|
||||
|
||||
config GCC_USE_SYSTEM_PPL_CLOOG
|
||||
bool
|
||||
prompt "Use the system versions of PPL and CLooG"
|
||||
depends on GCC_USE_GRAPHITE && GCC_VERSION_4_8
|
||||
default n
|
||||
|
||||
config EXTRA_GCC_CONFIG_OPTIONS
|
||||
string
|
||||
prompt "Additional gcc configure options" if TOOLCHAINOPTS
|
||||
|
@ -80,11 +80,7 @@ ifdef CONFIG_INSTALL_GCCGO
|
||||
endif
|
||||
|
||||
ifdef CONFIG_GCC_USE_GRAPHITE
|
||||
ifdef CONFIG_GCC_VERSION_4_8
|
||||
GRAPHITE_CONFIGURE=--with-cloog=$(REAL_STAGING_DIR_HOST)
|
||||
else
|
||||
GRAPHITE_CONFIGURE=--with-isl=$(REAL_STAGING_DIR_HOST)
|
||||
endif
|
||||
GRAPHITE_CONFIGURE=--with-isl=$(REAL_STAGING_DIR_HOST)
|
||||
else
|
||||
GRAPHITE_CONFIGURE=--without-isl --without-cloog
|
||||
endif
|
||||
|
@ -14,13 +14,7 @@ tools-y :=
|
||||
ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
|
||||
BUILD_TOOLCHAIN := y
|
||||
ifdef CONFIG_GCC_USE_GRAPHITE
|
||||
ifneq ($(CONFIG_GCC_VERSION_4_8),)
|
||||
ifeq ($(CONFIG_GCC_USE_SYSTEM_PPL_CLOOG),)
|
||||
BUILD_PPL_CLOOG = y
|
||||
endif
|
||||
else
|
||||
BUILD_ISL = y
|
||||
endif
|
||||
BUILD_ISL = y
|
||||
endif
|
||||
endif
|
||||
ifneq ($(CONFIG_SDK)$(CONFIG_PACKAGE_kmod-b43)$(CONFIG_PACKAGE_b43legacy-firmware)$(CONFIG_BRCMSMAC_USE_FW_FROM_WL),)
|
||||
@ -41,7 +35,6 @@ tools-$(CONFIG_TARGET_ar71xx) += lzma-old squashfs
|
||||
tools-$(CONFIG_USES_MINOR) += kernel2minor
|
||||
tools-y += lzma squashfs4
|
||||
tools-$(BUILD_B43_TOOLS) += b43-tools
|
||||
tools-$(BUILD_PPL_CLOOG) += ppl cloog
|
||||
tools-$(BUILD_ISL) += isl
|
||||
tools-$(CONFIG_USE_SPARSE) += sparse
|
||||
tools-$(CONFIG_TARGET_apm821xx) += genext2fs
|
||||
@ -59,8 +52,6 @@ $(curdir)/automake/compile := $(curdir)/m4/install $(curdir)/autoconf/install $(
|
||||
$(curdir)/gmp/compile := $(curdir)/libtool/install
|
||||
$(curdir)/mpc/compile := $(curdir)/mpfr/install $(curdir)/gmp/install
|
||||
$(curdir)/mpfr/compile := $(curdir)/gmp/install
|
||||
$(curdir)/ppl/compile := $(curdir)/gmp/install
|
||||
$(curdir)/cloog/compile := $(curdir)/ppl/install
|
||||
$(curdir)/mtd-utils/compile := $(curdir)/e2fsprogs/install $(curdir)/xz/install
|
||||
$(curdir)/mkimage/compile := $(curdir)/sed/install
|
||||
$(curdir)/mklibs/compile := $(curdir)/libtool/install
|
||||
@ -73,7 +64,6 @@ $(curdir)/libelf/compile := $(curdir)/libtool/install
|
||||
$(curdir)/sdcc/compile := $(curdir)/bison/install
|
||||
$(curdir)/b43-tools/compile := $(curdir)/bison/install
|
||||
$(curdir)/padjffs2/compile := $(curdir)/findutils/install
|
||||
$(curdir)/cloog/compile := $(curdir)/ppl/install
|
||||
$(curdir)/isl/compile := $(curdir)/gmp/install
|
||||
$(curdir)/bc/compile := $(curdir)/bison/install
|
||||
$(curdir)/findutils/compile := $(curdir)/bison/install
|
||||
|
@ -1,41 +0,0 @@
|
||||
#
|
||||
# Copyright (C) 2009-2013 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=cloog
|
||||
PKG_VERSION:=0.18.1
|
||||
|
||||
PKG_SOURCE_URL:=http://www.bastoul.net/cloog/pages/download/
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_HASH:=02500a4edd14875f94fe84cbeda4290425cb0c1c2474c6f75d75a303d64b4196
|
||||
|
||||
HOST_FIXUP:=autoreconf
|
||||
|
||||
HOST_BUILD_PARALLEL:=1
|
||||
HOST_CONFIGURE_PARALLEL:=1
|
||||
|
||||
include $(INCLUDE_DIR)/host-build.mk
|
||||
|
||||
unexport CFLAGS
|
||||
|
||||
HOST_CONFIGURE_VARS += \
|
||||
LIBS=-lstdc++
|
||||
|
||||
HOST_CONFIGURE_ARGS += \
|
||||
--enable-static \
|
||||
--disable-shared \
|
||||
--with-ppl=$(BUILD_DIR_HOST)
|
||||
|
||||
define Host/Configure
|
||||
(cd $(HOST_BUILD_DIR)/$(3); \
|
||||
$(HOST_CONFIGURE_CMD) \
|
||||
$(HOST_CONFIGURE_VARS) \
|
||||
$(HOST_CONFIGURE_ARGS); \
|
||||
)
|
||||
endef
|
||||
|
||||
$(eval $(call HostBuild))
|
@ -1,37 +0,0 @@
|
||||
#
|
||||
# Copyright (C) 2009-2013 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=ppl
|
||||
PKG_VERSION:=1.2
|
||||
|
||||
PKG_SOURCE_URL:=http://bugseng.com/products/ppl/download/ftp/releases/$(PKG_VERSION)/
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_HASH:=691f0d5a4fb0e206f4e132fc9132c71d6e33cdda168470d40ac3cf62340e9a60
|
||||
|
||||
HOST_FIXUP:=autoreconf
|
||||
|
||||
HOST_BUILD_PARALLEL:=1
|
||||
HOST_CONFIGURE_PARALLEL:=1
|
||||
|
||||
include $(INCLUDE_DIR)/host-build.mk
|
||||
|
||||
unexport CFLAGS
|
||||
|
||||
HOST_CONFIGURE_ARGS += \
|
||||
--enable-static \
|
||||
--disable-shared
|
||||
|
||||
define Host/Configure
|
||||
(cd $(HOST_BUILD_DIR)/$(3); \
|
||||
$(HOST_CONFIGURE_CMD) \
|
||||
$(HOST_CONFIGURE_VARS) \
|
||||
$(HOST_CONFIGURE_ARGS); \
|
||||
)
|
||||
endef
|
||||
|
||||
$(eval $(call HostBuild))
|
@ -1,44 +0,0 @@
|
||||
--- a/tests/BD_Shape/Makefile.am
|
||||
+++ b/tests/BD_Shape/Makefile.am
|
||||
@@ -21,8 +21,6 @@
|
||||
# For the most up-to-date information see the Parma Polyhedra Library
|
||||
# site: http://bugseng.com/products/ppl/ .
|
||||
|
||||
-AUTOMAKE_OPTIONS = serial-tests
|
||||
-
|
||||
if VALGRIND_TESTS_ENABLED
|
||||
|
||||
CHECKER = \
|
||||
--- a/tests/Box/Makefile.am
|
||||
+++ b/tests/Box/Makefile.am
|
||||
@@ -21,8 +21,6 @@
|
||||
# For the most up-to-date information see the Parma Polyhedra Library
|
||||
# site: http://bugseng.com/products/ppl/ .
|
||||
|
||||
-AUTOMAKE_OPTIONS = serial-tests
|
||||
-
|
||||
if VALGRIND_TESTS_ENABLED
|
||||
|
||||
CHECKER = \
|
||||
--- a/tests/Concrete_Expression/Makefile.am
|
||||
+++ b/tests/Concrete_Expression/Makefile.am
|
||||
@@ -21,8 +21,6 @@
|
||||
# For the most up-to-date information see the Parma Polyhedra Library
|
||||
# site: http://bugseng.com/products/ppl/ .
|
||||
|
||||
-AUTOMAKE_OPTIONS = serial-tests
|
||||
-
|
||||
if VALGRIND_TESTS_ENABLED
|
||||
|
||||
CHECKER = \
|
||||
--- a/tests/Octagonal_Shape/Makefile.am
|
||||
+++ b/tests/Octagonal_Shape/Makefile.am
|
||||
@@ -21,8 +21,6 @@
|
||||
# For the most up-to-date information see the Parma Polyhedra Library
|
||||
# site: http://bugseng.com/products/ppl/ .
|
||||
|
||||
-AUTOMAKE_OPTIONS = serial-tests
|
||||
-
|
||||
if VALGRIND_TESTS_ENABLED
|
||||
|
||||
CHECKER = \
|
Loading…
Reference in New Issue
Block a user