brcm63xx: add DT support for USR9108
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> SVN-Revision: 43575
This commit is contained in:
parent
218582e8ea
commit
3fa17f6d58
30
target/linux/brcm63xx/dts/usr9108.dts
Normal file
30
target/linux/brcm63xx/dts/usr9108.dts
Normal file
@ -0,0 +1,30 @@
|
|||||||
|
/dts-v1/;
|
||||||
|
|
||||||
|
/include/ "bcm6348.dtsi"
|
||||||
|
|
||||||
|
/ {
|
||||||
|
model = "USRobotics 9108";
|
||||||
|
compatible = "usr,9108", "brcm,bcm6348";
|
||||||
|
};
|
||||||
|
|
||||||
|
&pflash {
|
||||||
|
status = "ok";
|
||||||
|
|
||||||
|
linux,part-probe = "bcm63xxpart";
|
||||||
|
|
||||||
|
cfe@0 {
|
||||||
|
label = "CFE";
|
||||||
|
reg = <0x000000 0x010000>;
|
||||||
|
read-only;
|
||||||
|
};
|
||||||
|
|
||||||
|
linux@10000 {
|
||||||
|
label = "linux";
|
||||||
|
reg = <0x010000 0x3e0000>;
|
||||||
|
};
|
||||||
|
|
||||||
|
nvram@3f0000 {
|
||||||
|
label = "nvram";
|
||||||
|
reg = <0x3f0000 0x010000>;
|
||||||
|
};
|
||||||
|
};
|
@ -200,9 +200,6 @@ define Image/Build
|
|||||||
# RTA1320_16M (numerous routers)
|
# RTA1320_16M (numerous routers)
|
||||||
$(call Image/Build/CFE,$(1),RTA1320_16M,6338,RTA1320_16M,,--layoutver 5)
|
$(call Image/Build/CFE,$(1),RTA1320_16M,6338,RTA1320_16M,,--layoutver 5)
|
||||||
|
|
||||||
# USR 9108
|
|
||||||
$(call Image/Build/CFE,$(1),96348GW-A,6348,USR9108)
|
|
||||||
|
|
||||||
# Inventel Livebox
|
# Inventel Livebox
|
||||||
$(call Image/Build/RedBoot,livebox)
|
$(call Image/Build/RedBoot,livebox)
|
||||||
|
|
||||||
@ -333,6 +330,8 @@ $(eval $(call ImageDTB,CFEDTB,Neufbox4,nb4-ser-r0,96358VW,6358,NEUFBOX4-SER,--rs
|
|||||||
$(eval $(call ImageDTB,CFEDTB,Neufbox4,nb4-fxc-r1,96358VW,6358,NEUFBOX4-FXC,--rsa-signature "OpenWRT-$(REVISION)"))
|
$(eval $(call ImageDTB,CFEDTB,Neufbox4,nb4-fxc-r1,96358VW,6358,NEUFBOX4-FXC,--rsa-signature "OpenWRT-$(REVISION)"))
|
||||||
# SFR neufbox 6
|
# SFR neufbox 6
|
||||||
$(eval $(call ImageDTB,CFEDTB,Neufbox6,nb6-ser-r0,NB6-SER-r0,6362,NEUFBOX6,--rsa-signature "OpenWRT-$(REVISION)"))
|
$(eval $(call ImageDTB,CFEDTB,Neufbox6,nb6-ser-r0,NB6-SER-r0,6362,NEUFBOX6,--rsa-signature "OpenWRT-$(REVISION)"))
|
||||||
|
# USRobotics 9108
|
||||||
|
$(eval $(call ImageDTB,CFEDTB,USR9108,usr9108,96348GW-A,6348,USR9108))
|
||||||
# ZyXEL P870HW-51a v2
|
# ZyXEL P870HW-51a v2
|
||||||
$(eval $(call ImageDTB,ZYXCFEDTB,P870HW_51a_v2,p870hw-51a-v2,96368VVW,6368,P870HW-51a_v2,--rsa-signature "ZyXEL" --signature "ZyXEL_0001"))
|
$(eval $(call ImageDTB,ZYXCFEDTB,P870HW_51a_v2,p870hw-51a-v2,96368VVW,6368,P870HW-51a_v2,--rsa-signature "ZyXEL" --signature "ZyXEL_0001"))
|
||||||
|
|
||||||
|
@ -14,7 +14,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
|
|||||||
|
|
||||||
--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
|
--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
|
||||||
+++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
|
+++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
|
||||||
@@ -736,6 +736,48 @@ static const struct board_info __initcon
|
@@ -736,6 +736,49 @@ static const struct board_info __initcon
|
||||||
};
|
};
|
||||||
|
|
||||||
static struct of_device_id const bcm963xx_boards_dt[] = {
|
static struct of_device_id const bcm963xx_boards_dt[] = {
|
||||||
@ -43,6 +43,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
|
|||||||
+ { .compatible = "netgear,dg834gtpn", .data = &board_96348gw_10, },
|
+ { .compatible = "netgear,dg834gtpn", .data = &board_96348gw_10, },
|
||||||
+ { .compatible = "sagem,f@st2404", .data = &board_FAST2404, },
|
+ { .compatible = "sagem,f@st2404", .data = &board_FAST2404, },
|
||||||
+ { .compatible = "tp-link,td-w8900gb", .data = &board_96348gw_11, },
|
+ { .compatible = "tp-link,td-w8900gb", .data = &board_96348gw_11, },
|
||||||
|
+ { .compatible = "usr,9108", .data = &board_96348gw_a, },
|
||||||
+#endif
|
+#endif
|
||||||
+#ifdef CONFIG_BCM63XX_CPU_6358
|
+#ifdef CONFIG_BCM63XX_CPU_6358
|
||||||
+ { .compatible = "alcatel,rg100a", .data = &board_96358vw2, },
|
+ { .compatible = "alcatel,rg100a", .data = &board_96358vw2, },
|
||||||
|
@ -14,7 +14,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
|
|||||||
|
|
||||||
--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
|
--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
|
||||||
+++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
|
+++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
|
||||||
@@ -736,6 +736,48 @@ static const struct board_info __initcon
|
@@ -736,6 +736,49 @@ static const struct board_info __initcon
|
||||||
};
|
};
|
||||||
|
|
||||||
static struct of_device_id const bcm963xx_boards_dt[] = {
|
static struct of_device_id const bcm963xx_boards_dt[] = {
|
||||||
@ -43,6 +43,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
|
|||||||
+ { .compatible = "netgear,dg834gtpn", .data = &board_96348gw_10, },
|
+ { .compatible = "netgear,dg834gtpn", .data = &board_96348gw_10, },
|
||||||
+ { .compatible = "sagem,f@st2404", .data = &board_FAST2404, },
|
+ { .compatible = "sagem,f@st2404", .data = &board_FAST2404, },
|
||||||
+ { .compatible = "tp-link,td-w8900gb", .data = &board_96348gw_11, },
|
+ { .compatible = "tp-link,td-w8900gb", .data = &board_96348gw_11, },
|
||||||
|
+ { .compatible = "usr,9108", .data = &board_96348gw_a, },
|
||||||
+#endif
|
+#endif
|
||||||
+#ifdef CONFIG_BCM63XX_CPU_6358
|
+#ifdef CONFIG_BCM63XX_CPU_6358
|
||||||
+ { .compatible = "alcatel,rg100a", .data = &board_96358vw2, },
|
+ { .compatible = "alcatel,rg100a", .data = &board_96358vw2, },
|
||||||
|
16
target/linux/brcm63xx/profiles/usrobotics.mk
Normal file
16
target/linux/brcm63xx/profiles/usrobotics.mk
Normal file
@ -0,0 +1,16 @@
|
|||||||
|
#
|
||||||
|
# Copyright (C) 2014 OpenWrt.org
|
||||||
|
#
|
||||||
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
|
# See /LICENSE for more information.
|
||||||
|
#
|
||||||
|
|
||||||
|
define Profile/USR9108
|
||||||
|
NAME:=USRobotics 9108
|
||||||
|
PACKAGES:=kmod-b43 wpad-mini\
|
||||||
|
kmod-usb-ohci
|
||||||
|
endef
|
||||||
|
define Profile/USR9108/Description
|
||||||
|
Package set optimized for USR9108.
|
||||||
|
endef
|
||||||
|
$(eval $(call Profile,USR9108))
|
Loading…
Reference in New Issue
Block a user