ar71xx: Add support for Black Swift
Add support for the Black Swift board: http://www.black-swift.com/ Took relevant parts and slightly adapted from: https://github.com/blackswift/openwrt/blob/master/bsb.patch Signed-off-by: Bruno Randolf <br1@einfach.org> SVN-Revision: 46651
This commit is contained in:
parent
9b0516c9fc
commit
4463bc017b
@ -41,6 +41,9 @@ get_status_led() {
|
||||
aw-nr580)
|
||||
status_led="aw-nr580:green:ready"
|
||||
;;
|
||||
bsb)
|
||||
status_led="bsb:red:sys"
|
||||
;;
|
||||
bullet-m | rocket-m | rocket-m-xw | nano-m | nanostation-m | nanostation-m-xw | loco-m-xw)
|
||||
status_led="ubnt:green:link4"
|
||||
;;
|
||||
|
@ -55,6 +55,10 @@ ap147-010)
|
||||
ucidef_set_led_wlan "wlan2g" "WLAN 2.4 GHz" "ap147:green:wlan-2g" "phy0tpt"
|
||||
;;
|
||||
|
||||
bsb)
|
||||
ucidef_set_led_default "sys" "SYS" "bsb:red:sys" "1"
|
||||
;;
|
||||
|
||||
bullet-m | \
|
||||
nanostation-m | \
|
||||
rocket-m | \
|
||||
|
7
target/linux/ar71xx/base-files/etc/uci-defaults/02_network
Executable file → Normal file
7
target/linux/ar71xx/base-files/etc/uci-defaults/02_network
Executable file → Normal file
@ -72,6 +72,13 @@ tl-wdr4900-v2)
|
||||
ucidef_add_switch_vlan "switch0" "2" "1 6"
|
||||
;;
|
||||
|
||||
bsb)
|
||||
ucidef_set_interfaces_lan_wan "eth1" "eth0"
|
||||
ucidef_add_switch "switch0" "1" "1"
|
||||
ucidef_add_switch_vlan "switch0" "1" "0 1 3"
|
||||
ucidef_set_interface_wlan
|
||||
;;
|
||||
|
||||
cpe510)
|
||||
ucidef_set_interfaces_lan_wan "eth0.1" "eth0.2"
|
||||
ucidef_add_switch "switch0" "1" "1"
|
||||
|
@ -676,6 +676,9 @@ ar71xx_board_detect() {
|
||||
*"SMART-300")
|
||||
name="smart-300"
|
||||
;;
|
||||
"Smart Electronics Black Swift board"*)
|
||||
name="bsb"
|
||||
;;
|
||||
*TEW-632BRP)
|
||||
name="tew-632brp"
|
||||
;;
|
||||
|
@ -263,6 +263,7 @@ platform_check_image() {
|
||||
return 1
|
||||
;;
|
||||
|
||||
bsb | \
|
||||
dir-825-b1 | \
|
||||
tew-673gru)
|
||||
dir825b_check_image "$1" && return 0
|
||||
|
@ -47,6 +47,7 @@ CONFIG_ATH79_MACH_AP96=y
|
||||
CONFIG_ATH79_MACH_ARCHER_C7=y
|
||||
CONFIG_ATH79_MACH_AW_NR580=y
|
||||
CONFIG_ATH79_MACH_BHU_BXU2000N2_A=y
|
||||
CONFIG_ATH79_MACH_BSB=y
|
||||
CONFIG_ATH79_MACH_CAP4200AG=y
|
||||
CONFIG_ATH79_MACH_CARAMBOLA2=y
|
||||
CONFIG_ATH79_MACH_CPE510=y
|
||||
|
83
target/linux/ar71xx/files/arch/mips/ath79/mach-bsb.c
Normal file
83
target/linux/ar71xx/files/arch/mips/ath79/mach-bsb.c
Normal file
@ -0,0 +1,83 @@
|
||||
/*
|
||||
* Smart Electronics Black Swift board support
|
||||
*
|
||||
* Copyright (C) 2014 Dmitriy Zherebkov dzh@black-swift.com
|
||||
*
|
||||
* This program is free software; you can redistribute it and/or modify it
|
||||
* under the terms of the GNU General Public License version 2 as published
|
||||
* by the Free Software Foundation.
|
||||
*/
|
||||
|
||||
#include <asm/mach-ath79/ath79.h>
|
||||
#include <asm/mach-ath79/ar71xx_regs.h>
|
||||
#include "common.h"
|
||||
#include "dev-eth.h"
|
||||
#include "dev-gpio-buttons.h"
|
||||
#include "dev-leds-gpio.h"
|
||||
#include "dev-m25p80.h"
|
||||
#include "dev-spi.h"
|
||||
#include "dev-usb.h"
|
||||
#include "dev-wmac.h"
|
||||
#include "machtypes.h"
|
||||
|
||||
#define BSB_GPIO_LED_SYS 27
|
||||
|
||||
#define BSB_GPIO_BTN_RESET 11
|
||||
|
||||
#define BSB_KEYS_POLL_INTERVAL 20 /* msecs */
|
||||
#define BSB_KEYS_DEBOUNCE_INTERVAL (3 * BSB_KEYS_POLL_INTERVAL)
|
||||
|
||||
#define BSB_MAC_OFFSET 0x0000
|
||||
#define BSB_CALDATA_OFFSET 0x1000
|
||||
|
||||
static struct gpio_led bsb_leds_gpio[] __initdata = {
|
||||
{
|
||||
.name = "bsb:red:sys",
|
||||
.gpio = BSB_GPIO_LED_SYS,
|
||||
.active_low = 1,
|
||||
}
|
||||
};
|
||||
|
||||
static struct gpio_keys_button bsb_gpio_keys[] __initdata = {
|
||||
{
|
||||
.desc = "reset button",
|
||||
.type = EV_KEY,
|
||||
.code = KEY_RESTART,
|
||||
.debounce_interval = BSB_KEYS_DEBOUNCE_INTERVAL,
|
||||
.gpio = BSB_GPIO_BTN_RESET,
|
||||
.active_low = 1,
|
||||
},
|
||||
};
|
||||
|
||||
static void __init bsb_setup(void)
|
||||
{
|
||||
u8 *art = (u8 *) KSEG1ADDR(0x1fff0000);
|
||||
|
||||
/* disable PHY_SWAP and PHY_ADDR_SWAP bits */
|
||||
ath79_setup_ar933x_phy4_switch(false,false);
|
||||
|
||||
ath79_register_leds_gpio(-1, ARRAY_SIZE(bsb_leds_gpio),
|
||||
bsb_leds_gpio);
|
||||
ath79_register_gpio_keys_polled(-1, BSB_KEYS_POLL_INTERVAL,
|
||||
ARRAY_SIZE(bsb_gpio_keys),
|
||||
bsb_gpio_keys);
|
||||
|
||||
ath79_register_usb();
|
||||
|
||||
ath79_register_m25p80(NULL);
|
||||
|
||||
ath79_init_mac(ath79_eth0_data.mac_addr, art + BSB_MAC_OFFSET, 1);
|
||||
ath79_init_mac(ath79_eth1_data.mac_addr, art + BSB_MAC_OFFSET, 2);
|
||||
|
||||
ath79_register_mdio(0, 0x0);
|
||||
|
||||
ath79_register_eth(0);
|
||||
ath79_register_eth(1);
|
||||
|
||||
ath79_register_wmac(art + BSB_CALDATA_OFFSET,
|
||||
art + BSB_MAC_OFFSET);
|
||||
}
|
||||
|
||||
MIPS_MACHINE(ATH79_MACH_BSB, "BSB", "Smart Electronics Black Swift board",
|
||||
bsb_setup);
|
||||
|
17
target/linux/ar71xx/generic/profiles/smartelectronics.mk
Normal file
17
target/linux/ar71xx/generic/profiles/smartelectronics.mk
Normal file
@ -0,0 +1,17 @@
|
||||
#
|
||||
# Copyright (C) 2013 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
|
||||
define Profile/BSB
|
||||
NAME:=Smart Electronics Black Swift board
|
||||
PACKAGES:=kmod-usb-core kmod-usb2
|
||||
endef
|
||||
|
||||
define Profile/BSB/Description
|
||||
Package set optimized for the Smart Electronics Black Swift board.
|
||||
endef
|
||||
|
||||
$(eval $(call Profile,BSB))
|
@ -172,6 +172,14 @@ define Device/Default
|
||||
IMAGE/sysupgrade.bin = append-kernel $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE)
|
||||
endef
|
||||
|
||||
define Device/bsb
|
||||
BOARDNAME = BSB
|
||||
IMAGE_SIZE = 16000k
|
||||
CONSOLE = ttyATH0,115200
|
||||
MTDPARTS = spi0.0:128k(u-boot)ro,64k(u-boot-env)ro,16128k(firmware),64k(art)ro
|
||||
endef
|
||||
TARGET_DEVICES += bsb
|
||||
|
||||
define Device/carambola2
|
||||
BOARDNAME = CARAMBOLA2
|
||||
IMAGE_SIZE = 16000k
|
||||
|
@ -0,0 +1,45 @@
|
||||
Index: linux-4.1.4/arch/mips/ath79/Kconfig
|
||||
===================================================================
|
||||
--- linux-4.1.4.orig/arch/mips/ath79/Kconfig 2015-08-10 16:28:12.409834069 +0100
|
||||
+++ linux-4.1.4/arch/mips/ath79/Kconfig 2015-08-10 16:30:16.341831945 +0100
|
||||
@@ -904,6 +904,16 @@
|
||||
select ATH79_DEV_LEDS_GPIO
|
||||
select ATH79_DEV_M25P80
|
||||
|
||||
+config ATH79_MACH_BSB
|
||||
+ bool "Smart Electronics Black Swift board"
|
||||
+ select SOC_AR933X
|
||||
+ select ATH79_DEV_ETH
|
||||
+ select ATH79_DEV_GPIO_BUTTONS
|
||||
+ select ATH79_DEV_LEDS_GPIO
|
||||
+ select ATH79_DEV_M25P80
|
||||
+ select ATH79_DEV_USB
|
||||
+ select ATH79_DEV_WMAC
|
||||
+
|
||||
config ATH79_MACH_ARCHER_C7
|
||||
bool "TP-LINK Archer C5/C7/TL-WDR4900 v2 board support"
|
||||
select SOC_QCA955X
|
||||
Index: linux-4.1.4/arch/mips/ath79/Makefile
|
||||
===================================================================
|
||||
--- linux-4.1.4.orig/arch/mips/ath79/Makefile 2015-08-10 16:28:12.409834069 +0100
|
||||
+++ linux-4.1.4/arch/mips/ath79/Makefile 2015-08-10 16:30:39.985831540 +0100
|
||||
@@ -56,6 +56,7 @@
|
||||
obj-$(CONFIG_ATH79_MACH_ARCHER_C7) += mach-archer-c7.o
|
||||
obj-$(CONFIG_ATH79_MACH_AW_NR580) += mach-aw-nr580.o
|
||||
obj-$(CONFIG_ATH79_MACH_BHU_BXU2000N2_A)+= mach-bhu-bxu2000n2-a.o
|
||||
+obj-$(CONFIG_ATH79_MACH_BSB) += mach-bsb.o
|
||||
obj-$(CONFIG_ATH79_MACH_CAP4200AG) += mach-cap4200ag.o
|
||||
obj-$(CONFIG_ATH79_MACH_CPE510) += mach-cpe510.o
|
||||
obj-$(CONFIG_ATH79_MACH_DB120) += mach-db120.o
|
||||
Index: linux-4.1.4/arch/mips/ath79/machtypes.h
|
||||
===================================================================
|
||||
--- linux-4.1.4.orig/arch/mips/ath79/machtypes.h 2015-08-10 16:28:12.409834069 +0100
|
||||
+++ linux-4.1.4/arch/mips/ath79/machtypes.h 2015-08-10 16:31:13.693830962 +0100
|
||||
@@ -39,6 +39,7 @@
|
||||
ATH79_MACH_ARCHER_C7, /* TP-LINK Archer C7 board */
|
||||
ATH79_MACH_AW_NR580, /* AzureWave AW-NR580 */
|
||||
ATH79_MACH_BHU_BXU2000N2_A1, /* BHU BXU2000n-2 A1 */
|
||||
+ ATH79_MACH_BSB, /* Smart Electronics Black Swift board */
|
||||
ATH79_MACH_CAP4200AG, /* Senao CAP4200AG */
|
||||
ATH79_MACH_CARAMBOLA2, /* 8devices Carambola2 */
|
||||
ATH79_MACH_CPE510, /* TP-LINK CPE510 */
|
Loading…
Reference in New Issue
Block a user