iproute2: dont filter cached routes on iproute_get (#8339)
SVN-Revision: 24216
This commit is contained in:
parent
6f7e2d4ce8
commit
4482f4b5f1
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=iproute2
|
||||
PKG_VERSION:=2.6.35
|
||||
PKG_RELEASE:=2
|
||||
PKG_RELEASE:=3
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=http://devresources.linux-foundation.org/dev/iproute2/download/
|
||||
|
@ -10,8 +10,8 @@
|
||||
tc/q_wrr.c | 322 ++++++++++++++++++++++++++++
|
||||
9 files changed, 1177 insertions(+), 5 deletions(-)
|
||||
|
||||
--- iproute2-2.6.35.orig/doc/ip-cref.tex
|
||||
+++ iproute2-2.6.35/doc/ip-cref.tex
|
||||
--- a/doc/ip-cref.tex
|
||||
+++ b/doc/ip-cref.tex
|
||||
@@ -1307,6 +1307,19 @@ peers are allowed to send to us.
|
||||
--- \threeonly the clamp for congestion window. It is ignored if the \verb|lock|
|
||||
flag is not used.
|
||||
@ -32,18 +32,18 @@
|
||||
|
||||
\item \verb|advmss NUMBER|
|
||||
|
||||
@@ -2664,6 +2677,9 @@ http://www.cisco.com/univercd/cc/td/doc/
|
||||
|
||||
@@ -2665,6 +2678,9 @@ http://www.cisco.com/univercd/cc/td/doc/
|
||||
\bibitem{RFC2414} M.~Allman, S.~Floyd, C.~Partridge.
|
||||
``Increasing TCP's Initial Window'', RFC-2414.
|
||||
+
|
||||
|
||||
+\bibitem{RFC2414} M.~Allman, S.~Floyd, C.~Partridge.
|
||||
+``Increasing TCP's Initial Window'', RFC-2414.
|
||||
|
||||
+
|
||||
\end{thebibliography}
|
||||
|
||||
--- iproute2-2.6.35.orig/doc/Makefile
|
||||
+++ iproute2-2.6.35/doc/Makefile
|
||||
|
||||
--- a/doc/Makefile
|
||||
+++ b/doc/Makefile
|
||||
@@ -14,6 +14,7 @@ PAGESIZE=a4
|
||||
PAGESPERPAGE=2
|
||||
|
||||
@ -75,8 +75,8 @@
|
||||
clean:
|
||||
- rm -f *.aux *.log *.toc $(PSFILES) $(DVIFILES) *.html
|
||||
+ rm -f *.aux *.log *.toc $(PSFILES) $(DVIFILES) *.html $(TXTFILES)
|
||||
--- iproute2-2.6.35.orig/include/linux/pkt_sched.h
|
||||
+++ iproute2-2.6.35/include/linux/pkt_sched.h
|
||||
--- a/include/linux/pkt_sched.h
|
||||
+++ b/include/linux/pkt_sched.h
|
||||
@@ -1,3 +1,409 @@
|
||||
+#if 0
|
||||
+#ifndef __LINUX_PKT_SCHED_H
|
||||
@ -604,8 +604,8 @@
|
||||
+};
|
||||
+
|
||||
#endif
|
||||
--- iproute2-2.6.35.orig/ip/iptunnel.c
|
||||
+++ iproute2-2.6.35/ip/iptunnel.c
|
||||
--- a/ip/iptunnel.c
|
||||
+++ b/ip/iptunnel.c
|
||||
@@ -130,7 +130,7 @@ static int parse_args(int argc, char **a
|
||||
NEXT_ARG();
|
||||
p->o_flags |= GRE_KEY;
|
||||
@ -615,8 +615,8 @@
|
||||
else {
|
||||
if (get_unsigned(&uval, *argv, 0)<0) {
|
||||
fprintf(stderr, "invalid value of \"okey\"\n");
|
||||
--- iproute2-2.6.35.orig/Makefile
|
||||
+++ iproute2-2.6.35/Makefile
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -57,7 +57,7 @@ install: all
|
||||
$(DESTDIR)$(DOCDIR)/examples
|
||||
install -m 0644 $(shell find examples/diffserv -maxdepth 1 -type f) \
|
||||
@ -635,8 +635,8 @@
|
||||
do $(MAKE) $(MFLAGS) -C $$i clean; done
|
||||
|
||||
clobber: clean
|
||||
--- iproute2-2.6.35.orig/misc/Makefile
|
||||
+++ iproute2-2.6.35/misc/Makefile
|
||||
--- a/misc/Makefile
|
||||
+++ b/misc/Makefile
|
||||
@@ -1,7 +1,8 @@
|
||||
SSOBJ=ss.o ssfilter.o
|
||||
LNSTATOBJ=lnstat.o lnstat_util.o
|
||||
@ -647,8 +647,8 @@
|
||||
|
||||
include ../Config
|
||||
|
||||
--- iproute2-2.6.35.orig/tc/Makefile
|
||||
+++ iproute2-2.6.35/tc/Makefile
|
||||
--- a/tc/Makefile
|
||||
+++ b/tc/Makefile
|
||||
@@ -15,6 +15,7 @@ TCMODULES += q_cbq.o
|
||||
TCMODULES += q_rr.o
|
||||
TCMODULES += q_multiq.o
|
||||
@ -657,8 +657,8 @@
|
||||
TCMODULES += f_rsvp.o
|
||||
TCMODULES += f_u32.o
|
||||
TCMODULES += f_route.o
|
||||
--- iproute2-2.6.35.orig/tc/q_htb.c
|
||||
+++ iproute2-2.6.35/tc/q_htb.c
|
||||
--- a/tc/q_htb.c
|
||||
+++ b/tc/q_htb.c
|
||||
@@ -1,3 +1,311 @@
|
||||
+#if 0
|
||||
+/*
|
||||
@ -972,7 +972,7 @@
|
||||
* q_htb.c HTB.
|
||||
*
|
||||
--- /dev/null
|
||||
+++ iproute2-2.6.35/tc/q_wrr.c
|
||||
+++ b/tc/q_wrr.c
|
||||
@@ -0,0 +1,322 @@
|
||||
+#include <stdio.h>
|
||||
+#include <stdlib.h>
|
||||
|
@ -2,8 +2,8 @@
|
||||
ip/ipxfrm.c | 2 --
|
||||
1 file changed, 2 deletions(-)
|
||||
|
||||
--- iproute2-2.6.35.orig/ip/ipxfrm.c
|
||||
+++ iproute2-2.6.35/ip/ipxfrm.c
|
||||
--- a/ip/ipxfrm.c
|
||||
+++ b/ip/ipxfrm.c
|
||||
@@ -467,7 +467,6 @@ void xfrm_selector_print(struct xfrm_sel
|
||||
switch (sel->proto) {
|
||||
case IPPROTO_TCP:
|
||||
|
@ -0,0 +1,10 @@
|
||||
--- a/ip/iproute.c
|
||||
+++ b/ip/iproute.c
|
||||
@@ -1286,6 +1286,7 @@ int iproute_get(int argc, char **argv)
|
||||
memset(&req, 0, sizeof(req));
|
||||
|
||||
iproute_reset_filter();
|
||||
+ filter.cloned = 2;
|
||||
|
||||
req.n.nlmsg_len = NLMSG_LENGTH(sizeof(struct rtmsg));
|
||||
req.n.nlmsg_flags = NLM_F_REQUEST;
|
@ -4,8 +4,8 @@
|
||||
tc/q_esfq.c | 200 ++++++++++++++++++++++++++++++++++++++++++++++
|
||||
3 files changed, 260 insertions(+)
|
||||
|
||||
--- iproute2-2.6.35.orig/include/linux/pkt_sched.h
|
||||
+++ iproute2-2.6.35/include/linux/pkt_sched.h
|
||||
--- a/include/linux/pkt_sched.h
|
||||
+++ b/include/linux/pkt_sched.h
|
||||
@@ -174,8 +174,38 @@ struct tc_sfq_qopt
|
||||
*
|
||||
* The only reason for this is efficiency, it is possible
|
||||
@ -83,8 +83,8 @@
|
||||
/* RED section */
|
||||
|
||||
enum {
|
||||
--- iproute2-2.6.35.orig/tc/Makefile
|
||||
+++ iproute2-2.6.35/tc/Makefile
|
||||
--- a/tc/Makefile
|
||||
+++ b/tc/Makefile
|
||||
@@ -8,6 +8,7 @@ SHARED_LIBS ?= y
|
||||
TCMODULES :=
|
||||
TCMODULES += q_fifo.o
|
||||
@ -94,7 +94,7 @@
|
||||
TCMODULES += q_prio.o
|
||||
TCMODULES += q_tbf.o
|
||||
--- /dev/null
|
||||
+++ iproute2-2.6.35/tc/q_esfq.c
|
||||
+++ b/tc/q_esfq.c
|
||||
@@ -0,0 +1,200 @@
|
||||
+/*
|
||||
+ * q_esfq.c ESFQ.
|
||||
|
@ -2,8 +2,8 @@
|
||||
include/linux/netfilter_ipv4/ip_tables.h | 3 +++
|
||||
1 file changed, 3 insertions(+)
|
||||
|
||||
--- iproute2-2.6.35.orig/include/linux/netfilter_ipv4/ip_tables.h
|
||||
+++ iproute2-2.6.35/include/linux/netfilter_ipv4/ip_tables.h
|
||||
--- a/include/linux/netfilter_ipv4/ip_tables.h
|
||||
+++ b/include/linux/netfilter_ipv4/ip_tables.h
|
||||
@@ -113,7 +113,10 @@ struct ipt_entry {
|
||||
#define IPT_CONTINUE XT_CONTINUE
|
||||
#define IPT_RETURN XT_RETURN
|
||||
|
@ -2,8 +2,8 @@
|
||||
tc/q_fifo.c | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
--- iproute2-2.6.35.orig/tc/q_fifo.c
|
||||
+++ iproute2-2.6.35/tc/q_fifo.c
|
||||
--- a/tc/q_fifo.c
|
||||
+++ b/tc/q_fifo.c
|
||||
@@ -98,5 +98,6 @@ struct qdisc_util pfifo_head_drop_qdisc_
|
||||
extern int prio_print_opt(struct qdisc_util *qu, FILE *f, struct rtattr *opt);
|
||||
struct qdisc_util pfifo_fast_qdisc_util = {
|
||||
|
Loading…
Reference in New Issue
Block a user