add bitchx package from Duncan, thx
SVN-Revision: 3374
This commit is contained in:
parent
11b0a8d40c
commit
48069eee67
@ -15,6 +15,7 @@ source "package/nvram/Config.in"
|
||||
endmenu
|
||||
|
||||
menu "Applications"
|
||||
source "package/bitchx/Config.in"
|
||||
source "package/collectd/Config.in"
|
||||
source "package/cbtt/Config.in"
|
||||
source "package/ctorrent/Config.in"
|
||||
|
@ -13,6 +13,7 @@ package-$(BR2_COMPILE_ATFTP) += atftp
|
||||
package-$(BR2_COMPILE_AVAHI) += avahi
|
||||
package-$(BR2_COMPILE_BC) += bc
|
||||
package-$(BR2_COMPILE_BIND) += bind
|
||||
package-$(BR2_PACKAGE_BITCHX) += bitchx
|
||||
package-$(BR2_PACKAGE_BLUEZ_LIBS) += bluez-libs
|
||||
package-$(BR2_PACKAGE_BLUEZ_UTILS) += bluez-utils
|
||||
package-$(BR2_PACKAGE_BRIDGE) += bridge
|
||||
@ -284,6 +285,7 @@ arpwatch-compile: libpcap-compile
|
||||
atftp-compile: readline-compile
|
||||
avahi-compile: libdaemon-compile expat-compile libgdbm-compile
|
||||
bind-compile: openssl-compile
|
||||
bitchx-compile: ncurses-compile
|
||||
cbtt-compile: mysql-compile zlib-compile
|
||||
clinkc-compile: expat-compile
|
||||
curl-compile: openssl-compile zlib-compile
|
||||
|
9
openwrt/package/bitchx/Config.in
Normal file
9
openwrt/package/bitchx/Config.in
Normal file
@ -0,0 +1,9 @@
|
||||
config BR2_PACKAGE_BITCHX
|
||||
prompt "BitchX............................ popular IRC client"
|
||||
tristate
|
||||
default m if CONFIG_DEVEL
|
||||
help
|
||||
A popular IRC client
|
||||
|
||||
http://www.bitchx.org/
|
||||
|
90
openwrt/package/bitchx/Makefile
Normal file
90
openwrt/package/bitchx/Makefile
Normal file
@ -0,0 +1,90 @@
|
||||
# $Id$
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=bitchx
|
||||
PKG_VERSION:=1.1
|
||||
PKG_RELEASE:=1
|
||||
PKG_MD5SUM:=611d2dda222f00c10140236f4c331572
|
||||
|
||||
PKG_SOURCE_URL:=http://bitchx.org/files/source/
|
||||
PKG_SOURCE:=ircii-pana-$(PKG_VERSION)-final.tar.gz
|
||||
PKG_CAT:=zcat
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/BitchX
|
||||
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
|
||||
|
||||
include $(TOPDIR)/package/rules.mk
|
||||
|
||||
$(eval $(call PKG_template,BITCHX,bitchx,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
|
||||
|
||||
$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
|
||||
(cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
|
||||
$(TARGET_CONFIGURE_OPTS) \
|
||||
CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include" \
|
||||
CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
|
||||
LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
|
||||
./configure \
|
||||
--target=$(GNU_HOST_NAME) \
|
||||
--host=mipsel-linux-uclibc-gcc \
|
||||
--build=$(GNU_HOST_NAME) \
|
||||
--program-prefix="" \
|
||||
--program-suffix="" \
|
||||
--prefix=/usr \
|
||||
--exec-prefix=/usr \
|
||||
--bindir=/usr/bin \
|
||||
--datadir=/usr/share \
|
||||
--includedir=/usr/include \
|
||||
--infodir=/usr/share/info \
|
||||
--libdir=/usr/lib \
|
||||
--libexecdir=/usr/lib \
|
||||
--localstatedir=/var \
|
||||
--mandir=/usr/share/man \
|
||||
--sbindir=/usr/sbin \
|
||||
--sysconfdir=/etc \
|
||||
$(DISABLE_LARGEFILE) \
|
||||
$(DISABLE_NLS) \
|
||||
);
|
||||
touch $@
|
||||
|
||||
$(PKG_BUILD_DIR)/.built:
|
||||
rm -rf $(PKG_INSTALL_DIR)
|
||||
mkdir -p $(PKG_INSTALL_DIR)
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||
all
|
||||
mkdir -p $(PKG_INSTALL_DIR)/tmp
|
||||
mkdir -p $(PKG_INSTALL_DIR)/etc/init.d
|
||||
mkdir -p $(PKG_INSTALL_DIR)/usr/bin
|
||||
mkdir -p $(PKG_INSTALL_DIR)/usr/lib/bx
|
||||
mkdir -p $(PKG_INSTALL_DIR)/usr/share/man/man1
|
||||
mkdir -p $(PKG_INSTALL_DIR)/usr/lib/bx/translation
|
||||
mkdir -p $(PKG_INSTALL_DIR)/usr/lib/bx/plugins
|
||||
mkdir -p $(PKG_INSTALL_DIR)/usr/lib/bx/help
|
||||
install -c $(PKG_BUILD_DIR)/source/BitchX $(PKG_INSTALL_DIR)/usr/bin/BitchX-1.1-final
|
||||
rm -f $(PKG_INSTALL_DIR)/usr/bin/BitchX
|
||||
ln -s /usr/bin/BitchX-1.1-final $(PKG_INSTALL_DIR)/usr/bin/BitchX
|
||||
install -c $(PKG_BUILD_DIR)/BitchX.help $(PKG_INSTALL_DIR)/usr/lib/bx/BitchX.help
|
||||
install -c $(PKG_BUILD_DIR)/BitchX.ircnames $(PKG_INSTALL_DIR)/usr/lib/bx/BitchX.ircnames
|
||||
install -c $(PKG_BUILD_DIR)/BitchX.quit $(PKG_INSTALL_DIR)/usr/lib/bx/BitchX.quit
|
||||
install -c $(PKG_BUILD_DIR)/BitchX.reasons $(PKG_INSTALL_DIR)/usr/lib/bx/BitchX.kick
|
||||
install -c $(PKG_BUILD_DIR)/source/wserv $(PKG_INSTALL_DIR)/usr/lib/bx/wserv
|
||||
install -c $(PKG_BUILD_DIR)/source/scr-bx $(PKG_INSTALL_DIR)/usr/bin/scr-bx
|
||||
cp -fpR $(PKG_BUILD_DIR)/script $(PKG_INSTALL_DIR)/usr/lib/bx/
|
||||
cp -fpR $(PKG_BUILD_DIR)/translation $(PKG_INSTALL_DIR)/usr/lib/bx/
|
||||
bzip2 $(PKG_INSTALL_DIR)/usr/lib/bx/translation/*
|
||||
cp -f ./files/bitchxrc $(PKG_INSTALL_DIR)/tmp/.bitchxrc
|
||||
cp -pf ./files/S98bitchxrc $(PKG_INSTALL_DIR)/etc/init.d/S98bitchxrc
|
||||
touch $@
|
||||
|
||||
$(IPKG_BITCHX):
|
||||
install -d -m0755 $(IDIR_BITCHX)/usr/bin
|
||||
cp -fpR $(PKG_INSTALL_DIR)/usr/bin/* $(IDIR_BITCHX)/usr/bin
|
||||
install -d -m0755 $(IDIR_BITCHX)/usr/lib
|
||||
cp -fpR $(PKG_INSTALL_DIR)/usr/lib/* $(IDIR_BITCHX)/usr/lib
|
||||
install -d $(IDIR_BITCHX)/etc/init.d
|
||||
cp -fp $(PKG_INSTALL_DIR)/etc/init.d/S98bitchxrc $(IDIR_BITCHX)/etc/init.d
|
||||
install -d -m0755 $(IDIR_BITCHX)/tmp
|
||||
cp -fp $(PKG_INSTALL_DIR)/tmp/.bitchxrc $(IDIR_BITCHX)/tmp
|
||||
$(RSTRIP) $(IDIR_BITCHX)
|
||||
$(IPKG_BUILD) $(IDIR_BITCHX) $(PACKAGE_DIR)
|
7
openwrt/package/bitchx/files/S98bitchxrc
Executable file
7
openwrt/package/bitchx/files/S98bitchxrc
Executable file
@ -0,0 +1,7 @@
|
||||
#!/bin/sh
|
||||
# make /tmp/.bitchxrc as many servers ban root
|
||||
if [ ! -e /tmp/.bitchxrc ]
|
||||
then
|
||||
echo "IRCUSER OpenWrt" >/tmp/.bitchxrc
|
||||
echo "IRCNAME OpenWrt User!" >>/tmp/.bitchxrc
|
||||
fi
|
2
openwrt/package/bitchx/files/bitchxrc
Normal file
2
openwrt/package/bitchx/files/bitchxrc
Normal file
@ -0,0 +1,2 @@
|
||||
IRCUSER OpenWrt
|
||||
IRCNAME OpenWrt User!
|
7
openwrt/package/bitchx/ipkg/bitchx.control
Normal file
7
openwrt/package/bitchx/ipkg/bitchx.control
Normal file
@ -0,0 +1,7 @@
|
||||
Package: bitchx
|
||||
Priority: optional
|
||||
Section: net
|
||||
Maintainer: Duncan Lindley <drhl@drhl.org>
|
||||
Source: http://www.bitchx.org
|
||||
Depends: libncurses
|
||||
Description: A popular IRC client
|
10
openwrt/package/bitchx/patches/BitchX-tparm.patch
Normal file
10
openwrt/package/bitchx/patches/BitchX-tparm.patch
Normal file
@ -0,0 +1,10 @@
|
||||
--- BitchX/source/term.c.orig 2006-03-05 15:01:46.000000000 +1000
|
||||
+++ BitchX/source/term.c 2006-03-05 15:01:53.000000000 +1000
|
||||
@@ -92,7 +92,6 @@
|
||||
#endif
|
||||
|
||||
extern char *getenv();
|
||||
-extern char *tparm();
|
||||
|
||||
/*
|
||||
* The old code assumed termcap. termcap is almost always present, but on
|
Loading…
Reference in New Issue
Block a user