mac80211: update to wireless-testing 2011-11-01
SVN-Revision: 28711
This commit is contained in:
parent
2afada967c
commit
48a77bb98b
@ -10,10 +10,10 @@ include $(INCLUDE_DIR)/kernel.mk
|
||||
|
||||
PKG_NAME:=mac80211
|
||||
|
||||
PKG_VERSION:=2011-10-05
|
||||
PKG_VERSION:=2011-11-01
|
||||
PKG_RELEASE:=1
|
||||
PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources
|
||||
PKG_MD5SUM:=328dd4c42fb5baa2d96c78009b11af7e
|
||||
PKG_MD5SUM:=24d4062ffb7115e2b2db8eabdb61bd30
|
||||
|
||||
PKG_SOURCE:=compat-wireless-$(PKG_VERSION).tar.bz2
|
||||
PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/compat-wireless-$(PKG_VERSION)
|
||||
@ -1202,6 +1202,9 @@ MAKE_OPTS:= \
|
||||
CONFIG_ATL2= \
|
||||
CONFIG_ATL1E= \
|
||||
CONFIG_ATL1C= \
|
||||
CONFIG_BRCMFMAC= \
|
||||
CONFIG_BRCMUMAC= \
|
||||
CONFIG_BRCMSMAC= \
|
||||
KLIB_BUILD="$(LINUX_DIR)" \
|
||||
MODPROBE=: \
|
||||
KLIB=$(TARGET_MODULES_DIR) \
|
||||
|
@ -9,7 +9,7 @@
|
||||
|
||||
ifeq ($(CONFIG_MAC80211),y)
|
||||
$(error "ERROR: you have MAC80211 compiled into the kernel, CONFIG_MAC80211=y, as such you cannot replace its mac80211 driver. You need this set to CONFIG_MAC80211=m. If you are using Fedora upgrade your kernel as later version should this set as modular. For further information on Fedora see https://bugzilla.redhat.com/show_bug.cgi?id=470143. If you are using your own kernel recompile it and make mac80211 modular")
|
||||
@@ -640,10 +640,10 @@ endif #CONFIG_COMPAT_KERNEL_2_6_27
|
||||
@@ -632,10 +632,10 @@ endif #CONFIG_COMPAT_KERNEL_2_6_27
|
||||
# We need the backported rfkill module on kernel < 2.6.31.
|
||||
# In more recent kernel versions use the in kernel rfkill module.
|
||||
ifdef CONFIG_COMPAT_KERNEL_2_6_31
|
||||
|
@ -37,7 +37,7 @@
|
||||
|
||||
CONFIG_BCMA=m
|
||||
CONFIG_BCMA_BLOCKIO=y
|
||||
@@ -537,7 +537,6 @@ endif #CONFIG_SPI_MASTER end of SPI driv
|
||||
@@ -535,7 +535,6 @@ endif #CONFIG_SPI_MASTER end of SPI driv
|
||||
|
||||
ifdef CONFIG_MMC
|
||||
|
||||
|
@ -28,7 +28,7 @@
|
||||
endif #CONFIG_COMPAT_KERNEL_2_6_27
|
||||
|
||||
ifdef CONFIG_WIRELESS_EXT
|
||||
@@ -434,21 +434,21 @@ endif #CONFIG_COMPAT_KERNEL_2_6_29
|
||||
@@ -432,21 +432,21 @@ endif #CONFIG_COMPAT_KERNEL_2_6_29
|
||||
# Note: this depends on CONFIG_USB_NET_RNDIS_HOST and CONFIG_USB_NET_CDCETHER
|
||||
# it also requires new RNDIS_HOST and CDC_ETHER modules which we add
|
||||
ifdef CONFIG_COMPAT_KERNEL_2_6_29
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- a/config.mk
|
||||
+++ b/config.mk
|
||||
@@ -520,7 +520,7 @@ endif #CONFIG_SPI_MASTER end of SPI driv
|
||||
@@ -518,7 +518,7 @@ endif #CONFIG_SPI_MASTER end of SPI driv
|
||||
|
||||
ifdef CONFIG_MMC
|
||||
|
||||
|
@ -9,7 +9,7 @@
|
||||
CONFIG_RT2400PCI=m
|
||||
CONFIG_RT2500PCI=m
|
||||
ifdef CONFIG_CRC_CCITT
|
||||
@@ -469,7 +469,7 @@ CONFIG_RT2800USB_RT35XX=y
|
||||
@@ -467,7 +467,7 @@ CONFIG_RT2800USB_RT35XX=y
|
||||
# CONFIG_RT2800USB_RT53XX=y
|
||||
CONFIG_RT2800USB_UNKNOWN=y
|
||||
endif #CONFIG_CRC_CCITT
|
||||
|
@ -33,7 +33,7 @@
|
||||
#endif
|
||||
--- a/config.mk
|
||||
+++ b/config.mk
|
||||
@@ -455,7 +455,7 @@ endif #CONFIG_COMPAT_KERNEL_2_6_29
|
||||
@@ -453,7 +453,7 @@ endif #CONFIG_COMPAT_KERNEL_2_6_29
|
||||
# This activates a threading fix for usb urb.
|
||||
# this is mainline commit: b3e670443b7fb8a2d29831b62b44a039c283e351
|
||||
# This fix will be included in some stable releases.
|
||||
|
File diff suppressed because it is too large
Load Diff
@ -18,7 +18,7 @@
|
||||
goto end;
|
||||
--- a/drivers/net/wireless/ath/ath5k/base.c
|
||||
+++ b/drivers/net/wireless/ath/ath5k/base.c
|
||||
@@ -1866,7 +1866,7 @@ ath5k_beacon_send(struct ath5k_hw *ah)
|
||||
@@ -1860,7 +1860,7 @@ ath5k_beacon_send(struct ath5k_hw *ah)
|
||||
ah->bmisscount = 0;
|
||||
}
|
||||
|
||||
@ -27,7 +27,7 @@
|
||||
ah->opmode == NL80211_IFTYPE_MESH_POINT) {
|
||||
u64 tsf = ath5k_hw_get_tsf64(ah);
|
||||
u32 tsftu = TSF_TO_TU(tsf);
|
||||
@@ -1951,7 +1951,7 @@ ath5k_beacon_update_timers(struct ath5k_
|
||||
@@ -1945,7 +1945,7 @@ ath5k_beacon_update_timers(struct ath5k_
|
||||
u64 hw_tsf;
|
||||
|
||||
intval = ah->bintval & AR5K_BEACON_PERIOD;
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- a/include/net/mac80211.h
|
||||
+++ b/include/net/mac80211.h
|
||||
@@ -813,7 +813,7 @@ enum ieee80211_smps_mode {
|
||||
@@ -815,7 +815,7 @@ enum ieee80211_smps_mode {
|
||||
*/
|
||||
struct ieee80211_conf {
|
||||
u32 flags;
|
||||
@ -11,7 +11,7 @@
|
||||
u16 listen_interval;
|
||||
--- a/net/mac80211/cfg.c
|
||||
+++ b/net/mac80211/cfg.c
|
||||
@@ -1597,7 +1597,7 @@ static int ieee80211_get_tx_power(struct
|
||||
@@ -1615,7 +1615,7 @@ static int ieee80211_get_tx_power(struct
|
||||
{
|
||||
struct ieee80211_local *local = wiphy_priv(wiphy);
|
||||
|
||||
|
@ -65,7 +65,7 @@
|
||||
__skb_unlink(skb, &tid->buf_q);
|
||||
list_add_tail(&bf->list, bf_q);
|
||||
if (bf_prev)
|
||||
@@ -1687,6 +1698,8 @@ static void ath_tx_send_ampdu(struct ath
|
||||
@@ -1680,6 +1691,8 @@ static void ath_tx_send_ampdu(struct ath
|
||||
/* Add sub-frame to BAW */
|
||||
ath_tx_addto_baw(sc, tid, bf->bf_state.seqno);
|
||||
|
||||
@ -74,7 +74,7 @@
|
||||
/* Queue to h/w without aggregation */
|
||||
TX_STAT_INC(txctl->txq->axq_qnum, a_queued_hw);
|
||||
bf->bf_lastbf = bf;
|
||||
@@ -1815,23 +1828,13 @@ error:
|
||||
@@ -1808,23 +1821,13 @@ error:
|
||||
|
||||
/* FIXME: tx power */
|
||||
static void ath_tx_start_dma(struct ath_softc *sc, struct sk_buff *skb,
|
||||
@ -100,7 +100,7 @@
|
||||
|
||||
if ((tx_info->flags & IEEE80211_TX_CTL_AMPDU) && tid) {
|
||||
/*
|
||||
@@ -1866,6 +1869,7 @@ int ath_tx_start(struct ieee80211_hw *hw
|
||||
@@ -1859,6 +1862,7 @@ int ath_tx_start(struct ieee80211_hw *hw
|
||||
struct ieee80211_vif *vif = info->control.vif;
|
||||
struct ath_softc *sc = hw->priv;
|
||||
struct ath_txq *txq = txctl->txq;
|
||||
@ -108,7 +108,7 @@
|
||||
int padpos, padsize;
|
||||
int frmlen = skb->len + FCS_LEN;
|
||||
int q;
|
||||
@@ -1908,6 +1912,24 @@ int ath_tx_start(struct ieee80211_hw *hw
|
||||
@@ -1901,6 +1905,24 @@ int ath_tx_start(struct ieee80211_hw *hw
|
||||
|
||||
setup_frame_info(hw, skb, frmlen);
|
||||
|
||||
@ -133,7 +133,7 @@
|
||||
/*
|
||||
* At this point, the vif, hw_key and sta pointers in the tx control
|
||||
* info are no longer valid (overwritten by the ath_frame_info data.
|
||||
@@ -1922,7 +1944,7 @@ int ath_tx_start(struct ieee80211_hw *hw
|
||||
@@ -1915,7 +1937,7 @@ int ath_tx_start(struct ieee80211_hw *hw
|
||||
}
|
||||
spin_unlock_bh(&txq->axq_lock);
|
||||
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- a/include/net/mac80211.h
|
||||
+++ b/include/net/mac80211.h
|
||||
@@ -681,6 +681,9 @@ enum mac80211_rx_flags {
|
||||
@@ -683,6 +683,9 @@ enum mac80211_rx_flags {
|
||||
* @mactime: value in microseconds of the 64-bit Time Synchronization Function
|
||||
* (TSF) timer when the first data symbol (MPDU) arrived at the hardware.
|
||||
* @band: the active band when this frame was received
|
||||
@ -10,7 +10,7 @@
|
||||
* @freq: frequency the radio was tuned to when receiving this frame, in MHz
|
||||
* @signal: signal strength when receiving this frame, either in dBm, in dB or
|
||||
* unspecified depending on the hardware capabilities flags
|
||||
@@ -694,6 +697,10 @@ enum mac80211_rx_flags {
|
||||
@@ -696,6 +699,10 @@ enum mac80211_rx_flags {
|
||||
struct ieee80211_rx_status {
|
||||
u64 mactime;
|
||||
enum ieee80211_band band;
|
||||
@ -78,27 +78,27 @@
|
||||
kfree(sta);
|
||||
--- a/include/net/cfg80211.h
|
||||
+++ b/include/net/cfg80211.h
|
||||
@@ -497,6 +497,8 @@ struct station_parameters {
|
||||
* @STATION_INFO_BSS_PARAM: @bss_param filled
|
||||
@@ -498,6 +498,8 @@ struct station_parameters {
|
||||
* @STATION_INFO_CONNECTED_TIME: @connected_time filled
|
||||
* @STATION_INFO_ASSOC_REQ_IES: @assoc_req_ies filled
|
||||
* @STATION_INFO_STA_FLAGS: @sta_flags filled
|
||||
+ * @STATION_INFO_CHAIN_SIGNAL: @chain_signal filled
|
||||
+ * @STATION_INFO_CHAIN_SIGNAL_AVG: @chain_signal_avg filled
|
||||
*/
|
||||
enum station_info_flags {
|
||||
STATION_INFO_INACTIVE_TIME = 1<<0,
|
||||
@@ -516,7 +518,9 @@ enum station_info_flags {
|
||||
STATION_INFO_RX_BITRATE = 1<<14,
|
||||
@@ -518,7 +520,9 @@ enum station_info_flags {
|
||||
STATION_INFO_BSS_PARAM = 1<<15,
|
||||
STATION_INFO_CONNECTED_TIME = 1<<16,
|
||||
- STATION_INFO_ASSOC_REQ_IES = 1<<17
|
||||
+ STATION_INFO_ASSOC_REQ_IES = 1<<17,
|
||||
+ STATION_INFO_CHAIN_SIGNAL = 1<<18,
|
||||
+ STATION_INFO_CHAIN_SIGNAL_AVG = 1<<19,
|
||||
STATION_INFO_ASSOC_REQ_IES = 1<<17,
|
||||
- STATION_INFO_STA_FLAGS = 1<<18
|
||||
+ STATION_INFO_STA_FLAGS = 1<<18,
|
||||
+ STATION_INFO_CHAIN_SIGNAL = 1<<19,
|
||||
+ STATION_INFO_CHAIN_SIGNAL_AVG = 1<<20,
|
||||
};
|
||||
|
||||
/**
|
||||
@@ -596,6 +600,9 @@ struct sta_bss_parameters {
|
||||
@@ -598,6 +602,9 @@ struct sta_bss_parameters {
|
||||
* @plink_state: mesh peer link state
|
||||
* @signal: signal strength of last received packet in dBm
|
||||
* @signal_avg: signal strength average in dBm
|
||||
@ -108,7 +108,7 @@
|
||||
* @txrate: current unicast bitrate from this station
|
||||
* @rxrate: current unicast bitrate to this station
|
||||
* @rx_packets: packets received from this station
|
||||
@@ -625,6 +632,11 @@ struct station_info {
|
||||
@@ -627,6 +634,11 @@ struct station_info {
|
||||
u8 plink_state;
|
||||
s8 signal;
|
||||
s8 signal_avg;
|
||||
@ -271,19 +271,19 @@
|
||||
RX_SAMP_DBG(rate) = rs->rs_rate;
|
||||
--- a/include/linux/nl80211.h
|
||||
+++ b/include/linux/nl80211.h
|
||||
@@ -1548,6 +1548,8 @@ enum nl80211_sta_bss_param {
|
||||
* @NL80211_STA_INFO_BSS_PARAM: current station's view of BSS, nested attribute
|
||||
@@ -1549,6 +1549,8 @@ enum nl80211_sta_bss_param {
|
||||
* containing info as possible, see &enum nl80211_sta_bss_param
|
||||
* @NL80211_STA_INFO_CONNECTED_TIME: time since the station is last connected
|
||||
* @NL80211_STA_INFO_STA_FLAGS: Contains a struct nl80211_sta_flag_update.
|
||||
+ * @NL80211_STA_INFO_CHAIN_SIGNAL: per-chain signal strength of last PPDU
|
||||
+ * @NL80211_STA_INFO_CHAIN_SIGNAL_AVG: per-chain signal strength average
|
||||
* @__NL80211_STA_INFO_AFTER_LAST: internal
|
||||
* @NL80211_STA_INFO_MAX: highest possible station info attribute
|
||||
*/
|
||||
@@ -1569,6 +1571,8 @@ enum nl80211_sta_info {
|
||||
NL80211_STA_INFO_RX_BITRATE,
|
||||
@@ -1571,6 +1573,8 @@ enum nl80211_sta_info {
|
||||
NL80211_STA_INFO_BSS_PARAM,
|
||||
NL80211_STA_INFO_CONNECTED_TIME,
|
||||
NL80211_STA_INFO_STA_FLAGS,
|
||||
+ NL80211_STA_INFO_CHAIN_SIGNAL,
|
||||
+ NL80211_STA_INFO_CHAIN_SIGNAL_AVG,
|
||||
|
||||
@ -354,7 +354,7 @@
|
||||
|
||||
sinfo->generation = sdata->local->sta_generation;
|
||||
|
||||
@@ -364,6 +365,17 @@ static void sta_set_sinfo(struct sta_inf
|
||||
@@ -365,6 +366,17 @@ static void sta_set_sinfo(struct sta_inf
|
||||
sinfo->signal = (s8)sta->last_signal;
|
||||
sinfo->signal_avg = (s8) -ewma_read(&sta->avg_signal);
|
||||
}
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- a/config.mk
|
||||
+++ b/config.mk
|
||||
@@ -573,6 +573,7 @@ CONFIG_RT2X00=y
|
||||
@@ -567,6 +567,7 @@ CONFIG_RT2X00=y
|
||||
CONFIG_RT2X00_LIB=m
|
||||
CONFIG_RT2800_LIB=m
|
||||
CONFIG_RT2X00_LIB_FIRMWARE=y
|
||||
|
Loading…
Reference in New Issue
Block a user