fix compile against musl
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> SVN-Revision: 43000
This commit is contained in:
parent
549f7d0366
commit
48c507b7ed
@ -1,5 +1,5 @@
|
||||
#
|
||||
# Copyright (C) 2006-2012 OpenWrt.org
|
||||
# Copyright (C) 2006-2014 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=comgt
|
||||
PKG_VERSION:=0.32
|
||||
PKG_RELEASE:=23
|
||||
PKG_RELEASE:=24
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME).$(PKG_VERSION).tgz
|
||||
PKG_SOURCE_URL:=@SF/comgt
|
||||
|
29
package/network/utils/comgt/patches/002-termios.patch
Normal file
29
package/network/utils/comgt/patches/002-termios.patch
Normal file
@ -0,0 +1,29 @@
|
||||
--- a/comgt.c
|
||||
+++ b/comgt.c
|
||||
@@ -30,7 +30,7 @@
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
#include <signal.h>
|
||||
-#include <termio.h>
|
||||
+#include <termios.h>
|
||||
#include <fcntl.h>
|
||||
#include <unistd.h>
|
||||
#include <string.h>
|
||||
@@ -81,7 +81,7 @@ char token[MAXTOKEN]; /* For gettoken(
|
||||
char scriptfile[MAXPATH]; /* Script file name */
|
||||
char scriptfilepath[MAXPATH]; /* temp storage for full path */
|
||||
BOOL verbose=0; /* Log actions */
|
||||
-struct termio cons, stbuf, svbuf; /* termios: svbuf=before, stbuf=while */
|
||||
+struct termios cons, stbuf, svbuf; /* termios: svbuf=before, stbuf=while */
|
||||
int comfd=0; /* Communication file descriptor. Defaults to stdin. */
|
||||
char msg[STRINGL]; /* Massage messages here */
|
||||
int preturn,returns[MAXGOSUBS];
|
||||
@@ -926,7 +926,7 @@ void setcom(void) {
|
||||
}
|
||||
|
||||
void doset(void) {
|
||||
- struct termio console;
|
||||
+ struct termios console;
|
||||
int a,b;
|
||||
gettoken();
|
||||
if(strcmp(token,"echo")==0) {
|
Loading…
Reference in New Issue
Block a user