fix build on systems without libgcrypt-config
SVN-Revision: 2752
This commit is contained in:
parent
81e1edf005
commit
4a4b453988
@ -1,14 +1,21 @@
|
|||||||
diff -ruN vpnc-0.3.3-old/Makefile vpnc-0.3.3-new/Makefile
|
diff -Nur vpnc-0.3.3/Makefile vpnc-0.3.3.patched/Makefile
|
||||||
--- vpnc-0.3.3-old/Makefile 2005-05-01 22:30:35.000000000 +0200
|
--- vpnc-0.3.3/Makefile 2005-05-01 22:30:35.000000000 +0200
|
||||||
+++ vpnc-0.3.3-new/Makefile 2005-12-13 17:23:26.000000000 +0100
|
+++ vpnc-0.3.3.patched/Makefile 2005-12-23 23:43:55.222055250 +0100
|
||||||
@@ -23,25 +23,26 @@
|
@@ -17,31 +17,32 @@
|
||||||
|
# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
|
||||||
|
|
||||||
|
DESTDIR=
|
||||||
|
-PREFIX=/usr/local
|
||||||
|
+PREFIX=/usr
|
||||||
|
ETCDIR=/etc/vpnc
|
||||||
|
SBINDIR=$(PREFIX)/sbin
|
||||||
MANDIR=$(PREFIX)/share/man
|
MANDIR=$(PREFIX)/share/man
|
||||||
|
|
||||||
CC=gcc
|
CC=gcc
|
||||||
-CFLAGS=-W -Wall -O -g '-DVERSION="$(shell cat VERSION)"' $(shell libgcrypt-config --cflags)
|
-CFLAGS=-W -Wall -O -g '-DVERSION="$(shell cat VERSION)"' $(shell libgcrypt-config --cflags)
|
||||||
-LDFLAGS=-g $(shell libgcrypt-config --libs)
|
-LDFLAGS=-g $(shell libgcrypt-config --libs)
|
||||||
+CFLAGS=-W -Wall -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include $(OFLAGS) '-DVERSION="$(shell cat VERSION)"' $(shell libgcrypt-config --cflags)
|
+CFLAGS=-W -Wall -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include $(OFLAGS) '-DVERSION="$(shell cat VERSION)"'
|
||||||
+LDFLAGS=-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib $(shell libgcrypt-config --libs)
|
+LDFLAGS=-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib -lgcrypt -lgpg-error
|
||||||
|
|
||||||
-ifeq ($(shell uname -s), Linux)
|
-ifeq ($(shell uname -s), Linux)
|
||||||
+OS=$(shell uname -s)
|
+OS=$(shell uname -s)
|
||||||
|
Loading…
Reference in New Issue
Block a user