xtables-addons: remove version 1.x for old kernels
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 42047
This commit is contained in:
parent
053a3a4aaf
commit
4d39f186bc
@ -9,16 +9,9 @@ include $(TOPDIR)/rules.mk
|
||||
include $(INCLUDE_DIR)/kernel.mk
|
||||
|
||||
PKG_NAME:=xtables-addons
|
||||
ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.7.0)),1)
|
||||
PKG_VERSION:=2.3
|
||||
PKG_RELEASE:=1
|
||||
PKG_MD5SUM:=7d942729c365a549513511061f74c3e3
|
||||
else
|
||||
PKG_VERSION:=1.45
|
||||
PKG_RELEASE:=3
|
||||
PKG_MD5SUM:=802d2f556a5e545f44e4b69937bf8490
|
||||
PATCH_DIR:=./patches-1.x
|
||||
endif
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=@SF/xtables-addons
|
||||
@ -37,6 +30,7 @@ define Package/xtables-addons
|
||||
SECTION:=net
|
||||
CATEGORY:=Network
|
||||
SUBMENU:=Firewall
|
||||
DEPENDS:=@!LINUX_3_3
|
||||
TITLE:=Extensions not distributed in the main Xtables
|
||||
URL:=http://xtables-addons.sourceforge.net/
|
||||
endef
|
||||
|
@ -1,16 +0,0 @@
|
||||
---
|
||||
Makefile.in | 3 +--
|
||||
1 file changed, 1 insertion(+), 2 deletions(-)
|
||||
|
||||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -11,9 +11,6 @@ FORCE:
|
||||
xtables-addons.8: FORCE
|
||||
${MAKE} -f Makefile.mans all;
|
||||
|
||||
-install-exec-hook:
|
||||
- depmod -a || :;
|
||||
-
|
||||
config.status: Makefile.iptrules.in
|
||||
|
||||
tmpdir := $(shell mktemp -dtu)
|
@ -1,22 +0,0 @@
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -11780,7 +11780,7 @@ regular_CFLAGS="-Wall -Waggregate-return
|
||||
if test -n "$kbuilddir"; then
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking kernel version that we will build against" >&5
|
||||
$as_echo_n "checking kernel version that we will build against... " >&6; }
|
||||
- krel="$(make -sC "$kbuilddir" M=$PWD kernelrelease)";
|
||||
+ krel="$(make -sC "$kbuilddir" M=$PWD kernelversion)";
|
||||
kmajor="${krel%%[^0-9]*}";
|
||||
kmajor="$(($kmajor+0))";
|
||||
krel="${krel:${#kmajor}}";
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -44,7 +44,7 @@ regular_CFLAGS="-Wall -Waggregate-return
|
||||
|
||||
if test -n "$kbuilddir"; then
|
||||
AC_MSG_CHECKING([kernel version that we will build against])
|
||||
- krel="$(make -sC "$kbuilddir" M=$PWD kernelrelease)";
|
||||
+ krel="$(make -sC "$kbuilddir" M=$PWD kernelversion)";
|
||||
kmajor="${krel%%[[^0-9]]*}";
|
||||
kmajor="$(($kmajor+0))";
|
||||
krel="${krel:${#kmajor}}";
|
@ -1,11 +0,0 @@
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -31,7 +31,7 @@ xtlibdir="$(pkg-config --variable=xtlibd
|
||||
|
||||
AC_ARG_WITH([xtlibdir],
|
||||
AS_HELP_STRING([--with-xtlibdir=PATH],
|
||||
- [Path where to install Xtables extensions [[autodetect]]]]),
|
||||
+ [Path where to install Xtables extensions [[autodetect]]]),
|
||||
[xtlibdir="$withval"])
|
||||
AC_MSG_CHECKING([Xtables module directory])
|
||||
AC_MSG_RESULT([$xtlibdir])
|
File diff suppressed because it is too large
Load Diff
@ -1,22 +0,0 @@
|
||||
--- a/extensions/rtsp/nf_conntrack_rtsp.c
|
||||
+++ b/extensions/rtsp/nf_conntrack_rtsp.c
|
||||
@@ -28,6 +28,7 @@
|
||||
* - Port to new NF API
|
||||
*/
|
||||
|
||||
+#include <linux/version.h>
|
||||
#include <linux/module.h>
|
||||
#include <linux/netfilter.h>
|
||||
#include <linux/ip.h>
|
||||
@@ -496,7 +497,11 @@ init(void)
|
||||
} else {
|
||||
sprintf(tmpname, "rtsp-%d", i);
|
||||
}
|
||||
+#if LINUX_VERSION_CODE >= KERNEL_VERSION(3,6,0)
|
||||
+ strncpy(hlpr->name, tmpname, sizeof(hlpr->name));
|
||||
+#else
|
||||
hlpr->name = tmpname;
|
||||
+#endif
|
||||
|
||||
pr_debug("port #%d: %d\n", i, ports[i]);
|
||||
|
File diff suppressed because it is too large
Load Diff
@ -1,89 +0,0 @@
|
||||
--- a/extensions/LUA/xt_LUA_target.c
|
||||
+++ b/extensions/LUA/xt_LUA_target.c
|
||||
@@ -64,10 +64,10 @@ uint32_t lua_state_refs[LUA_STATE_ARRAY
|
||||
* XT_CONTINUE inside the *register_lua_packet_lib* function.
|
||||
*/
|
||||
|
||||
-spinlock_t lock = SPIN_LOCK_UNLOCKED;
|
||||
+DEFINE_SPINLOCK(lock);
|
||||
|
||||
static uint32_t
|
||||
-lua_tg(struct sk_buff *pskb, const struct xt_target_param *par)
|
||||
+lua_tg(struct sk_buff *pskb, const struct xt_action_param *par)
|
||||
{
|
||||
uint32_t verdict;
|
||||
lua_packet_segment *p;
|
||||
@@ -208,16 +208,16 @@ static bool load_script_into_state(uint3
|
||||
* some workqueue initialization. So far this is done each time this function
|
||||
* is called, subject to change.
|
||||
*/
|
||||
-static bool
|
||||
+static int
|
||||
lua_tg_checkentry(const struct xt_tgchk_param *par)
|
||||
{
|
||||
const struct xt_lua_tginfo *info = par->targinfo;
|
||||
|
||||
if (load_script_into_state(info->state_id, info->script_size, (char *)info->buf)) {
|
||||
lua_state_refs[info->state_id]++;
|
||||
- return true;
|
||||
+ return 0;
|
||||
}
|
||||
- return false;
|
||||
+ return -EINVAL;
|
||||
}
|
||||
|
||||
/*::*
|
||||
--- a/extensions/LUA/lua/llimits.h
|
||||
+++ b/extensions/LUA/lua/llimits.h
|
||||
@@ -8,7 +8,6 @@
|
||||
#define llimits_h
|
||||
|
||||
#include <stddef.h>
|
||||
-#include <limits.h>
|
||||
|
||||
#include "lua.h"
|
||||
|
||||
--- a/extensions/LUA/lua/lapi.c
|
||||
+++ b/extensions/LUA/lua/lapi.c
|
||||
@@ -4,9 +4,6 @@
|
||||
** See Copyright Notice in lua.h
|
||||
*/
|
||||
|
||||
-#include <stdarg.h>
|
||||
-#include <math.h>
|
||||
-#include <assert.h>
|
||||
#include <string.h>
|
||||
|
||||
#define lapi_c
|
||||
--- a/extensions/LUA/lua/ltable.c
|
||||
+++ b/extensions/LUA/lua/ltable.c
|
||||
@@ -18,7 +18,6 @@
|
||||
** Hence even when the load factor reaches 100%, performance remains good.
|
||||
*/
|
||||
|
||||
-#include <math.h>
|
||||
#include <string.h>
|
||||
|
||||
#define ltable_c
|
||||
--- a/extensions/LUA/lua/luaconf.h
|
||||
+++ b/extensions/LUA/lua/luaconf.h
|
||||
@@ -13,6 +13,10 @@
|
||||
#if !defined(__KERNEL__)
|
||||
#include <limits.h>
|
||||
#else
|
||||
+#undef UCHAR_MAX
|
||||
+#undef SHRT_MAX
|
||||
+#undef BUFSIZ
|
||||
+#undef NO_FPU
|
||||
#define UCHAR_MAX 255
|
||||
#define SHRT_MAX 32767
|
||||
#define BUFSIZ 8192
|
||||
@@ -637,6 +641,8 @@ union luai_Cast { double l_d; long l_l;
|
||||
*/
|
||||
#if defined(__KERNEL__)
|
||||
#undef LUA_USE_ULONGJMP
|
||||
+#define setjmp __builtin_setjmp
|
||||
+#define longjmp __builtin_longjmp
|
||||
#endif
|
||||
|
||||
#if defined(__cplusplus)
|
@ -1,18 +0,0 @@
|
||||
--- a/extensions/libxt_geoip.c
|
||||
+++ b/extensions/libxt_geoip.c
|
||||
@@ -59,13 +59,13 @@ geoip_get_subnets(const char *code, uint
|
||||
|
||||
/* Use simple integer vector files */
|
||||
if (nfproto == NFPROTO_IPV6) {
|
||||
-#if __BYTE_ORDER == _BIG_ENDIAN
|
||||
+#if BYTE_ORDER == BIG_ENDIAN
|
||||
snprintf(buf, sizeof(buf), GEOIP_DB_DIR "/BE/%s.iv6", code);
|
||||
#else
|
||||
snprintf(buf, sizeof(buf), GEOIP_DB_DIR "/LE/%s.iv6", code);
|
||||
#endif
|
||||
} else {
|
||||
-#if __BYTE_ORDER == _BIG_ENDIAN
|
||||
+#if BYTE_ORDER == BIG_ENDIAN
|
||||
snprintf(buf, sizeof(buf), GEOIP_DB_DIR "/BE/%s.iv4", code);
|
||||
#else
|
||||
snprintf(buf, sizeof(buf), GEOIP_DB_DIR "/LE/%s.iv4", code);
|
Loading…
Reference in New Issue
Block a user