package/opkg: refresh patches
SVN-Revision: 20474
This commit is contained in:
parent
179ba60e0e
commit
5c5b8928d2
@ -6,7 +6,7 @@ Signed-off-by: Nicolas Thill <nico@openwrt.org>
|
||||
|
||||
--- a/libopkg/opkg_conf.c
|
||||
+++ b/libopkg/opkg_conf.c
|
||||
@@ -62,6 +62,7 @@
|
||||
@@ -62,6 +62,7 @@ opkg_option_t options[] = {
|
||||
{ "download_only", OPKG_OPT_TYPE_BOOL, &_conf.download_only },
|
||||
{ "nodeps", OPKG_OPT_TYPE_BOOL, &_conf.nodeps },
|
||||
{ "offline_root", OPKG_OPT_TYPE_STRING, &_conf.offline_root },
|
||||
@ -16,7 +16,7 @@ Signed-off-by: Nicolas Thill <nico@openwrt.org>
|
||||
{ "query-all", OPKG_OPT_TYPE_BOOL, &_conf.query_all },
|
||||
--- a/libopkg/opkg_conf.h
|
||||
+++ b/libopkg/opkg_conf.h
|
||||
@@ -76,6 +76,7 @@
|
||||
@@ -76,6 +76,7 @@ struct opkg_conf
|
||||
int check_signature;
|
||||
int nodeps; /* do not follow dependences */
|
||||
char *offline_root;
|
||||
@ -34,7 +34,7 @@ Signed-off-by: Nicolas Thill <nico@openwrt.org>
|
||||
|
||||
#include "pkg.h"
|
||||
#include "pkg_hash.h"
|
||||
@@ -189,13 +190,24 @@
|
||||
@@ -189,13 +190,24 @@ static int
|
||||
verify_pkg_installable(pkg_t *pkg)
|
||||
{
|
||||
unsigned long kbs_available, pkg_size_kbs;
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- a/libopkg/Makefile.am
|
||||
+++ b/libopkg/Makefile.am
|
||||
@@ -35,16 +35,10 @@
|
||||
@@ -35,16 +35,10 @@ if HAVE_SHA256
|
||||
opkg_util_sources += sha256.c sha256.h
|
||||
endif
|
||||
|
||||
@ -22,7 +22,7 @@
|
||||
+libopkg_a_LIBADD = $(top_builddir)/libbb/libbb.a $(CURL_LIBS) $(GPGME_LIBS) $(OPENSSL_LIBS) $(PATHFINDER_LIBS)
|
||||
--- a/libbb/Makefile.am
|
||||
+++ b/libbb/Makefile.am
|
||||
@@ -2,9 +2,9 @@
|
||||
@@ -2,9 +2,9 @@ HOST_CPU=@host_cpu@
|
||||
BUILD_CPU=@build_cpu@
|
||||
ALL_CFLAGS=-g -O -Wall -DHOST_CPU_STR=\"$(HOST_CPU)\" -DBUILD_CPU=@build_cpu@
|
||||
|
||||
@ -36,7 +36,7 @@
|
||||
wfopen.c \
|
||||
--- a/tests/Makefile.am
|
||||
+++ b/tests/Makefile.am
|
||||
@@ -4,11 +4,11 @@
|
||||
@@ -4,11 +4,11 @@ AM_CFLAGS = $(ALL_CFLAGS) -Wall -g -O3 -
|
||||
#noinst_PROGRAMS = libopkg_test opkg_active_list_test
|
||||
noinst_PROGRAMS = libopkg_test
|
||||
|
||||
@ -50,7 +50,7 @@
|
||||
#opkg_extract_test_SOURCES = opkg_extract_test.c
|
||||
#opkg_extract_test_CFLAGS = $(ALL_CFLAGS) -I$(top_srcdir)
|
||||
|
||||
@@ -16,7 +16,7 @@
|
||||
@@ -16,7 +16,7 @@ noinst_PROGRAMS = libopkg_test
|
||||
#opkg_active_list_test_SOURCES = opkg_active_list_test.c
|
||||
#opkg_active_list_test_CFLAGS = $(ALL_CFLAGS) -I$(top_srcdir)
|
||||
|
||||
@ -61,7 +61,7 @@
|
||||
|
||||
--- a/src/Makefile.am
|
||||
+++ b/src/Makefile.am
|
||||
@@ -2,5 +2,5 @@
|
||||
@@ -2,5 +2,5 @@ AM_CFLAGS = -I${top_srcdir}/libopkg ${AL
|
||||
bin_PROGRAMS = opkg-cl
|
||||
|
||||
opkg_cl_SOURCES = opkg-cl.c
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- a/libopkg/opkg_cmd.c
|
||||
+++ b/libopkg/opkg_cmd.c
|
||||
@@ -498,17 +498,6 @@
|
||||
@@ -498,17 +498,6 @@ opkg_upgrade_cmd(int argc, char **argv)
|
||||
opkg_install_by_name(arg);
|
||||
}
|
||||
}
|
||||
@ -18,7 +18,7 @@
|
||||
}
|
||||
|
||||
opkg_configure_packages(NULL);
|
||||
@@ -1166,7 +1155,7 @@
|
||||
@@ -1166,7 +1155,7 @@ opkg_print_architecture_cmd(int argc, ch
|
||||
array for easier maintenance */
|
||||
static opkg_cmd_t cmds[] = {
|
||||
{"update", 0, (opkg_cmd_fun_t)opkg_update_cmd, PFM_DESCRIPTION|PFM_SOURCE},
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- a/libopkg/opkg_cmd.c
|
||||
+++ b/libopkg/opkg_cmd.c
|
||||
@@ -738,49 +738,6 @@
|
||||
@@ -738,49 +738,6 @@ opkg_remove_cmd(int argc, char **argv)
|
||||
}
|
||||
|
||||
static int
|
||||
@ -50,7 +50,7 @@
|
||||
opkg_files_cmd(int argc, char **argv)
|
||||
{
|
||||
pkg_t *pkg;
|
||||
@@ -1162,7 +1119,6 @@
|
||||
@@ -1162,7 +1119,6 @@ static opkg_cmd_t cmds[] = {
|
||||
{"list_upgradable", 0, (opkg_cmd_fun_t)opkg_list_upgradable_cmd, PFM_SOURCE},
|
||||
{"list-upgradable", 0, (opkg_cmd_fun_t)opkg_list_upgradable_cmd, PFM_SOURCE},
|
||||
{"info", 0, (opkg_cmd_fun_t)opkg_info_cmd, 0},
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- a/src/opkg-cl.c
|
||||
+++ b/src/opkg-cl.c
|
||||
@@ -172,7 +172,10 @@
|
||||
@@ -172,7 +172,10 @@ args_parse(int argc, char *argv[])
|
||||
printf("Confusion: getopt_long returned %d\n", c);
|
||||
}
|
||||
}
|
||||
|
Loading…
Reference in New Issue
Block a user