update sangam-atm driver to 07.02.01.00 (closes: #2177, thanks to Matteo Croce)
SVN-Revision: 8426
This commit is contained in:
parent
3b4fa7de59
commit
60157ca058
@ -10,20 +10,20 @@ include $(TOPDIR)/rules.mk
|
||||
include $(INCLUDE_DIR)/kernel.mk
|
||||
|
||||
PKG_NAME:=sangam_atm
|
||||
PKG_VERSION:=07.01.00.10
|
||||
PKG_VERSION:=07.02.01.00
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=http://downloads.openwrt.org/sources
|
||||
PKG_MD5SUM:=d35e8889ada0f79b3f562bb12dcef0d4
|
||||
PKG_MD5SUM:=dc4d5c36532503a2f234f3303a0bf563
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define KernelPackage/sangam-atm-annex-a
|
||||
SUBMENU:=Network Devices
|
||||
DEPENDS:=@LINUX_2_6_AR7 +kmod-atm
|
||||
TITLE:=AR7 ADSL driver (Annex A)
|
||||
DESCRIPTION:=The AR7 ADSL driver for Annex A
|
||||
TITLE:=AR7 ADSL driver (Annex A, ADSL over POTS)
|
||||
DESCRIPTION:=The AR7 ADSL driver for Annex A (ADSL over POTS)
|
||||
VERSION:=$(PKG_VERSION)+$(LINUX_VERSION)-$(BOARD)-$(PKG_RELEASE)
|
||||
FILES:=$(PKG_BUILD_DIR)/tiatm.$(LINUX_KMOD_SUFFIX)
|
||||
AUTOLOAD:=$(call AutoLoad,50,tiatm)
|
||||
@ -31,8 +31,8 @@ endef
|
||||
|
||||
define KernelPackage/sangam-atm-annex-b
|
||||
$(call KernelPackage/sangam-atm-annex-a)
|
||||
TITLE:=AR7 ADSL driver (Annex B)
|
||||
DESCRIPTION:=The AR7 ADSL driver for Annex B
|
||||
TITLE:=AR7 ADSL driver (Annex B, ADSL over ISDN)
|
||||
DESCRIPTION:=The AR7 ADSL driver for Annex B (ADSL over ISDN)
|
||||
endef
|
||||
|
||||
define Build/Compile
|
||||
|
@ -1,6 +1,6 @@
|
||||
diff -urN sangam_atm-07.01.00.10/cppi_cpaal5.c sangam-atm-0.3/cppi_cpaal5.c
|
||||
--- sangam_atm-07.01.00.10/cppi_cpaal5.c 2005-04-08 14:22:04.000000000 +0200
|
||||
+++ sangam-atm-0.3/cppi_cpaal5.c 2007-04-17 13:45:11.000000000 +0200
|
||||
diff -urN sangam_atm-07.02.01.00/cppi_cpaal5.c sangam_atm-07.02.01.00/cppi_cpaal5.c
|
||||
--- sangam_atm-07.02.01.00/cppi_cpaal5.c 2007-08-06 18:15:52.000000000 +0200
|
||||
+++ sangam_atm-07.02.01.00/cppi_cpaal5.c 2007-08-06 18:58:42.000000000 +0200
|
||||
@@ -352,7 +352,7 @@
|
||||
{
|
||||
/* malloc failed, add this RCB to Needs Buffer List */
|
||||
@ -10,12 +10,12 @@ diff -urN sangam_atm-07.01.00.10/cppi_cpaal5.c sangam-atm-0.3/cppi_cpaal5.c
|
||||
|
||||
if(HalDev->NeedsCount < MAX_NEEDS) /* +MJH 030410 */
|
||||
{ /* +MJH 030410 */
|
||||
diff -urN sangam_atm-07.01.00.10/dsl_hal_api.c sangam-atm-0.3/dsl_hal_api.c
|
||||
--- sangam_atm-07.01.00.10/dsl_hal_api.c 2006-10-26 16:46:54.000000000 +0200
|
||||
+++ sangam-atm-0.3/dsl_hal_api.c 2007-04-19 01:12:40.000000000 +0200
|
||||
@@ -229,15 +229,15 @@
|
||||
* 10/4/06 JZ CQ10979: Request for TR-069 Support for RP7.1
|
||||
* UR8_MERGE_END CQ10979*
|
||||
diff -urN sangam_atm-07.02.01.00/dsl_hal_api.c sangam_atm-07.02.01.00/dsl_hal_api.c
|
||||
--- sangam_atm-07.02.01.00/dsl_hal_api.c 2007-08-06 18:15:52.000000000 +0200
|
||||
+++ sangam_atm-07.02.01.00/dsl_hal_api.c 2007-08-06 18:58:42.000000000 +0200
|
||||
@@ -241,15 +241,15 @@
|
||||
* UR8_MERGE_START_END CQ11247_TR69_DS_LATN_SATN YW
|
||||
* 12/18/06 Yan Wang CQ11247: TR069 range and precision changes for LATNds, SATNds
|
||||
******************************************************************************/
|
||||
-#include <dev_host_interface.h>
|
||||
-#include <dsl_hal_register.h>
|
||||
@ -32,11 +32,11 @@ diff -urN sangam_atm-07.01.00.10/dsl_hal_api.c sangam-atm-0.3/dsl_hal_api.c
|
||||
-#include <dsl_hal_version.h>
|
||||
+#include "dsl_hal_version.h"
|
||||
|
||||
static unsigned int hybrid_selected;
|
||||
static unsigned int showtimeFlag = FALSE;
|
||||
diff -urN sangam_atm-07.01.00.10/dsl_hal_support.c sangam-atm-0.3/dsl_hal_support.c
|
||||
--- sangam_atm-07.01.00.10/dsl_hal_support.c 2006-08-11 21:17:38.000000000 +0200
|
||||
+++ sangam-atm-0.3/dsl_hal_support.c 2007-04-19 01:13:30.000000000 +0200
|
||||
// UR8_MERGE_START CQ11054 Jack Zhang
|
||||
static unsigned int highprecision_selected = 0; //By default we use low precision for backward compt.
|
||||
diff -urN sangam_atm-07.02.01.00/dsl_hal_support.c sangam_atm-07.02.01.00/dsl_hal_support.c
|
||||
--- sangam_atm-07.02.01.00/dsl_hal_support.c 2007-08-06 18:15:52.000000000 +0200
|
||||
+++ sangam_atm-07.02.01.00/dsl_hal_support.c 2007-08-06 18:58:42.000000000 +0200
|
||||
@@ -140,9 +140,9 @@
|
||||
* oamFeature are overriden
|
||||
// UR8_MERGE_END CQ10774 Ram
|
||||
@ -50,9 +50,9 @@ diff -urN sangam_atm-07.01.00.10/dsl_hal_support.c sangam-atm-0.3/dsl_hal_suppor
|
||||
|
||||
#define NUM_READ_RETRIES 3
|
||||
static unsigned int dslhal_support_adsl2ByteSwap32(unsigned int in32Bits);
|
||||
diff -urN sangam_atm-07.01.00.10/dsl_hal_support.h sangam-atm-0.3/dsl_hal_support.h
|
||||
--- sangam_atm-07.01.00.10/dsl_hal_support.h 2005-11-11 13:07:04.000000000 +0100
|
||||
+++ sangam-atm-0.3/dsl_hal_support.h 2007-04-19 01:12:01.000000000 +0200
|
||||
diff -urN sangam_atm-07.02.01.00/dsl_hal_support.h sangam_atm-07.02.01.00/dsl_hal_support.h
|
||||
--- sangam_atm-07.02.01.00/dsl_hal_support.h 2007-08-06 18:15:52.000000000 +0200
|
||||
+++ sangam_atm-07.02.01.00/dsl_hal_support.h 2007-08-06 18:58:42.000000000 +0200
|
||||
@@ -49,7 +49,7 @@
|
||||
* 04Nov05 0.11.00 CPH Fixed T1413 mode got Zero DS/US rate when DSL_BIT_TMODE is set.
|
||||
*******************************************************************************/
|
||||
@ -62,9 +62,9 @@ diff -urN sangam_atm-07.01.00.10/dsl_hal_support.h sangam-atm-0.3/dsl_hal_suppor
|
||||
|
||||
#define virtual2Physical(a) (((int)a)&~0xe0000000)
|
||||
/* External Function Prototype Declarations */
|
||||
diff -urN sangam_atm-07.01.00.10/Makefile sangam-atm-0.3/Makefile
|
||||
--- sangam_atm-07.01.00.10/Makefile 2005-06-01 09:46:28.000000000 +0200
|
||||
+++ sangam-atm-0.3/Makefile 2007-04-19 01:09:02.000000000 +0200
|
||||
diff -urN sangam_atm-07.02.01.00/Makefile sangam_atm-07.02.01.00/Makefile
|
||||
--- sangam_atm-07.02.01.00/Makefile 2007-08-06 18:15:52.000000000 +0200
|
||||
+++ sangam_atm-07.02.01.00/Makefile 2007-08-06 18:58:42.000000000 +0200
|
||||
@@ -1,18 +1,9 @@
|
||||
-# File: drivers/atm/ti_evm3/Makefile
|
||||
#
|
||||
@ -90,18 +90,18 @@ diff -urN sangam_atm-07.01.00.10/Makefile sangam-atm-0.3/Makefile
|
||||
+EXTRA_CFLAGS += -DEL -I$(PWD) -DPOST_SILICON -DCOMMON_NSP -DNO_ACT -D__NO__VOICE_PATCH__ -DEL
|
||||
+obj-$(CONFIG_SANGAM_ATM) := tiatm.o
|
||||
+tiatm-objs += cpsar.o aal5sar.o tn7sar.o tn7atm.o tn7dsl.o dsl_hal_api.o dsl_hal_support.o
|
||||
diff -urN sangam_atm-07.01.00.10/tn7atm.c sangam-atm-0.3/tn7atm.c
|
||||
--- sangam_atm-07.01.00.10/tn7atm.c 2006-10-26 16:48:52.000000000 +0200
|
||||
+++ sangam-atm-0.3/tn7atm.c 2007-07-27 20:49:07.000000000 +0200
|
||||
@@ -58,7 +58,6 @@
|
||||
* UR8_MERGE_END CQ10979*
|
||||
diff -urN sangam_atm-07.02.01.00/tn7atm.c sangam_atm-07.02.01.00/tn7atm.c
|
||||
--- sangam_atm-07.02.01.00/tn7atm.c 2007-08-06 18:15:52.000000000 +0200
|
||||
+++ sangam_atm-07.02.01.00/tn7atm.c 2007-08-06 18:58:42.000000000 +0200
|
||||
@@ -61,7 +61,6 @@
|
||||
* UR8_MERGE_END CQ11057*
|
||||
*********************************************************************************************/
|
||||
|
||||
-#include <linux/config.h>
|
||||
#include <linux/kernel.h>
|
||||
#include <linux/module.h>
|
||||
#include <linux/init.h>
|
||||
@@ -67,7 +66,7 @@
|
||||
@@ -70,7 +69,7 @@
|
||||
#include <linux/spinlock.h>
|
||||
#include <linux/smp_lock.h>
|
||||
#include <asm/io.h>
|
||||
@ -110,7 +110,7 @@ diff -urN sangam_atm-07.01.00.10/tn7atm.c sangam-atm-0.3/tn7atm.c
|
||||
#include <linux/proc_fs.h>
|
||||
#include <linux/string.h>
|
||||
#include <linux/ctype.h>
|
||||
@@ -79,6 +78,7 @@
|
||||
@@ -82,6 +81,7 @@
|
||||
#include "dsl_hal_register.h"
|
||||
|
||||
#ifdef MODULE
|
||||
@ -118,7 +118,7 @@ diff -urN sangam_atm-07.01.00.10/tn7atm.c sangam-atm-0.3/tn7atm.c
|
||||
MODULE_DESCRIPTION ("Tnetd73xx ATM Device Driver");
|
||||
MODULE_AUTHOR ("Zhicheng Tang");
|
||||
#endif
|
||||
@@ -97,9 +97,9 @@
|
||||
@@ -100,9 +100,9 @@
|
||||
|
||||
/*end of externs */
|
||||
|
||||
@ -131,7 +131,7 @@ diff -urN sangam_atm-07.01.00.10/tn7atm.c sangam-atm-0.3/tn7atm.c
|
||||
|
||||
#define tn7atm_kfree_skb(x) dev_kfree_skb(x)
|
||||
|
||||
@@ -111,7 +111,7 @@
|
||||
@@ -114,7 +114,7 @@
|
||||
/* prototypes */
|
||||
static int tn7atm_set_can_support_adsl2 (int can);
|
||||
|
||||
@ -140,7 +140,7 @@ diff -urN sangam_atm-07.01.00.10/tn7atm.c sangam-atm-0.3/tn7atm.c
|
||||
|
||||
static void tn7atm_close (struct atm_vcc *vcc);
|
||||
|
||||
@@ -254,13 +254,12 @@
|
||||
@@ -257,13 +257,12 @@
|
||||
getsockopt: NULL,
|
||||
setsockopt: NULL,
|
||||
send: tn7atm_send,
|
||||
@ -155,7 +155,7 @@ diff -urN sangam_atm-07.01.00.10/tn7atm.c sangam-atm-0.3/tn7atm.c
|
||||
static struct proc_dir_entry *root_proc_dir_entry = NULL;
|
||||
#define DRV_PROC_MODE 0644
|
||||
static int proc_root_already_exists = TRUE;
|
||||
@@ -549,56 +548,6 @@
|
||||
@@ -564,56 +563,6 @@
|
||||
|
||||
/*~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
|
||||
*
|
||||
@ -212,7 +212,7 @@ diff -urN sangam_atm-07.01.00.10/tn7atm.c sangam-atm-0.3/tn7atm.c
|
||||
* Function: int tn7atm_sar_irq(void)
|
||||
*
|
||||
* Description: tnetd73xx SAR interrupt.
|
||||
@@ -694,8 +643,8 @@
|
||||
@@ -709,8 +658,8 @@
|
||||
{
|
||||
def_sar_inter_pace = os_atoi (ptr);
|
||||
}
|
||||
@ -223,7 +223,7 @@ diff -urN sangam_atm-07.01.00.10/tn7atm.c sangam-atm-0.3/tn7atm.c
|
||||
|
||||
/*
|
||||
* Reigster Receive interrupt A
|
||||
@@ -865,11 +814,15 @@
|
||||
@@ -880,11 +829,15 @@
|
||||
#define ATM_VBR_RT 5
|
||||
#endif
|
||||
|
||||
@ -240,7 +240,7 @@ diff -urN sangam_atm-07.01.00.10/tn7atm.c sangam-atm-0.3/tn7atm.c
|
||||
|
||||
dgprintf(1, "tn7atm_open()\n");
|
||||
|
||||
@@ -881,24 +834,18 @@
|
||||
@@ -896,24 +849,18 @@
|
||||
return -1;
|
||||
}
|
||||
|
||||
@ -271,7 +271,7 @@ diff -urN sangam_atm-07.01.00.10/tn7atm.c sangam-atm-0.3/tn7atm.c
|
||||
{
|
||||
/* always use (max_dma_chan+1) for clear eoc */
|
||||
tn7atm_activate_vc_parm.chan = EOC_DMA_CHAN;
|
||||
@@ -906,7 +853,7 @@
|
||||
@@ -921,7 +868,7 @@
|
||||
/* check to see whether clear eoc is opened or not */
|
||||
if (tn7atm_activate_vc_parm.priv->lut[tn7atm_activate_vc_parm.chan].inuse)
|
||||
{
|
||||
@ -280,7 +280,7 @@ diff -urN sangam_atm-07.01.00.10/tn7atm.c sangam-atm-0.3/tn7atm.c
|
||||
printk("tn7atm_open: Clear EOC channel (dmachan=%d) already in use.\n", tn7atm_activate_vc_parm.chan);
|
||||
return -EBUSY;
|
||||
}
|
||||
@@ -915,7 +862,7 @@
|
||||
@@ -930,7 +877,7 @@
|
||||
if (rc)
|
||||
{
|
||||
printk("tn7atm_open: failed to setup clear_eoc\n");
|
||||
@ -289,7 +289,7 @@ diff -urN sangam_atm-07.01.00.10/tn7atm.c sangam-atm-0.3/tn7atm.c
|
||||
return -EBUSY;
|
||||
}
|
||||
tn7atm_set_lut(tn7atm_activate_vc_parm.priv,vcc, tn7atm_activate_vc_parm.chan);
|
||||
@@ -924,17 +871,17 @@
|
||||
@@ -939,17 +886,17 @@
|
||||
}
|
||||
else /* PVC channel setup */
|
||||
{
|
||||
@ -310,7 +310,7 @@ diff -urN sangam_atm-07.01.00.10/tn7atm.c sangam-atm-0.3/tn7atm.c
|
||||
printk("PVC already opened. dmachan = %d\n", rc);
|
||||
return -EBUSY;
|
||||
}
|
||||
@@ -966,6 +913,7 @@
|
||||
@@ -981,6 +928,7 @@
|
||||
tn7atm_activate_vc_parm.priority = 2;
|
||||
break;
|
||||
|
||||
@ -318,7 +318,7 @@ diff -urN sangam_atm-07.01.00.10/tn7atm.c sangam-atm-0.3/tn7atm.c
|
||||
case ATM_VBR: /* Variable Bit Rate-Non RealTime*/
|
||||
tn7atm_activate_vc_parm.qos = 1;
|
||||
tn7atm_activate_vc_parm.priority = 1;
|
||||
@@ -987,6 +935,7 @@
|
||||
@@ -1002,6 +950,7 @@
|
||||
tn7atm_activate_vc_parm.mbs = vcc->qos.txtp.max_pcr;
|
||||
tn7atm_activate_vc_parm.cdvt = vcc->qos.txtp.max_cdv;
|
||||
break;
|
||||
@ -326,7 +326,7 @@ diff -urN sangam_atm-07.01.00.10/tn7atm.c sangam-atm-0.3/tn7atm.c
|
||||
|
||||
default:
|
||||
tn7atm_activate_vc_parm.qos = 2;
|
||||
@@ -1014,7 +963,7 @@
|
||||
@@ -1029,7 +978,7 @@
|
||||
if (rc < 0)
|
||||
{
|
||||
printk("failed to activate hw channel\n");
|
||||
@ -335,7 +335,7 @@ diff -urN sangam_atm-07.01.00.10/tn7atm.c sangam-atm-0.3/tn7atm.c
|
||||
tn7atm_lut_clear(vcc, tn7atm_activate_vc_parm.chan);
|
||||
//spin_unlock_irqrestore(&chan_init_lock, flags);
|
||||
return -EBUSY;
|
||||
@@ -1104,7 +1053,7 @@
|
||||
@@ -1119,7 +1068,7 @@
|
||||
tn7atm_lut_clear (vcc, dmachan);
|
||||
//spin_unlock_irqrestore (&closeLock, closeFlag);
|
||||
|
||||
@ -344,7 +344,7 @@ diff -urN sangam_atm-07.01.00.10/tn7atm.c sangam-atm-0.3/tn7atm.c
|
||||
|
||||
dgprintf (1, "Leave tn7atm_close\n");
|
||||
}
|
||||
@@ -1518,8 +1467,7 @@
|
||||
@@ -1533,8 +1482,7 @@
|
||||
* firewall is on */
|
||||
|
||||
dgprintf (3, "pushing the skb...\n");
|
||||
@ -354,7 +354,7 @@ diff -urN sangam_atm-07.01.00.10/tn7atm.c sangam-atm-0.3/tn7atm.c
|
||||
|
||||
xdump ((unsigned char *) skb->data, skb->len, 5);
|
||||
|
||||
@@ -1715,8 +1663,7 @@
|
||||
@@ -1730,8 +1678,7 @@
|
||||
|
||||
kfree (dev->dev_data);
|
||||
|
||||
@ -364,7 +364,7 @@ diff -urN sangam_atm-07.01.00.10/tn7atm.c sangam-atm-0.3/tn7atm.c
|
||||
|
||||
/*
|
||||
* remove proc entries
|
||||
@@ -1875,9 +1822,6 @@
|
||||
@@ -1890,9 +1837,6 @@
|
||||
/*
|
||||
* Set up proc entry for atm stats
|
||||
*/
|
||||
@ -374,7 +374,7 @@ diff -urN sangam_atm-07.01.00.10/tn7atm.c sangam-atm-0.3/tn7atm.c
|
||||
printk ("Creating new root folder %s in the proc for the driver stats \n",
|
||||
drv_proc_root_folder);
|
||||
root_proc_dir_entry = proc_mkdir (drv_proc_root_folder, NULL);
|
||||
@@ -1887,7 +1831,6 @@
|
||||
@@ -1902,7 +1846,6 @@
|
||||
return -ENOMEM;
|
||||
}
|
||||
proc_root_already_exists = FALSE;
|
||||
@ -382,7 +382,7 @@ diff -urN sangam_atm-07.01.00.10/tn7atm.c sangam-atm-0.3/tn7atm.c
|
||||
|
||||
/*
|
||||
* AV: Clean-up. Moved all the definitions to the data structure.
|
||||
@@ -2469,7 +2412,5 @@
|
||||
@@ -2484,7 +2427,5 @@
|
||||
return count;
|
||||
}
|
||||
|
||||
@ -390,9 +390,9 @@ diff -urN sangam_atm-07.01.00.10/tn7atm.c sangam-atm-0.3/tn7atm.c
|
||||
module_init (tn7atm_detect);
|
||||
module_exit (tn7atm_exit);
|
||||
-#endif /* MODULE */
|
||||
diff -urN sangam_atm-07.01.00.10/tn7atm.h sangam-atm-0.3/tn7atm.h
|
||||
--- sangam_atm-07.01.00.10/tn7atm.h 2006-04-05 11:33:06.000000000 +0200
|
||||
+++ sangam-atm-0.3/tn7atm.h 2007-04-18 03:45:08.000000000 +0200
|
||||
diff -urN sangam_atm-07.02.01.00/tn7atm.h sangam_atm-07.02.01.00/tn7atm.h
|
||||
--- sangam_atm-07.02.01.00/tn7atm.h 2007-08-06 18:15:52.000000000 +0200
|
||||
+++ sangam_atm-07.02.01.00/tn7atm.h 2007-08-06 18:58:42.000000000 +0200
|
||||
@@ -19,7 +19,8 @@
|
||||
//#include "mips_support.h"
|
||||
#include <linux/list.h>
|
||||
@ -403,18 +403,18 @@ diff -urN sangam_atm-07.01.00.10/tn7atm.h sangam-atm-0.3/tn7atm.h
|
||||
|
||||
#ifdef CONFIG_MODVERSIONS
|
||||
#include <linux/modversions.h>
|
||||
diff -urN sangam_atm-07.01.00.10/tn7dsl.c sangam-atm-0.3/tn7dsl.c
|
||||
--- sangam_atm-07.01.00.10/tn7dsl.c 2006-10-26 16:48:44.000000000 +0200
|
||||
+++ sangam-atm-0.3/tn7dsl.c 2007-04-18 15:45:58.000000000 +0200
|
||||
@@ -88,7 +88,6 @@
|
||||
* 10/4/06 JZ CQ10979: Request for TR-069 Support for RP7.1
|
||||
* UR8_MERGE_END CQ10979*
|
||||
diff -urN sangam_atm-07.02.01.00/tn7dsl.c sangam_atm-07.02.01.00/tn7dsl.c
|
||||
--- sangam_atm-07.02.01.00/tn7dsl.c 2007-08-06 18:15:52.000000000 +0200
|
||||
+++ sangam_atm-07.02.01.00/tn7dsl.c 2007-08-06 18:58:42.000000000 +0200
|
||||
@@ -94,7 +94,6 @@
|
||||
* 1/02/07 JZ CQ11054: Data Precision and Range Changes for TR-069 Conformance
|
||||
* UR8_MERGE_END CQ11054*
|
||||
*********************************************************************************************/
|
||||
-#include <linux/config.h>
|
||||
#include <linux/kernel.h>
|
||||
#include <linux/module.h>
|
||||
#include <linux/init.h>
|
||||
@@ -97,7 +96,7 @@
|
||||
@@ -103,7 +102,7 @@
|
||||
#include <linux/spinlock.h>
|
||||
#include <linux/smp_lock.h>
|
||||
#include <asm/io.h>
|
||||
@ -423,7 +423,7 @@ diff -urN sangam_atm-07.01.00.10/tn7dsl.c sangam-atm-0.3/tn7dsl.c
|
||||
#include <linux/proc_fs.h>
|
||||
#include <linux/string.h>
|
||||
#include <linux/ctype.h>
|
||||
@@ -105,6 +104,8 @@
|
||||
@@ -111,6 +110,8 @@
|
||||
#include <linux/timer.h>
|
||||
#include <linux/vmalloc.h>
|
||||
#include <linux/file.h>
|
||||
@ -432,9 +432,9 @@ diff -urN sangam_atm-07.01.00.10/tn7dsl.c sangam-atm-0.3/tn7dsl.c
|
||||
/* Modules specific header files */
|
||||
#include "tn7atm.h"
|
||||
#include "tn7api.h"
|
||||
@@ -312,6 +313,14 @@
|
||||
static int tn7dsl_proc_snr_print (char *buf, int count, int *eof, int data);
|
||||
/* end of internal functions */
|
||||
@@ -323,6 +324,14 @@
|
||||
#define gDot1(a) ((a>0)?(a%10):((-a)%10))
|
||||
// UR8_MERGE_END CQ11054*
|
||||
|
||||
+int avalanche_request_intr_pacing(int irq_nr, unsigned int blk_num,
|
||||
+ unsigned int pace_value)
|
||||
@ -447,7 +447,7 @@ diff -urN sangam_atm-07.01.00.10/tn7dsl.c sangam-atm-0.3/tn7dsl.c
|
||||
int os_atoi(const char *pStr)
|
||||
{
|
||||
int MulNeg = (*pStr == '-' ? -1 : 1);
|
||||
@@ -348,39 +357,6 @@
|
||||
@@ -359,39 +368,6 @@
|
||||
#endif
|
||||
}
|
||||
|
||||
@ -487,7 +487,7 @@ diff -urN sangam_atm-07.01.00.10/tn7dsl.c sangam-atm-0.3/tn7dsl.c
|
||||
// * UR8_MERGE_START CQ10640 Jack Zhang
|
||||
int tn7dsl_dump_dsp_memory(char *input_str) //cph99
|
||||
{
|
||||
@@ -430,101 +406,74 @@
|
||||
@@ -441,101 +417,74 @@
|
||||
return CpuFrequency;
|
||||
}
|
||||
|
||||
@ -651,7 +651,7 @@ diff -urN sangam_atm-07.01.00.10/tn7dsl.c sangam-atm-0.3/tn7dsl.c
|
||||
}
|
||||
|
||||
int shim_osLoadDebugFWImage(unsigned char *ptr)
|
||||
@@ -3367,7 +3316,7 @@
|
||||
@@ -3442,7 +3391,7 @@
|
||||
*/
|
||||
if(write)
|
||||
{
|
||||
@ -660,7 +660,7 @@ diff -urN sangam_atm-07.01.00.10/tn7dsl.c sangam-atm-0.3/tn7dsl.c
|
||||
|
||||
switch (ctl->ctl_name)
|
||||
{
|
||||
@@ -3453,7 +3402,7 @@
|
||||
@@ -3528,7 +3477,7 @@
|
||||
else
|
||||
{
|
||||
len += sprintf(info+len, mod_req);
|
||||
@ -669,7 +669,7 @@ diff -urN sangam_atm-07.01.00.10/tn7dsl.c sangam-atm-0.3/tn7dsl.c
|
||||
}
|
||||
return ret;
|
||||
}
|
||||
@@ -3483,8 +3432,7 @@
|
||||
@@ -3558,8 +3507,7 @@
|
||||
if (initialized == 1)
|
||||
return;
|
||||
|
||||
@ -679,9 +679,9 @@ diff -urN sangam_atm-07.01.00.10/tn7dsl.c sangam-atm-0.3/tn7dsl.c
|
||||
|
||||
/*
|
||||
* set the defaults
|
||||
diff -urN sangam_atm-07.01.00.10/tn7sar.c sangam-atm-0.3/tn7sar.c
|
||||
--- sangam_atm-07.01.00.10/tn7sar.c 2006-07-27 10:34:42.000000000 +0200
|
||||
+++ sangam-atm-0.3/tn7sar.c 2007-04-18 03:47:39.000000000 +0200
|
||||
diff -urN sangam_atm-07.02.01.00/tn7sar.c sangam_atm-07.02.01.00/tn7sar.c
|
||||
--- sangam_atm-07.02.01.00/tn7sar.c 2007-08-06 18:15:52.000000000 +0200
|
||||
+++ sangam_atm-07.02.01.00/tn7sar.c 2007-08-06 18:58:42.000000000 +0200
|
||||
@@ -42,7 +42,6 @@
|
||||
* UR8_MERGE_END CQ10700
|
||||
*******************************************************************************/
|
||||
|
@ -1,7 +1,7 @@
|
||||
diff -ur atm.old/tn7atm.c atm.dev/tn7atm.c
|
||||
--- atm.old/tn7atm.c 2007-04-20 21:04:28.479287240 +0200
|
||||
+++ atm.dev/tn7atm.c 2007-04-20 21:09:05.288205888 +0200
|
||||
@@ -553,7 +553,7 @@
|
||||
@@ -568,7 +568,7 @@
|
||||
* Description: tnetd73xx SAR interrupt.
|
||||
*
|
||||
*~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~*/
|
||||
@ -10,7 +10,7 @@ diff -ur atm.old/tn7atm.c atm.dev/tn7atm.c
|
||||
{
|
||||
struct atm_dev *atmdev;
|
||||
Tn7AtmPrivate *priv;
|
||||
@@ -580,6 +580,7 @@
|
||||
@@ -595,6 +595,7 @@
|
||||
#ifdef TIATM_INST_SUPP
|
||||
psp_trace_par (ATM_DRV_SAR_ISR_EXIT, retval);
|
||||
#endif
|
||||
@ -18,7 +18,7 @@ diff -ur atm.old/tn7atm.c atm.dev/tn7atm.c
|
||||
}
|
||||
|
||||
/*~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
|
||||
@@ -589,7 +590,7 @@
|
||||
@@ -604,7 +604,7 @@
|
||||
* Description: tnetd73xx DSL interrupt.
|
||||
*
|
||||
*~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~*/
|
||||
@ -27,7 +27,7 @@ diff -ur atm.old/tn7atm.c atm.dev/tn7atm.c
|
||||
{
|
||||
struct atm_dev *atmdev;
|
||||
Tn7AtmPrivate *priv;
|
||||
@@ -611,6 +612,8 @@
|
||||
@@ -626,6 +626,8 @@
|
||||
#ifdef TIATM_INST_SUPP
|
||||
psp_trace_par (ATM_DRV_DSL_ISR_EXIT, retval);
|
||||
#endif
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- sangam_atm-07.01.00.10/tn7api.h 2006-10-26 16:48:34.000000000 +0200
|
||||
+++ sangam_atm-07.01.00.10.new/tn7api.h 2007-07-24 12:43:04.000000000 +0200
|
||||
@@ -104,7 +104,7 @@
|
||||
@@ -110,7 +110,7 @@
|
||||
|
||||
int tn7dsl_proc_write_stats(struct file *fp, const char * buf, unsigned long count, void * data);
|
||||
int tn7dsl_proc_modem(char* buf, char **start, off_t offset, int count,int *eof, void *data);
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- atm.old/tn7dsl.c 2006-10-26 16:48:44.000000000 +0200
|
||||
+++ atm.dev/tn7dsl.c 2007-06-22 23:36:27.000000000 +0200
|
||||
@@ -2864,6 +2811,14 @@
|
||||
@@ -2867,6 +2814,14 @@
|
||||
dslhal_api_setRateAdaptFlag(pIhw, os_atoi(ptr));
|
||||
}
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user