atheros: remove static gpio_request() from board setup and include generic kmod-gpio-button-hotplug instead.
This change is based on a patch by Karl Palsson <karlp@remake.is> See http://patchwork.openwrt.org/patch/3536/. SVN-Revision: 36513
This commit is contained in:
parent
7f2743d458
commit
6ac2b3b76a
@ -1,5 +1,5 @@
|
||||
#
|
||||
# Copyright (C) 2006-2011 OpenWrt.org
|
||||
# Copyright (C) 2006-2013 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
@ -15,7 +15,7 @@ LINUX_VERSION:=3.8.11
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
DEFAULT_PACKAGES += wpad-mini kmod-ath5k swconfig
|
||||
DEFAULT_PACKAGES += wpad-mini kmod-ath5k swconfig kmod-gpio-button-hotplug
|
||||
|
||||
define Target/Description
|
||||
Build firmware images for Atheros SoC boards
|
||||
|
@ -2106,7 +2106,7 @@
|
||||
+
|
||||
--- /dev/null
|
||||
+++ b/arch/mips/ar231x/ar2315.c
|
||||
@@ -0,0 +1,694 @@
|
||||
@@ -0,0 +1,692 @@
|
||||
+/*
|
||||
+ * This file is subject to the terms and conditions of the GNU General Public
|
||||
+ * License. See the file "COPYING" in the main directory of this archive
|
||||
@ -2789,8 +2789,6 @@
|
||||
+ if (!is_2315())
|
||||
+ return;
|
||||
+
|
||||
+ gpio_request(AR2315_RESET_GPIO, "reset");
|
||||
+
|
||||
+ /* Clear any lingering AHB errors */
|
||||
+ config = read_c0_config();
|
||||
+ write_c0_config(config & ~0x3);
|
||||
|
Loading…
Reference in New Issue
Block a user