move alsa from target/linux/package to package, add compile fix for linux 2.4
SVN-Revision: 3862
This commit is contained in:
parent
9d4ba07b77
commit
7486d2e8d5
@ -1,18 +1,18 @@
|
|||||||
# $Id$
|
# $Id$
|
||||||
|
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
include ../../rules.mk
|
include $(TOPDIR)/package/kernel.mk
|
||||||
|
|
||||||
PKG_NAME:=alsa-driver
|
PKG_NAME:=alsa-driver
|
||||||
PKG_VERSION:=1.0.11rc4
|
PKG_VERSION:=1.0.11
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
PKG_MD5SUM:=8e5794026082a964b09b46f9d881e6ec
|
PKG_MD5SUM:=57534e4297cd683371402220e3753885
|
||||||
|
|
||||||
PKG_SOURCE_URL:=ftp://ftp.alsa-project.org/pub/driver/
|
PKG_SOURCE_URL:=ftp://ftp.alsa-project.org/pub/driver/
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||||
PKG_CAT:=bzcat
|
PKG_CAT:=bzcat
|
||||||
|
|
||||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||||
|
|
||||||
include $(TOPDIR)/package/rules.mk
|
include $(TOPDIR)/package/rules.mk
|
||||||
|
|
||||||
@ -25,9 +25,7 @@ KERNEL_C_INCS:= -I$(LINUX_DIR)/include/asm-mips/mach-generic
|
|||||||
KERNEL_C_OPTS:= -Os -G 0 -mno-abicalls -fno-pic -finline-limit=100000 -mabi=32 -march=mips32 -Wa,-32 -Wa,-march=mips32 -Wa,-mips32 -Wa,--trap
|
KERNEL_C_OPTS:= -Os -G 0 -mno-abicalls -fno-pic -finline-limit=100000 -mabi=32 -march=mips32 -Wa,-32 -Wa,-march=mips32 -Wa,-mips32 -Wa,--trap
|
||||||
endif
|
endif
|
||||||
|
|
||||||
$(eval $(call PKG_template,KMOD_ALSA,kmod-alsa,$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(PKG_RELEASE),$(ARCH),kernel ($(LINUX_VERSION)-$(BOARD)-$(LINUX_RELEASE))))
|
define Build/Configure
|
||||||
|
|
||||||
$(PKG_BUILD_DIR)/.configured:
|
|
||||||
(cd $(PKG_BUILD_DIR); \
|
(cd $(PKG_BUILD_DIR); \
|
||||||
CFLAGS="$(KERNEL_C_INCS)" \
|
CFLAGS="$(KERNEL_C_INCS)" \
|
||||||
./configure \
|
./configure \
|
||||||
@ -41,20 +39,32 @@ $(PKG_BUILD_DIR)/.configured:
|
|||||||
--with-sequencer=no \
|
--with-sequencer=no \
|
||||||
--with-cards=usb-audio \
|
--with-cards=usb-audio \
|
||||||
);
|
);
|
||||||
touch $@
|
endef
|
||||||
|
|
||||||
$(PKG_BUILD_DIR)/.built:
|
define Build/Compile
|
||||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||||
ARCH="$(LINUX_KARCH)" \
|
ARCH="$(LINUX_KARCH)" \
|
||||||
CROSS_COMPILE="$(TARGET_CROSS)" \
|
CROSS_COMPILE="$(TARGET_CROSS)" \
|
||||||
c_opts="$(KERNEL_C_OPTS)" \
|
c_opts="$(KERNEL_C_OPTS)" \
|
||||||
all
|
all
|
||||||
touch $@
|
endef
|
||||||
|
|
||||||
$(IPKG_KMOD_ALSA):
|
define Package/kmod-alsa
|
||||||
install -d -m0755 $(IDIR_KMOD_ALSA)/etc/modules.d
|
SECTION:=drivers
|
||||||
install -m0644 ./files/alsa.modules $(IDIR_KMOD_ALSA)/etc/modules.d/70-alsa
|
CATEGORY:=Drivers
|
||||||
install -d -m0755 $(IDIR_KMOD_ALSA)/lib/modules/$(LINUX_VERSION)
|
DEPENDS:=@PCI_SUPPORT
|
||||||
|
TITLE:=Advanced Linux Sound Architecture
|
||||||
|
DESCRIPTION:=Advanced Linux Sound Architecture
|
||||||
|
URL:=http://alsa-project.org/
|
||||||
|
VERSION:=$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(PKG_RELEASE)
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/kmod-alsa/install
|
||||||
|
install -d -m0755 $(1)/etc/modules.d
|
||||||
|
install -m0644 ./files/alsa.modules $(1)/etc/modules.d/70-alsa
|
||||||
|
install -d -m0755 $(1)/lib/modules/$(LINUX_VERSION)
|
||||||
install -m0644 $(PKG_BUILD_DIR)/modules/*.$(LINUX_KMOD_SUFFIX) \
|
install -m0644 $(PKG_BUILD_DIR)/modules/*.$(LINUX_KMOD_SUFFIX) \
|
||||||
$(IDIR_KMOD_ALSA)/lib/modules/$(LINUX_VERSION)/
|
$(1)/lib/modules/$(LINUX_VERSION)/
|
||||||
$(IPKG_BUILD) $(IDIR_KMOD_ALSA) $(PACKAGE_DIR)
|
endef
|
||||||
|
|
||||||
|
$(eval $(call BuildPackage,kmod-alsa))
|
18
openwrt/package/alsa/patches/100-compile_fix.patch
Normal file
18
openwrt/package/alsa/patches/100-compile_fix.patch
Normal file
@ -0,0 +1,18 @@
|
|||||||
|
diff -urN alsa.old/include/adriver.h alsa.dev/include/adriver.h
|
||||||
|
--- alsa.old/include/adriver.h 2006-04-19 08:24:30.000000000 +0200
|
||||||
|
+++ alsa.dev/include/adriver.h 2006-05-31 17:24:49.000000000 +0200
|
||||||
|
@@ -451,7 +451,7 @@
|
||||||
|
#endif /* < 2.6.0 */
|
||||||
|
|
||||||
|
/* workarounds for USB API */
|
||||||
|
-#if defined(SND_NEED_USB_WRAPPER) && (defined(CONFIG_USB) || defined(CONFIG_USB_MODULE))
|
||||||
|
+#if 1
|
||||||
|
|
||||||
|
#include <linux/usb.h>
|
||||||
|
|
||||||
|
@@ -1174,4 +1174,5 @@
|
||||||
|
*/
|
||||||
|
#define OPL3_HW_OPL3_PC98 0x0305 /* PC9800 */
|
||||||
|
|
||||||
|
+#undef info /* used in several structs */
|
||||||
|
#endif /* __SOUND_LOCAL_DRIVER_H */
|
Loading…
Reference in New Issue
Block a user