orion: rename patches directory to patches-3.18
Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
This commit is contained in:
parent
d99169536e
commit
74aecc2d45
@ -1,24 +1,24 @@
|
||||
--- a/arch/arm/mach-orion5x/wrt350n-v2-setup.c
|
||||
+++ b/arch/arm/mach-orion5x/wrt350n-v2-setup.c
|
||||
@@ -134,11 +134,11 @@ static struct mtd_partition wrt350n_v2_n
|
||||
{
|
||||
.name = "kernel",
|
||||
.offset = 0x00000000,
|
||||
{
|
||||
.name = "kernel",
|
||||
.offset = 0x00000000,
|
||||
- .size = 0x00760000,
|
||||
+ .size = 0x00140000, // change to kernel mtd size here (1/3)
|
||||
}, {
|
||||
.name = "rootfs",
|
||||
}, {
|
||||
.name = "rootfs",
|
||||
- .offset = 0x001a0000,
|
||||
- .size = 0x005c0000,
|
||||
+ .offset = 0x00140000, // change to kernel mtd size here (2/3)
|
||||
+ .size = 0x00610000, // adopt to kernel mtd size here (3/3) = 0x00750000 - <kernel mtd size>
|
||||
}, {
|
||||
.name = "lang",
|
||||
.offset = 0x00760000,
|
||||
}, {
|
||||
.name = "lang",
|
||||
.offset = 0x00760000,
|
||||
@@ -151,6 +151,14 @@ static struct mtd_partition wrt350n_v2_n
|
||||
.name = "u-boot",
|
||||
.offset = 0x007c0000,
|
||||
.size = 0x00040000,
|
||||
.name = "u-boot",
|
||||
.offset = 0x007c0000,
|
||||
.size = 0x00040000,
|
||||
+ }, {
|
||||
+ .name = "eRcOmM_do_not_touch",
|
||||
+ .offset = 0x00750000,
|
||||
@ -27,6 +27,5 @@
|
||||
+ .name = "image", // for sysupgrade
|
||||
+ .offset = 0x00000000,
|
||||
+ .size = 0x00750000,
|
||||
},
|
||||
},
|
||||
};
|
||||
|
@ -1,25 +1,24 @@
|
||||
--- a/arch/arm/mach-orion5x/wnr854t-setup.c
|
||||
+++ b/arch/arm/mach-orion5x/wnr854t-setup.c
|
||||
@@ -57,15 +57,19 @@ static struct mtd_partition wnr854t_nor_
|
||||
{
|
||||
.name = "kernel",
|
||||
.offset = 0x00000000,
|
||||
{
|
||||
.name = "kernel",
|
||||
.offset = 0x00000000,
|
||||
- .size = 0x00100000,
|
||||
+ .size = 0x00140000,
|
||||
}, {
|
||||
.name = "rootfs",
|
||||
}, {
|
||||
.name = "rootfs",
|
||||
- .offset = 0x00100000,
|
||||
- .size = 0x00660000,
|
||||
+ .offset = 0x00140000,
|
||||
+ .size = 0x00620000,
|
||||
}, {
|
||||
.name = "uboot",
|
||||
.offset = 0x00760000,
|
||||
.size = 0x00040000,
|
||||
}, {
|
||||
.name = "uboot",
|
||||
.offset = 0x00760000,
|
||||
.size = 0x00040000,
|
||||
+ }, {
|
||||
+ .name = "image", // for sysupgrade
|
||||
+ .offset = 0x00000000,
|
||||
+ .size = 0x00760000,
|
||||
},
|
||||
},
|
||||
};
|
||||
|
@ -1,9 +1,9 @@
|
||||
--- a/arch/arm/mach-orion5x/Kconfig
|
||||
+++ b/arch/arm/mach-orion5x/Kconfig
|
||||
@@ -36,6 +36,13 @@ config MACH_RD88F5182_DT
|
||||
Say 'Y' here if you want your kernel to support the Marvell
|
||||
Orion-NAS (88F5182) RD2, Flattened Device Tree.
|
||||
|
||||
Say 'Y' here if you want your kernel to support the Marvell
|
||||
Orion-NAS (88F5182) RD2, Flattened Device Tree.
|
||||
|
||||
+config MACH_DT2
|
||||
+ bool "Freecom DataTank Gateway"
|
||||
+ select I2C_BOARDINFO
|
||||
@ -12,8 +12,8 @@
|
||||
+ Freecom DataTank Gateway
|
||||
+
|
||||
config MACH_KUROBOX_PRO
|
||||
bool "KuroBox Pro"
|
||||
select I2C_BOARDINFO
|
||||
bool "KuroBox Pro"
|
||||
select I2C_BOARDINFO
|
||||
--- a/arch/arm/mach-orion5x/Makefile
|
||||
+++ b/arch/arm/mach-orion5x/Makefile
|
||||
@@ -14,6 +14,7 @@ obj-$(CONFIG_MACH_TS78XX) += ts78xx-setu
|
@ -1,27 +1,27 @@
|
||||
--- a/arch/arm/mach-orion5x/Kconfig
|
||||
+++ b/arch/arm/mach-orion5x/Kconfig
|
||||
@@ -144,10 +144,13 @@ config MACH_MSS2_DT
|
||||
Maxtor Shared Storage II platform.
|
||||
|
||||
Maxtor Shared Storage II platform.
|
||||
|
||||
config MACH_WNR854T
|
||||
- bool "Netgear WNR854T"
|
||||
+ bool "Netgear WNR854T / WN802T"
|
||||
help
|
||||
Say 'Y' here if you want your kernel to support the
|
||||
help
|
||||
Say 'Y' here if you want your kernel to support the
|
||||
- Netgear WNR854T platform.
|
||||
+ Netgear WNR854T or WN802T platform.
|
||||
+
|
||||
+config MACH_WN802T
|
||||
+ def_bool MACH_WNR854T
|
||||
|
||||
|
||||
config MACH_RD88F5181L_GE
|
||||
bool "Marvell Orion-VoIP GE Reference Design"
|
||||
bool "Marvell Orion-VoIP GE Reference Design"
|
||||
--- a/arch/arm/mach-orion5x/wnr854t-setup.c
|
||||
+++ b/arch/arm/mach-orion5x/wnr854t-setup.c
|
||||
@@ -115,6 +115,15 @@ static struct dsa_platform_data wnr854t_
|
||||
.chip = &wnr854t_switch_chip_data,
|
||||
.chip = &wnr854t_switch_chip_data,
|
||||
};
|
||||
|
||||
|
||||
+static struct dsa_chip_data wn802t_switch_chip_data = {
|
||||
+ .port_names[2] = "wan",
|
||||
+ .port_names[3] = "cpu",
|
||||
@ -33,11 +33,11 @@
|
||||
+};
|
||||
static void __init wnr854t_init(void)
|
||||
{
|
||||
/*
|
||||
/*
|
||||
@@ -128,7 +137,12 @@ static void __init wnr854t_init(void)
|
||||
* Configure peripherals.
|
||||
*/
|
||||
orion5x_eth_init(&wnr854t_eth_data);
|
||||
* Configure peripherals.
|
||||
*/
|
||||
orion5x_eth_init(&wnr854t_eth_data);
|
||||
- orion5x_eth_switch_init(&wnr854t_switch_plat_data, NO_IRQ);
|
||||
+
|
||||
+ if (machine_is_wn802t())
|
||||
@ -45,22 +45,22 @@
|
||||
+ else
|
||||
+ orion5x_eth_switch_init(&wnr854t_switch_plat_data, NO_IRQ);
|
||||
+
|
||||
orion5x_uart0_init();
|
||||
|
||||
mvebu_mbus_add_window_by_id(ORION_MBUS_DEVBUS_BOOT_TARGET,
|
||||
orion5x_uart0_init();
|
||||
|
||||
mvebu_mbus_add_window_by_id(ORION_MBUS_DEVBUS_BOOT_TARGET,
|
||||
@@ -168,7 +182,7 @@ static struct hw_pci wnr854t_pci __initd
|
||||
|
||||
|
||||
static int __init wnr854t_pci_init(void)
|
||||
{
|
||||
- if (machine_is_wnr854t())
|
||||
+ if (machine_is_wnr854t() || machine_is_wn802t())
|
||||
pci_common_init(&wnr854t_pci);
|
||||
|
||||
return 0;
|
||||
pci_common_init(&wnr854t_pci);
|
||||
|
||||
return 0;
|
||||
@@ -179,6 +193,18 @@ MACHINE_START(WNR854T, "Netgear WNR854T"
|
||||
/* Maintainer: Imre Kaloz <kaloz@openwrt.org> */
|
||||
.atag_offset = 0x100,
|
||||
.init_machine = wnr854t_init,
|
||||
/* Maintainer: Imre Kaloz <kaloz@openwrt.org> */
|
||||
.atag_offset = 0x100,
|
||||
.init_machine = wnr854t_init,
|
||||
+ .map_io = orion5x_map_io,
|
||||
+ .init_early = orion5x_init_early,
|
||||
+ .init_irq = orion5x_init_irq,
|
||||
@ -73,6 +73,6 @@
|
||||
+ /* Maintainer: Imre Kaloz <kaloz@openwrt.org> */
|
||||
+ .atag_offset = 0x100,
|
||||
+ .init_machine = wnr854t_init,
|
||||
.map_io = orion5x_map_io,
|
||||
.init_early = orion5x_init_early,
|
||||
.init_irq = orion5x_init_irq,
|
||||
.map_io = orion5x_map_io,
|
||||
.init_early = orion5x_init_early,
|
||||
.init_irq = orion5x_init_irq,
|
Loading…
Reference in New Issue
Block a user