bcm53xx: prepare to support Asus RT-N18U
DT file doesn't include any GPIOs yet, but let's add it as we got some interest in this device on IRC. Signed-off-by: Rafał Miłecki <zajec5@gmail.com> SVN-Revision: 42864
This commit is contained in:
parent
9473673ae3
commit
78be7225c3
@ -37,6 +37,15 @@ define Image/Build/DTB
|
||||
$(STAGING_DIR_HOST)/bin/lzma e $(KDIR)/$(1)-$(2).dts $(KDIR)/$(1)-$(2).lzma -d16
|
||||
endef
|
||||
|
||||
# $(1): filesystem type (e.g. squashfs, initramfs).
|
||||
# $(2): dts filename (also used for the firmware file).
|
||||
# $(3): device specific magic.
|
||||
define Image/Build/AsusTrx
|
||||
$(call Image/Build/$(1)/DTB,$(2))
|
||||
# TODO: Put magic in TRX file
|
||||
cp $(KDIR)/$(IMG_PREFIX)-$(2)-$(1).trx $(BIN_DIR)/
|
||||
endef
|
||||
|
||||
# $(1): filesystem type (e.g. squashfs, initramfs).
|
||||
# $(2): dts filename (also used for the firmware file).
|
||||
define Image/Build/Trx
|
||||
@ -55,6 +64,8 @@ endef
|
||||
|
||||
# $(1): filesystem type (e.g. squashfs, initramfs).
|
||||
define Image/Build
|
||||
$(call Image/Build/AsusTrx,$(1),bcm47081-asus-rt-n18u,RT-N18U)
|
||||
|
||||
$(call Image/Build/Trx,$(1),bcm4708-buffalo-wzr-1750dhp)
|
||||
|
||||
$(call Image/Build/Chk,$(1),bcm4708-netgear-r6250,U12H245T00_NETGEAR,1)
|
||||
|
@ -0,0 +1,105 @@
|
||||
From 14126edd3b5cd6e08e46857283724f783db92c99 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Rafa=C5=82=20Mi=C5=82ecki?= <zajec5@gmail.com>
|
||||
Date: Thu, 9 Oct 2014 18:16:26 +0200
|
||||
Subject: [PATCH] ARM: BCM5301X: Add DT for Asus RT-N18U
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
|
||||
---
|
||||
arch/arm/boot/dts/Makefile | 1 +
|
||||
arch/arm/boot/dts/bcm47081-asus-rt-n18u.dts | 35 +++++++++++++++++++++++++++++
|
||||
arch/arm/boot/dts/bcm47081.dtsi | 26 +++++++++++++++++++++
|
||||
3 files changed, 62 insertions(+)
|
||||
create mode 100644 arch/arm/boot/dts/bcm47081-asus-rt-n18u.dts
|
||||
create mode 100644 arch/arm/boot/dts/bcm47081.dtsi
|
||||
|
||||
diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
|
||||
index 17c717b..77f932d 100644
|
||||
--- a/arch/arm/boot/dts/Makefile
|
||||
+++ b/arch/arm/boot/dts/Makefile
|
||||
@@ -51,6 +51,7 @@ dtb-$(CONFIG_ARCH_BCM_MOBILE) += bcm11351-brt.dtb \
|
||||
bcm28155-ap.dtb
|
||||
dtb-$(CONFIG_ARCH_BCM2835) += bcm2835-rpi-b.dtb
|
||||
dtb-$(CONFIG_ARCH_BCM_5301X) += \
|
||||
+ bcm47081-asus-rt-n18u.dtb \
|
||||
bcm4708-buffalo-wzr-1750dhp.dtb \
|
||||
bcm4708-netgear-r6250.dtb \
|
||||
bcm4708-netgear-r6300-v2.dtb
|
||||
diff --git a/arch/arm/boot/dts/bcm47081-asus-rt-n18u.dts b/arch/arm/boot/dts/bcm47081-asus-rt-n18u.dts
|
||||
new file mode 100644
|
||||
index 0000000..e6347a9
|
||||
--- /dev/null
|
||||
+++ b/arch/arm/boot/dts/bcm47081-asus-rt-n18u.dts
|
||||
@@ -0,0 +1,35 @@
|
||||
+/*
|
||||
+ * Broadcom BCM470X / BCM5301X arm platform code.
|
||||
+ * DTS for Asus RT-N18U
|
||||
+ *
|
||||
+ * Copyright © 2014 Rafał Miłecki <zajec5@gmail.com>
|
||||
+ *
|
||||
+ * Licensed under the GNU/GPL. See COPYING for details.
|
||||
+ */
|
||||
+
|
||||
+/dts-v1/;
|
||||
+
|
||||
+#include "bcm47081.dtsi"
|
||||
+
|
||||
+/ {
|
||||
+ compatible = "asus,rt-n18u", "brcm,bcm47081";
|
||||
+ model = "Asus RT-N18U (BCM47081)";
|
||||
+
|
||||
+ chosen {
|
||||
+ bootargs = "console=ttyS0,115200";
|
||||
+ };
|
||||
+
|
||||
+ memory {
|
||||
+ reg = <0x00000000 0x08000000>;
|
||||
+ };
|
||||
+
|
||||
+ chipcommonA {
|
||||
+ uart0: serial@0300 {
|
||||
+ status = "okay";
|
||||
+ };
|
||||
+
|
||||
+ uart1: serial@0400 {
|
||||
+ status = "okay";
|
||||
+ };
|
||||
+ };
|
||||
+};
|
||||
diff --git a/arch/arm/boot/dts/bcm47081.dtsi b/arch/arm/boot/dts/bcm47081.dtsi
|
||||
new file mode 100644
|
||||
index 0000000..f720012
|
||||
--- /dev/null
|
||||
+++ b/arch/arm/boot/dts/bcm47081.dtsi
|
||||
@@ -0,0 +1,26 @@
|
||||
+/*
|
||||
+ * Broadcom BCM470X / BCM5301X ARM platform code.
|
||||
+ * DTS for BCM47081 SoC.
|
||||
+ *
|
||||
+ * Copyright © 2014 Rafał Miłecki <zajec5@gmail.com>
|
||||
+ *
|
||||
+ * Licensed under the GNU/GPL. See COPYING for details.
|
||||
+ */
|
||||
+
|
||||
+#include "bcm5301x.dtsi"
|
||||
+
|
||||
+/ {
|
||||
+ compatible = "brcm,bcm47081";
|
||||
+
|
||||
+ cpus {
|
||||
+ #address-cells = <1>;
|
||||
+ #size-cells = <0>;
|
||||
+
|
||||
+ cpu@0 {
|
||||
+ device_type = "cpu";
|
||||
+ compatible = "arm,cortex-a9";
|
||||
+ next-level-cache = <&L2>;
|
||||
+ reg = <0x0>;
|
||||
+ };
|
||||
+ };
|
||||
+};
|
||||
--
|
||||
1.8.4.5
|
||||
|
Loading…
Reference in New Issue
Block a user