upgrade the linaro gcc to 2011.06
SVN-Revision: 27326
This commit is contained in:
parent
0b250e3123
commit
7c4a91b216
@ -37,11 +37,11 @@ ifdef CONFIG_GCC_VERSION_LLVM
|
|||||||
HOST_BUILD_DIR:=$(BUILD_DIR_TOOLCHAIN)/$(GCC_DIR)
|
HOST_BUILD_DIR:=$(BUILD_DIR_TOOLCHAIN)/$(GCC_DIR)
|
||||||
else
|
else
|
||||||
ifeq ($(CONFIG_GCC_VERSION),"linaro")
|
ifeq ($(CONFIG_GCC_VERSION),"linaro")
|
||||||
PKG_REV:=4.5-2011.05-0
|
PKG_REV:=4.5-2011.06-0
|
||||||
PKG_VERSION:=4.5.4
|
PKG_VERSION:=4.5.4
|
||||||
PKG_SOURCE_URL:=http://launchpad.net/gcc-linaro/4.5/$(PKG_REV)/+download/
|
PKG_SOURCE_URL:=http://launchpad.net/gcc-linaro/4.5/$(PKG_REV)/+download/
|
||||||
PKG_SOURCE:=$(PKG_NAME)-linaro-$(PKG_REV).tar.bz2
|
PKG_SOURCE:=$(PKG_NAME)-linaro-$(PKG_REV).tar.bz2
|
||||||
PKG_MD5SUM:=7ec3e08bc39fe24f3c14006c003f5669
|
PKG_MD5SUM:=34562e19a3ea5baf05a2046c7da0a00b
|
||||||
GCC_DIR:=gcc-linaro-$(PKG_REV)
|
GCC_DIR:=gcc-linaro-$(PKG_REV)
|
||||||
HOST_BUILD_DIR:=$(BUILD_DIR_TOOLCHAIN)/$(GCC_DIR)
|
HOST_BUILD_DIR:=$(BUILD_DIR_TOOLCHAIN)/$(GCC_DIR)
|
||||||
else
|
else
|
||||||
|
@ -24,7 +24,7 @@
|
|||||||
#define LINUX_TARGET_LINK_SPEC "%{h*} %{version:-v} \
|
#define LINUX_TARGET_LINK_SPEC "%{h*} %{version:-v} \
|
||||||
--- a/gcc/config/linux.h
|
--- a/gcc/config/linux.h
|
||||||
+++ b/gcc/config/linux.h
|
+++ b/gcc/config/linux.h
|
||||||
@@ -116,6 +116,10 @@
|
@@ -116,6 +116,10 @@ see the files COPYING3 and COPYING.RUNTI
|
||||||
#define USE_LD_AS_NEEDED 1
|
#define USE_LD_AS_NEEDED 1
|
||||||
#endif
|
#endif
|
||||||
|
|
||||||
@ -37,7 +37,7 @@
|
|||||||
-muclibc or -mglibc or -mbionic has been passed to change the default. */
|
-muclibc or -mglibc or -mbionic has been passed to change the default. */
|
||||||
--- a/gcc/mkmap-symver.awk
|
--- a/gcc/mkmap-symver.awk
|
||||||
+++ b/gcc/mkmap-symver.awk
|
+++ b/gcc/mkmap-symver.awk
|
||||||
@@ -132,5 +132,5 @@
|
@@ -132,5 +132,5 @@ function output(lib) {
|
||||||
else if (inherit[lib])
|
else if (inherit[lib])
|
||||||
printf("} %s;\n", inherit[lib]);
|
printf("} %s;\n", inherit[lib]);
|
||||||
else
|
else
|
||||||
@ -46,7 +46,7 @@
|
|||||||
}
|
}
|
||||||
--- a/libgcc/Makefile.in
|
--- a/libgcc/Makefile.in
|
||||||
+++ b/libgcc/Makefile.in
|
+++ b/libgcc/Makefile.in
|
||||||
@@ -265,7 +265,7 @@
|
@@ -265,7 +265,7 @@ ifeq ($(enable_shared),yes)
|
||||||
# For -fvisibility=hidden. We need both a -fvisibility=hidden on
|
# For -fvisibility=hidden. We need both a -fvisibility=hidden on
|
||||||
# the command line, and a #define to prevent libgcc2.h etc from
|
# the command line, and a #define to prevent libgcc2.h etc from
|
||||||
# overriding that with #pragmas.
|
# overriding that with #pragmas.
|
||||||
|
@ -214,7 +214,7 @@
|
|||||||
+
|
+
|
||||||
--- a/gcc/config/arm/t-arm
|
--- a/gcc/config/arm/t-arm
|
||||||
+++ b/gcc/config/arm/t-arm
|
+++ b/gcc/config/arm/t-arm
|
||||||
@@ -23,6 +23,7 @@ MD_INCLUDES= $(srcdir)/config/arm/arm-t
|
@@ -23,6 +23,7 @@ MD_INCLUDES= $(srcdir)/config/arm/arm-tu
|
||||||
$(srcdir)/config/arm/arm-generic.md \
|
$(srcdir)/config/arm/arm-generic.md \
|
||||||
$(srcdir)/config/arm/arm1020e.md \
|
$(srcdir)/config/arm/arm1020e.md \
|
||||||
$(srcdir)/config/arm/arm1026ejs.md \
|
$(srcdir)/config/arm/arm1026ejs.md \
|
||||||
|
Loading…
Reference in New Issue
Block a user