utils/f2fs-tools: Update to 1.8.0
Update f2fs-tools to 1.8.0 Refresh patches Remove selinux patch, use configure argument instead. Switch to xz tarball Adjust url to avoid redirects Signed-off-by: Daniel Engberg <daniel.engberg.lists@pyret.net>
This commit is contained in:
parent
1d76542cca
commit
7eb58cf109
@ -8,14 +8,14 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=f2fs-tools
|
||||
PKG_VERSION:=1.7.0
|
||||
PKG_VERSION:=1.8.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_LICENSE:=GPLv2
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://git.kernel.org/cgit/linux/kernel/git/jaegeuk/f2fs-tools.git/snapshot/
|
||||
PKG_HASH:=33d454c2e95aabef5659949c4fff15f6c9877b48349e64411de502bc62b0cbd4
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=https://git.kernel.org/pub/scm/linux/kernel/git/jaegeuk/f2fs-tools.git/snapshot/
|
||||
PKG_HASH:=34790bccd74086e6b4f04fcac3a167ce1ca3319ce660454bceefc45c52906f94
|
||||
|
||||
PKG_FIXUP:=autoreconf
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
@ -56,6 +56,9 @@ define Package/libf2fs
|
||||
DEPENDS:=+libuuid
|
||||
endef
|
||||
|
||||
CONFIGURE_ARGS += \
|
||||
--without-selinux
|
||||
|
||||
define Package/libf2fs/install
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(CP) \
|
||||
|
@ -1,55 +0,0 @@
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -49,7 +49,7 @@ AC_PATH_PROG([LDCONFIG], [ldconfig],
|
||||
|
||||
# Checks for libraries.
|
||||
PKG_CHECK_MODULES([libuuid], [uuid])
|
||||
-PKG_CHECK_MODULES([libselinux], [libselinux])
|
||||
+# PKG_CHECK_MODULES([libselinux], [libselinux])
|
||||
|
||||
# Checks for header files.
|
||||
AC_CHECK_HEADERS([linux/fs.h fcntl.h mntent.h stdlib.h string.h \
|
||||
--- a/fsck/sload.c
|
||||
+++ b/fsck/sload.c
|
||||
@@ -16,10 +16,11 @@
|
||||
#include <libgen.h>
|
||||
#include <dirent.h>
|
||||
#include <mntent.h>
|
||||
+
|
||||
+#ifdef WITH_ANDROID
|
||||
#include <selinux/selinux.h>
|
||||
#include <selinux/label.h>
|
||||
|
||||
-#ifdef WITH_ANDROID
|
||||
#include <selinux/label.h>
|
||||
#include <private/android_filesystem_config.h>
|
||||
|
||||
@@ -110,10 +111,12 @@ static int build_directory(struct f2fs_s
|
||||
handle_selabel(dentries + i, S_ISDIR(stat.st_mode),
|
||||
target_out_dir);
|
||||
|
||||
+#ifdef WITH_ANDROID
|
||||
if (sehnd && selabel_lookup(sehnd, &dentries[i].secon,
|
||||
dentries[i].path, stat.st_mode) < 0)
|
||||
ERR_MSG("Cannot lookup security context for %s\n",
|
||||
dentries[i].path);
|
||||
+#endif
|
||||
|
||||
dentries[i].pino = dir_ino;
|
||||
|
||||
@@ -218,6 +221,7 @@ int f2fs_sload(struct f2fs_sb_info *sbi,
|
||||
return ret;
|
||||
}
|
||||
|
||||
+#ifdef WITH_ANDROID
|
||||
if (sehnd) {
|
||||
char *secontext = NULL;
|
||||
|
||||
@@ -233,6 +237,7 @@ int f2fs_sload(struct f2fs_sb_info *sbi,
|
||||
}
|
||||
free(secontext);
|
||||
}
|
||||
+#endif
|
||||
|
||||
/* update curseg info; can update sit->types */
|
||||
move_curseg_info(sbi, SM_I(sbi)->main_blkaddr);
|
Loading…
Reference in New Issue
Block a user