quilt: fix building with dash test x == x
gives a syntax error with dash (standard in Debian). The modified patch reflects the current upstream: http://git.savannah.gnu.org/cgit/quilt.git/commit/?id=38df0b210c3df67f3e784af92232ae1946b98ecd
SVN-Revision: 26804
This commit is contained in:
parent
a18ec3c37e
commit
8324bf036c
@ -1,11 +1,15 @@
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -274,7 +274,7 @@ fi
|
||||
@@ -274,7 +274,11 @@ fi
|
||||
AC_MSG_CHECKING([the version of $PATCH])
|
||||
if $PATCH --version 2> /dev/null | grep GNU >/dev/null; then
|
||||
set -- `$PATCH --version 2> /dev/null`
|
||||
- patch_version=$2
|
||||
+ test $2 == "patch" && patch_version=$3 || patch_version=$2
|
||||
+ if test x$1 = xGNU ; then
|
||||
+ patch_version=$3
|
||||
+ else
|
||||
+ patch_version=$2
|
||||
+ fi
|
||||
AC_MSG_RESULT($patch_version)
|
||||
saved_IFS=$IFS; IFS='.'
|
||||
set -- $patch_version
|
||||
|
Loading…
Reference in New Issue
Block a user