iftop: update iftop to 1.0pre2
Most significantly, includes IPv6 support. This version forces libncurses, by patching the configure script, instead of allowing libncursesw, saving (~65k) image space. Signed-off-by: Russell Senior <russell@personaltelco.net> SVN-Revision: 33782
This commit is contained in:
parent
e75106aa0d
commit
8fc2b30281
@ -8,12 +8,12 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=iftop
|
||||
PKG_VERSION:=0.17
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=1.0pre2
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://www.ex-parrot.com/~pdw/iftop/download
|
||||
PKG_MD5SUM:=062bc8fb3856580319857326e0b8752d
|
||||
PKG_MD5SUM:=fef521a49ec0122458d02c64212af3c5
|
||||
|
||||
PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
|
||||
|
||||
|
12
package/network/utils/iftop/patches/0001-force-ncurses.patch
Normal file
12
package/network/utils/iftop/patches/0001-force-ncurses.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -ru iftop-1.0pre2-old/configure iftop-1.0pre2/configure
|
||||
--- iftop-1.0pre2-old/configure 2011-10-04 13:30:30.000000000 -0700
|
||||
+++ iftop-1.0pre2/configure 2012-09-09 22:26:05.000000000 -0700
|
||||
@@ -7568,7 +7568,7 @@
|
||||
{ $as_echo "$as_me:$LINENO: checking for a curses library containing mvchgat" >&5
|
||||
$as_echo_n "checking for a curses library containing mvchgat... " >&6; }
|
||||
oldLIBS=$LIBS
|
||||
-for curseslib in ncursesw curses ncurses ; do
|
||||
+for curseslib in ncurses ; do
|
||||
LIBS="$oldLIBS -l$curseslib"
|
||||
cat >conftest.$ac_ext <<_ACEOF
|
||||
/* confdefs.h. */
|
@ -1,11 +0,0 @@
|
||||
--- a/ether.h
|
||||
+++ b/ether.h
|
||||
@@ -12,7 +12,7 @@ struct ether_header {
|
||||
u_int8_t ether_dhost[ETHER_ADDR_LEN];
|
||||
u_int8_t ether_shost[ETHER_ADDR_LEN];
|
||||
u_int16_t ether_type;
|
||||
-};
|
||||
+} __attribute__((packed));
|
||||
|
||||
struct vlan_8021q_header {
|
||||
u_int16_t priority_cfi_vid;
|
@ -1,10 +0,0 @@
|
||||
--- a/ui.c
|
||||
+++ b/ui.c
|
||||
@@ -446,6 +446,7 @@ void screen_hash_clear() {
|
||||
hash_node_type* n = NULL;
|
||||
while(hash_next_item(screen_hash, &n) == HASH_STATUS_OK) {
|
||||
host_pair_line* hpl = (host_pair_line*)n->rec;
|
||||
+ hpl->total_recv = hpl->total_sent = 0;
|
||||
memset(hpl->recv, 0, sizeof(hpl->recv));
|
||||
memset(hpl->sent, 0, sizeof(hpl->sent));
|
||||
}
|
@ -1,15 +0,0 @@
|
||||
--- a/cfgfile.c
|
||||
+++ b/cfgfile.c
|
||||
@@ -45,9 +45,9 @@ stringmap config;
|
||||
extern options_t options ;
|
||||
|
||||
int is_cfgdirective_valid(const char *s) {
|
||||
- char **t;
|
||||
- for (t = config_directives; *t != NULL; ++t)
|
||||
- if (strcmp(s, *t) == 0) return 1;
|
||||
+ int t;
|
||||
+ for (t = 0; config_directives[t] != NULL; t++)
|
||||
+ if (strcmp(s, config_directives[t]) == 0) return 1;
|
||||
return 0;
|
||||
}
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- a/options.c
|
||||
+++ b/options.c
|
||||
@@ -302,7 +302,7 @@ void options_read_args(int argc, char **
|
||||
break;
|
||||
|
||||
case 'b':
|
||||
- config_set_string("show-bars", "true");
|
||||
+ config_set_string("show-bars", "false");
|
||||
break;
|
||||
|
||||
case 'B':
|
@ -1,11 +0,0 @@
|
||||
--- a/ui.c
|
||||
+++ b/ui.c
|
||||
@@ -263,7 +263,7 @@ static void draw_bar_scale(int* y) {
|
||||
char s[40], *p;
|
||||
int x;
|
||||
/* This 1024 vs 1000 stuff is just plain evil */
|
||||
- readable_size(i, s, sizeof s, options.log_scale ? 1000 : 1024, 0);
|
||||
+ readable_size(i, s, sizeof s, options.log_scale ? 1000 : 1024, options.bandwidth_in_bytes);
|
||||
p = s + strspn(s, " ");
|
||||
x = get_bar_length(i * 8);
|
||||
mvaddch(*y + 1, x, ACS_BTEE);
|
Loading…
Reference in New Issue
Block a user