Change popt packaging
SVN-Revision: 486
This commit is contained in:
parent
a8417fb070
commit
902f880364
@ -4,7 +4,7 @@ include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME := popt
|
||||
PKG_VERSION := 1.7
|
||||
PKG_RELEASE := 3
|
||||
PKG_RELEASE := 4
|
||||
PKG_MD5SUM := 5988e7aeb0ae4dac8d83561265984cc9
|
||||
|
||||
PKG_SOURCE_SITE := ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.1.x/
|
||||
@ -21,16 +21,15 @@ $(DL_DIR)/$(PKG_SOURCE_FILE):
|
||||
$(PKG_BUILD_DIR)/ipkg/rules: $(DL_DIR)/$(PKG_SOURCE_FILE)
|
||||
mkdir -p $(TOOL_BUILD_DIR)
|
||||
$(PKG_SOURCE_CAT) $(DL_DIR)/$(PKG_SOURCE_FILE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
|
||||
$(PATCH) $(PKG_BUILD_DIR) . $(PKG_NAME)-\*.diff
|
||||
# $(PATCH) $(PKG_BUILD_DIR) ./patches
|
||||
cp -fpR ./ipkg $(PKG_BUILD_DIR)/
|
||||
chmod a+x $(PKG_BUILD_DIR)/ipkg/rules
|
||||
|
||||
$(PKG_IPK): $(PKG_BUILD_DIR)/ipkg/rules
|
||||
cd $(PKG_BUILD_DIR); \
|
||||
ipkg/rules \
|
||||
TOPDIR="$(TOPDIR)" \
|
||||
IPKG_RULES_INC="$(TOPDIR)/rules.mk" \
|
||||
INSTALL_DIR="$(STAGING_DIR)" \
|
||||
package
|
||||
TOPDIR="$(TOPDIR)" IPKG_RULES_INC="$(TOPDIR)/rules.mk" \
|
||||
INSTALL_DIR="$(STAGING_DIR)" \
|
||||
ipkg/rules package
|
||||
|
||||
$(IPKG_STATE_DIR)/info/lib$(PKG_NAME).list: $(PKG_IPK)
|
||||
$(IPKG) install $(PKG_IPK)
|
||||
@ -42,10 +41,9 @@ install: $(IPKG_STATE_DIR)/info/lib$(PKG_NAME).list
|
||||
|
||||
clean:
|
||||
-cd $(PKG_BUILD_DIR); \
|
||||
ipkg/rules \
|
||||
TOPDIR="$(TOPDIR)" IPKG_RULES_INC="$(TOPDIR)/rules.mk" \
|
||||
INSTALL_DIR="$(STAGING_DIR)" \
|
||||
clean
|
||||
TOPDIR="$(TOPDIR)" IPKG_RULES_INC="$(TOPDIR)/rules.mk" \
|
||||
INSTALL_DIR="$(STAGING_DIR)" \
|
||||
ipkg/rules clean
|
||||
rm -rf $(PKG_BUILD_DIR)
|
||||
rm -r $(PKG_IPK)
|
||||
|
||||
|
8
openwrt/package/popt/ipkg/libpopt-dev/CONTROL/control
Normal file
8
openwrt/package/popt/ipkg/libpopt-dev/CONTROL/control
Normal file
@ -0,0 +1,8 @@
|
||||
Package: libpopt-dev
|
||||
Priority: optional
|
||||
Section: devel
|
||||
Version: [TBDL]
|
||||
Architecture: [TBDL]
|
||||
Maintainer: Nico <nthill@free.fr>
|
||||
Source: http://nthill.free.fr/openwrt/sources/popt/
|
||||
Description: a command line option parsing library (development)
|
8
openwrt/package/popt/ipkg/libpopt/CONTROL/control
Normal file
8
openwrt/package/popt/ipkg/libpopt/CONTROL/control
Normal file
@ -0,0 +1,8 @@
|
||||
Package: libpopt
|
||||
Priority: optional
|
||||
Section: libs
|
||||
Version: [TBDL]
|
||||
Architecture: [TBDL]
|
||||
Maintainer: Nico <nthill@free.fr>
|
||||
Source: http://nthill.free.fr/openwrt/sources/popt/
|
||||
Description: a command line option parsing library
|
128
openwrt/package/popt/ipkg/rules
Normal file
128
openwrt/package/popt/ipkg/rules
Normal file
@ -0,0 +1,128 @@
|
||||
#!/usr/bin/make -f
|
||||
|
||||
ifneq ($(strip ${IPKG_RULES_INC}),)
|
||||
include $(IPKG_RULES_INC)
|
||||
endif
|
||||
|
||||
##
|
||||
|
||||
PKG_VERSION := $(shell cat ./ipkg/version)
|
||||
CURRENT_DIR := $(shell pwd)
|
||||
INSTALL_DIR ?= $(CURRENT_DIR)/ipkg-install
|
||||
|
||||
unexport INSTALL_DIR
|
||||
|
||||
I_LIBPOPT := ipkg/libpopt
|
||||
I_LIBPOPT_DEV := ipkg/libpopt-dev
|
||||
|
||||
BUILD_DEPS := \
|
||||
|
||||
CONFIGURE_OPTS = \
|
||||
--enable-shared \
|
||||
--enable-static \
|
||||
|
||||
##
|
||||
|
||||
all: package
|
||||
|
||||
|
||||
.stamp-configured: $(BUILD_DEPS)
|
||||
|
||||
rm -rf config.cache
|
||||
$(TARGET_CONFIGURE_OPTS) \
|
||||
CFLAGS="$(TARGET_CFLAGS)" \
|
||||
am_cv_func_iconv=no \
|
||||
./configure \
|
||||
--target=$(GNU_TARGET_NAME) \
|
||||
--host=$(GNU_TARGET_NAME) \
|
||||
--build=$(GNU_HOST_NAME) \
|
||||
--program-prefix="" \
|
||||
--program-suffix="" \
|
||||
--prefix=/usr \
|
||||
--exec-prefix=/usr \
|
||||
--bindir=/usr/bin \
|
||||
--datadir=/usr/share \
|
||||
--includedir=/usr/include \
|
||||
--infodir=/usr/share/info \
|
||||
--libdir=/usr/lib \
|
||||
--libexecdir=/usr/lib \
|
||||
--localstatedir=/var \
|
||||
--mandir=/usr/share/man \
|
||||
--sbindir=/usr/sbin \
|
||||
--sysconfdir=/etc \
|
||||
$(DISABLE_LARGEFILE) \
|
||||
$(DISABLE_NLS) \
|
||||
$(CONFIGURE_OPTS) \
|
||||
|
||||
touch .stamp-configured
|
||||
|
||||
|
||||
.stamp-built: .stamp-configured
|
||||
|
||||
$(MAKE)
|
||||
|
||||
touch .stamp-built
|
||||
|
||||
|
||||
$(INSTALL_DIR)/usr/include/popt.h: .stamp-built
|
||||
|
||||
mkdir -p $(INSTALL_DIR)
|
||||
|
||||
$(MAKE) \
|
||||
DESTDIR="$(INSTALL_DIR)" \
|
||||
install
|
||||
|
||||
|
||||
configure: .stamp-configured
|
||||
|
||||
|
||||
build: .stamp-built
|
||||
|
||||
|
||||
install: $(INSTALL_DIR)/usr/include/popt.h
|
||||
|
||||
|
||||
package: $(INSTALL_DIR)/usr/include/popt.h
|
||||
|
||||
mkdir -p $(I_LIBPOPT)/usr/lib
|
||||
cp -fpR $(INSTALL_DIR)/usr/lib/libpopt*.so.* $(I_LIBPOPT)/usr/lib/
|
||||
$(STRIP) $(I_LIBPOPT)/usr/lib/lib*.so.*
|
||||
|
||||
mkdir -p $(I_LIBPOPT_DEV)/usr/include
|
||||
cp -fpR $(INSTALL_DIR)/usr/include/popt.h $(I_LIBPOPT_DEV)/usr/include/
|
||||
mkdir -p $(I_LIBPOPT_DEV)/usr/lib
|
||||
cp -fpR $(INSTALL_DIR)/usr/lib/libpopt*.a $(I_LIBPOPT_DEV)/usr/lib/
|
||||
cp -fpR $(INSTALL_DIR)/usr/lib/libpopt*.so* $(I_LIBPOPT_DEV)/usr/lib/
|
||||
|
||||
chmod 0755 ipkg/*/CONTROL/
|
||||
chmod 0644 ipkg/*/CONTROL/control
|
||||
|
||||
perl -pi -e "s/^Arch.*:.*/Architecture: $(ARCH)/g" ipkg/*/CONTROL/control
|
||||
ifneq ($(strip $(PKG_VERSION)),)
|
||||
perl -pi -e "s/^Vers.*:.*/Version: $(PKG_VERSION)/g" ipkg/*/CONTROL/control
|
||||
endif
|
||||
|
||||
$(IPKG_BUILD) $(I_LIBPOPT) $(IPKG_TARGET_DIR)
|
||||
$(IPKG_BUILD) $(I_LIBPOPT_DEV) $(IPKG_TARGET_DIR)
|
||||
|
||||
|
||||
clean:
|
||||
|
||||
-$(MAKE) \
|
||||
DESTDIR="$(INSTALL_DIR)" \
|
||||
uninstall clean
|
||||
|
||||
rm -rf .stamp-* \
|
||||
$(I_LIBPOPT)/usr \
|
||||
$(I_LIBPOPT_DEV)/usr \
|
||||
|
||||
|
||||
control:
|
||||
|
||||
@cat $(I_LIBPOPT)/CONTROL/control
|
||||
@echo
|
||||
@cat $(I_LIBPOPT_DEV)/CONTROL/control
|
||||
@echo
|
||||
|
||||
|
||||
.PHONY: configure build install package clean control
|
1
openwrt/package/popt/ipkg/version
Normal file
1
openwrt/package/popt/ipkg/version
Normal file
@ -0,0 +1 @@
|
||||
1.7-4
|
@ -1,159 +0,0 @@
|
||||
diff -ruN popt-1.7-orig/ipkg/libpopt/CONTROL/control popt-1.7-3/ipkg/libpopt/CONTROL/control
|
||||
--- popt-1.7-orig/ipkg/libpopt/CONTROL/control 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ popt-1.7-3/ipkg/libpopt/CONTROL/control 2005-03-08 03:24:11.000000000 +0100
|
||||
@@ -0,0 +1,8 @@
|
||||
+Package: libpopt
|
||||
+Priority: optional
|
||||
+Section: libs
|
||||
+Version: [TBDL]
|
||||
+Architecture: [TBDL]
|
||||
+Maintainer: Nico <nthill@free.fr>
|
||||
+Source: http://nthill.free.fr/openwrt/sources/popt/
|
||||
+Description: a command line option parsing library
|
||||
diff -ruN popt-1.7-orig/ipkg/popt-dev/CONTROL/control popt-1.7-3/ipkg/popt-dev/CONTROL/control
|
||||
--- popt-1.7-orig/ipkg/popt-dev/CONTROL/control 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ popt-1.7-3/ipkg/popt-dev/CONTROL/control 2005-03-08 03:26:21.000000000 +0100
|
||||
@@ -0,0 +1,8 @@
|
||||
+Package: popt-dev
|
||||
+Priority: optional
|
||||
+Section: devel
|
||||
+Version: [TBDL]
|
||||
+Architecture: [TBDL]
|
||||
+Maintainer: Nico <nthill@free.fr>
|
||||
+Source: http://nthill.free.fr/openwrt/sources/popt/
|
||||
+Description: a command line option parsing library (development)
|
||||
diff -ruN popt-1.7-orig/ipkg/rules popt-1.7-3/ipkg/rules
|
||||
--- popt-1.7-orig/ipkg/rules 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ popt-1.7-3/ipkg/rules 2005-03-08 03:50:49.000000000 +0100
|
||||
@@ -0,0 +1,126 @@
|
||||
+#!/usr/bin/make -f
|
||||
+
|
||||
+ifneq ($(strip ${IPKG_RULES_INC}),)
|
||||
+ include $(IPKG_RULES_INC)
|
||||
+endif
|
||||
+
|
||||
+##
|
||||
+
|
||||
+PKG_VERSION := $(shell cat ./ipkg/version)
|
||||
+CURRENT_DIR := $(shell pwd)
|
||||
+INSTALL_DIR = $(CURRENT_DIR)/ipkg-install
|
||||
+
|
||||
+I_LIBPOPT := ipkg/libpopt
|
||||
+I_POPT_DEV := ipkg/popt-dev
|
||||
+
|
||||
+BUILD_DEPS := \
|
||||
+
|
||||
+CONFIGURE_OPTS = \
|
||||
+ --enable-shared \
|
||||
+ --enable-static \
|
||||
+
|
||||
+##
|
||||
+
|
||||
+all: package
|
||||
+
|
||||
+
|
||||
+.stamp-configured: $(BUILD_DEPS)
|
||||
+
|
||||
+ rm -rf config.cache
|
||||
+ $(TARGET_CONFIGURE_OPTS) \
|
||||
+ CFLAGS="$(TARGET_CFLAGS)" \
|
||||
+ am_cv_func_iconv=no \
|
||||
+ ./configure \
|
||||
+ --target=$(GNU_TARGET_NAME) \
|
||||
+ --host=$(GNU_TARGET_NAME) \
|
||||
+ --build=$(GNU_HOST_NAME) \
|
||||
+ --prefix=/usr \
|
||||
+ --exec-prefix=/usr \
|
||||
+ --bindir=/usr/bin \
|
||||
+ --datadir=/usr/share \
|
||||
+ --includedir=/usr/include \
|
||||
+ --infodir=/usr/share/info \
|
||||
+ --libdir=/usr/lib \
|
||||
+ --libexecdir=/usr/lib \
|
||||
+ --localstatedir=/var \
|
||||
+ --mandir=/usr/share/man \
|
||||
+ --sbindir=/usr/sbin \
|
||||
+ --sysconfdir=/etc \
|
||||
+ $(DISABLE_NLS) \
|
||||
+ $(CONFIGURE_OPTS) \
|
||||
+
|
||||
+ touch .stamp-configured
|
||||
+
|
||||
+
|
||||
+.stamp-built: .stamp-configured
|
||||
+
|
||||
+ $(MAKE) \
|
||||
+ $(TARGET_CONFIGURE_OPTS) \
|
||||
+ CFLAGS="$(TARGET_CFLAGS)" \
|
||||
+
|
||||
+ touch .stamp-built
|
||||
+
|
||||
+
|
||||
+$(INSTALL_DIR)/usr/include/popt.h: .stamp-built
|
||||
+
|
||||
+ mkdir -p $(INSTALL_DIR)
|
||||
+
|
||||
+ $(MAKE) \
|
||||
+ DESTDIR="$(INSTALL_DIR)" \
|
||||
+ transform="s,x,x," \
|
||||
+ install
|
||||
+
|
||||
+
|
||||
+configure: .stamp-configured
|
||||
+
|
||||
+
|
||||
+build: .stamp-built
|
||||
+
|
||||
+
|
||||
+install: $(INSTALL_DIR)/usr/include/popt.h
|
||||
+
|
||||
+
|
||||
+package: $(INSTALL_DIR)/usr/include/popt.h
|
||||
+
|
||||
+ mkdir -p $(I_LIBPOPT)/usr/lib
|
||||
+ cp -fpR $(INSTALL_DIR)/usr/lib/libpopt*.so.* $(I_LIBPOPT)/usr/lib/
|
||||
+ $(STRIP) $(I_LIBPOPT)/usr/lib/lib*.so.*
|
||||
+
|
||||
+ mkdir -p $(I_POPT_DEV)/usr/include
|
||||
+ cp -fpR $(INSTALL_DIR)/usr/include/popt.h $(I_POPT_DEV)/usr/include/
|
||||
+ mkdir -p $(I_POPT_DEV)/usr/lib
|
||||
+ cp -fpR $(INSTALL_DIR)/usr/lib/libpopt*.a $(I_POPT_DEV)/usr/lib/
|
||||
+ cp -fpR $(INSTALL_DIR)/usr/lib/libpopt*.so* $(I_POPT_DEV)/usr/lib/
|
||||
+
|
||||
+ chmod 0755 ipkg/*/CONTROL/
|
||||
+ chmod 0644 ipkg/*/CONTROL/control
|
||||
+
|
||||
+ perl -pi -e "s/^Arch.*:.*/Architecture: $(ARCH)/g" ipkg/*/CONTROL/control
|
||||
+ifneq ($(strip $(PKG_VERSION)),)
|
||||
+ perl -pi -e "s/^Vers.*:.*/Version: $(PKG_VERSION)/g" ipkg/*/CONTROL/control
|
||||
+endif
|
||||
+
|
||||
+ $(IPKG_BUILD) $(I_LIBPOPT) $(IPKG_TARGET_DIR)
|
||||
+ $(IPKG_BUILD) $(I_POPT_DEV) $(IPKG_TARGET_DIR)
|
||||
+
|
||||
+
|
||||
+clean:
|
||||
+
|
||||
+ -$(MAKE) clean
|
||||
+ rm -rf .stamp-*
|
||||
+ rm -rf $(INSTALL_DIR)/usr/include/popt*
|
||||
+ rm -rf $(INSTALL_DIR)/usr/include/libpopt*
|
||||
+ rm -rf $(INSTALL_DIR)/usr/share/man/man*/popt*
|
||||
+ rm -rf $(I_LIBPOPT)/usr
|
||||
+ rm -rf $(I_POPT_DEV)/usr
|
||||
+
|
||||
+
|
||||
+control:
|
||||
+
|
||||
+ @cat $(I_LIBPOPT)/CONTROL/control
|
||||
+ @echo
|
||||
+ @cat $(I_POPT_DEV)/CONTROL/control
|
||||
+ @echo
|
||||
+
|
||||
+
|
||||
+.PHONY: configure build install package clean control
|
||||
diff -ruN popt-1.7-orig/ipkg/version popt-1.7-3/ipkg/version
|
||||
--- popt-1.7-orig/ipkg/version 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ popt-1.7-3/ipkg/version 2005-03-08 03:23:49.000000000 +0100
|
||||
@@ -0,0 +1 @@
|
||||
+1.7-3
|
Loading…
Reference in New Issue
Block a user