Added initial support for at91 plaform (HCG)
SVN-Revision: 6508
This commit is contained in:
parent
bc60eb3610
commit
99657a3be5
24
target/linux/at91-2.6/Makefile
Normal file
24
target/linux/at91-2.6/Makefile
Normal file
@ -0,0 +1,24 @@
|
||||
#
|
||||
# Copyright (C) 2006 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
ARCH:=arm
|
||||
BOARD:=at91
|
||||
BOARDNAME:=AT91
|
||||
FEATURES:=squashfs
|
||||
|
||||
define Target/Description
|
||||
Build fimware images for Figment Design Labs VersaLink board.
|
||||
endef
|
||||
|
||||
include $(INCLUDE_DIR)/kernel-build.mk
|
||||
|
||||
#include the profiles
|
||||
-include profiles/*.mk
|
||||
|
||||
KERNELNAME:="uImage"
|
||||
$(eval $(call BuildKernel))
|
310
target/linux/at91-2.6/config/default
Normal file
310
target/linux/at91-2.6/config/default
Normal file
@ -0,0 +1,310 @@
|
||||
# CONFIG_AEABI is not set
|
||||
CONFIG_ALIGNMENT_TRAP=y
|
||||
# CONFIG_APM is not set
|
||||
# CONFIG_ARCH_AAEC2000 is not set
|
||||
CONFIG_ARCH_AT91=y
|
||||
CONFIG_ARCH_AT91RM9200=y
|
||||
# CONFIG_ARCH_AT91RM9200DK is not set
|
||||
# CONFIG_ARCH_AT91SAM9260 is not set
|
||||
# CONFIG_ARCH_AT91SAM9261 is not set
|
||||
# CONFIG_ARCH_CLPS711X is not set
|
||||
# CONFIG_ARCH_CLPS7500 is not set
|
||||
# CONFIG_ARCH_CO285 is not set
|
||||
# CONFIG_ARCH_DISCONTIGMEM_ENABLE is not set
|
||||
# CONFIG_ARCH_EBSA110 is not set
|
||||
# CONFIG_ARCH_EP93XX is not set
|
||||
# CONFIG_ARCH_FOOTBRIDGE is not set
|
||||
# CONFIG_ARCH_H720X is not set
|
||||
# CONFIG_ARCH_IMX is not set
|
||||
# CONFIG_ARCH_INTEGRATOR is not set
|
||||
# CONFIG_ARCH_IOP32X is not set
|
||||
# CONFIG_ARCH_IOP33X is not set
|
||||
# CONFIG_ARCH_IXP2000 is not set
|
||||
# CONFIG_ARCH_IXP23XX is not set
|
||||
# CONFIG_ARCH_IXP4XX is not set
|
||||
# CONFIG_ARCH_L7200 is not set
|
||||
# CONFIG_ARCH_LH7A40X is not set
|
||||
# CONFIG_ARCH_NETX is not set
|
||||
# CONFIG_ARCH_OMAP is not set
|
||||
# CONFIG_ARCH_PNX4008 is not set
|
||||
# CONFIG_ARCH_PXA is not set
|
||||
# CONFIG_ARCH_REALVIEW is not set
|
||||
# CONFIG_ARCH_RPC is not set
|
||||
# CONFIG_ARCH_S3C2410 is not set
|
||||
# CONFIG_ARCH_SA1100 is not set
|
||||
# CONFIG_ARCH_SHARK is not set
|
||||
# CONFIG_ARCH_VERSATILE is not set
|
||||
CONFIG_ARM=y
|
||||
CONFIG_ARM_AT91_ETHER=y
|
||||
CONFIG_ARM_THUMB=y
|
||||
# CONFIG_ARPD is not set
|
||||
# CONFIG_ARTHUR is not set
|
||||
# CONFIG_AT91_PROGRAMMABLE_CLOCKS is not set
|
||||
CONFIG_AT91_SPI=y
|
||||
CONFIG_AT91_SPIDEV=y
|
||||
# CONFIG_ATM is not set
|
||||
CONFIG_BASE_SMALL=0
|
||||
# CONFIG_BINFMT_AOUT is not set
|
||||
# CONFIG_BLK_DEV_LOOP is not set
|
||||
# CONFIG_BLK_DEV_NBD is not set
|
||||
CONFIG_BLK_DEV_RAM=y
|
||||
CONFIG_BLK_DEV_RAM_BLOCKSIZE=1024
|
||||
CONFIG_BLK_DEV_RAM_COUNT=16
|
||||
CONFIG_BLK_DEV_RAM_SIZE=4096
|
||||
# CONFIG_BONDING is not set
|
||||
# CONFIG_BRIDGE_NF_EBTABLES is not set
|
||||
# CONFIG_BSD_PROCESS_ACCT is not set
|
||||
# CONFIG_BT is not set
|
||||
# CONFIG_CIFS is not set
|
||||
# CONFIG_CLS_U32_MARK is not set
|
||||
# CONFIG_CLS_U32_PERF is not set
|
||||
# CONFIG_CONFIGFS_FS is not set
|
||||
CONFIG_CPU_32=y
|
||||
CONFIG_CPU_32v4T=y
|
||||
CONFIG_CPU_ABRT_EV4T=y
|
||||
CONFIG_CPU_ARM920T=y
|
||||
CONFIG_CPU_CACHE_V4WT=y
|
||||
CONFIG_CPU_CACHE_VIVT=y
|
||||
CONFIG_CPU_COPY_V4WB=y
|
||||
CONFIG_CPU_CP15=y
|
||||
CONFIG_CPU_CP15_MMU=y
|
||||
# CONFIG_CPU_DCACHE_DISABLE is not set
|
||||
# CONFIG_CPU_DCACHE_WRITETHROUGH is not set
|
||||
# CONFIG_CPU_ICACHE_DISABLE is not set
|
||||
CONFIG_CPU_TLB_V4WBI=y
|
||||
# CONFIG_CRC16 is not set
|
||||
CONFIG_CRC32=m
|
||||
# CONFIG_CRYPTO_AES is not set
|
||||
CONFIG_CRYPTO_ALGAPI=m
|
||||
# CONFIG_CRYPTO_ANUBIS is not set
|
||||
CONFIG_CRYPTO_BLKCIPHER=m
|
||||
# CONFIG_CRYPTO_BLOWFISH is not set
|
||||
# CONFIG_CRYPTO_CAST5 is not set
|
||||
# CONFIG_CRYPTO_CAST6 is not set
|
||||
CONFIG_CRYPTO_CBC=m
|
||||
# CONFIG_CRYPTO_CRC32C is not set
|
||||
CONFIG_CRYPTO_DES=m
|
||||
# CONFIG_CRYPTO_KHAZAD is not set
|
||||
CONFIG_CRYPTO_MANAGER=m
|
||||
# CONFIG_CRYPTO_MD4 is not set
|
||||
CONFIG_CRYPTO_MD5=m
|
||||
# CONFIG_CRYPTO_MICHAEL_MIC is not set
|
||||
# CONFIG_CRYPTO_NULL is not set
|
||||
# CONFIG_CRYPTO_SERPENT is not set
|
||||
# CONFIG_CRYPTO_SHA256 is not set
|
||||
# CONFIG_CRYPTO_SHA512 is not set
|
||||
# CONFIG_CRYPTO_TEA is not set
|
||||
# CONFIG_CRYPTO_TEST is not set
|
||||
# CONFIG_CRYPTO_TGR192 is not set
|
||||
# CONFIG_CRYPTO_TWOFISH is not set
|
||||
# CONFIG_CRYPTO_WP512 is not set
|
||||
CONFIG_DAVICOM_PHY=y
|
||||
# CONFIG_DEBUG_BUGVERBOSE is not set
|
||||
CONFIG_DEBUG_DRIVER=y
|
||||
# CONFIG_DEBUG_ERRORS is not set
|
||||
# CONFIG_DEBUG_INFO is not set
|
||||
CONFIG_DEBUG_KERNEL=y
|
||||
# CONFIG_DEBUG_KOBJECT is not set
|
||||
# CONFIG_DEBUG_LIST is not set
|
||||
# CONFIG_DEBUG_LL is not set
|
||||
# CONFIG_DEBUG_LOCKING_API_SELFTESTS is not set
|
||||
# CONFIG_DEBUG_MUTEXES is not set
|
||||
# CONFIG_DEBUG_RT_MUTEXES is not set
|
||||
# CONFIG_DEBUG_RWSEMS is not set
|
||||
# CONFIG_DEBUG_SLAB is not set
|
||||
# CONFIG_DEBUG_SPINLOCK is not set
|
||||
# CONFIG_DEBUG_SPINLOCK_SLEEP is not set
|
||||
# CONFIG_DEBUG_USER is not set
|
||||
# CONFIG_DEBUG_VM is not set
|
||||
# CONFIG_DEBUG_WAITQ is not set
|
||||
CONFIG_DETECT_SOFTLOCKUP=y
|
||||
# CONFIG_DM9000 is not set
|
||||
CONFIG_DNOTIFY=y
|
||||
CONFIG_DUMMY_CONSOLE=y
|
||||
# CONFIG_EXT2_FS is not set
|
||||
# CONFIG_EXT3_FS is not set
|
||||
# CONFIG_FIRMWARE_EDID is not set
|
||||
# CONFIG_FIXED_PHY is not set
|
||||
CONFIG_FORCED_INLINING=y
|
||||
# CONFIG_FPE_FASTFPE is not set
|
||||
CONFIG_FPE_NWFPE=y
|
||||
# CONFIG_FPE_NWFPE_XP is not set
|
||||
CONFIG_FRAME_POINTER=y
|
||||
# CONFIG_FW_LOADER is not set
|
||||
# CONFIG_GENERIC_TIME is not set
|
||||
# CONFIG_HAMRADIO is not set
|
||||
CONFIG_HARDIRQS_SW_RESEND=y
|
||||
# CONFIG_HFSPLUS_FS is not set
|
||||
# CONFIG_HFS_FS is not set
|
||||
CONFIG_HW_CONSOLE=y
|
||||
# CONFIG_HW_RANDOM is not set
|
||||
CONFIG_HZ=100
|
||||
# CONFIG_I2C is not set
|
||||
# CONFIG_IEEE80211 is not set
|
||||
# CONFIG_IKCONFIG is not set
|
||||
# CONFIG_INET6_TUNNEL is not set
|
||||
# CONFIG_INET6_XFRM_TUNNEL is not set
|
||||
CONFIG_INITRAMFS_SOURCE=""
|
||||
# CONFIG_INOTIFY is not set
|
||||
CONFIG_INPUT=y
|
||||
# CONFIG_INPUT_EVDEV is not set
|
||||
CONFIG_INPUT_MOUSEDEV=y
|
||||
# CONFIG_INPUT_MOUSEDEV_PSAUX is not set
|
||||
CONFIG_INPUT_MOUSEDEV_SCREEN_X=1024
|
||||
CONFIG_INPUT_MOUSEDEV_SCREEN_Y=768
|
||||
# CONFIG_IPV6 is not set
|
||||
# CONFIG_IP_DCCP is not set
|
||||
# CONFIG_IP_NF_ARPTABLES is not set
|
||||
# CONFIG_IP_NF_CT_PROTO_SCTP is not set
|
||||
# CONFIG_IP_NF_MATCH_ADDRTYPE is not set
|
||||
# CONFIG_IP_NF_MATCH_HASHLIMIT is not set
|
||||
# CONFIG_IP_NF_TARGET_IMQ is not set
|
||||
CONFIG_IP_NF_TARGET_LOG=y
|
||||
# CONFIG_IP_NF_TARGET_NETMAP is not set
|
||||
# CONFIG_IP_NF_TARGET_ROUTE is not set
|
||||
# CONFIG_IP_NF_TARGET_SAME is not set
|
||||
# CONFIG_IP_ROUTE_FWMARK is not set
|
||||
# CONFIG_IP_ROUTE_MULTIPATH_CACHED is not set
|
||||
# CONFIG_IP_ROUTE_VERBOSE is not set
|
||||
# CONFIG_ISO9660_FS is not set
|
||||
# CONFIG_JFFS2_FS is not set
|
||||
# CONFIG_JFS_FS is not set
|
||||
# CONFIG_LEDS is not set
|
||||
# CONFIG_LIBCRC32C is not set
|
||||
# CONFIG_LLC2 is not set
|
||||
# CONFIG_LOCALVERSION_AUTO is not set
|
||||
# CONFIG_MACH_AT91RM9200EK is not set
|
||||
# CONFIG_MACH_ATEB9200 is not set
|
||||
# CONFIG_MACH_CARMEVA is not set
|
||||
# CONFIG_MACH_CSB337 is not set
|
||||
# CONFIG_MACH_CSB637 is not set
|
||||
# CONFIG_MACH_KAFA is not set
|
||||
# CONFIG_MACH_KB9200 is not set
|
||||
# CONFIG_MACH_ONEARM is not set
|
||||
CONFIG_MACH_VLINK=y
|
||||
# CONFIG_MINIX_FS is not set
|
||||
CONFIG_MINI_FO=y
|
||||
# CONFIG_MODULE_UNLOAD is not set
|
||||
# CONFIG_MSDOS_FS is not set
|
||||
CONFIG_MTD=y
|
||||
# CONFIG_MTD_ABSENT is not set
|
||||
# CONFIG_MTD_AFS_PARTS is not set
|
||||
CONFIG_MTD_AT91_DATAFLASH=y
|
||||
CONFIG_MTD_BLOCK=y
|
||||
# CONFIG_MTD_BLOCK2MTD is not set
|
||||
# CONFIG_MTD_CFI is not set
|
||||
CONFIG_MTD_CFI_I1=y
|
||||
CONFIG_MTD_CFI_I2=y
|
||||
# CONFIG_MTD_CFI_I4 is not set
|
||||
# CONFIG_MTD_CFI_I8 is not set
|
||||
CONFIG_MTD_CHAR=y
|
||||
# CONFIG_MTD_CMDLINE_PARTS is not set
|
||||
# CONFIG_MTD_COMPLEX_MAPPINGS is not set
|
||||
# CONFIG_MTD_CONCAT is not set
|
||||
CONFIG_MTD_DATAFLASH=y
|
||||
# CONFIG_MTD_DEBUG is not set
|
||||
# CONFIG_MTD_DOC2000 is not set
|
||||
# CONFIG_MTD_DOC2001 is not set
|
||||
# CONFIG_MTD_DOC2001PLUS is not set
|
||||
# CONFIG_MTD_JEDECPROBE is not set
|
||||
# CONFIG_MTD_M25P80 is not set
|
||||
CONFIG_MTD_MAP_BANK_WIDTH_1=y
|
||||
# CONFIG_MTD_MAP_BANK_WIDTH_16 is not set
|
||||
CONFIG_MTD_MAP_BANK_WIDTH_2=y
|
||||
# CONFIG_MTD_MAP_BANK_WIDTH_32 is not set
|
||||
CONFIG_MTD_MAP_BANK_WIDTH_4=y
|
||||
# CONFIG_MTD_MAP_BANK_WIDTH_8 is not set
|
||||
# CONFIG_MTD_MTDRAM is not set
|
||||
# CONFIG_MTD_NAND is not set
|
||||
# CONFIG_MTD_OBSOLETE_CHIPS is not set
|
||||
# CONFIG_MTD_ONENAND is not set
|
||||
CONFIG_MTD_PARTITIONS=y
|
||||
# CONFIG_MTD_PHRAM is not set
|
||||
# CONFIG_MTD_PLATRAM is not set
|
||||
# CONFIG_MTD_RAM is not set
|
||||
# CONFIG_MTD_REDBOOT_PARTS is not set
|
||||
# CONFIG_MTD_ROM is not set
|
||||
# CONFIG_MTD_SLRAM is not set
|
||||
# CONFIG_NETFILTER_XT_MATCH_COMMENT is not set
|
||||
# CONFIG_NETFILTER_XT_MATCH_CONNBYTES is not set
|
||||
# CONFIG_NETFILTER_XT_MATCH_CONNMARK is not set
|
||||
# CONFIG_NETFILTER_XT_MATCH_CONNTRACK is not set
|
||||
# CONFIG_NETFILTER_XT_MATCH_DCCP is not set
|
||||
# CONFIG_NETFILTER_XT_MATCH_HELPER is not set
|
||||
CONFIG_NETFILTER_XT_MATCH_LIMIT=m
|
||||
# CONFIG_NETFILTER_XT_MATCH_PHYSDEV is not set
|
||||
# CONFIG_NETFILTER_XT_MATCH_PKTTYPE is not set
|
||||
# CONFIG_NETFILTER_XT_MATCH_REALM is not set
|
||||
# CONFIG_NETFILTER_XT_MATCH_SCTP is not set
|
||||
# CONFIG_NETFILTER_XT_MATCH_STATE is not set
|
||||
# CONFIG_NETFILTER_XT_TARGET_CONNMARK is not set
|
||||
# CONFIG_NETFILTER_XT_TARGET_DSCP is not set
|
||||
# CONFIG_NETFILTER_XT_TARGET_NFQUEUE is not set
|
||||
# CONFIG_NETFILTER_XT_TARGET_NOTRACK is not set
|
||||
# CONFIG_NET_CLS_ACT is not set
|
||||
# CONFIG_NET_CLS_IND is not set
|
||||
# CONFIG_NET_CLS_RSVP6 is not set
|
||||
# CONFIG_NET_EMATCH is not set
|
||||
# CONFIG_NET_IPGRE_BROADCAST is not set
|
||||
# CONFIG_NET_PKTGEN is not set
|
||||
# CONFIG_NET_RADIO is not set
|
||||
# CONFIG_NET_SCH_NETEM is not set
|
||||
# CONFIG_NEW_LEDS is not set
|
||||
# CONFIG_NFSD is not set
|
||||
# CONFIG_NFS_FS is not set
|
||||
# CONFIG_NLS is not set
|
||||
# CONFIG_NO_IDLE_HZ is not set
|
||||
# CONFIG_NTFS_FS is not set
|
||||
# CONFIG_NVRAM is not set
|
||||
# CONFIG_PARTITION_ADVANCED is not set
|
||||
# CONFIG_PCCARD is not set
|
||||
CONFIG_PHYLIB=y
|
||||
# CONFIG_PM is not set
|
||||
# CONFIG_PPP_MULTILINK is not set
|
||||
# CONFIG_PPP_SYNC_TTY is not set
|
||||
# CONFIG_QSEMI_PHY is not set
|
||||
# CONFIG_RCU_TORTURE_TEST is not set
|
||||
# CONFIG_REISERFS_FS is not set
|
||||
# CONFIG_ROMFS_FS is not set
|
||||
CONFIG_RTC_LIB=y
|
||||
# CONFIG_RT_MUTEX_TESTER is not set
|
||||
CONFIG_RWSEM_GENERIC_SPINLOCK=y
|
||||
# CONFIG_SCHEDSTATS is not set
|
||||
# CONFIG_SCSI is not set
|
||||
# CONFIG_SERIAL_8250 is not set
|
||||
CONFIG_SERIAL_ATMEL=y
|
||||
CONFIG_SERIAL_ATMEL_CONSOLE=y
|
||||
# CONFIG_SERIAL_ATMEL_TTYAT is not set
|
||||
CONFIG_SERIO=y
|
||||
# CONFIG_SERIO_LIBPS2 is not set
|
||||
CONFIG_SERIO_RAW=y
|
||||
CONFIG_SERIO_SERPORT=y
|
||||
# CONFIG_SMB_FS is not set
|
||||
# CONFIG_SMC91X is not set
|
||||
# CONFIG_SMSC_PHY is not set
|
||||
# CONFIG_SOUND is not set
|
||||
# CONFIG_SPARSEMEM_STATIC is not set
|
||||
CONFIG_SPI=y
|
||||
CONFIG_SPI_ATMEL=y
|
||||
CONFIG_SPI_BITBANG=y
|
||||
CONFIG_SPI_DEBUG=y
|
||||
CONFIG_SPI_MASTER=y
|
||||
CONFIG_SPLIT_PTLOCK_CPUS=4096
|
||||
# CONFIG_UDF_FS is not set
|
||||
CONFIG_UID16=y
|
||||
# CONFIG_UNUSED_SYMBOLS is not set
|
||||
# CONFIG_USB is not set
|
||||
# CONFIG_USB_ARCH_HAS_EHCI is not set
|
||||
CONFIG_VECTORS_BASE=0xffff0000
|
||||
# CONFIG_VFAT_FS is not set
|
||||
# CONFIG_VGA_CONSOLE is not set
|
||||
CONFIG_VT=y
|
||||
CONFIG_VT_CONSOLE=y
|
||||
# CONFIG_VT_HW_CONSOLE_BINDING is not set
|
||||
# CONFIG_WATCHDOG is not set
|
||||
# CONFIG_XFRM_USER is not set
|
||||
# CONFIG_XFS_FS is not set
|
||||
# CONFIG_XIP_KERNEL is not set
|
||||
CONFIG_ZBOOT_ROM_BSS=0x0
|
||||
CONFIG_ZBOOT_ROM_TEXT=0x0
|
||||
CONFIG_ZLIB_DEFLATE=m
|
36
target/linux/at91-2.6/image/Makefile
Normal file
36
target/linux/at91-2.6/image/Makefile
Normal file
@ -0,0 +1,36 @@
|
||||
#
|
||||
# Copyright (C) 2006 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
|
||||
TARGET_DEVICE_TABLE:=$(TOPDIR)/target/linux/vlink-2.6/image/device_table.txt
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
include $(INCLUDE_DIR)/image.mk
|
||||
|
||||
define Build/Clean
|
||||
endef
|
||||
|
||||
define Image/Prepare
|
||||
cp $(LINUX_DIR)/arch/arm/boot/uImage $(KDIR)/uImage
|
||||
endef
|
||||
|
||||
define Image/BuildKernel
|
||||
cp $(KDIR)/uImage $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-uImage
|
||||
endef
|
||||
|
||||
define Image/Build
|
||||
$(call Image/Build/$(1),$(1))
|
||||
endef
|
||||
|
||||
define Image/Build/jffs2-64k
|
||||
dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img bs=65536 conv=sync
|
||||
endef
|
||||
|
||||
define Image/Build/jffs2-128k
|
||||
dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img bs=131072 conv=sync
|
||||
endef
|
||||
|
||||
$(eval $(call BuildImage))
|
19066
target/linux/at91-2.6/patches/000-at91patches.patch
Normal file
19066
target/linux/at91-2.6/patches/000-at91patches.patch
Normal file
File diff suppressed because it is too large
Load Diff
191
target/linux/at91-2.6/patches/001-vlink-machine.patch
Normal file
191
target/linux/at91-2.6/patches/001-vlink-machine.patch
Normal file
@ -0,0 +1,191 @@
|
||||
diff -Naur linux-2.6.19.1/arch/arm/boot/compressed/head-at91rm9200.S linux/arch/arm/boot/compressed/head-at91rm9200.S
|
||||
--- linux-2.6.19.1/arch/arm/boot/compressed/head-at91rm9200.S 2006-12-11 20:32:53.000000000 +0100
|
||||
+++ linux/arch/arm/boot/compressed/head-at91rm9200.S 2007-01-20 10:26:21.000000000 +0100
|
||||
@@ -61,6 +61,12 @@
|
||||
cmp r7, r3
|
||||
beq 99f
|
||||
|
||||
+ @ FDL Versalink : 1053
|
||||
+ mov r3, #(MACH_TYPE_VLINK & 0xff)
|
||||
+ orr r3, r3, #(MACH_TYPE_VLINK & 0xff00)
|
||||
+ cmp r7, r3
|
||||
+ beq 99f
|
||||
+
|
||||
@ Ajeco 1ARM : 1075
|
||||
mov r3, #(MACH_TYPE_ONEARM & 0xff)
|
||||
orr r3, r3, #(MACH_TYPE_ONEARM & 0xff00)
|
||||
diff -Naur linux-2.6.19.1/arch/arm/mach-at91rm9200/board-vlink.c linux/arch/arm/mach-at91rm9200/board-vlink.c
|
||||
--- linux-2.6.19.1/arch/arm/mach-at91rm9200/board-vlink.c 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ linux/arch/arm/mach-at91rm9200/board-vlink.c 2007-01-19 21:18:00.000000000 +0100
|
||||
@@ -0,0 +1,144 @@
|
||||
+/*
|
||||
+ * linux/arch/arm/mach-at91rm9200/board-ek.c
|
||||
+ *
|
||||
+ * Copyright (C) 2006,2007 Hamish Guthrie
|
||||
+ * Guthrie Consulting.
|
||||
+ *
|
||||
+ * This program is free software; you can redistribute it and/or modify
|
||||
+ * it under the terms of the GNU General Public License as published by
|
||||
+ * the Free Software Foundation; either version 2 of the License, or
|
||||
+ * (at your option) any later version.
|
||||
+ *
|
||||
+ * This program is distributed in the hope that it will be useful,
|
||||
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
||||
+ * GNU General Public License for more details.
|
||||
+ *
|
||||
+ * You should have received a copy of the GNU General Public License
|
||||
+ * along with this program; if not, write to the Free Software
|
||||
+ * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
|
||||
+ */
|
||||
+
|
||||
+#include <linux/types.h>
|
||||
+#include <linux/init.h>
|
||||
+#include <linux/mm.h>
|
||||
+#include <linux/module.h>
|
||||
+#include <linux/platform_device.h>
|
||||
+#include <linux/spi/spi.h>
|
||||
+
|
||||
+#include <asm/hardware.h>
|
||||
+#include <asm/setup.h>
|
||||
+#include <asm/mach-types.h>
|
||||
+#include <asm/irq.h>
|
||||
+
|
||||
+#include <asm/mach/arch.h>
|
||||
+#include <asm/mach/map.h>
|
||||
+#include <asm/mach/irq.h>
|
||||
+
|
||||
+#include <asm/arch/board.h>
|
||||
+#include <asm/arch/gpio.h>
|
||||
+
|
||||
+#include "generic.h"
|
||||
+
|
||||
+
|
||||
+/*
|
||||
+ * Serial port configuration.
|
||||
+ * 0 .. 3 = USART0 .. USART3
|
||||
+ * 4 = DBGU
|
||||
+ */
|
||||
+static struct at91_uart_config __initdata vlink_uart_config = {
|
||||
+ .console_tty = 0, /* ttyS0 */
|
||||
+ .nr_tty = 5,
|
||||
+ .tty_map = { 4, 1, 0, 3, 2 } /* ttyS0, ..., ttyS4 */
|
||||
+};
|
||||
+
|
||||
+static void __init vlink_map_io(void)
|
||||
+{
|
||||
+ /* Initialize processor: 18.432 MHz crystal */
|
||||
+ at91rm9200_initialize(18432000, AT91RM9200_PQFP);
|
||||
+
|
||||
+ /* Setup the LEDs */
|
||||
+// at91_init_leds(AT91_PIN_PB1, AT91_PIN_PB2);
|
||||
+
|
||||
+ /* Setup the serial ports and console */
|
||||
+ at91_init_serial(&vlink_uart_config);
|
||||
+}
|
||||
+
|
||||
+static void __init vlink_init_irq(void)
|
||||
+{
|
||||
+ at91rm9200_init_interrupts(NULL);
|
||||
+}
|
||||
+
|
||||
+static struct eth_platform_data __initdata vlink_eth_data = {
|
||||
+ .phy_irq_pin = AT91_PIN_PC4,
|
||||
+ .is_rmii = 1,
|
||||
+};
|
||||
+
|
||||
+static struct at91_usbh_data __initdata vlink_usbh_data = {
|
||||
+ .ports = 1,
|
||||
+};
|
||||
+
|
||||
+static struct at91_udc_data __initdata vlink_udc_data = {
|
||||
+ .vbus_pin = AT91_PIN_PD4,
|
||||
+ .pullup_pin = AT91_PIN_PD5,
|
||||
+};
|
||||
+
|
||||
+/*static struct at91_mmc_data __initdata ek_mmc_data = {
|
||||
+ .det_pin = AT91_PIN_PB27,
|
||||
+ .is_b = 0,
|
||||
+ .wire4 = 1,
|
||||
+ .wp_pin = AT91_PIN_PA17,
|
||||
+};
|
||||
+*/
|
||||
+
|
||||
+static struct spi_board_info vlink_spi_devices[] = {
|
||||
+ { /* DataFlash chip */
|
||||
+ .modalias = "mtd_dataflash",
|
||||
+ .chip_select = 0,
|
||||
+ .max_speed_hz = 15 * 1000 * 1000,
|
||||
+ },
|
||||
+#ifdef CONFIG_MTD_AT91_DATAFLASH_CARD
|
||||
+ { /* DataFlash card */
|
||||
+ .modalias = "mtd_dataflash",
|
||||
+ .chip_select = 3,
|
||||
+ .max_speed_hz = 15 * 1000 * 1000,
|
||||
+ },
|
||||
+#endif
|
||||
+};
|
||||
+
|
||||
+static void __init vlink_board_init(void)
|
||||
+{
|
||||
+ /* Serial */
|
||||
+ at91_add_device_serial();
|
||||
+ /* Ethernet */
|
||||
+ at91_add_device_eth(&vlink_eth_data);
|
||||
+ /* USB Host */
|
||||
+ at91_add_device_usbh(&vlink_usbh_data);
|
||||
+ /* USB Device */
|
||||
+ at91_add_device_udc(&vlink_udc_data);
|
||||
+ at91_set_multi_drive(vlink_udc_data.pullup_pin, 1); /* pullup_pin is connected to reset */
|
||||
+ /* I2C */
|
||||
+ at91_add_device_i2c();
|
||||
+ /* SPI */
|
||||
+ at91_add_device_spi(vlink_spi_devices, ARRAY_SIZE(vlink_spi_devices));
|
||||
+#ifdef CONFIG_MTD_AT91_DATAFLASH_CARD
|
||||
+ /* DataFlash card */
|
||||
+// at91_set_gpio_output(AT91_PIN_PB22, 0);
|
||||
+#else
|
||||
+ /* MMC */
|
||||
+// at91_set_gpio_output(AT91_PIN_PB22, 1); /* this MMC card slot can optionally use SPI signaling (CS3). */
|
||||
+// at91_add_device_mmc(&vlink_mmc_data);
|
||||
+#endif
|
||||
+ /* VGA */
|
||||
+}
|
||||
+
|
||||
+MACHINE_START(VLINK, "FDL VersaLink")
|
||||
+ /* Maintainer: Guthrie Consulting */
|
||||
+ .phys_io = AT91_BASE_SYS,
|
||||
+ .io_pg_offst = (AT91_VA_BASE_SYS >> 18) & 0xfffc,
|
||||
+ .boot_params = AT91_SDRAM_BASE + 0x100,
|
||||
+ .timer = &at91rm9200_timer,
|
||||
+ .map_io = vlink_map_io,
|
||||
+ .init_irq = vlink_init_irq,
|
||||
+ .init_machine = vlink_board_init,
|
||||
+MACHINE_END
|
||||
diff -Naur linux-2.6.19.1/arch/arm/mach-at91rm9200/Kconfig linux/arch/arm/mach-at91rm9200/Kconfig
|
||||
--- linux-2.6.19.1/arch/arm/mach-at91rm9200/Kconfig 2006-12-11 20:32:53.000000000 +0100
|
||||
+++ linux/arch/arm/mach-at91rm9200/Kconfig 2007-01-19 21:17:49.000000000 +0100
|
||||
@@ -82,6 +82,12 @@
|
||||
help
|
||||
Select this if you are using Sperry-Sun's KAFA board.
|
||||
|
||||
+config MACH_VLINK
|
||||
+ bool "Figment Design Labs VersaLink"
|
||||
+ depends on ARCH_AT91RM9200
|
||||
+ help
|
||||
+ Select this if you are using FDL's VersaLink board
|
||||
+
|
||||
endif
|
||||
|
||||
# ----------------------------------------------------------
|
||||
diff -Naur linux-2.6.19.1/arch/arm/mach-at91rm9200/Makefile linux/arch/arm/mach-at91rm9200/Makefile
|
||||
--- linux-2.6.19.1/arch/arm/mach-at91rm9200/Makefile 2006-12-11 20:32:53.000000000 +0100
|
||||
+++ linux/arch/arm/mach-at91rm9200/Makefile 2007-01-19 21:17:42.000000000 +0100
|
||||
@@ -24,6 +24,7 @@
|
||||
obj-$(CONFIG_MACH_KB9200) += board-kb9202.o
|
||||
obj-$(CONFIG_MACH_ATEB9200) += board-eb9200.o
|
||||
obj-$(CONFIG_MACH_KAFA) += board-kafa.o
|
||||
+obj-$(CONFIG_MACH_VLINK) += board-vlink.o
|
||||
|
||||
# AT91SAM9260 board-specific support
|
||||
|
Loading…
Reference in New Issue
Block a user