Remove patches already included in mainline kernel.
SVN-Revision: 17735
This commit is contained in:
parent
8673372e20
commit
99c3549ea3
@ -1,326 +0,0 @@
|
|||||||
This add watchdog driver for broadcom 47xx device.
|
|
||||||
It uses the ssb subsytem to access embeded watchdog device.
|
|
||||||
|
|
||||||
Because the watchdog timeout is very short (about 2s), a soft timer is used
|
|
||||||
to increase the watchdog period.
|
|
||||||
|
|
||||||
Note : A patch for exporting the ssb_watchdog_timer_set will
|
|
||||||
be submitted on next linux-mips merge. Without this patch it can't
|
|
||||||
be build as a module.
|
|
||||||
|
|
||||||
Signed-off-by: Aleksandar Radovanovic <biblbroks@sezampro.rs>
|
|
||||||
Signed-off-by: Matthieu CASTET <castet.matthieu@free.fr>
|
|
||||||
--- a/drivers/watchdog/Kconfig
|
|
||||||
+++ b/drivers/watchdog/Kconfig
|
|
||||||
@@ -764,6 +764,12 @@ config TXX9_WDT
|
|
||||||
help
|
|
||||||
Hardware driver for the built-in watchdog timer on TXx9 MIPS SoCs.
|
|
||||||
|
|
||||||
+config BCM47XX_WDT
|
|
||||||
+ tristate "Broadcom BCM47xx Watchdog Timer"
|
|
||||||
+ depends on BCM47XX
|
|
||||||
+ help
|
|
||||||
+ Hardware driver for the Broadcom BCM47xx Watchog Timer.
|
|
||||||
+
|
|
||||||
# PARISC Architecture
|
|
||||||
|
|
||||||
# POWERPC Architecture
|
|
||||||
--- a/drivers/watchdog/Makefile
|
|
||||||
+++ b/drivers/watchdog/Makefile
|
|
||||||
@@ -105,6 +105,7 @@ obj-$(CONFIG_WDT_RM9K_GPI) += rm9k_wdt.o
|
|
||||||
obj-$(CONFIG_SIBYTE_WDOG) += sb_wdog.o
|
|
||||||
obj-$(CONFIG_AR7_WDT) += ar7_wdt.o
|
|
||||||
obj-$(CONFIG_TXX9_WDT) += txx9wdt.o
|
|
||||||
+obj-$(CONFIG_BCM47XX_WDT) += bcm47xx_wdt.o
|
|
||||||
|
|
||||||
# PARISC Architecture
|
|
||||||
|
|
||||||
--- /dev/null
|
|
||||||
+++ b/drivers/watchdog/bcm47xx_wdt.c
|
|
||||||
@@ -0,0 +1,286 @@
|
|
||||||
+/*
|
|
||||||
+ * Watchdog driver for Broadcom BCM47XX
|
|
||||||
+ *
|
|
||||||
+ * Copyright (C) 2008 Aleksandar Radovanovic <biblbroks@sezampro.rs>
|
|
||||||
+ * Copyright (C) 2009 Matthieu CASTET <castet.matthieu@free.fr>
|
|
||||||
+ *
|
|
||||||
+ * This program is free software; you can redistribute it and/or
|
|
||||||
+ * modify it under the terms of the GNU General Public License
|
|
||||||
+ * as published by the Free Software Foundation; either version
|
|
||||||
+ * 2 of the License, or (at your option) any later version.
|
|
||||||
+ */
|
|
||||||
+
|
|
||||||
+#include <linux/bitops.h>
|
|
||||||
+#include <linux/errno.h>
|
|
||||||
+#include <linux/fs.h>
|
|
||||||
+#include <linux/init.h>
|
|
||||||
+#include <linux/kernel.h>
|
|
||||||
+#include <linux/miscdevice.h>
|
|
||||||
+#include <linux/module.h>
|
|
||||||
+#include <linux/moduleparam.h>
|
|
||||||
+#include <linux/reboot.h>
|
|
||||||
+#include <linux/types.h>
|
|
||||||
+#include <linux/uaccess.h>
|
|
||||||
+#include <linux/watchdog.h>
|
|
||||||
+#include <linux/timer.h>
|
|
||||||
+#include <linux/jiffies.h>
|
|
||||||
+#include <linux/ssb/ssb_embedded.h>
|
|
||||||
+#include <asm/mach-bcm47xx/bcm47xx.h>
|
|
||||||
+
|
|
||||||
+#define DRV_NAME "bcm47xx_wdt"
|
|
||||||
+
|
|
||||||
+#define WDT_DEFAULT_TIME 30 /* seconds */
|
|
||||||
+#define WDT_MAX_TIME 256 /* seconds */
|
|
||||||
+
|
|
||||||
+static int wdt_time = WDT_DEFAULT_TIME;
|
|
||||||
+static int nowayout = WATCHDOG_NOWAYOUT;
|
|
||||||
+
|
|
||||||
+module_param(wdt_time, int, 0);
|
|
||||||
+MODULE_PARM_DESC(wdt_time, "Watchdog time in seconds. (default="
|
|
||||||
+ __MODULE_STRING(WDT_DEFAULT_TIME) ")");
|
|
||||||
+
|
|
||||||
+#ifdef CONFIG_WATCHDOG_NOWAYOUT
|
|
||||||
+module_param(nowayout, int, 0);
|
|
||||||
+MODULE_PARM_DESC(nowayout,
|
|
||||||
+ "Watchdog cannot be stopped once started (default="
|
|
||||||
+ __MODULE_STRING(WATCHDOG_NOWAYOUT) ")");
|
|
||||||
+#endif
|
|
||||||
+
|
|
||||||
+static unsigned long bcm47xx_wdt_busy;
|
|
||||||
+static char expect_release;
|
|
||||||
+static struct timer_list wdt_timer;
|
|
||||||
+static atomic_t ticks;
|
|
||||||
+
|
|
||||||
+static inline void bcm47xx_wdt_hw_start(void)
|
|
||||||
+{
|
|
||||||
+ /* this is 2,5s on 100Mhz clock and 2s on 133 Mhz */
|
|
||||||
+ ssb_watchdog_timer_set(&ssb_bcm47xx, 0xfffffff);
|
|
||||||
+}
|
|
||||||
+
|
|
||||||
+static inline int bcm47xx_wdt_hw_stop(void)
|
|
||||||
+{
|
|
||||||
+ return ssb_watchdog_timer_set(&ssb_bcm47xx, 0);
|
|
||||||
+}
|
|
||||||
+
|
|
||||||
+static void bcm47xx_timer_tick(unsigned long unused)
|
|
||||||
+{
|
|
||||||
+ if (!atomic_dec_and_test(&ticks)) {
|
|
||||||
+ bcm47xx_wdt_hw_start();
|
|
||||||
+ mod_timer(&wdt_timer, jiffies + HZ);
|
|
||||||
+ } else {
|
|
||||||
+ printk(KERN_CRIT DRV_NAME "Watchdog will fire soon!!!\n");
|
|
||||||
+ }
|
|
||||||
+}
|
|
||||||
+
|
|
||||||
+static inline void bcm47xx_wdt_pet(void)
|
|
||||||
+{
|
|
||||||
+ atomic_set(&ticks, wdt_time);
|
|
||||||
+}
|
|
||||||
+
|
|
||||||
+static void bcm47xx_wdt_start(void)
|
|
||||||
+{
|
|
||||||
+ bcm47xx_wdt_pet();
|
|
||||||
+ bcm47xx_timer_tick(0);
|
|
||||||
+}
|
|
||||||
+
|
|
||||||
+static void bcm47xx_wdt_pause(void)
|
|
||||||
+{
|
|
||||||
+ del_timer_sync(&wdt_timer);
|
|
||||||
+ bcm47xx_wdt_hw_stop();
|
|
||||||
+}
|
|
||||||
+
|
|
||||||
+static void bcm47xx_wdt_stop(void)
|
|
||||||
+{
|
|
||||||
+ bcm47xx_wdt_pause();
|
|
||||||
+}
|
|
||||||
+
|
|
||||||
+static int bcm47xx_wdt_settimeout(int new_time)
|
|
||||||
+{
|
|
||||||
+ if ((new_time <= 0) || (new_time > WDT_MAX_TIME))
|
|
||||||
+ return -EINVAL;
|
|
||||||
+
|
|
||||||
+ wdt_time = new_time;
|
|
||||||
+ return 0;
|
|
||||||
+}
|
|
||||||
+
|
|
||||||
+static int bcm47xx_wdt_open(struct inode *inode, struct file *file)
|
|
||||||
+{
|
|
||||||
+ if (test_and_set_bit(0, &bcm47xx_wdt_busy))
|
|
||||||
+ return -EBUSY;
|
|
||||||
+
|
|
||||||
+ bcm47xx_wdt_start();
|
|
||||||
+ return nonseekable_open(inode, file);
|
|
||||||
+}
|
|
||||||
+
|
|
||||||
+static int bcm47xx_wdt_release(struct inode *inode, struct file *file)
|
|
||||||
+{
|
|
||||||
+ if (expect_release == 42) {
|
|
||||||
+ bcm47xx_wdt_stop();
|
|
||||||
+ } else {
|
|
||||||
+ printk(KERN_CRIT DRV_NAME
|
|
||||||
+ ": Unexpected close, not stopping watchdog!\n");
|
|
||||||
+ bcm47xx_wdt_start();
|
|
||||||
+ }
|
|
||||||
+
|
|
||||||
+ clear_bit(0, &bcm47xx_wdt_busy);
|
|
||||||
+ expect_release = 0;
|
|
||||||
+ return 0;
|
|
||||||
+}
|
|
||||||
+
|
|
||||||
+static ssize_t bcm47xx_wdt_write(struct file *file, const char __user *data,
|
|
||||||
+ size_t len, loff_t *ppos)
|
|
||||||
+{
|
|
||||||
+ if (len) {
|
|
||||||
+ if (!nowayout) {
|
|
||||||
+ size_t i;
|
|
||||||
+
|
|
||||||
+ expect_release = 0;
|
|
||||||
+
|
|
||||||
+ for (i = 0; i != len; i++) {
|
|
||||||
+ char c;
|
|
||||||
+ if (get_user(c, data + i))
|
|
||||||
+ return -EFAULT;
|
|
||||||
+ if (c == 'V')
|
|
||||||
+ expect_release = 42;
|
|
||||||
+ }
|
|
||||||
+ }
|
|
||||||
+ bcm47xx_wdt_pet();
|
|
||||||
+ }
|
|
||||||
+ return len;
|
|
||||||
+}
|
|
||||||
+
|
|
||||||
+static struct watchdog_info bcm47xx_wdt_info = {
|
|
||||||
+ .identity = DRV_NAME,
|
|
||||||
+ .options = WDIOF_SETTIMEOUT |
|
|
||||||
+ WDIOF_KEEPALIVEPING |
|
|
||||||
+ WDIOF_MAGICCLOSE,
|
|
||||||
+};
|
|
||||||
+
|
|
||||||
+static long bcm47xx_wdt_ioctl(struct file *file,
|
|
||||||
+ unsigned int cmd, unsigned long arg)
|
|
||||||
+{
|
|
||||||
+ void __user *argp = (void __user *)arg;
|
|
||||||
+ int __user *p = argp;
|
|
||||||
+ int new_value, retval = -EINVAL;;
|
|
||||||
+
|
|
||||||
+ switch (cmd) {
|
|
||||||
+ case WDIOC_GETSUPPORT:
|
|
||||||
+ return copy_to_user(argp, &bcm47xx_wdt_info,
|
|
||||||
+ sizeof(bcm47xx_wdt_info)) ? -EFAULT : 0;
|
|
||||||
+
|
|
||||||
+ case WDIOC_GETSTATUS:
|
|
||||||
+ case WDIOC_GETBOOTSTATUS:
|
|
||||||
+ return put_user(0, p);
|
|
||||||
+
|
|
||||||
+ case WDIOC_SETOPTIONS:
|
|
||||||
+ if (get_user(new_value, p))
|
|
||||||
+ return -EFAULT;
|
|
||||||
+
|
|
||||||
+ if (new_value & WDIOS_DISABLECARD) {
|
|
||||||
+ bcm47xx_wdt_stop();
|
|
||||||
+ retval = 0;
|
|
||||||
+ }
|
|
||||||
+
|
|
||||||
+ if (new_value & WDIOS_ENABLECARD) {
|
|
||||||
+ bcm47xx_wdt_start();
|
|
||||||
+ retval = 0;
|
|
||||||
+ }
|
|
||||||
+
|
|
||||||
+ return retval;
|
|
||||||
+
|
|
||||||
+ case WDIOC_KEEPALIVE:
|
|
||||||
+ bcm47xx_wdt_pet();
|
|
||||||
+ return 0;
|
|
||||||
+
|
|
||||||
+ case WDIOC_SETTIMEOUT:
|
|
||||||
+ if (get_user(new_value, p))
|
|
||||||
+ return -EFAULT;
|
|
||||||
+
|
|
||||||
+ if (bcm47xx_wdt_settimeout(new_value))
|
|
||||||
+ return -EINVAL;
|
|
||||||
+
|
|
||||||
+ bcm47xx_wdt_pet();
|
|
||||||
+
|
|
||||||
+ case WDIOC_GETTIMEOUT:
|
|
||||||
+ return put_user(wdt_time, p);
|
|
||||||
+
|
|
||||||
+ default:
|
|
||||||
+ return -ENOTTY;
|
|
||||||
+ }
|
|
||||||
+}
|
|
||||||
+
|
|
||||||
+static int bcm47xx_wdt_notify_sys(struct notifier_block *this,
|
|
||||||
+ unsigned long code, void *unused)
|
|
||||||
+{
|
|
||||||
+ if (code == SYS_DOWN || code == SYS_HALT)
|
|
||||||
+ bcm47xx_wdt_stop();
|
|
||||||
+ return NOTIFY_DONE;
|
|
||||||
+}
|
|
||||||
+
|
|
||||||
+static const struct file_operations bcm47xx_wdt_fops = {
|
|
||||||
+ .owner = THIS_MODULE,
|
|
||||||
+ .llseek = no_llseek,
|
|
||||||
+ .unlocked_ioctl = bcm47xx_wdt_ioctl,
|
|
||||||
+ .open = bcm47xx_wdt_open,
|
|
||||||
+ .release = bcm47xx_wdt_release,
|
|
||||||
+ .write = bcm47xx_wdt_write,
|
|
||||||
+};
|
|
||||||
+
|
|
||||||
+static struct miscdevice bcm47xx_wdt_miscdev = {
|
|
||||||
+ .minor = WATCHDOG_MINOR,
|
|
||||||
+ .name = "watchdog",
|
|
||||||
+ .fops = &bcm47xx_wdt_fops,
|
|
||||||
+};
|
|
||||||
+
|
|
||||||
+static struct notifier_block bcm47xx_wdt_notifier = {
|
|
||||||
+ .notifier_call = bcm47xx_wdt_notify_sys,
|
|
||||||
+};
|
|
||||||
+
|
|
||||||
+static int __init bcm47xx_wdt_init(void)
|
|
||||||
+{
|
|
||||||
+ int ret;
|
|
||||||
+
|
|
||||||
+ if (bcm47xx_wdt_hw_stop() < 0)
|
|
||||||
+ return -ENODEV;
|
|
||||||
+
|
|
||||||
+ setup_timer(&wdt_timer, bcm47xx_timer_tick, 0L);
|
|
||||||
+
|
|
||||||
+ if (bcm47xx_wdt_settimeout(wdt_time)) {
|
|
||||||
+ bcm47xx_wdt_settimeout(WDT_DEFAULT_TIME);
|
|
||||||
+ printk(KERN_INFO DRV_NAME
|
|
||||||
+ ": wdt_time value must be 1 <= wdt_time <= 256, using %d\n",
|
|
||||||
+ wdt_time);
|
|
||||||
+ }
|
|
||||||
+
|
|
||||||
+ ret = register_reboot_notifier(&bcm47xx_wdt_notifier);
|
|
||||||
+ if (ret)
|
|
||||||
+ return ret;
|
|
||||||
+
|
|
||||||
+ ret = misc_register(&bcm47xx_wdt_miscdev);
|
|
||||||
+ if (ret) {
|
|
||||||
+ unregister_reboot_notifier(&bcm47xx_wdt_notifier);
|
|
||||||
+ return ret;
|
|
||||||
+ }
|
|
||||||
+
|
|
||||||
+ printk(KERN_INFO "BCM47xx Watchdog Timer enabled (%d seconds%s)\n",
|
|
||||||
+ wdt_time, nowayout ? ", nowayout" : "");
|
|
||||||
+ return 0;
|
|
||||||
+}
|
|
||||||
+
|
|
||||||
+static void __exit bcm47xx_wdt_exit(void)
|
|
||||||
+{
|
|
||||||
+ if (!nowayout)
|
|
||||||
+ bcm47xx_wdt_stop();
|
|
||||||
+
|
|
||||||
+ misc_deregister(&bcm47xx_wdt_miscdev);
|
|
||||||
+
|
|
||||||
+ unregister_reboot_notifier(&bcm47xx_wdt_notifier);
|
|
||||||
+}
|
|
||||||
+
|
|
||||||
+module_init(bcm47xx_wdt_init);
|
|
||||||
+module_exit(bcm47xx_wdt_exit);
|
|
||||||
+
|
|
||||||
+MODULE_AUTHOR("Aleksandar Radovanovic");
|
|
||||||
+MODULE_DESCRIPTION("Watchdog driver for Broadcom BCM47xx");
|
|
||||||
+MODULE_LICENSE("GPL");
|
|
||||||
+MODULE_ALIAS_MISCDEV(WATCHDOG_MINOR);
|
|
@ -1,183 +0,0 @@
|
|||||||
the current ssb irq setup (in ssb_mipscore_init) have some problem :
|
|
||||||
it configure some device on some irq without checking that the irq is not taken by an other device.
|
|
||||||
|
|
||||||
For example in my case PCI host is on irq 0 and IPSEC on irq 3.
|
|
||||||
The current code :
|
|
||||||
- store in dev->irq that IPSEC irq is 3+2
|
|
||||||
- do a set_irq 0->3 on PCI host
|
|
||||||
|
|
||||||
But now IPSEC irq is not routed anymore to the mips code and dev->irq is wrong. This cause problem described in [1].
|
|
||||||
|
|
||||||
This patch try to solve the problem by making set_irq configure the device we want to take the irq on the shared irq0.
|
|
||||||
The previous example become :
|
|
||||||
- store in dev->irq that IPSEC irq is 3+2
|
|
||||||
- do a set_irq 0->3 on PCI host :
|
|
||||||
- irq 3 is already taken by IPSEC. do a set_irq 3->0 on IPSEC
|
|
||||||
|
|
||||||
|
|
||||||
I also added some code to print the irq configuration before and after irq setup to allow easier debugging. And I add extra checking in ssb_mips_irq to report device without irq or device with not routed irq.
|
|
||||||
|
|
||||||
|
|
||||||
[1] http://www.danm.de/files/src/bcm5365p/REPORTED_DEVICES
|
|
||||||
|
|
||||||
Signed-off-by: Matthieu CASTET <castet.matthieu@free.fr>
|
|
||||||
--- a/drivers/ssb/driver_mipscore.c
|
|
||||||
+++ b/drivers/ssb/driver_mipscore.c
|
|
||||||
@@ -49,29 +49,54 @@ static const u32 ipsflag_irq_shift[] = {
|
|
||||||
|
|
||||||
static inline u32 ssb_irqflag(struct ssb_device *dev)
|
|
||||||
{
|
|
||||||
- return ssb_read32(dev, SSB_TPSFLAG) & SSB_TPSFLAG_BPFLAG;
|
|
||||||
+ u32 tpsflag = ssb_read32(dev, SSB_TPSFLAG);
|
|
||||||
+ if (tpsflag)
|
|
||||||
+ return ssb_read32(dev, SSB_TPSFLAG) & SSB_TPSFLAG_BPFLAG;
|
|
||||||
+ else
|
|
||||||
+ /* not irq supported */
|
|
||||||
+ return 0x3f;
|
|
||||||
+}
|
|
||||||
+
|
|
||||||
+static struct ssb_device *find_device(struct ssb_device *rdev, int irqflag)
|
|
||||||
+{
|
|
||||||
+ struct ssb_bus *bus = rdev->bus;
|
|
||||||
+ int i;
|
|
||||||
+ for (i = 0; i < bus->nr_devices; i++) {
|
|
||||||
+ struct ssb_device *dev;
|
|
||||||
+ dev = &(bus->devices[i]);
|
|
||||||
+ if (ssb_irqflag(dev) == irqflag)
|
|
||||||
+ return dev;
|
|
||||||
+ }
|
|
||||||
+ return NULL;
|
|
||||||
}
|
|
||||||
|
|
||||||
/* Get the MIPS IRQ assignment for a specified device.
|
|
||||||
* If unassigned, 0 is returned.
|
|
||||||
+ * If disabled, 5 is returned.
|
|
||||||
+ * If not supported, 6 is returned.
|
|
||||||
*/
|
|
||||||
unsigned int ssb_mips_irq(struct ssb_device *dev)
|
|
||||||
{
|
|
||||||
struct ssb_bus *bus = dev->bus;
|
|
||||||
+ struct ssb_device *mdev = bus->mipscore.dev;
|
|
||||||
u32 irqflag;
|
|
||||||
u32 ipsflag;
|
|
||||||
u32 tmp;
|
|
||||||
unsigned int irq;
|
|
||||||
|
|
||||||
irqflag = ssb_irqflag(dev);
|
|
||||||
+ if (irqflag == 0x3f)
|
|
||||||
+ return 6;
|
|
||||||
ipsflag = ssb_read32(bus->mipscore.dev, SSB_IPSFLAG);
|
|
||||||
for (irq = 1; irq <= 4; irq++) {
|
|
||||||
tmp = ((ipsflag & ipsflag_irq_mask[irq]) >> ipsflag_irq_shift[irq]);
|
|
||||||
if (tmp == irqflag)
|
|
||||||
break;
|
|
||||||
}
|
|
||||||
- if (irq == 5)
|
|
||||||
- irq = 0;
|
|
||||||
+ if (irq == 5) {
|
|
||||||
+ if ((1 << irqflag) & ssb_read32(mdev, SSB_INTVEC))
|
|
||||||
+ irq = 0;
|
|
||||||
+ }
|
|
||||||
|
|
||||||
return irq;
|
|
||||||
}
|
|
||||||
@@ -97,25 +122,56 @@ static void set_irq(struct ssb_device *d
|
|
||||||
struct ssb_device *mdev = bus->mipscore.dev;
|
|
||||||
u32 irqflag = ssb_irqflag(dev);
|
|
||||||
|
|
||||||
+ BUG_ON(oldirq == 6);
|
|
||||||
+
|
|
||||||
dev->irq = irq + 2;
|
|
||||||
|
|
||||||
- ssb_dprintk(KERN_INFO PFX
|
|
||||||
- "set_irq: core 0x%04x, irq %d => %d\n",
|
|
||||||
- dev->id.coreid, oldirq, irq);
|
|
||||||
/* clear the old irq */
|
|
||||||
if (oldirq == 0)
|
|
||||||
ssb_write32(mdev, SSB_INTVEC, (~(1 << irqflag) & ssb_read32(mdev, SSB_INTVEC)));
|
|
||||||
- else
|
|
||||||
+ else if (oldirq != 5)
|
|
||||||
clear_irq(bus, oldirq);
|
|
||||||
|
|
||||||
/* assign the new one */
|
|
||||||
if (irq == 0) {
|
|
||||||
ssb_write32(mdev, SSB_INTVEC, ((1 << irqflag) | ssb_read32(mdev, SSB_INTVEC)));
|
|
||||||
} else {
|
|
||||||
+ u32 ipsflag = ssb_read32(mdev, SSB_IPSFLAG);
|
|
||||||
+ if ((ipsflag & ipsflag_irq_mask[irq]) != ipsflag_irq_mask[irq]) {
|
|
||||||
+ u32 oldipsflag = (ipsflag & ipsflag_irq_mask[irq]) >> ipsflag_irq_shift[irq];
|
|
||||||
+ struct ssb_device *olddev = find_device(dev, oldipsflag);
|
|
||||||
+ if (olddev)
|
|
||||||
+ set_irq(olddev, 0);
|
|
||||||
+ }
|
|
||||||
irqflag <<= ipsflag_irq_shift[irq];
|
|
||||||
- irqflag |= (ssb_read32(mdev, SSB_IPSFLAG) & ~ipsflag_irq_mask[irq]);
|
|
||||||
+ irqflag |= (ipsflag & ~ipsflag_irq_mask[irq]);
|
|
||||||
ssb_write32(mdev, SSB_IPSFLAG, irqflag);
|
|
||||||
}
|
|
||||||
+ ssb_dprintk(KERN_INFO PFX
|
|
||||||
+ "set_irq: core 0x%04x, irq %d => %d\n",
|
|
||||||
+ dev->id.coreid, oldirq+2, irq+2);
|
|
||||||
+}
|
|
||||||
+
|
|
||||||
+static void print_irq(struct ssb_device *dev, unsigned int irq)
|
|
||||||
+{
|
|
||||||
+ int i;
|
|
||||||
+ static const char *irq_name[] = {"2(S)", "3", "4", "5", "6", "D", "I"};
|
|
||||||
+ ssb_dprintk(KERN_INFO PFX
|
|
||||||
+ "core 0x%04x, irq :", dev->id.coreid);
|
|
||||||
+ for (i = 0; i <= 6; i++) {
|
|
||||||
+ ssb_dprintk(" %s%s", irq_name[i], i==irq?"*":" ");
|
|
||||||
+ }
|
|
||||||
+ ssb_dprintk("\n");
|
|
||||||
+}
|
|
||||||
+
|
|
||||||
+static void dump_irq(struct ssb_bus *bus)
|
|
||||||
+{
|
|
||||||
+ int i;
|
|
||||||
+ for (i = 0; i < bus->nr_devices; i++) {
|
|
||||||
+ struct ssb_device *dev;
|
|
||||||
+ dev = &(bus->devices[i]);
|
|
||||||
+ print_irq(dev, ssb_mips_irq(dev));
|
|
||||||
+ }
|
|
||||||
}
|
|
||||||
|
|
||||||
static void ssb_mips_serial_init(struct ssb_mipscore *mcore)
|
|
||||||
@@ -197,18 +253,26 @@ void ssb_mipscore_init(struct ssb_mipsco
|
|
||||||
else if (bus->chipco.dev)
|
|
||||||
ssb_chipco_timing_init(&bus->chipco, ns);
|
|
||||||
|
|
||||||
+ dump_irq(bus);
|
|
||||||
/* Assign IRQs to all cores on the bus, start with irq line 2, because serial usually takes 1 */
|
|
||||||
for (irq = 2, i = 0; i < bus->nr_devices; i++) {
|
|
||||||
+ int mips_irq;
|
|
||||||
dev = &(bus->devices[i]);
|
|
||||||
- dev->irq = ssb_mips_irq(dev) + 2;
|
|
||||||
+ mips_irq = ssb_mips_irq(dev);
|
|
||||||
+ if (mips_irq > 4)
|
|
||||||
+ dev->irq = 0;
|
|
||||||
+ else
|
|
||||||
+ dev->irq = mips_irq + 2;
|
|
||||||
+ if (dev->irq > 5)
|
|
||||||
+ continue;
|
|
||||||
switch (dev->id.coreid) {
|
|
||||||
case SSB_DEV_USB11_HOST:
|
|
||||||
/* shouldn't need a separate irq line for non-4710, most of them have a proper
|
|
||||||
* external usb controller on the pci */
|
|
||||||
if ((bus->chip_id == 0x4710) && (irq <= 4)) {
|
|
||||||
set_irq(dev, irq++);
|
|
||||||
- break;
|
|
||||||
}
|
|
||||||
+ break;
|
|
||||||
/* fallthrough */
|
|
||||||
case SSB_DEV_PCI:
|
|
||||||
case SSB_DEV_ETHERNET:
|
|
||||||
@@ -222,6 +286,8 @@ void ssb_mipscore_init(struct ssb_mipsco
|
|
||||||
}
|
|
||||||
}
|
|
||||||
}
|
|
||||||
+ ssb_dprintk(KERN_INFO PFX "after irq reconfiguration\n");
|
|
||||||
+ dump_irq(bus);
|
|
||||||
|
|
||||||
ssb_mips_serial_init(mcore);
|
|
||||||
ssb_mips_flash_detect(mcore);
|
|
Loading…
Reference in New Issue
Block a user