* adds mkelfimage
SVN-Revision: 26918
This commit is contained in:
parent
c6a93676de
commit
9abcc01305
@ -19,7 +19,7 @@ tools-y += sstrip ipkg-utils genext2fs e2fsprogs mtd-utils mkimage
|
||||
tools-y += firmware-utils patch-cmdline quilt yaffs2 flock
|
||||
tools-y += mm-macros xorg-macros xfce-macros missing-macros xz cmake
|
||||
tools-$(CONFIG_TARGET_orion_generic) += wrt350nv2-builder upslug2
|
||||
tools-$(CONFIG_TARGET_x86) += qemu
|
||||
tools-$(CONFIG_TARGET_x86) += qemu mkelfimage
|
||||
ifneq ($(CONFIG_TARGET_ar71xx),)
|
||||
tools-y += lzma-old squashfs
|
||||
endif
|
||||
|
23
tools/mkelfimage/Makefile
Normal file
23
tools/mkelfimage/Makefile
Normal file
@ -0,0 +1,23 @@
|
||||
#
|
||||
# Copyright (C) 2006 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=mkelfimage
|
||||
PKG_VERSION:=2.7
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
|
||||
PKG_SOURCE_URL:=http://ftp.debian.org/debian/pool/main/m/mkelfimage/
|
||||
PKG_MD5SUM:=e505cb87e9c0cdc44cf03d2c4ea8c74b
|
||||
|
||||
include $(INCLUDE_DIR)/host-build.mk
|
||||
|
||||
define Host/Install
|
||||
$(INSTALL_DIR) $(STAGING_DIR_HOST)/bin
|
||||
$(INSTALL_BIN) $(HOST_BUILD_DIR)/objdir/sbin/mkelfImage $(STAGING_DIR_HOST)/bin
|
||||
endef
|
||||
|
||||
$(eval $(call HostBuild))
|
11
tools/mkelfimage/patches/no-stack-protector.patch
Normal file
11
tools/mkelfimage/patches/no-stack-protector.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- mkelfimage-2.7.old//Makefile 2006-03-28 02:44:59.000000000 +0300
|
||||
+++ mkelfimage-2.7/Makefile 2011-01-17 14:15:13.000000000 +0200
|
||||
@@ -14,7 +14,7 @@
|
||||
pkglibdir = $(libdir)/$(PACKAGE)
|
||||
pkgincludedir = $(includedir)/$(PACKAGE)
|
||||
|
||||
-CPPFLAGS=-DVERSION='"$(VERSION)"' -DRELEASE_DATE='"$(RELEASE_DATE)"' -I include
|
||||
+CPPFLAGS=-DVERSION='"$(VERSION)"' -DRELEASE_DATE='"$(RELEASE_DATE)"' -I include -fno-stack-protector
|
||||
HOST_CPPFLAGS=$(CPPFLAGS)
|
||||
I386_CPPFLAGS=$(CPPFLAGS) -I arch/i386/include
|
||||
IA64_CPPFLAGS=$(CPPFLAGS) -I arch/ia64/include
|
Loading…
Reference in New Issue
Block a user