ar71xx: add GL-AR300 support V3
This is the patch for GL-AR300 V3, tested against the latest trunk. Signed-off-by: alzhao<alzhao@gmail.com> SVN-Revision: 47621
This commit is contained in:
parent
72093bd528
commit
a04c3e73a3
@ -221,6 +221,10 @@ gl-ar150)
|
|||||||
ucidef_set_led_wlan "wlan" "WLAN" "gl_ar150:wlan" "phy0tpt"
|
ucidef_set_led_wlan "wlan" "WLAN" "gl_ar150:wlan" "phy0tpt"
|
||||||
;;
|
;;
|
||||||
|
|
||||||
|
gl-ar300)
|
||||||
|
ucidef_set_led_wlan "wlan" "WLAN" "gl_ar300:wlan" "phy0tpt"
|
||||||
|
;;
|
||||||
|
|
||||||
gl-inet)
|
gl-inet)
|
||||||
ucidef_set_led_netdev "lan" "LAN" "gl-connect:green:lan" "eth1"
|
ucidef_set_led_netdev "lan" "LAN" "gl-connect:green:lan" "eth1"
|
||||||
ucidef_set_led_wlan "wlan" "WLAN" "gl-connect:red:wlan" "phy0tpt"
|
ucidef_set_led_wlan "wlan" "WLAN" "gl-connect:red:wlan" "phy0tpt"
|
||||||
|
@ -408,6 +408,12 @@ wpe72)
|
|||||||
ucidef_set_interfaces_lan_wan "eth1" "eth0"
|
ucidef_set_interfaces_lan_wan "eth1" "eth0"
|
||||||
;;
|
;;
|
||||||
|
|
||||||
|
gl-ar300)
|
||||||
|
ucidef_set_interfaces_lan_wan "eth1" "eth0"
|
||||||
|
ucidef_add_switch "switch0" "1" "1"
|
||||||
|
ucidef_add_switch_vlan "switch0" "1" "0 1 2 3 4"
|
||||||
|
;;
|
||||||
|
|
||||||
wpj344)
|
wpj344)
|
||||||
ucidef_set_interfaces_lan_wan "eth0.1" "eth0.2"
|
ucidef_set_interfaces_lan_wan "eth0.1" "eth0.2"
|
||||||
ucidef_add_switch "switch0" "1" "1"
|
ucidef_add_switch "switch0" "1" "1"
|
||||||
|
@ -485,6 +485,9 @@ ar71xx_board_detect() {
|
|||||||
*"GL AR150")
|
*"GL AR150")
|
||||||
name="gl-ar150"
|
name="gl-ar150"
|
||||||
;;
|
;;
|
||||||
|
*"GL AR300")
|
||||||
|
name="gl-ar300"
|
||||||
|
;;
|
||||||
*"EnGenius EPG5000")
|
*"EnGenius EPG5000")
|
||||||
name="epg5000"
|
name="epg5000"
|
||||||
;;
|
;;
|
||||||
|
@ -221,6 +221,7 @@ platform_check_image() {
|
|||||||
ew-dorin | \
|
ew-dorin | \
|
||||||
ew-dorin-router | \
|
ew-dorin-router | \
|
||||||
gl-ar150 | \
|
gl-ar150 | \
|
||||||
|
gl-ar300 | \
|
||||||
hiwifi-hc6361 | \
|
hiwifi-hc6361 | \
|
||||||
hornet-ub-x2 | \
|
hornet-ub-x2 | \
|
||||||
mzk-w04nu | \
|
mzk-w04nu | \
|
||||||
|
@ -77,6 +77,7 @@ CONFIG_ATH79_MACH_ESR900=y
|
|||||||
CONFIG_ATH79_MACH_EW_DORIN=y
|
CONFIG_ATH79_MACH_EW_DORIN=y
|
||||||
CONFIG_ATH79_MACH_F9K1115V2=y
|
CONFIG_ATH79_MACH_F9K1115V2=y
|
||||||
CONFIG_ATH79_MACH_GL_AR150=y
|
CONFIG_ATH79_MACH_GL_AR150=y
|
||||||
|
CONFIG_ATH79_MACH_GL_AR300=y
|
||||||
CONFIG_ATH79_MACH_GL_INET=y
|
CONFIG_ATH79_MACH_GL_INET=y
|
||||||
CONFIG_ATH79_MACH_GS_MINIBOX_V1=y
|
CONFIG_ATH79_MACH_GS_MINIBOX_V1=y
|
||||||
CONFIG_ATH79_MACH_GS_OOLITE=y
|
CONFIG_ATH79_MACH_GS_OOLITE=y
|
||||||
|
103
target/linux/ar71xx/files/arch/mips/ath79/mach-gl-ar300.c
Normal file
103
target/linux/ar71xx/files/arch/mips/ath79/mach-gl-ar300.c
Normal file
@ -0,0 +1,103 @@
|
|||||||
|
/*
|
||||||
|
* Domino board support
|
||||||
|
*
|
||||||
|
* Copyright (C) 2011 dongyuqi <729650915@qq.com>
|
||||||
|
* Copyright (C) 2011-2012 Gabor Juhos <juhosg@openwrt.org>
|
||||||
|
* Copyright (C) 2013 alzhao <alzhao@gmail.com>
|
||||||
|
* Copyright (C) 2014 Michel Stempin <michel.stempin@wanadoo.fr>
|
||||||
|
*
|
||||||
|
* This program is free software; you can redistribute it and/or modify it
|
||||||
|
* under the terms of the GNU General Public License version 2 as published
|
||||||
|
* by the Free Software Foundation.
|
||||||
|
*/
|
||||||
|
|
||||||
|
#include <linux/gpio.h>
|
||||||
|
#include <linux/platform_device.h>
|
||||||
|
#include <linux/ath9k_platform.h>
|
||||||
|
#include <asm/mach-ath79/ar71xx_regs.h>
|
||||||
|
#include <asm/mach-ath79/ath79.h>
|
||||||
|
|
||||||
|
#include "common.h"
|
||||||
|
#include "dev-eth.h"
|
||||||
|
#include "dev-gpio-buttons.h"
|
||||||
|
#include "dev-leds-gpio.h"
|
||||||
|
#include "dev-m25p80.h"
|
||||||
|
#include "dev-usb.h"
|
||||||
|
#include "dev-wmac.h"
|
||||||
|
#include "machtypes.h"
|
||||||
|
|
||||||
|
#define GL_AR300_GPIO_LED_WLAN 13
|
||||||
|
#define GL_AR300_GPIO_LED_WAN 14
|
||||||
|
#define GL_AR300_GPIO_BTN_RESET 16
|
||||||
|
|
||||||
|
|
||||||
|
#define GL_AR300_KEYS_POLL_INTERVAL 20 /* msecs */
|
||||||
|
#define GL_AR300_KEYS_DEBOUNCE_INTERVAL (3 * GL_AR300_KEYS_POLL_INTERVAL)
|
||||||
|
|
||||||
|
#define GL_AR300_MAC0_OFFSET 0x0000
|
||||||
|
#define GL_AR300_MAC1_OFFSET 0x0000
|
||||||
|
#define GL_AR300_CALDATA_OFFSET 0x1000
|
||||||
|
#define GL_AR300_WMAC_MAC_OFFSET 0x0000
|
||||||
|
|
||||||
|
static struct gpio_led gl_ar300_leds_gpio[] __initdata = {
|
||||||
|
{
|
||||||
|
.name = "gl_ar300:wlan",
|
||||||
|
.gpio = GL_AR300_GPIO_LED_WLAN,
|
||||||
|
.active_low = 1,
|
||||||
|
},
|
||||||
|
{
|
||||||
|
.name = "gl_ar300:wan",
|
||||||
|
.gpio = GL_AR300_GPIO_LED_WAN,
|
||||||
|
.active_low = 1,
|
||||||
|
},
|
||||||
|
};
|
||||||
|
|
||||||
|
static struct gpio_keys_button gl_ar300_gpio_keys[] __initdata = {
|
||||||
|
{
|
||||||
|
.desc = "reset",
|
||||||
|
.type = EV_KEY,
|
||||||
|
.code = KEY_RESTART,
|
||||||
|
.debounce_interval = GL_AR300_KEYS_DEBOUNCE_INTERVAL,
|
||||||
|
.gpio = GL_AR300_GPIO_BTN_RESET,
|
||||||
|
.active_low = 1,
|
||||||
|
},
|
||||||
|
};
|
||||||
|
|
||||||
|
static void __init gl_ar300_setup(void)
|
||||||
|
{
|
||||||
|
|
||||||
|
/* ART base address */
|
||||||
|
u8 *art = (u8 *) KSEG1ADDR(0x1fff0000);
|
||||||
|
|
||||||
|
/* register flash. */
|
||||||
|
ath79_register_m25p80(NULL);
|
||||||
|
|
||||||
|
/* register gpio LEDs and keys */
|
||||||
|
ath79_register_leds_gpio(-1, ARRAY_SIZE(gl_ar300_leds_gpio),
|
||||||
|
gl_ar300_leds_gpio);
|
||||||
|
ath79_register_gpio_keys_polled(-1, GL_AR300_KEYS_POLL_INTERVAL,
|
||||||
|
ARRAY_SIZE(gl_ar300_gpio_keys),
|
||||||
|
gl_ar300_gpio_keys);
|
||||||
|
|
||||||
|
/* enable usb */
|
||||||
|
ath79_register_usb();
|
||||||
|
ath79_register_mdio(1, 0x0);
|
||||||
|
|
||||||
|
/* register eth0 as WAN, eth1 as LAN */
|
||||||
|
ath79_init_mac(ath79_eth0_data.mac_addr, art+GL_AR300_MAC0_OFFSET, 0);
|
||||||
|
ath79_switch_data.phy4_mii_en = 1;
|
||||||
|
ath79_switch_data.phy_poll_mask = BIT(4);
|
||||||
|
ath79_eth0_data.phy_if_mode = PHY_INTERFACE_MODE_MII;
|
||||||
|
ath79_eth0_data.phy_mask = BIT(4);
|
||||||
|
ath79_eth0_data.mii_bus_dev = &ath79_mdio1_device.dev;
|
||||||
|
ath79_register_eth(0);
|
||||||
|
|
||||||
|
ath79_init_mac(ath79_eth1_data.mac_addr, art+GL_AR300_MAC1_OFFSET, 0);
|
||||||
|
ath79_eth1_data.phy_if_mode = PHY_INTERFACE_MODE_GMII;
|
||||||
|
ath79_register_eth(1);
|
||||||
|
|
||||||
|
/* register wireless mac with cal data */
|
||||||
|
ath79_register_wmac(art + GL_AR300_CALDATA_OFFSET, art + GL_AR300_WMAC_MAC_OFFSET);
|
||||||
|
}
|
||||||
|
|
||||||
|
MIPS_MACHINE(ATH79_MACH_GL_AR300, "GL-AR300", "GL AR300",gl_ar300_setup);
|
@ -25,3 +25,14 @@ define Profile/GL-AR150/Description
|
|||||||
endef
|
endef
|
||||||
|
|
||||||
$(eval $(call Profile,GL-AR150))
|
$(eval $(call Profile,GL-AR150))
|
||||||
|
|
||||||
|
define Profile/GL-AR300
|
||||||
|
NAME:=GL AR300
|
||||||
|
PACKAGES:=kmod-usb-core kmod-usb2
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Profile/GL-AR300/Description
|
||||||
|
Configuration of GL AR300.
|
||||||
|
endef
|
||||||
|
|
||||||
|
$(eval $(call Profile,GL-AR300))
|
||||||
|
@ -196,6 +196,15 @@ define Device/gl-ar150
|
|||||||
endef
|
endef
|
||||||
TARGET_DEVICES += gl-ar150
|
TARGET_DEVICES += gl-ar150
|
||||||
|
|
||||||
|
define Device/gl-ar300
|
||||||
|
BOARDNAME = GL-AR300
|
||||||
|
IMAGE_SIZE = 16000k
|
||||||
|
CONSOLE = ttyS0,115200
|
||||||
|
MTDPARTS = spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,16000k(firmware),64k(art)ro
|
||||||
|
endef
|
||||||
|
TARGET_DEVICES += gl-ar300
|
||||||
|
|
||||||
|
|
||||||
define Device/wndr3700
|
define Device/wndr3700
|
||||||
BOARDNAME = WNDR3700
|
BOARDNAME = WNDR3700
|
||||||
NETGEAR_KERNEL_MAGIC = 0x33373030
|
NETGEAR_KERNEL_MAGIC = 0x33373030
|
||||||
|
@ -0,0 +1,39 @@
|
|||||||
|
--- a/arch/mips/ath79/Kconfig
|
||||||
|
+++ b/arch/mips/ath79/Kconfig
|
||||||
|
@@ -587,6 +587,16 @@ config ATH79_MACH_GL_AR150
|
||||||
|
select ATH79_DEV_USB
|
||||||
|
select ATH79_DEV_WMAC
|
||||||
|
|
||||||
|
+config ATH79_MACH_GL_AR300
|
||||||
|
+ bool "GL_AR300 support"
|
||||||
|
+ select SOC_AR934X
|
||||||
|
+ select ATH79_DEV_ETH
|
||||||
|
+ select ATH79_DEV_GPIO_BUTTONS
|
||||||
|
+ select ATH79_DEV_LEDS_GPIO
|
||||||
|
+ select ATH79_DEV_M25P80
|
||||||
|
+ select ATH79_DEV_USB
|
||||||
|
+ select ATH79_DEV_WMAC
|
||||||
|
+
|
||||||
|
config ATH79_MACH_GL_INET
|
||||||
|
bool "GL-INET support"
|
||||||
|
select SOC_AR933X
|
||||||
|
--- a/arch/mips/ath79/Makefile
|
||||||
|
+++ b/arch/mips/ath79/Makefile
|
||||||
|
@@ -84,6 +84,7 @@ obj-$(CONFIG_ATH79_MACH_EPG5000) += mach
|
||||||
|
obj-$(CONFIG_ATH79_MACH_ESR1750) += mach-esr1750.o
|
||||||
|
obj-$(CONFIG_ATH79_MACH_F9K1115V2) += mach-f9k1115v2.o
|
||||||
|
obj-$(CONFIG_ATH79_MACH_GL_AR150) += mach-gl-ar150.o
|
||||||
|
+obj-$(CONFIG_ATH79_MACH_GL_AR300) += mach-gl-ar300.o
|
||||||
|
obj-$(CONFIG_ATH79_MACH_GL_INET) += mach-gl-inet.o
|
||||||
|
obj-$(CONFIG_ATH79_MACH_GS_MINIBOX_V1) += mach-gs-minibox-v1.o
|
||||||
|
obj-$(CONFIG_ATH79_MACH_GS_OOLITE) += mach-gs-oolite.o
|
||||||
|
--- a/arch/mips/ath79/machtypes.h
|
||||||
|
+++ b/arch/mips/ath79/machtypes.h
|
||||||
|
@@ -73,6 +73,7 @@ enum ath79_mach_type {
|
||||||
|
ATH79_MACH_EPG5000, /* EnGenius EPG5000 */
|
||||||
|
ATH79_MACH_F9K1115V2, /* Belkin AC1750DB */
|
||||||
|
ATH79_MACH_GL_AR150, /* GL-AR150 support */
|
||||||
|
+ ATH79_MACH_GL_AR300, /* GL-AR300 */
|
||||||
|
ATH79_MACH_GL_INET, /* GL-CONNECT GL-INET */
|
||||||
|
ATH79_MACH_GS_MINIBOX_V1, /* Gainstrong MiniBox V1.0 */
|
||||||
|
ATH79_MACH_GS_OOLITE, /* GS OOLITE V1.0 */
|
Loading…
Reference in New Issue
Block a user