ar71xx: rework changes from r35840

Signed-off-by: Luka Perkov <luka@openwrt.org>
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>

SVN-Revision: 35865
This commit is contained in:
Luka Perkov 2013-03-03 21:59:34 +00:00
parent 7f0cc47d85
commit a5ebfc79ba
19 changed files with 28 additions and 64 deletions

View File

@ -152,8 +152,7 @@ get_status_led() {
status_led="buffalo:green:status" status_led="buffalo:green:status"
;; ;;
wzr-hp-ag300h | \ wzr-hp-ag300h | \
wzr-hp-g300nh2 | \ wzr-hp-g300nh2)
wzr-600dhp)
status_led="buffalo:red:diag" status_led="buffalo:red:diag"
;; ;;
wndr3700) wndr3700)

View File

@ -42,8 +42,7 @@ if [ $phyname -a $ACTION = "add" ]; then
. /lib/ar71xx.sh . /lib/ar71xx.sh
case $(ar71xx_board_name) in case $(ar71xx_board_name) in
wzr-hp-ag300h|\ wzr-hp-ag300h)
wzr-600dhp)
ar922x_disable_gpio_jtag $phyname ar922x_disable_gpio_jtag $phyname
;; ;;
esac; esac;

View File

@ -212,8 +212,7 @@ wlae-ag300n)
ucidef_set_led_netdev "wireless" "WIRELESS" "buffalo:green:wireless" "wlan0" ucidef_set_led_netdev "wireless" "WIRELESS" "buffalo:green:wireless" "wlan0"
;; ;;
wzr-hp-ag300h | \ wzr-hp-ag300h)
wzr-600dhp)
ucidef_set_led_default "diag" "DIAG" "buffalo:red:diag" "0" ucidef_set_led_default "diag" "DIAG" "buffalo:red:diag" "0"
ucidef_set_led_netdev "router" "ROUTER" "buffalo:green:router" "eth1" ucidef_set_led_netdev "router" "ROUTER" "buffalo:green:router" "eth1"
ucidef_set_led_usbdev "usb" "USB" "buffalo:green:usb" "1-1" ucidef_set_led_usbdev "usb" "USB" "buffalo:green:usb" "1-1"

View File

@ -233,8 +233,7 @@ tl-wr841n-v7 |\
whr-g301n |\ whr-g301n |\
whr-hp-g300n |\ whr-hp-g300n |\
whr-hp-gn |\ whr-hp-gn |\
wzr-hp-ag300h |\ wzr-hp-ag300h)
wzr-600dhp)
ucidef_set_interfaces_lan_wan "eth0" "eth1" ucidef_set_interfaces_lan_wan "eth0" "eth1"
ucidef_add_switch "switch0" "1" "1" ucidef_add_switch "switch0" "1" "1"
ucidef_add_switch_vlan "switch0" "1" "0 1 2 3 4" ucidef_add_switch_vlan "switch0" "1" "0 1 2 3 4"

View File

@ -75,7 +75,6 @@ whr-hp-g300n|\
whr-hp-gn|\ whr-hp-gn|\
wzr-hp-ag300h|\ wzr-hp-ag300h|\
wzr-hp-g450h|\ wzr-hp-g450h|\
wzr-600dhp|\
ew-dorin|\ ew-dorin|\
ew-dorin-router) ew-dorin-router)
migrate_switch_name "eth0" "switch0" migrate_switch_name "eth0" "switch0"

View File

@ -456,7 +456,7 @@ ar71xx_board_detect() {
*WRT400N) *WRT400N)
name="wrt400n" name="wrt400n"
;; ;;
*WZR-HP-AG300H) *"WZR-HP-AG300H/WZR-600DHP")
name="wzr-hp-ag300h" name="wzr-hp-ag300h"
;; ;;
*WZR-HP-G300NH) *WZR-HP-G300NH)
@ -468,9 +468,6 @@ ar71xx_board_detect() {
*WZR-HP-G300NH2) *WZR-HP-G300NH2)
name="wzr-hp-g300nh2" name="wzr-hp-g300nh2"
;; ;;
*WZR-600DHP)
name="wzr-600dhp"
;;
*WHR-HP-G300N) *WHR-HP-G300N)
name="whr-hp-g300n" name="whr-hp-g300n"
;; ;;

View File

@ -125,7 +125,6 @@ platform_check_image() {
wzr-hp-g300nh | \ wzr-hp-g300nh | \
wzr-hp-g450h | \ wzr-hp-g450h | \
wzr-hp-ag300h | \ wzr-hp-ag300h | \
wzr-600dhp | \
whr-g301n | \ whr-g301n | \
whr-hp-g300n | \ whr-hp-g300n | \
whr-hp-gn | \ whr-hp-gn | \

View File

@ -92,7 +92,6 @@ CONFIG_ATH79_MACH_WZR_HP_AG300H=y
CONFIG_ATH79_MACH_WZR_HP_G300NH=y CONFIG_ATH79_MACH_WZR_HP_G300NH=y
CONFIG_ATH79_MACH_WZR_HP_G300NH2=y CONFIG_ATH79_MACH_WZR_HP_G300NH2=y
CONFIG_ATH79_MACH_WZR_HP_G450H=y CONFIG_ATH79_MACH_WZR_HP_G450H=y
CONFIG_ATH79_MACH_WZR_600DHP=y
CONFIG_ATH79_MACH_ZCN_1523H=y CONFIG_ATH79_MACH_ZCN_1523H=y
CONFIG_ATH79_NVRAM=y CONFIG_ATH79_NVRAM=y
CONFIG_ATH79_PCI_ATH9K_FIXUP=y CONFIG_ATH79_PCI_ATH9K_FIXUP=y

View File

@ -92,7 +92,6 @@ CONFIG_ATH79_MACH_WZR_HP_AG300H=y
CONFIG_ATH79_MACH_WZR_HP_G300NH=y CONFIG_ATH79_MACH_WZR_HP_G300NH=y
CONFIG_ATH79_MACH_WZR_HP_G300NH2=y CONFIG_ATH79_MACH_WZR_HP_G300NH2=y
CONFIG_ATH79_MACH_WZR_HP_G450H=y CONFIG_ATH79_MACH_WZR_HP_G450H=y
CONFIG_ATH79_MACH_WZR_600DHP=y
CONFIG_ATH79_MACH_ZCN_1523H=y CONFIG_ATH79_MACH_ZCN_1523H=y
CONFIG_ATH79_NVRAM=y CONFIG_ATH79_NVRAM=y
CONFIG_ATH79_PCI_ATH9K_FIXUP=y CONFIG_ATH79_PCI_ATH9K_FIXUP=y

View File

@ -36,6 +36,7 @@ static struct mtd_partition wzrhpag300h_flash_partitions[] = {
.name = "u-boot-env", .name = "u-boot-env",
.offset = 0x0040000, .offset = 0x0040000,
.size = 0x0010000, .size = 0x0010000,
.mask_flags = MTD_WRITEABLE,
}, { }, {
.name = "art", .name = "art",
.offset = 0x0050000, .offset = 0x0050000,
@ -209,8 +210,4 @@ static void __init wzrhpag300h_setup(void)
} }
MIPS_MACHINE(ATH79_MACH_WZR_HP_AG300H, "WZR-HP-AG300H", MIPS_MACHINE(ATH79_MACH_WZR_HP_AG300H, "WZR-HP-AG300H",
"Buffalo WZR-HP-AG300H", wzrhpag300h_setup); "Buffalo WZR-HP-AG300H/WZR-600DHP", wzrhpag300h_setup);
MIPS_MACHINE(ATH79_MACH_WZR_600DHP, "WZR-600DHP",
"Buffalo WZR-600DHP", wzrhpag300h_setup);

View File

@ -960,7 +960,7 @@ $(eval $(call SingleProfile,WZRHPG30XNH,$(fs_128k),WZRHPG300NH,wzr-hp-g300nh,WZR
$(eval $(call SingleProfile,WZRHPG30XNH,$(fs_64k),WZRHPG300NH2,wzr-hp-g300nh2,WZR-HP-G300NH2,ttyS0,115200,WZR-HP-G300NH2)) $(eval $(call SingleProfile,WZRHPG30XNH,$(fs_64k),WZRHPG300NH2,wzr-hp-g300nh2,WZR-HP-G300NH2,ttyS0,115200,WZR-HP-G300NH2))
$(eval $(call SingleProfile,WZRHPG30XNH,$(fs_64k),WZRHPAG300H,wzr-hp-ag300h,WZR-HP-AG300H,ttyS0,115200,WZR-HP-AG300H)) $(eval $(call SingleProfile,WZRHPG30XNH,$(fs_64k),WZRHPAG300H,wzr-hp-ag300h,WZR-HP-AG300H,ttyS0,115200,WZR-HP-AG300H))
$(eval $(call SingleProfile,WZRHPG30XNH,$(fs_64k),WZRHPG450H,wzr-hp-g450h,WZR-HP-G450H,ttyS0,115200,WZR-HP-AG450H)) $(eval $(call SingleProfile,WZRHPG30XNH,$(fs_64k),WZRHPG450H,wzr-hp-g450h,WZR-HP-G450H,ttyS0,115200,WZR-HP-AG450H))
$(eval $(call SingleProfile,WZRHPG30XNH,$(fs_64k),WZR600DHP,wzr-600dhp,WZR-600DHP,ttyS0,115200,WZR-600DHP)) $(eval $(call SingleProfile,WZRHPG30XNH,$(fs_64k),WZR600DHP,wzr-600dhp,WZR-HP-AG300H,ttyS0,115200,WZR-600DHP))
$(eval $(call SingleProfile,Zcomax,$(fs_64k),ZCN1523H28,zcn-1523h-2-8,ZCN-1523H-2,ttyS0,115200,$$(zcn1523h_mtdlayout))) $(eval $(call SingleProfile,Zcomax,$(fs_64k),ZCN1523H28,zcn-1523h-2-8,ZCN-1523H-2,ttyS0,115200,$$(zcn1523h_mtdlayout)))
$(eval $(call SingleProfile,Zcomax,$(fs_64k),ZCN1523H516,zcn-1523h-5-16,ZCN-1523H-5,ttyS0,115200,$$(zcn1523h_mtdlayout))) $(eval $(call SingleProfile,Zcomax,$(fs_64k),ZCN1523H516,zcn-1523h-5-16,ZCN-1523H-5,ttyS0,115200,$$(zcn1523h_mtdlayout)))

View File

@ -1,6 +1,6 @@
--- a/arch/mips/ath79/machtypes.h --- a/arch/mips/ath79/machtypes.h
+++ b/arch/mips/ath79/machtypes.h +++ b/arch/mips/ath79/machtypes.h
@@ -16,22 +16,113 @@ @@ -16,22 +16,112 @@
enum ath79_mach_type { enum ath79_mach_type {
ATH79_MACH_GENERIC = 0, ATH79_MACH_GENERIC = 0,
@ -108,7 +108,6 @@
+ ATH79_MACH_WZR_HP_G300NH, /* Buffalo WZR-HP-G300NH */ + ATH79_MACH_WZR_HP_G300NH, /* Buffalo WZR-HP-G300NH */
+ ATH79_MACH_WZR_HP_G300NH2, /* Buffalo WZR-HP-G300NH2 */ + ATH79_MACH_WZR_HP_G300NH2, /* Buffalo WZR-HP-G300NH2 */
+ ATH79_MACH_WZR_HP_G450H, /* Buffalo WZR-HP-G450H */ + ATH79_MACH_WZR_HP_G450H, /* Buffalo WZR-HP-G450H */
+ ATH79_MACH_WZR_600DHP, /* Buffalo WZR-600DHP */
+ ATH79_MACH_ZCN_1523H_2, /* Zcomax ZCN-1523H-2-xx */ + ATH79_MACH_ZCN_1523H_2, /* Zcomax ZCN-1523H-2-xx */
+ ATH79_MACH_ZCN_1523H_5, /* Zcomax ZCN-1523H-5-xx */ + ATH79_MACH_ZCN_1523H_5, /* Zcomax ZCN-1523H-5-xx */
}; };
@ -217,7 +216,7 @@
config ATH79_MACH_PB44 config ATH79_MACH_PB44
bool "Atheros PB44 reference board" bool "Atheros PB44 reference board"
select SOC_AR71XX select SOC_AR71XX
@@ -68,6 +148,497 @@ config ATH79_MACH_PB44 @@ -68,6 +148,488 @@ config ATH79_MACH_PB44
Say 'Y' here if you want your kernel to support the Say 'Y' here if you want your kernel to support the
Atheros PB44 reference board. Atheros PB44 reference board.
@ -294,15 +293,6 @@
+ select ATH79_DEV_M25P80 + select ATH79_DEV_M25P80
+ select ATH79_DEV_USB + select ATH79_DEV_USB
+ +
+config ATH79_MACH_WZR_600DHP
+ bool "Buffalo WZR-600DHP board support"
+ select SOC_AR71XX
+ select ATH79_DEV_ETH
+ select ATH79_DEV_GPIO_BUTTONS
+ select ATH79_DEV_LEDS_GPIO
+ select ATH79_DEV_M25P80
+ select ATH79_DEV_USB
+
+config ATH79_MACH_WP543 +config ATH79_MACH_WP543
+ bool "Compex WP543/WPJ543 board support" + bool "Compex WP543/WPJ543 board support"
+ select SOC_AR71XX + select SOC_AR71XX
@ -715,7 +705,7 @@
config ATH79_MACH_UBNT_XM config ATH79_MACH_UBNT_XM
bool "Ubiquiti Networks XM/UniFi boards" bool "Ubiquiti Networks XM/UniFi boards"
select SOC_AR724X select SOC_AR724X
@@ -83,6 +654,24 @@ config ATH79_MACH_UBNT_XM @@ -83,6 +645,24 @@ config ATH79_MACH_UBNT_XM
Say 'Y' here if you want your kernel to support the Say 'Y' here if you want your kernel to support the
Ubiquiti Networks XM (rev 1.0) board. Ubiquiti Networks XM (rev 1.0) board.
@ -740,7 +730,7 @@
endmenu endmenu
config SOC_AR71XX config SOC_AR71XX
@@ -118,10 +707,6 @@ config SOC_QCA955X @@ -118,10 +698,6 @@ config SOC_QCA955X
select PCI_AR724X if PCI select PCI_AR724X if PCI
def_bool n def_bool n
@ -751,7 +741,7 @@
config ATH79_DEV_AP9X_PCI config ATH79_DEV_AP9X_PCI
select ATH79_PCI_ATH9K_FIXUP select ATH79_PCI_ATH9K_FIXUP
def_bool n def_bool n
@@ -132,7 +717,14 @@ config ATH79_DEV_DSA @@ -132,7 +708,14 @@ config ATH79_DEV_DSA
config ATH79_DEV_ETH config ATH79_DEV_ETH
def_bool n def_bool n
@ -767,7 +757,7 @@
def_bool n def_bool n
config ATH79_DEV_GPIO_BUTTONS config ATH79_DEV_GPIO_BUTTONS
@@ -164,4 +756,7 @@ config ATH79_PCI_ATH9K_FIXUP @@ -164,4 +747,7 @@ config ATH79_PCI_ATH9K_FIXUP
config ATH79_ROUTERBOOT config ATH79_ROUTERBOOT
def_bool n def_bool n
@ -777,7 +767,7 @@
endif endif
--- a/arch/mips/ath79/Makefile --- a/arch/mips/ath79/Makefile
+++ b/arch/mips/ath79/Makefile +++ b/arch/mips/ath79/Makefile
@@ -38,9 +38,72 @@ obj-$(CONFIG_ATH79_ROUTERBOOT) += route @@ -38,9 +38,71 @@ obj-$(CONFIG_ATH79_ROUTERBOOT) += route
# #
# Machines # Machines
# #
@ -847,7 +837,6 @@
+obj-$(CONFIG_ATH79_MACH_WZR_HP_G300NH2) += mach-wzr-hp-g300nh2.o +obj-$(CONFIG_ATH79_MACH_WZR_HP_G300NH2) += mach-wzr-hp-g300nh2.o
+obj-$(CONFIG_ATH79_MACH_WZR_HP_AG300H) += mach-wzr-hp-ag300h.o +obj-$(CONFIG_ATH79_MACH_WZR_HP_AG300H) += mach-wzr-hp-ag300h.o
+obj-$(CONFIG_ATH79_MACH_WZR_HP_G450H) += mach-wzr-hp-g450h.o +obj-$(CONFIG_ATH79_MACH_WZR_HP_G450H) += mach-wzr-hp-g450h.o
+obj-$(CONFIG_ATH79_MACH_WZR_600DHP) += mach-wzr-hp-ag300h.o
+obj-$(CONFIG_ATH79_MACH_ZCN_1523H) += mach-zcn-1523h.o +obj-$(CONFIG_ATH79_MACH_ZCN_1523H) += mach-zcn-1523h.o
+ +
--- a/arch/mips/ath79/prom.c --- a/arch/mips/ath79/prom.c

View File

@ -10,7 +10,7 @@
ATH79_MACH_EAP7660D, /* Senao EAP7660D */ ATH79_MACH_EAP7660D, /* Senao EAP7660D */
--- a/arch/mips/ath79/Kconfig --- a/arch/mips/ath79/Kconfig
+++ b/arch/mips/ath79/Kconfig +++ b/arch/mips/ath79/Kconfig
@@ -292,6 +292,17 @@ config ATH79_MACH_DIR_825_B1 @@ -283,6 +283,17 @@ config ATH79_MACH_DIR_825_B1
select ATH79_DEV_M25P80 select ATH79_DEV_M25P80
select ATH79_DEV_USB select ATH79_DEV_USB

View File

@ -10,7 +10,7 @@
ATH79_MACH_TL_WR1043ND, /* TP-LINK TL-WR1043ND */ ATH79_MACH_TL_WR1043ND, /* TP-LINK TL-WR1043ND */
--- a/arch/mips/ath79/Kconfig --- a/arch/mips/ath79/Kconfig
+++ b/arch/mips/ath79/Kconfig +++ b/arch/mips/ath79/Kconfig
@@ -523,6 +523,17 @@ config ATH79_MACH_TL_WA901ND_V2 @@ -514,6 +514,17 @@ config ATH79_MACH_TL_WA901ND_V2
select ATH79_DEV_M25P80 select ATH79_DEV_M25P80
select ATH79_DEV_WMAC select ATH79_DEV_WMAC

View File

@ -10,7 +10,7 @@
ATH79_MACH_RW2458N, /* Redwave RW2458N */ ATH79_MACH_RW2458N, /* Redwave RW2458N */
--- a/arch/mips/ath79/Kconfig --- a/arch/mips/ath79/Kconfig
+++ b/arch/mips/ath79/Kconfig +++ b/arch/mips/ath79/Kconfig
@@ -369,6 +369,16 @@ config ATH79_MACH_RB750 @@ -360,6 +360,16 @@ config ATH79_MACH_RB750
select ATH79_ROUTERBOOT select ATH79_ROUTERBOOT
select RLE_DECOMPRESS select RLE_DECOMPRESS

View File

@ -1,6 +1,6 @@
--- a/arch/mips/ath79/machtypes.h --- a/arch/mips/ath79/machtypes.h
+++ b/arch/mips/ath79/machtypes.h +++ b/arch/mips/ath79/machtypes.h
@@ -16,22 +16,113 @@ @@ -16,22 +16,112 @@
enum ath79_mach_type { enum ath79_mach_type {
ATH79_MACH_GENERIC = 0, ATH79_MACH_GENERIC = 0,
@ -108,7 +108,6 @@
+ ATH79_MACH_WZR_HP_G300NH, /* Buffalo WZR-HP-G300NH */ + ATH79_MACH_WZR_HP_G300NH, /* Buffalo WZR-HP-G300NH */
+ ATH79_MACH_WZR_HP_G300NH2, /* Buffalo WZR-HP-G300NH2 */ + ATH79_MACH_WZR_HP_G300NH2, /* Buffalo WZR-HP-G300NH2 */
+ ATH79_MACH_WZR_HP_G450H, /* Buffalo WZR-HP-G450H */ + ATH79_MACH_WZR_HP_G450H, /* Buffalo WZR-HP-G450H */
+ ATH79_MACH_WZR_600DHP, /* Buffalo WZR-600DHP */
+ ATH79_MACH_ZCN_1523H_2, /* Zcomax ZCN-1523H-2-xx */ + ATH79_MACH_ZCN_1523H_2, /* Zcomax ZCN-1523H-2-xx */
+ ATH79_MACH_ZCN_1523H_5, /* Zcomax ZCN-1523H-5-xx */ + ATH79_MACH_ZCN_1523H_5, /* Zcomax ZCN-1523H-5-xx */
}; };
@ -217,7 +216,7 @@
config ATH79_MACH_PB44 config ATH79_MACH_PB44
bool "Atheros PB44 reference board" bool "Atheros PB44 reference board"
select SOC_AR71XX select SOC_AR71XX
@@ -68,6 +148,497 @@ config ATH79_MACH_PB44 @@ -68,6 +148,488 @@ config ATH79_MACH_PB44
Say 'Y' here if you want your kernel to support the Say 'Y' here if you want your kernel to support the
Atheros PB44 reference board. Atheros PB44 reference board.
@ -294,15 +293,6 @@
+ select ATH79_DEV_M25P80 + select ATH79_DEV_M25P80
+ select ATH79_DEV_USB + select ATH79_DEV_USB
+ +
+config ATH79_MACH_WZR_600DHP
+ bool "Buffalo WZR-600DHP board support"
+ select SOC_AR71XX
+ select ATH79_DEV_ETH
+ select ATH79_DEV_GPIO_BUTTONS
+ select ATH79_DEV_LEDS_GPIO
+ select ATH79_DEV_M25P80
+ select ATH79_DEV_USB
+
+config ATH79_MACH_WP543 +config ATH79_MACH_WP543
+ bool "Compex WP543/WPJ543 board support" + bool "Compex WP543/WPJ543 board support"
+ select SOC_AR71XX + select SOC_AR71XX
@ -715,7 +705,7 @@
config ATH79_MACH_UBNT_XM config ATH79_MACH_UBNT_XM
bool "Ubiquiti Networks XM/UniFi boards" bool "Ubiquiti Networks XM/UniFi boards"
select SOC_AR724X select SOC_AR724X
@@ -83,6 +654,24 @@ config ATH79_MACH_UBNT_XM @@ -83,6 +645,24 @@ config ATH79_MACH_UBNT_XM
Say 'Y' here if you want your kernel to support the Say 'Y' here if you want your kernel to support the
Ubiquiti Networks XM (rev 1.0) board. Ubiquiti Networks XM (rev 1.0) board.
@ -740,7 +730,7 @@
endmenu endmenu
config SOC_AR71XX config SOC_AR71XX
@@ -118,10 +707,6 @@ config SOC_QCA955X @@ -118,10 +698,6 @@ config SOC_QCA955X
select PCI_AR724X if PCI select PCI_AR724X if PCI
def_bool n def_bool n
@ -751,7 +741,7 @@
config ATH79_DEV_AP9X_PCI config ATH79_DEV_AP9X_PCI
select ATH79_PCI_ATH9K_FIXUP select ATH79_PCI_ATH9K_FIXUP
def_bool n def_bool n
@@ -132,7 +717,14 @@ config ATH79_DEV_DSA @@ -132,7 +708,14 @@ config ATH79_DEV_DSA
config ATH79_DEV_ETH config ATH79_DEV_ETH
def_bool n def_bool n
@ -767,7 +757,7 @@
def_bool n def_bool n
config ATH79_DEV_GPIO_BUTTONS config ATH79_DEV_GPIO_BUTTONS
@@ -164,4 +756,7 @@ config ATH79_PCI_ATH9K_FIXUP @@ -164,4 +747,7 @@ config ATH79_PCI_ATH9K_FIXUP
config ATH79_ROUTERBOOT config ATH79_ROUTERBOOT
def_bool n def_bool n
@ -777,7 +767,7 @@
endif endif
--- a/arch/mips/ath79/Makefile --- a/arch/mips/ath79/Makefile
+++ b/arch/mips/ath79/Makefile +++ b/arch/mips/ath79/Makefile
@@ -38,9 +38,72 @@ obj-$(CONFIG_ATH79_ROUTERBOOT) += route @@ -38,9 +38,71 @@ obj-$(CONFIG_ATH79_ROUTERBOOT) += route
# #
# Machines # Machines
# #
@ -847,7 +837,6 @@
+obj-$(CONFIG_ATH79_MACH_WZR_HP_G300NH2) += mach-wzr-hp-g300nh2.o +obj-$(CONFIG_ATH79_MACH_WZR_HP_G300NH2) += mach-wzr-hp-g300nh2.o
+obj-$(CONFIG_ATH79_MACH_WZR_HP_AG300H) += mach-wzr-hp-ag300h.o +obj-$(CONFIG_ATH79_MACH_WZR_HP_AG300H) += mach-wzr-hp-ag300h.o
+obj-$(CONFIG_ATH79_MACH_WZR_HP_G450H) += mach-wzr-hp-g450h.o +obj-$(CONFIG_ATH79_MACH_WZR_HP_G450H) += mach-wzr-hp-g450h.o
+obj-$(CONFIG_ATH79_MACH_WZR_600DHP) += mach-wzr-hp-ag300h.o
+obj-$(CONFIG_ATH79_MACH_ZCN_1523H) += mach-zcn-1523h.o +obj-$(CONFIG_ATH79_MACH_ZCN_1523H) += mach-zcn-1523h.o
+ +
--- a/arch/mips/ath79/prom.c --- a/arch/mips/ath79/prom.c

View File

@ -10,7 +10,7 @@
ATH79_MACH_EAP7660D, /* Senao EAP7660D */ ATH79_MACH_EAP7660D, /* Senao EAP7660D */
--- a/arch/mips/ath79/Kconfig --- a/arch/mips/ath79/Kconfig
+++ b/arch/mips/ath79/Kconfig +++ b/arch/mips/ath79/Kconfig
@@ -292,6 +292,17 @@ config ATH79_MACH_DIR_825_B1 @@ -283,6 +283,17 @@ config ATH79_MACH_DIR_825_B1
select ATH79_DEV_M25P80 select ATH79_DEV_M25P80
select ATH79_DEV_USB select ATH79_DEV_USB

View File

@ -10,7 +10,7 @@
ATH79_MACH_TL_WR1043ND, /* TP-LINK TL-WR1043ND */ ATH79_MACH_TL_WR1043ND, /* TP-LINK TL-WR1043ND */
--- a/arch/mips/ath79/Kconfig --- a/arch/mips/ath79/Kconfig
+++ b/arch/mips/ath79/Kconfig +++ b/arch/mips/ath79/Kconfig
@@ -523,6 +523,17 @@ config ATH79_MACH_TL_WA901ND_V2 @@ -514,6 +514,17 @@ config ATH79_MACH_TL_WA901ND_V2
select ATH79_DEV_M25P80 select ATH79_DEV_M25P80
select ATH79_DEV_WMAC select ATH79_DEV_WMAC

View File

@ -10,7 +10,7 @@
ATH79_MACH_RW2458N, /* Redwave RW2458N */ ATH79_MACH_RW2458N, /* Redwave RW2458N */
--- a/arch/mips/ath79/Kconfig --- a/arch/mips/ath79/Kconfig
+++ b/arch/mips/ath79/Kconfig +++ b/arch/mips/ath79/Kconfig
@@ -369,6 +369,16 @@ config ATH79_MACH_RB750 @@ -360,6 +360,16 @@ config ATH79_MACH_RB750
select ATH79_ROUTERBOOT select ATH79_ROUTERBOOT
select RLE_DECOMPRESS select RLE_DECOMPRESS