ar71xx: Add support for AP147-010 reference board
Signed-off-by: Sven Eckelmann <sven@open-mesh.com> SVN-Revision: 46457
This commit is contained in:
parent
42c37d4381
commit
b98205c946
@ -23,6 +23,9 @@ get_status_led() {
|
|||||||
ap136-020)
|
ap136-020)
|
||||||
status_led="ap136:green:status"
|
status_led="ap136:green:status"
|
||||||
;;
|
;;
|
||||||
|
ap147-010)
|
||||||
|
status_led="ap147:green:status"
|
||||||
|
;;
|
||||||
ap135-020)
|
ap135-020)
|
||||||
status_led="ap135:green:status"
|
status_led="ap135:green:status"
|
||||||
;;
|
;;
|
||||||
|
@ -46,6 +46,15 @@ ap113)
|
|||||||
ucidef_set_led_usbdev "usb" "USB" "ap113:green:usb" "1-1"
|
ucidef_set_led_usbdev "usb" "USB" "ap113:green:usb" "1-1"
|
||||||
;;
|
;;
|
||||||
|
|
||||||
|
ap147-010)
|
||||||
|
ucidef_set_led_netdev "wan" "WAN" "ap147:green:wan" "eth1"
|
||||||
|
ucidef_set_led_switch "lan1" "LAN1" "ap147:green:lan1" "switch0" "0x10"
|
||||||
|
ucidef_set_led_switch "lan2" "LAN2" "ap147:green:lan2" "switch0" "0x08"
|
||||||
|
ucidef_set_led_switch "lan3" "LAN3" "ap147:green:lan3" "switch0" "0x04"
|
||||||
|
ucidef_set_led_switch "lan4" "LAN4" "ap147:green:lan4" "switch0" "0x02"
|
||||||
|
ucidef_set_led_wlan "wlan2g" "WLAN 2.4 GHz" "ap147:green:wlan-2g" "phy0tpt"
|
||||||
|
;;
|
||||||
|
|
||||||
bullet-m | \
|
bullet-m | \
|
||||||
nanostation-m | \
|
nanostation-m | \
|
||||||
rocket-m | \
|
rocket-m | \
|
||||||
|
@ -46,6 +46,13 @@ ap136-010)
|
|||||||
ucidef_add_switch_vlan "switch0" "2" "5 6"
|
ucidef_add_switch_vlan "switch0" "2" "5 6"
|
||||||
;;
|
;;
|
||||||
|
|
||||||
|
ap147-010)
|
||||||
|
ucidef_set_interfaces_lan_wan "eth0" "eth1"
|
||||||
|
ucidef_add_switch "switch0" "1" "1"
|
||||||
|
ucidef_add_switch_vlan "switch0" "1" "0 1 2 3 4"
|
||||||
|
ucidef_add_switch_vlan "switch0" "2" "5 6"
|
||||||
|
;;
|
||||||
|
|
||||||
ap136-020 |\
|
ap136-020 |\
|
||||||
ap135-020 |\
|
ap135-020 |\
|
||||||
tl-wr1043nd-v2 |\
|
tl-wr1043nd-v2 |\
|
||||||
|
@ -365,6 +365,9 @@ ar71xx_board_detect() {
|
|||||||
*"AP143 reference board")
|
*"AP143 reference board")
|
||||||
name="ap143"
|
name="ap143"
|
||||||
;;
|
;;
|
||||||
|
*"AP147-010 reference board")
|
||||||
|
name="ap147-010"
|
||||||
|
;;
|
||||||
*AP81)
|
*AP81)
|
||||||
name="ap81"
|
name="ap81"
|
||||||
;;
|
;;
|
||||||
|
@ -12,6 +12,7 @@ set_preinit_iface() {
|
|||||||
alfa-nx |\
|
alfa-nx |\
|
||||||
ap135-020 |\
|
ap135-020 |\
|
||||||
ap136-020 |\
|
ap136-020 |\
|
||||||
|
ap147-010 |\
|
||||||
ap83 |\
|
ap83 |\
|
||||||
archer-c5 |\
|
archer-c5 |\
|
||||||
archer-c7 |\
|
archer-c7 |\
|
||||||
|
@ -179,6 +179,7 @@ platform_check_image() {
|
|||||||
ap136-010 | \
|
ap136-010 | \
|
||||||
ap136-020 | \
|
ap136-020 | \
|
||||||
ap135-020 | \
|
ap135-020 | \
|
||||||
|
ap147-010 | \
|
||||||
ap96 | \
|
ap96 | \
|
||||||
bxu2000n-2-a1 | \
|
bxu2000n-2-a1 | \
|
||||||
db120 | \
|
db120 | \
|
||||||
|
@ -36,6 +36,7 @@ CONFIG_ATH79_MACH_AP121=y
|
|||||||
CONFIG_ATH79_MACH_AP132=y
|
CONFIG_ATH79_MACH_AP132=y
|
||||||
CONFIG_ATH79_MACH_AP136=y
|
CONFIG_ATH79_MACH_AP136=y
|
||||||
CONFIG_ATH79_MACH_AP143=y
|
CONFIG_ATH79_MACH_AP143=y
|
||||||
|
CONFIG_ATH79_MACH_AP147=y
|
||||||
CONFIG_ATH79_MACH_AP81=y
|
CONFIG_ATH79_MACH_AP81=y
|
||||||
CONFIG_ATH79_MACH_AP83=y
|
CONFIG_ATH79_MACH_AP83=y
|
||||||
CONFIG_ATH79_MACH_AP96=y
|
CONFIG_ATH79_MACH_AP96=y
|
||||||
|
@ -40,6 +40,7 @@ CONFIG_ATH79_MACH_AP121=y
|
|||||||
CONFIG_ATH79_MACH_AP132=y
|
CONFIG_ATH79_MACH_AP132=y
|
||||||
CONFIG_ATH79_MACH_AP136=y
|
CONFIG_ATH79_MACH_AP136=y
|
||||||
CONFIG_ATH79_MACH_AP143=y
|
CONFIG_ATH79_MACH_AP143=y
|
||||||
|
CONFIG_ATH79_MACH_AP147=y
|
||||||
CONFIG_ATH79_MACH_AP81=y
|
CONFIG_ATH79_MACH_AP81=y
|
||||||
CONFIG_ATH79_MACH_AP83=y
|
CONFIG_ATH79_MACH_AP83=y
|
||||||
CONFIG_ATH79_MACH_AP96=y
|
CONFIG_ATH79_MACH_AP96=y
|
||||||
|
125
target/linux/ar71xx/files/arch/mips/ath79/mach-ap147.c
Normal file
125
target/linux/ar71xx/files/arch/mips/ath79/mach-ap147.c
Normal file
@ -0,0 +1,125 @@
|
|||||||
|
/*
|
||||||
|
* Atheros AP147 reference board support
|
||||||
|
*
|
||||||
|
* Copyright (C) 2014 Matthias Schiffer <mschiffer@universe-factory.net>
|
||||||
|
* Copyright (C) 2015 Sven Eckelmann <sven@open-mesh.com>
|
||||||
|
*
|
||||||
|
* This program is free software; you can redistribute it and/or modify it
|
||||||
|
* under the terms of the GNU General Public License version 2 as published
|
||||||
|
* by the Free Software Foundation.
|
||||||
|
*/
|
||||||
|
|
||||||
|
#include <linux/platform_device.h>
|
||||||
|
#include <linux/ar8216_platform.h>
|
||||||
|
|
||||||
|
#include <asm/mach-ath79/ar71xx_regs.h>
|
||||||
|
#include <asm/mach-ath79/ath79.h>
|
||||||
|
|
||||||
|
#include "common.h"
|
||||||
|
#include "dev-ap9x-pci.h"
|
||||||
|
#include "dev-eth.h"
|
||||||
|
#include "dev-gpio-buttons.h"
|
||||||
|
#include "dev-leds-gpio.h"
|
||||||
|
#include "dev-m25p80.h"
|
||||||
|
#include "dev-usb.h"
|
||||||
|
#include "dev-wmac.h"
|
||||||
|
#include "machtypes.h"
|
||||||
|
#include "pci.h"
|
||||||
|
|
||||||
|
#define AP147_GPIO_LED_WAN 4
|
||||||
|
#define AP147_GPIO_LED_LAN1 16
|
||||||
|
#define AP147_GPIO_LED_LAN2 15
|
||||||
|
#define AP147_GPIO_LED_LAN3 14
|
||||||
|
#define AP147_GPIO_LED_LAN4 11
|
||||||
|
#define AP147_GPIO_LED_STATUS 13
|
||||||
|
#define AP147_GPIO_LED_WLAN_2G 12
|
||||||
|
|
||||||
|
#define AP147_GPIO_BTN_WPS 17
|
||||||
|
|
||||||
|
#define AP147_KEYS_POLL_INTERVAL 20 /* msecs */
|
||||||
|
#define AP147_KEYS_DEBOUNCE_INTERVAL (3 * AP147_KEYS_POLL_INTERVAL)
|
||||||
|
|
||||||
|
#define AP147_MAC0_OFFSET 0x1000
|
||||||
|
|
||||||
|
static struct gpio_led ap147_leds_gpio[] __initdata = {
|
||||||
|
{
|
||||||
|
.name = "ap147:green:status",
|
||||||
|
.gpio = AP147_GPIO_LED_STATUS,
|
||||||
|
.active_low = 1,
|
||||||
|
}, {
|
||||||
|
.name = "ap147:green:wlan-2g",
|
||||||
|
.gpio = AP147_GPIO_LED_WLAN_2G,
|
||||||
|
.active_low = 1,
|
||||||
|
}, {
|
||||||
|
.name = "ap147:green:lan1",
|
||||||
|
.gpio = AP147_GPIO_LED_LAN1,
|
||||||
|
.active_low = 1,
|
||||||
|
}, {
|
||||||
|
.name = "ap147:green:lan2",
|
||||||
|
.gpio = AP147_GPIO_LED_LAN2,
|
||||||
|
.active_low = 1,
|
||||||
|
}, {
|
||||||
|
.name = "ap147:green:lan3",
|
||||||
|
.gpio = AP147_GPIO_LED_LAN3,
|
||||||
|
.active_low = 1,
|
||||||
|
}, {
|
||||||
|
.name = "ap147:green:lan4",
|
||||||
|
.gpio = AP147_GPIO_LED_LAN4,
|
||||||
|
.active_low = 1,
|
||||||
|
}, {
|
||||||
|
.name = "ap147:green:wan",
|
||||||
|
.gpio = AP147_GPIO_LED_WAN,
|
||||||
|
.active_low = 1,
|
||||||
|
},
|
||||||
|
};
|
||||||
|
|
||||||
|
static struct gpio_keys_button ap147_gpio_keys[] __initdata = {
|
||||||
|
{
|
||||||
|
.desc = "wps button",
|
||||||
|
.type = EV_KEY,
|
||||||
|
.code = KEY_WPS_BUTTON,
|
||||||
|
.debounce_interval = AP147_KEYS_DEBOUNCE_INTERVAL,
|
||||||
|
.gpio = AP147_GPIO_BTN_WPS,
|
||||||
|
.active_low = 1,
|
||||||
|
}
|
||||||
|
};
|
||||||
|
|
||||||
|
static void __init ap147_setup(void)
|
||||||
|
{
|
||||||
|
u8 *art = (u8 *)KSEG1ADDR(0x1fff0000);
|
||||||
|
|
||||||
|
ath79_register_m25p80(NULL);
|
||||||
|
ath79_register_leds_gpio(-1, ARRAY_SIZE(ap147_leds_gpio),
|
||||||
|
ap147_leds_gpio);
|
||||||
|
ath79_register_gpio_keys_polled(-1, AP147_KEYS_POLL_INTERVAL,
|
||||||
|
ARRAY_SIZE(ap147_gpio_keys),
|
||||||
|
ap147_gpio_keys);
|
||||||
|
|
||||||
|
ath79_register_usb();
|
||||||
|
|
||||||
|
ath79_register_pci();
|
||||||
|
|
||||||
|
ath79_register_wmac(art + AP147_MAC0_OFFSET, NULL);
|
||||||
|
|
||||||
|
ath79_setup_ar933x_phy4_switch(false, false);
|
||||||
|
|
||||||
|
ath79_register_mdio(0, 0x0);
|
||||||
|
|
||||||
|
/* LAN */
|
||||||
|
ath79_eth1_data.phy_if_mode = PHY_INTERFACE_MODE_GMII;
|
||||||
|
ath79_eth1_data.duplex = DUPLEX_FULL;
|
||||||
|
ath79_switch_data.phy_poll_mask |= BIT(4);
|
||||||
|
ath79_init_mac(ath79_eth1_data.mac_addr, art, 0);
|
||||||
|
ath79_register_eth(1);
|
||||||
|
|
||||||
|
/* WAN */
|
||||||
|
ath79_switch_data.phy4_mii_en = 1;
|
||||||
|
ath79_eth0_data.phy_if_mode = PHY_INTERFACE_MODE_MII;
|
||||||
|
ath79_eth0_data.duplex = DUPLEX_FULL;
|
||||||
|
ath79_eth0_data.speed = SPEED_100;
|
||||||
|
ath79_eth0_data.phy_mask = BIT(4);
|
||||||
|
ath79_init_mac(ath79_eth0_data.mac_addr, art, 1);
|
||||||
|
ath79_register_eth(0);
|
||||||
|
}
|
||||||
|
|
||||||
|
MIPS_MACHINE(ATH79_MACH_AP147_010, "AP147-010", "Atheros AP147-010 reference board", ap147_setup);
|
@ -82,6 +82,16 @@ endef
|
|||||||
|
|
||||||
$(eval $(call Profile,AP143))
|
$(eval $(call Profile,AP143))
|
||||||
|
|
||||||
|
define Profile/AP147
|
||||||
|
NAME:=Qualcomm Atheros AP147 reference board
|
||||||
|
PACKAGES:=kmod-usb-core kmod-usb2 kmod-usb-storage
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Profile/AP147/Description
|
||||||
|
Package set optimized for the Atheros AP147 reference board.
|
||||||
|
endef
|
||||||
|
|
||||||
|
$(eval $(call Profile,AP147))
|
||||||
|
|
||||||
define Profile/AP81
|
define Profile/AP81
|
||||||
NAME:=Atheros AP81 reference board
|
NAME:=Atheros AP81 reference board
|
||||||
|
@ -1171,6 +1171,7 @@ ap135_mtdlayout=mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,14528k(rootfs),
|
|||||||
ap136_mtdlayout=mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,6336k(rootfs),1408k(kernel),64k(mib0),64k(art)ro,7744k@0x50000(firmware)
|
ap136_mtdlayout=mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,6336k(rootfs),1408k(kernel),64k(mib0),64k(art)ro,7744k@0x50000(firmware)
|
||||||
ap143_mtdlayout_8M=mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,6336k(rootfs),1472k(kernel),64k(art)ro,7744k@0x50000(firmware)
|
ap143_mtdlayout_8M=mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,6336k(rootfs),1472k(kernel),64k(art)ro,7744k@0x50000(firmware)
|
||||||
ap143_mtdlayout_16M=mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,14528k(rootfs),1472k(kernel),64k(art)ro,16000k@0x50000(firmware)
|
ap143_mtdlayout_16M=mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,14528k(rootfs),1472k(kernel),64k(art)ro,16000k@0x50000(firmware)
|
||||||
|
ap147_mtdlayout=mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,14528k(rootfs),1472k(kernel),64k(art),16000k@0x50000(firmware)
|
||||||
bxu2000n2_mtdlayout=mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,1408k(kernel),8448k(rootfs),6016k(user),64k(cfg),64k(oem),64k(art)ro
|
bxu2000n2_mtdlayout=mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,1408k(kernel),8448k(rootfs),6016k(user),64k(cfg),64k(oem),64k(art)ro
|
||||||
cameo_ap81_mtdlayout=mtdparts=spi0.0:128k(u-boot)ro,64k(config)ro,3840k(firmware),64k(art)ro
|
cameo_ap81_mtdlayout=mtdparts=spi0.0:128k(u-boot)ro,64k(config)ro,3840k(firmware),64k(art)ro
|
||||||
cameo_ap91_mtdlayout=mtdparts=spi0.0:192k(u-boot)ro,64k(nvram)ro,3712k(firmware),64k(mac)ro,64k(art)ro
|
cameo_ap91_mtdlayout=mtdparts=spi0.0:192k(u-boot)ro,64k(nvram)ro,3712k(firmware),64k(mac)ro,64k(art)ro
|
||||||
@ -2024,6 +2025,7 @@ $(eval $(call SingleProfile,AthLzma,64k,AP136_010,ap136-010,AP136-010,ttyS0,1152
|
|||||||
$(eval $(call SingleProfile,AthLzma,64k,AP136_020,ap136-020,AP136-020,ttyS0,115200,$$(ap136_mtdlayout),RKuImage))
|
$(eval $(call SingleProfile,AthLzma,64k,AP136_020,ap136-020,AP136-020,ttyS0,115200,$$(ap136_mtdlayout),RKuImage))
|
||||||
$(eval $(call SingleProfile,AthLzma,64k,AP143_8M,ap143-8M,AP143,ttyS0,115200,$$(ap143_mtdlayout_8M),RKuImage))
|
$(eval $(call SingleProfile,AthLzma,64k,AP143_8M,ap143-8M,AP143,ttyS0,115200,$$(ap143_mtdlayout_8M),RKuImage))
|
||||||
$(eval $(call SingleProfile,AthLzma,64k,AP143_16M,ap143-16M,AP143,ttyS0,115200,$$(ap143_mtdlayout_16M),RKuImage))
|
$(eval $(call SingleProfile,AthLzma,64k,AP143_16M,ap143-16M,AP143,ttyS0,115200,$$(ap143_mtdlayout_16M),RKuImage))
|
||||||
|
$(eval $(call SingleProfile,AthLzma,64k,AP147_010,ap147-010,AP147-010,ttyS0,115200,$$(ap147_mtdlayout),RKuImage))
|
||||||
$(eval $(call SingleProfile,AthLzma,64k,BXU2000N2,bxu2000n-2-a1,BXU2000n-2-A1,ttyS0,115200,$$(bxu2000n2_mtdlayout),RKuImage))
|
$(eval $(call SingleProfile,AthLzma,64k,BXU2000N2,bxu2000n-2-a1,BXU2000n-2-A1,ttyS0,115200,$$(bxu2000n2_mtdlayout),RKuImage))
|
||||||
$(eval $(call SingleProfile,AthLzma,64k,CAP4200AG,cap4200ag,CAP4200AG,ttyS0,115200,$$(cap4200ag_mtdlayout),KRuImage))
|
$(eval $(call SingleProfile,AthLzma,64k,CAP4200AG,cap4200ag,CAP4200AG,ttyS0,115200,$$(cap4200ag_mtdlayout),KRuImage))
|
||||||
$(eval $(call SingleProfile,AthLzma,64k,DB120,db120,DB120,ttyS0,115200,$$(db120_mtdlayout),RKuImage))
|
$(eval $(call SingleProfile,AthLzma,64k,DB120,db120,DB120,ttyS0,115200,$$(db120_mtdlayout),RKuImage))
|
||||||
@ -2178,6 +2180,7 @@ $(eval $(call SingleProfile,ZyXEL,64k,NBG_460N_550N_550NH,nbg460n_550n_550nh,NBG
|
|||||||
$(eval $(call MultiProfile,AP121,AP121_2M AP121_4M))
|
$(eval $(call MultiProfile,AP121,AP121_2M AP121_4M))
|
||||||
$(eval $(call MultiProfile,AP136,AP136_010 AP136_020))
|
$(eval $(call MultiProfile,AP136,AP136_010 AP136_020))
|
||||||
$(eval $(call MultiProfile,AP143,AP143_8M AP143_16M))
|
$(eval $(call MultiProfile,AP143,AP143_8M AP143_16M))
|
||||||
|
$(eval $(call MultiProfile,AP147,AP147_010))
|
||||||
$(eval $(call MultiProfile,DIR615IX,DIR615I1 DIR615I3))
|
$(eval $(call MultiProfile,DIR615IX,DIR615I1 DIR615I3))
|
||||||
$(eval $(call MultiProfile,EWDORIN, EWDORINAP EWDORINRT EWDORIN16M))
|
$(eval $(call MultiProfile,EWDORIN, EWDORINAP EWDORINRT EWDORIN16M))
|
||||||
$(eval $(call MultiProfile,OPENMESH,OM2P OM5P MR600 MR900))
|
$(eval $(call MultiProfile,OPENMESH,OM2P OM5P MR600 MR900))
|
||||||
|
@ -8,6 +8,7 @@
|
|||||||
# CONFIG_ATH79_MACH_AP121 is not set
|
# CONFIG_ATH79_MACH_AP121 is not set
|
||||||
# CONFIG_ATH79_MACH_AP132 is not set
|
# CONFIG_ATH79_MACH_AP132 is not set
|
||||||
# CONFIG_ATH79_MACH_AP136 is not set
|
# CONFIG_ATH79_MACH_AP136 is not set
|
||||||
|
# CONFIG_ATH79_MACH_AP147 is not set
|
||||||
# CONFIG_ATH79_MACH_AP81 is not set
|
# CONFIG_ATH79_MACH_AP81 is not set
|
||||||
# CONFIG_ATH79_MACH_AP83 is not set
|
# CONFIG_ATH79_MACH_AP83 is not set
|
||||||
# CONFIG_ATH79_MACH_AP96 is not set
|
# CONFIG_ATH79_MACH_AP96 is not set
|
||||||
|
@ -7,6 +7,7 @@
|
|||||||
# CONFIG_ATH79_MACH_AP121 is not set
|
# CONFIG_ATH79_MACH_AP121 is not set
|
||||||
# CONFIG_ATH79_MACH_AP132 is not set
|
# CONFIG_ATH79_MACH_AP132 is not set
|
||||||
# CONFIG_ATH79_MACH_AP136 is not set
|
# CONFIG_ATH79_MACH_AP136 is not set
|
||||||
|
# CONFIG_ATH79_MACH_AP147 is not set
|
||||||
# CONFIG_ATH79_MACH_AP81 is not set
|
# CONFIG_ATH79_MACH_AP81 is not set
|
||||||
# CONFIG_ATH79_MACH_AP83 is not set
|
# CONFIG_ATH79_MACH_AP83 is not set
|
||||||
# CONFIG_ATH79_MACH_AP96 is not set
|
# CONFIG_ATH79_MACH_AP96 is not set
|
||||||
|
@ -0,0 +1,42 @@
|
|||||||
|
--- a/arch/mips/ath79/Kconfig
|
||||||
|
+++ b/arch/mips/ath79/Kconfig
|
||||||
|
@@ -118,6 +118,19 @@ config ATH79_MACH_AP143
|
||||||
|
Say 'Y' here if you want your kernel to support the
|
||||||
|
Atheros AP143 reference board.
|
||||||
|
|
||||||
|
+config ATH79_MACH_AP147
|
||||||
|
+ bool "Atheros AP147 reference board"
|
||||||
|
+ select SOC_QCA953X
|
||||||
|
+ select ATH79_DEV_GPIO_BUTTONS
|
||||||
|
+ select ATH79_DEV_LEDS_GPIO
|
||||||
|
+ select ATH79_DEV_M25P80
|
||||||
|
+ select ATH79_DEV_USB
|
||||||
|
+ select ATH79_DEV_WMAC
|
||||||
|
+ select ATH79_DEV_AP9X_PCI if PCI
|
||||||
|
+ help
|
||||||
|
+ Say 'Y' here if you want your kernel to support the
|
||||||
|
+ QCA AP147 reference boards.
|
||||||
|
+
|
||||||
|
config ATH79_MACH_AP81
|
||||||
|
bool "Atheros AP81 reference board"
|
||||||
|
select SOC_AR913X
|
||||||
|
--- a/arch/mips/ath79/Makefile
|
||||||
|
+++ b/arch/mips/ath79/Makefile
|
||||||
|
@@ -47,6 +47,7 @@ obj-$(CONFIG_ATH79_MACH_AP121) += mach-
|
||||||
|
obj-$(CONFIG_ATH79_MACH_AP132) += mach-ap132.o
|
||||||
|
obj-$(CONFIG_ATH79_MACH_AP136) += mach-ap136.o
|
||||||
|
obj-$(CONFIG_ATH79_MACH_AP143) += mach-ap143.o
|
||||||
|
+obj-$(CONFIG_ATH79_MACH_AP147) += mach-ap147.o
|
||||||
|
obj-$(CONFIG_ATH79_MACH_AP81) += mach-ap81.o
|
||||||
|
obj-$(CONFIG_ATH79_MACH_AP83) += mach-ap83.o
|
||||||
|
obj-$(CONFIG_ATH79_MACH_AP96) += mach-ap96.o
|
||||||
|
--- a/arch/mips/ath79/machtypes.h
|
||||||
|
+++ b/arch/mips/ath79/machtypes.h
|
||||||
|
@@ -29,6 +29,7 @@ enum ath79_mach_type {
|
||||||
|
ATH79_MACH_AP136_010, /* Atheros AP136-010 reference board */
|
||||||
|
ATH79_MACH_AP136_020, /* Atheros AP136-020 reference board */
|
||||||
|
ATH79_MACH_AP143, /* Atheros AP143 reference board */
|
||||||
|
+ ATH79_MACH_AP147_010, /* Atheros AP147-010 reference board */
|
||||||
|
ATH79_MACH_AP81, /* Atheros AP81 reference board */
|
||||||
|
ATH79_MACH_AP83, /* Atheros AP83 */
|
||||||
|
ATH79_MACH_AP96, /* Atheros AP96 */
|
@ -0,0 +1,42 @@
|
|||||||
|
--- a/arch/mips/ath79/Kconfig
|
||||||
|
+++ b/arch/mips/ath79/Kconfig
|
||||||
|
@@ -118,6 +118,19 @@ config ATH79_MACH_AP143
|
||||||
|
Say 'Y' here if you want your kernel to support the
|
||||||
|
Atheros AP143 reference board.
|
||||||
|
|
||||||
|
+config ATH79_MACH_AP147
|
||||||
|
+ bool "Atheros AP147 reference board"
|
||||||
|
+ select SOC_QCA953X
|
||||||
|
+ select ATH79_DEV_GPIO_BUTTONS
|
||||||
|
+ select ATH79_DEV_LEDS_GPIO
|
||||||
|
+ select ATH79_DEV_M25P80
|
||||||
|
+ select ATH79_DEV_USB
|
||||||
|
+ select ATH79_DEV_WMAC
|
||||||
|
+ select ATH79_DEV_AP9X_PCI if PCI
|
||||||
|
+ help
|
||||||
|
+ Say 'Y' here if you want your kernel to support the
|
||||||
|
+ QCA AP147 reference boards.
|
||||||
|
+
|
||||||
|
config ATH79_MACH_AP81
|
||||||
|
bool "Atheros AP81 reference board"
|
||||||
|
select SOC_AR913X
|
||||||
|
--- a/arch/mips/ath79/Makefile
|
||||||
|
+++ b/arch/mips/ath79/Makefile
|
||||||
|
@@ -47,6 +47,7 @@ obj-$(CONFIG_ATH79_MACH_AP121) += mach-
|
||||||
|
obj-$(CONFIG_ATH79_MACH_AP132) += mach-ap132.o
|
||||||
|
obj-$(CONFIG_ATH79_MACH_AP136) += mach-ap136.o
|
||||||
|
obj-$(CONFIG_ATH79_MACH_AP143) += mach-ap143.o
|
||||||
|
+obj-$(CONFIG_ATH79_MACH_AP147) += mach-ap147.o
|
||||||
|
obj-$(CONFIG_ATH79_MACH_AP81) += mach-ap81.o
|
||||||
|
obj-$(CONFIG_ATH79_MACH_AP83) += mach-ap83.o
|
||||||
|
obj-$(CONFIG_ATH79_MACH_AP96) += mach-ap96.o
|
||||||
|
--- a/arch/mips/ath79/machtypes.h
|
||||||
|
+++ b/arch/mips/ath79/machtypes.h
|
||||||
|
@@ -29,6 +29,7 @@ enum ath79_mach_type {
|
||||||
|
ATH79_MACH_AP136_010, /* Atheros AP136-010 reference board */
|
||||||
|
ATH79_MACH_AP136_020, /* Atheros AP136-020 reference board */
|
||||||
|
ATH79_MACH_AP143, /* Atheros AP143 reference board */
|
||||||
|
+ ATH79_MACH_AP147_010, /* Atheros AP147-010 reference board */
|
||||||
|
ATH79_MACH_AP81, /* Atheros AP81 reference board */
|
||||||
|
ATH79_MACH_AP83, /* Atheros AP83 */
|
||||||
|
ATH79_MACH_AP96, /* Atheros AP96 */
|
Loading…
Reference in New Issue
Block a user