kernel: update to 3.10.49 Signed-off-by: John Crispin <blogic@openwrt.org>
SVN-Revision: 41776
This commit is contained in:
parent
34c9bc0596
commit
ba63338d3f
@ -14,8 +14,8 @@ endif
|
||||
ifeq ($(LINUX_VERSION),3.9.11)
|
||||
LINUX_KERNEL_MD5SUM:=edbf88eb7f7d34dbd5d3887726790755
|
||||
endif
|
||||
ifeq ($(LINUX_VERSION),3.10.44)
|
||||
LINUX_KERNEL_MD5SUM:=8a4006eff3bbd8aff58fe4b443223e7a
|
||||
ifeq ($(LINUX_VERSION),3.10.49)
|
||||
LINUX_KERNEL_MD5SUM:=9774e12764e740d49c80eda77d0ef3eb
|
||||
endif
|
||||
ifeq ($(LINUX_VERSION),3.13.7)
|
||||
LINUX_KERNEL_MD5SUM:=370adced5e5c1cb1d0d621c2dae2723f
|
||||
|
@ -13,7 +13,7 @@ FEATURES:=squashfs atm low_mem
|
||||
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
||||
SUBTARGETS:=generic ac49x
|
||||
|
||||
LINUX_VERSION:=3.10.44
|
||||
LINUX_VERSION:=3.10.49
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
@ -13,7 +13,7 @@ FEATURES:=mips16
|
||||
CPU_TYPE=34kc
|
||||
SUBTARGETS:=generic nand mikrotik
|
||||
|
||||
LINUX_VERSION:=3.10.44
|
||||
LINUX_VERSION:=3.10.49
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
@ -1,48 +0,0 @@
|
||||
From 2ff030d44672d745c5327b72463af43f5103e99b Mon Sep 17 00:00:00 2001
|
||||
From: Gabor Juhos <juhosg@openwrt.org>
|
||||
Date: Tue, 25 Mar 2014 17:07:46 +0100
|
||||
Subject: [PATCH] watchdog: ath79-wdt: avoid spurious restarts on AR934x
|
||||
|
||||
On some AR934x based systems, where the frequency of
|
||||
the AHB bus is relatively high, the built-in watchdog
|
||||
causes a spurious restart when it gets enabled.
|
||||
|
||||
The possible cause of these restarts is that the timeout
|
||||
value written into the TIMER register does not reaches
|
||||
the hardware in time.
|
||||
|
||||
Add an explicit delay into the ath79_wdt_enable function
|
||||
to avoid the spurious restarts.
|
||||
|
||||
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
|
||||
Cc: <stable@vger.kernel.org>
|
||||
---
|
||||
drivers/watchdog/ath79_wdt.c | 10 ++++++++++
|
||||
1 file changed, 10 insertions(+)
|
||||
|
||||
--- a/drivers/watchdog/ath79_wdt.c
|
||||
+++ b/drivers/watchdog/ath79_wdt.c
|
||||
@@ -20,6 +20,7 @@
|
||||
#define pr_fmt(fmt) KBUILD_MODNAME ": " fmt
|
||||
|
||||
#include <linux/bitops.h>
|
||||
+#include <linux/delay.h>
|
||||
#include <linux/errno.h>
|
||||
#include <linux/fs.h>
|
||||
#include <linux/init.h>
|
||||
@@ -91,6 +92,15 @@ static inline void ath79_wdt_keepalive(v
|
||||
static inline void ath79_wdt_enable(void)
|
||||
{
|
||||
ath79_wdt_keepalive();
|
||||
+
|
||||
+ /*
|
||||
+ * Updating the TIMER register requires a few microseconds
|
||||
+ * on the AR934x SoCs at least. Use a small delay to ensure
|
||||
+ * that the TIMER register is updated within the hardware
|
||||
+ * before enabling the watchdog.
|
||||
+ */
|
||||
+ udelay(2);
|
||||
+
|
||||
ath79_wdt_wr(WDOG_REG_CTRL, WDOG_CTRL_ACTION_FCR);
|
||||
/* flush write */
|
||||
ath79_wdt_rr(WDOG_REG_CTRL);
|
@ -13,7 +13,7 @@ BOARDNAME:=Atmel AT91
|
||||
FEATURES:=squashfs targz ext2 usb
|
||||
CPU_TYPE:=arm926ej-s
|
||||
|
||||
LINUX_VERSION:=3.10.44
|
||||
LINUX_VERSION:=3.10.49
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
@ -11,7 +11,7 @@ BOARD:=atheros
|
||||
BOARDNAME:=Atheros AR231x/AR5312
|
||||
FEATURES:=squashfs
|
||||
|
||||
LINUX_VERSION:=3.10.44
|
||||
LINUX_VERSION:=3.10.49
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
@ -13,7 +13,7 @@ FEATURES:=squashfs usb pci
|
||||
SUBTARGETS=au1500 au1550
|
||||
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=3.10.44
|
||||
LINUX_VERSION:=3.10.49
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
DEFAULT_PACKAGES += wpad-mini yamonenv
|
||||
|
@ -12,7 +12,7 @@ BOARDNAME:=Atmel AVR32
|
||||
FEATURES:=squashfs
|
||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=3.10.44
|
||||
LINUX_VERSION:=3.10.49
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
@ -13,7 +13,7 @@ FEATURES:=squashfs usb pci pcie gpio
|
||||
MAINTAINER:=Hauke Mehrtens <hauke@hauke-m.de>
|
||||
CPU_TYPE:=cortex-a9
|
||||
|
||||
LINUX_VERSION:=3.10.44
|
||||
LINUX_VERSION:=3.10.49
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
@ -15,7 +15,7 @@ MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
||||
CPU_TYPE:=arm1176jzf-s
|
||||
CPU_SUBTYPE:=vfp
|
||||
|
||||
LINUX_VERSION:=3.10.44
|
||||
LINUX_VERSION:=3.10.49
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
DEFAULT_PACKAGES += brcm2708-gpu-fw kmod-usb-hid kmod-sound-core kmod-sound-arm-bcm2835
|
||||
|
@ -13,7 +13,7 @@ FEATURES:=squashfs usb
|
||||
SUBTARGETS:=generic mips74k legacy
|
||||
MAINTAINER:=Hauke Mehrtens <hauke@hauke-m.de>
|
||||
|
||||
LINUX_VERSION:=3.10.44
|
||||
LINUX_VERSION:=3.10.49
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
@ -11,7 +11,7 @@ BOARD:=brcm63xx
|
||||
BOARDNAME:=Broadcom BCM63xx
|
||||
SUBTARGETS:=generic smp
|
||||
FEATURES:=squashfs usb atm pci pcmcia usbgadget
|
||||
LINUX_VERSION:=3.10.44
|
||||
LINUX_VERSION:=3.10.49
|
||||
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
@ -12,7 +12,7 @@ BOARDNAME:=Cavium Networks Econa CNS21xx
|
||||
FEATURES:=squashfs
|
||||
CPU_TYPE:=fa526
|
||||
|
||||
LINUX_VERSION:=3.10.44
|
||||
LINUX_VERSION:=3.10.49
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
@ -14,7 +14,7 @@ CPU_TYPE:=cortex-a9
|
||||
CPU_SUBTYPE:=neon
|
||||
MAINTAINER:=Luka Perkov <luka@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=3.10.44
|
||||
LINUX_VERSION:=3.10.49
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
@ -13,7 +13,7 @@ FEATURES:=squashfs
|
||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||
SUBTARGETS=generic harddisk
|
||||
|
||||
LINUX_VERSION:=3.10.44
|
||||
LINUX_VERSION:=3.10.49
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
@ -13,7 +13,7 @@ FEATURES:=targz usb jffs2_nand nand ubifs
|
||||
CPU_TYPE:=xscale
|
||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=3.10.44
|
||||
LINUX_VERSION:=3.10.49
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
@ -11,7 +11,7 @@ BOARDNAME:=Lantiq
|
||||
FEATURES:=squashfs
|
||||
SUBTARGETS=xway xrx200
|
||||
|
||||
LINUX_VERSION:=3.10.44
|
||||
LINUX_VERSION:=3.10.49
|
||||
|
||||
CPU_TYPE:=mips32r2
|
||||
|
||||
|
@ -12,7 +12,7 @@ SUBTARGETS:=le be le64 be64
|
||||
INITRAMFS_EXTRA_FILES:=
|
||||
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=3.10.44
|
||||
LINUX_VERSION:=3.10.49
|
||||
|
||||
DEVICE_TYPE:=developerboard
|
||||
|
||||
|
@ -14,7 +14,7 @@ FEATURES:=spe_fpu squashfs
|
||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||
SUBTARGETS=generic p1020
|
||||
|
||||
LINUX_VERSION:=3.10.44
|
||||
LINUX_VERSION:=3.10.49
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
@ -14,7 +14,7 @@ CPU_TYPE:=octeon
|
||||
CPU_CFLAGS_octeon:=-march=octeon -mabi=64
|
||||
MAINTAINER:=John Crispin <blogic@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=3.10.44
|
||||
LINUX_VERSION:=3.10.49
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
@ -13,7 +13,7 @@ FEATURES:=squashfs
|
||||
CPU_TYPE:=405
|
||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=3.10.44
|
||||
LINUX_VERSION:=3.10.49
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
@ -13,7 +13,7 @@ FEATURES:=squashfs broken
|
||||
CPU_TYPE:=440
|
||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=3.10.44
|
||||
LINUX_VERSION:=3.10.49
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
@ -12,7 +12,7 @@ BOARDNAME:=Ralink RT288x/RT3xxx
|
||||
SUBTARGETS:=rt305x mt7620a mt7620n mt7621 rt3883 rt288x
|
||||
FEATURES:=squashfs gpio
|
||||
|
||||
LINUX_VERSION:=3.10.44
|
||||
LINUX_VERSION:=3.10.49
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
DEFAULT_PACKAGES += \
|
||||
|
@ -11,7 +11,7 @@ BOARD:=rb532
|
||||
BOARDNAME:=Mikrotik RouterBoard 532
|
||||
FEATURES:=pci targz
|
||||
|
||||
LINUX_VERSION:=3.10.44
|
||||
LINUX_VERSION:=3.10.49
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
DEFAULT_PACKAGES += wpad-mini kmod-madwifi kmod-input-rb532
|
||||
|
@ -14,7 +14,7 @@ CPU_TYPE:=mpcore
|
||||
CPU_SUBTYPE:=vfp
|
||||
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=3.10.44
|
||||
LINUX_VERSION:=3.10.49
|
||||
|
||||
DEVICE_TYPE:=developerboard
|
||||
|
||||
|
@ -11,7 +11,7 @@ BOARD:=sparc
|
||||
BOARDNAME:=Sun UltraSPARC
|
||||
FEATURES+=fpu tgz ext4 squashfs broken
|
||||
|
||||
LINUX_VERSION:=3.10.44
|
||||
LINUX_VERSION:=3.10.49
|
||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
@ -23,7 +23,7 @@ BOARDNAME:=User Mode Linux
|
||||
FEATURES:=ext4 audio
|
||||
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=3.10.44
|
||||
LINUX_VERSION:=3.10.49
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
@ -13,7 +13,7 @@ FEATURES:=squashfs ext4 vdi vmdk pcmcia targz
|
||||
SUBTARGETS=generic olpc xen_domu ep80579 net5501 kvm_guest geos alix2 thincan \
|
||||
rdc
|
||||
|
||||
LINUX_VERSION:=3.10.44
|
||||
LINUX_VERSION:=3.10.49
|
||||
|
||||
KERNELNAME:=bzImage
|
||||
|
||||
|
@ -12,7 +12,7 @@ BOARDNAME:=Ingenic XBurst
|
||||
FEATURES:=targz nand ubifs audio
|
||||
SUBTARGETS:=qi_lb60 n516 n526 id800wt
|
||||
|
||||
LINUX_VERSION:=3.10.44
|
||||
LINUX_VERSION:=3.10.49
|
||||
|
||||
DEVICE_TYPE=other
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user