kernel: refresh patches for 4.1
Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 46441
This commit is contained in:
parent
02198322b9
commit
cc42b1049b
@ -11,7 +11,7 @@ Subject: [PATCH 033/121] config: Enable CONFIG_MEMCG, but leave it disabled
|
|||||||
|
|
||||||
--- a/kernel/cgroup.c
|
--- a/kernel/cgroup.c
|
||||||
+++ b/kernel/cgroup.c
|
+++ b/kernel/cgroup.c
|
||||||
@@ -5395,6 +5395,29 @@ static int __init cgroup_disable(char *s
|
@@ -5393,6 +5393,29 @@ static int __init cgroup_disable(char *s
|
||||||
}
|
}
|
||||||
__setup("cgroup_disable=", cgroup_disable);
|
__setup("cgroup_disable=", cgroup_disable);
|
||||||
|
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- a/drivers/rtc/Kconfig
|
--- a/drivers/rtc/Kconfig
|
||||||
+++ b/drivers/rtc/Kconfig
|
+++ b/drivers/rtc/Kconfig
|
||||||
@@ -1182,6 +1182,15 @@ config RTC_DRV_BFIN
|
@@ -1300,6 +1300,15 @@ config RTC_DRV_BFIN
|
||||||
This driver can also be built as a module. If so, the module
|
This driver can also be built as a module. If so, the module
|
||||||
will be called rtc-bfin.
|
will be called rtc-bfin.
|
||||||
|
|
||||||
@ -18,7 +18,7 @@
|
|||||||
depends on SH_LANDISK
|
depends on SH_LANDISK
|
||||||
--- a/drivers/rtc/Makefile
|
--- a/drivers/rtc/Makefile
|
||||||
+++ b/drivers/rtc/Makefile
|
+++ b/drivers/rtc/Makefile
|
||||||
@@ -60,6 +60,7 @@ obj-$(CONFIG_RTC_DRV_EFI) += rtc-efi.o
|
@@ -65,6 +65,7 @@ obj-$(CONFIG_RTC_DRV_EFI) += rtc-efi.o
|
||||||
obj-$(CONFIG_RTC_DRV_EM3027) += rtc-em3027.o
|
obj-$(CONFIG_RTC_DRV_EM3027) += rtc-em3027.o
|
||||||
obj-$(CONFIG_RTC_DRV_EP93XX) += rtc-ep93xx.o
|
obj-$(CONFIG_RTC_DRV_EP93XX) += rtc-ep93xx.o
|
||||||
obj-$(CONFIG_RTC_DRV_FM3130) += rtc-fm3130.o
|
obj-$(CONFIG_RTC_DRV_FM3130) += rtc-fm3130.o
|
||||||
@ -28,7 +28,7 @@
|
|||||||
obj-$(CONFIG_RTC_DRV_HYM8563) += rtc-hym8563.o
|
obj-$(CONFIG_RTC_DRV_HYM8563) += rtc-hym8563.o
|
||||||
--- a/arch/arm/mach-gemini/common.h
|
--- a/arch/arm/mach-gemini/common.h
|
||||||
+++ b/arch/arm/mach-gemini/common.h
|
+++ b/arch/arm/mach-gemini/common.h
|
||||||
@@ -18,9 +18,9 @@ extern void gemini_map_io(void);
|
@@ -20,9 +20,9 @@ extern void gemini_map_io(void);
|
||||||
extern void gemini_init_irq(void);
|
extern void gemini_init_irq(void);
|
||||||
extern void gemini_timer_init(void);
|
extern void gemini_timer_init(void);
|
||||||
extern void gemini_gpio_init(void);
|
extern void gemini_gpio_init(void);
|
||||||
|
@ -181,10 +181,9 @@
|
|||||||
|
|
||||||
static struct irqaction gemini_timer_irq = {
|
static struct irqaction gemini_timer_irq = {
|
||||||
- .name = "Gemini Timer Tick",
|
- .name = "Gemini Timer Tick",
|
||||||
- .flags = IRQF_TIMER,
|
|
||||||
- .handler = gemini_timer_interrupt,
|
|
||||||
+ .name = "gemini timer 1",
|
+ .name = "gemini timer 1",
|
||||||
+ .flags = IRQF_TIMER,
|
.flags = IRQF_TIMER,
|
||||||
|
- .handler = gemini_timer_interrupt,
|
||||||
+ .handler = gemini_timer_intr,
|
+ .handler = gemini_timer_intr,
|
||||||
};
|
};
|
||||||
|
|
||||||
|
@ -5514,7 +5514,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
|
|||||||
(transaction layer end-to-end CRC checking).
|
(transaction layer end-to-end CRC checking).
|
||||||
--- a/include/linux/pci.h
|
--- a/include/linux/pci.h
|
||||||
+++ b/include/linux/pci.h
|
+++ b/include/linux/pci.h
|
||||||
@@ -1175,6 +1175,8 @@ void pci_walk_bus(struct pci_bus *top, i
|
@@ -1177,6 +1177,8 @@ void pci_walk_bus(struct pci_bus *top, i
|
||||||
void *userdata);
|
void *userdata);
|
||||||
int pci_cfg_space_size(struct pci_dev *dev);
|
int pci_cfg_space_size(struct pci_dev *dev);
|
||||||
unsigned char pci_bus_max_busnr(struct pci_bus *bus);
|
unsigned char pci_bus_max_busnr(struct pci_bus *bus);
|
||||||
|
Loading…
Reference in New Issue
Block a user