mac80211: update to wireless-testing 2012-02-23
SVN-Revision: 30742
This commit is contained in:
parent
8ad6213f59
commit
e3ec30cad1
@ -10,10 +10,10 @@ include $(INCLUDE_DIR)/kernel.mk
|
||||
|
||||
PKG_NAME:=mac80211
|
||||
|
||||
PKG_VERSION:=2012-02-06
|
||||
PKG_RELEASE:=4
|
||||
PKG_VERSION:=2012-02-23
|
||||
PKG_RELEASE:=1
|
||||
PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources
|
||||
PKG_MD5SUM:=fae71c35ee3f3de6329f2db7aed6d265
|
||||
PKG_MD5SUM:=dc01b316954e7c9f2ea50c09bb68138e
|
||||
|
||||
PKG_SOURCE:=compat-wireless-$(PKG_VERSION).tar.bz2
|
||||
PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/compat-wireless-$(PKG_VERSION)
|
||||
@ -1303,7 +1303,7 @@ endef
|
||||
ifneq ($(CONFIG_PACKAGE_kmod-cfg80211)$(CONFIG_PACKAGE_kmod-lib80211),)
|
||||
define Build/Compile/kmod
|
||||
rm -rf $(PKG_BUILD_DIR)/modules
|
||||
$(MAKE) $(PKG_JOBS) -C "$(PKG_BUILD_DIR)" $(MAKE_OPTS) all
|
||||
$(MAKE) $(PKG_JOBS) -C "$(PKG_BUILD_DIR)" $(MAKE_OPTS) modules
|
||||
endef
|
||||
endif
|
||||
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -32,9 +32,6 @@ obj-$(CONFIG_COMPAT_WIRELESS_MODULES) +=
|
||||
@@ -26,9 +26,6 @@ obj-$(CONFIG_COMPAT_WIRELESS_MODULES) +=
|
||||
|
||||
obj-$(CONFIG_COMPAT_NET_USB_MODULES) += drivers/net/usb/
|
||||
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- a/config.mk
|
||||
+++ b/config.mk
|
||||
@@ -380,8 +380,8 @@ CONFIG_B43_BCMA_EXTRA=y
|
||||
@@ -368,8 +368,8 @@ CONFIG_B43_BCMA_EXTRA=y
|
||||
|
||||
CONFIG_P54_PCI=m
|
||||
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- a/config.mk
|
||||
+++ b/config.mk
|
||||
@@ -95,7 +95,7 @@ endif # build check
|
||||
@@ -83,7 +83,7 @@ endif # build check
|
||||
endif # kernel Makefile check
|
||||
|
||||
# These both are needed by compat-wireless || compat-bluetooth so enable them
|
||||
@ -9,7 +9,7 @@
|
||||
|
||||
ifeq ($(CONFIG_MAC80211),y)
|
||||
$(error "ERROR: you have MAC80211 compiled into the kernel, CONFIG_MAC80211=y, as such you cannot replace its mac80211 driver. You need this set to CONFIG_MAC80211=m. If you are using Fedora upgrade your kernel as later version should this set as modular. For further information on Fedora see https://bugzilla.redhat.com/show_bug.cgi?id=470143. If you are using your own kernel recompile it and make mac80211 modular")
|
||||
@@ -684,10 +684,10 @@ endif #CONFIG_COMPAT_KERNEL_2_6_27
|
||||
@@ -674,10 +674,10 @@ endif #CONFIG_COMPAT_KERNEL_2_6_27
|
||||
# We need the backported rfkill module on kernel < 2.6.31.
|
||||
# In more recent kernel versions use the in kernel rfkill module.
|
||||
ifdef CONFIG_COMPAT_KERNEL_2_6_31
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- a/config.mk
|
||||
+++ b/config.mk
|
||||
@@ -117,8 +117,8 @@ ifndef CONFIG_COMPAT_KERNEL_2_6_27
|
||||
@@ -105,8 +105,8 @@ ifndef CONFIG_COMPAT_KERNEL_2_6_27
|
||||
ifeq ($(CONFIG_BT),y)
|
||||
# we'll ignore compiling bluetooth
|
||||
else
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -32,7 +32,6 @@ obj-$(CONFIG_COMPAT_WIRELESS_MODULES) +=
|
||||
@@ -26,7 +26,6 @@ obj-$(CONFIG_COMPAT_WIRELESS_MODULES) +=
|
||||
|
||||
obj-$(CONFIG_COMPAT_NET_USB_MODULES) += drivers/net/usb/
|
||||
|
||||
@ -18,7 +18,7 @@
|
||||
else
|
||||
include $(KLIB_BUILD)/.config
|
||||
endif
|
||||
@@ -356,7 +355,8 @@ CONFIG_IPW2200_QOS=y
|
||||
@@ -344,7 +343,8 @@ CONFIG_IPW2200_QOS=y
|
||||
# % echo 1 > /sys/bus/pci/drivers/ipw2200/*/rtap_iface
|
||||
endif #CONFIG_WIRELESS_EXT
|
||||
|
||||
@ -28,7 +28,7 @@
|
||||
# Sonics Silicon Backplane
|
||||
CONFIG_SSB_SPROM=y
|
||||
|
||||
@@ -369,7 +369,7 @@ endif #CONFIG_PCMCIA
|
||||
@@ -357,7 +357,7 @@ endif #CONFIG_PCMCIA
|
||||
# CONFIG_SSB_DEBUG=y
|
||||
CONFIG_SSB_DRIVER_PCICORE=y
|
||||
CONFIG_B43_SSB=y
|
||||
@ -37,7 +37,7 @@
|
||||
|
||||
CONFIG_BCMA=m
|
||||
CONFIG_BCMA_BLOCKIO=y
|
||||
@@ -578,7 +578,6 @@ endif #CONFIG_SPI_MASTER end of SPI driv
|
||||
@@ -568,7 +568,6 @@ endif #CONFIG_SPI_MASTER end of SPI driv
|
||||
|
||||
ifdef CONFIG_MMC
|
||||
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -32,7 +32,6 @@ obj-$(CONFIG_COMPAT_WIRELESS_MODULES) +=
|
||||
@@ -26,7 +26,6 @@ obj-$(CONFIG_COMPAT_WIRELESS_MODULES) +=
|
||||
|
||||
obj-$(CONFIG_COMPAT_NET_USB_MODULES) += drivers/net/usb/
|
||||
|
||||
@ -10,7 +10,7 @@
|
||||
ifeq ($(CONFIG_STAGING_EXCLUDE_BUILD),)
|
||||
--- a/config.mk
|
||||
+++ b/config.mk
|
||||
@@ -371,12 +371,12 @@ CONFIG_SSB_DRIVER_PCICORE=y
|
||||
@@ -359,12 +359,12 @@ CONFIG_SSB_DRIVER_PCICORE=y
|
||||
CONFIG_B43_SSB=y
|
||||
endif #__CONFIG_SSB
|
||||
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- a/config.mk
|
||||
+++ b/config.mk
|
||||
@@ -254,7 +254,7 @@ $(warning "WARNING: CONFIG_CFG80211_WEXT
|
||||
@@ -242,7 +242,7 @@ $(warning "WARNING: CONFIG_CFG80211_WEXT
|
||||
endif #CONFIG_WIRELESS_EXT
|
||||
|
||||
ifdef CONFIG_STAGING
|
||||
@ -9,7 +9,7 @@
|
||||
endif #CONFIG_STAGING
|
||||
|
||||
# mac80211 test driver
|
||||
@@ -408,13 +408,13 @@ endif #CONFIG_CRC_ITU_T
|
||||
@@ -396,15 +396,15 @@ endif #CONFIG_CRC_ITU_T
|
||||
CONFIG_MWL8K=m
|
||||
|
||||
# Ethernet drivers go here
|
||||
@ -21,14 +21,18 @@
|
||||
+# CONFIG_ATL1E=m
|
||||
ifdef CONFIG_COMPAT_KERNEL_2_6_27
|
||||
-CONFIG_ATL1C=n
|
||||
-CONFIG_ALX=m
|
||||
+# CONFIG_ATL1C=n
|
||||
+# CONFIG_ALX=m
|
||||
else #CONFIG_COMPAT_KERNEL_2_6_27
|
||||
-CONFIG_ATL1C=m
|
||||
+# CONFIG_ATL1C=m
|
||||
-CONFIG_ATL1C=n
|
||||
-CONFIG_ALX=m
|
||||
+# CONFIG_ATL1C=n
|
||||
+# CONFIG_ALX=m
|
||||
endif #CONFIG_COMPAT_KERNEL_2_6_27
|
||||
|
||||
ifdef CONFIG_WIRELESS_EXT
|
||||
@@ -475,21 +475,21 @@ endif #CONFIG_COMPAT_KERNEL_2_6_29
|
||||
@@ -465,21 +465,21 @@ endif #CONFIG_COMPAT_KERNEL_2_6_29
|
||||
# Note: this depends on CONFIG_USB_NET_RNDIS_HOST and CONFIG_USB_NET_CDCETHER
|
||||
# it also requires new RNDIS_HOST and CDC_ETHER modules which we add
|
||||
ifdef CONFIG_COMPAT_KERNEL_2_6_29
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- a/config.mk
|
||||
+++ b/config.mk
|
||||
@@ -192,7 +192,7 @@ CONFIG_MAC80211_LEDS=y
|
||||
@@ -180,7 +180,7 @@ CONFIG_MAC80211_LEDS=y
|
||||
endif #CONFIG_LEDS_TRIGGERS
|
||||
|
||||
# enable mesh networking too
|
||||
|
@ -1,26 +1,11 @@
|
||||
--- a/config.mk
|
||||
+++ b/config.mk
|
||||
@@ -58,23 +58,6 @@ $(error "ERROR: Your 2.6.27 kernel has C
|
||||
endif
|
||||
endif
|
||||
|
||||
-# This is because with CONFIG_MAC80211 include/linux/skbuff.h will
|
||||
-# enable on 2.6.27 a new attribute:
|
||||
-#
|
||||
-# skb->do_not_encrypt
|
||||
-#
|
||||
-# and on 2.6.28 another new attribute:
|
||||
-#
|
||||
-# skb->requeue
|
||||
-#
|
||||
-# In kernel 2.6.32 both attributes were removed.
|
||||
-#
|
||||
-ifeq ($(shell test $(KERNEL_VERSION) -eq 2 -a $(KERNEL_SUBLEVEL) -ge 27 -a $(KERNEL_SUBLEVEL) -le 31 && echo yes),yes)
|
||||
-ifeq ($(CONFIG_MAC80211),)
|
||||
@@ -58,7 +58,7 @@ endif
|
||||
ifeq ($(KERNEL_VERSION),2)
|
||||
ifeq ($(shell test $(KERNEL_VERSION) -eq 2 -a $(KERNEL_26SUBLEVEL) -ge 27 -a $(KERNEL_26SUBLEVEL) -le 31 && echo yes),yes)
|
||||
ifeq ($(CONFIG_MAC80211),)
|
||||
-$(error "ERROR: Your >=2.6.27 and <= 2.6.31 kernel has CONFIG_MAC80211 disabled, you should have it CONFIG_MAC80211=m if you want to use this thing.")
|
||||
-endif
|
||||
-endif
|
||||
-
|
||||
ifneq ($(KERNELRELEASE),) # This prevents a warning
|
||||
|
||||
# We will warn when you don't have MQ support or NET_SCHED enabled.
|
||||
+# $(error "ERROR: Your >=2.6.27 and <= 2.6.31 kernel has CONFIG_MAC80211 disabled, you should have it CONFIG_MAC80211=m if you want to use this thing.")
|
||||
endif
|
||||
endif
|
||||
endif
|
||||
|
@ -9,7 +9,7 @@
|
||||
else
|
||||
include $(KLIB_BUILD)/.config
|
||||
endif
|
||||
@@ -289,7 +289,7 @@ CONFIG_B43=m
|
||||
@@ -294,7 +294,7 @@ CONFIG_B43=m
|
||||
CONFIG_B43_HWRNG=y
|
||||
CONFIG_B43_PCI_AUTOSELECT=y
|
||||
ifdef CONFIG_PCMCIA
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- a/config.mk
|
||||
+++ b/config.mk
|
||||
@@ -561,7 +561,7 @@ endif #CONFIG_SPI_MASTER end of SPI driv
|
||||
@@ -568,7 +568,7 @@ endif #CONFIG_SPI_MASTER end of SPI driv
|
||||
|
||||
ifdef CONFIG_MMC
|
||||
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- a/config.mk
|
||||
+++ b/config.mk
|
||||
@@ -295,8 +295,8 @@ ifdef CONFIG_MAC80211_LEDS
|
||||
@@ -300,8 +300,8 @@ ifdef CONFIG_MAC80211_LEDS
|
||||
CONFIG_B43_LEDS=y
|
||||
endif #CONFIG_MAC80211_LEDS
|
||||
CONFIG_B43_PHY_LP=y
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- a/config.mk
|
||||
+++ b/config.mk
|
||||
@@ -370,7 +370,7 @@ CONFIG_RTL8180=m
|
||||
@@ -375,7 +375,7 @@ CONFIG_RTL8180=m
|
||||
|
||||
CONFIG_ADM8211=m
|
||||
|
||||
@ -9,7 +9,7 @@
|
||||
CONFIG_RT2400PCI=m
|
||||
CONFIG_RT2500PCI=m
|
||||
ifdef CONFIG_CRC_CCITT
|
||||
@@ -510,7 +510,7 @@ CONFIG_RT2800USB_RT35XX=y
|
||||
@@ -517,7 +517,7 @@ CONFIG_RT2800USB_RT35XX=y
|
||||
CONFIG_RT2800USB_RT53XX=y
|
||||
CONFIG_RT2800USB_UNKNOWN=y
|
||||
endif #CONFIG_CRC_CCITT
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- a/config.mk
|
||||
+++ b/config.mk
|
||||
@@ -167,7 +167,7 @@ CONFIG_MAC80211_RC_DEFAULT_MINSTREL=y
|
||||
@@ -172,7 +172,7 @@ CONFIG_MAC80211_RC_DEFAULT_MINSTREL=y
|
||||
# This is the one used by our compat-wireless net/mac80211/rate.c
|
||||
# in case you have and old kernel which is overriding this to pid.
|
||||
CONFIG_COMPAT_MAC80211_RC_DEFAULT=minstrel_ht
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- a/config.mk
|
||||
+++ b/config.mk
|
||||
@@ -261,7 +261,7 @@ CONFIG_ATH9K_COMMON=m
|
||||
@@ -266,7 +266,7 @@ CONFIG_ATH9K_COMMON=m
|
||||
# as default once we get minstrel properly tested and blessed by
|
||||
# our systems engineering team. CCK rates also need to be used
|
||||
# for long range considerations.
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- a/config.mk
|
||||
+++ b/config.mk
|
||||
@@ -268,7 +268,7 @@ CONFIG_ATH9K_BTCOEX_SUPPORT=y
|
||||
@@ -273,7 +273,7 @@ CONFIG_ATH9K_BTCOEX_SUPPORT=y
|
||||
# PCI Drivers
|
||||
ifdef CONFIG_PCI
|
||||
|
||||
|
@ -31,7 +31,7 @@
|
||||
struct pcmcia_device *p_dev;
|
||||
--- a/include/linux/compat-2.6.28.h
|
||||
+++ b/include/linux/compat-2.6.28.h
|
||||
@@ -27,7 +27,7 @@
|
||||
@@ -44,7 +44,7 @@ typedef u32 phys_addr_t;
|
||||
})
|
||||
#endif /* From include/asm-generic/bug.h */
|
||||
|
||||
|
@ -22,7 +22,7 @@
|
||||
* @anchor: anchor the requests are bound to
|
||||
--- a/include/linux/compat-2.6.28.h
|
||||
+++ b/include/linux/compat-2.6.28.h
|
||||
@@ -52,7 +52,7 @@ int pcmcia_loop_config(struct pcmcia_dev
|
||||
@@ -69,7 +69,7 @@ int pcmcia_loop_config(struct pcmcia_dev
|
||||
/* USB anchors were added as of 2.6.23 */
|
||||
#if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,23))
|
||||
|
||||
@ -33,7 +33,7 @@
|
||||
#endif
|
||||
--- a/config.mk
|
||||
+++ b/config.mk
|
||||
@@ -496,7 +496,7 @@ endif #CONFIG_COMPAT_KERNEL_2_6_29
|
||||
@@ -503,7 +503,7 @@ endif #CONFIG_COMPAT_KERNEL_2_6_29
|
||||
# This activates a threading fix for usb urb.
|
||||
# this is mainline commit: b3e670443b7fb8a2d29831b62b44a039c283e351
|
||||
# This fix will be included in some stable releases.
|
||||
|
@ -1,22 +0,0 @@
|
||||
--- a/config.mk
|
||||
+++ b/config.mk
|
||||
@@ -20,16 +20,16 @@ COMPAT_LATEST_VERSION = 3
|
||||
KERNEL_VERSION := $(shell $(MAKE) -C $(KLIB_BUILD) kernelversion | sed -n 's/^\([0-9]\)\..*/\1/p')
|
||||
|
||||
ifneq ($(KERNEL_VERSION),2)
|
||||
-KERNEL_SUBLEVEL := $(shell $(MAKE) -C $(KLIB_BUILD) kernelversion | sed -n 's/^3\.\([0-9]\+\).*/\1/p')
|
||||
+COMPAT_KERNEL_SUBLEVEL := $(shell $(MAKE) -C $(KLIB_BUILD) kernelversion | sed -n 's/^3\.\([0-9]\+\).*/\1/p')
|
||||
else
|
||||
COMPAT_26LATEST_VERSION = 39
|
||||
KERNEL_26SUBLEVEL := $(shell $(MAKE) -C $(KLIB_BUILD) kernelversion | sed -n 's/^2\.6\.\([0-9]\+\).*/\1/p')
|
||||
COMPAT_26VERSIONS := $(shell I=$(COMPAT_26LATEST_VERSION); while [ "$$I" -gt $(KERNEL_26SUBLEVEL) ]; do echo $$I; I=$$(($$I - 1)); done)
|
||||
$(foreach ver,$(COMPAT_26VERSIONS),$(eval CONFIG_COMPAT_KERNEL_2_6_$(ver)=y))
|
||||
-KERNEL_SUBLEVEL := -1
|
||||
+COMPAT_KERNEL_SUBLEVEL := -1
|
||||
endif
|
||||
|
||||
-COMPAT_VERSIONS := $(shell I=$(COMPAT_LATEST_VERSION); while [ "$$I" -gt $(KERNEL_SUBLEVEL) ]; do echo $$I; I=$$(($$I - 1)); done)
|
||||
+COMPAT_VERSIONS := $(shell I=$(COMPAT_LATEST_VERSION); while [ "$$I" -gt $(COMPAT_KERNEL_SUBLEVEL) ]; do echo $$I; I=$$(($$I - 1)); done)
|
||||
$(foreach ver,$(COMPAT_VERSIONS),$(eval CONFIG_COMPAT_KERNEL_3_$(ver)=y))
|
||||
|
||||
RHEL_MAJOR := $(shell grep ^RHEL_MAJOR $(KLIB_BUILD)/Makefile | sed -n 's/.*= *\(.*\)/\1/p')
|
File diff suppressed because it is too large
Load Diff
@ -1,6 +1,6 @@
|
||||
--- a/drivers/net/wireless/ath/ath9k/main.c
|
||||
+++ b/drivers/net/wireless/ath/ath9k/main.c
|
||||
@@ -1454,15 +1454,6 @@ static int ath9k_add_interface(struct ie
|
||||
@@ -1450,15 +1450,6 @@ static int ath9k_add_interface(struct ie
|
||||
}
|
||||
}
|
||||
|
||||
@ -16,7 +16,7 @@
|
||||
ath_dbg(common, CONFIG, "Attach a VIF of type: %d\n", vif->type);
|
||||
|
||||
sc->nvifs++;
|
||||
@@ -1487,15 +1478,6 @@ static int ath9k_change_interface(struct
|
||||
@@ -1483,15 +1474,6 @@ static int ath9k_change_interface(struct
|
||||
mutex_lock(&sc->mutex);
|
||||
ath9k_ps_wakeup(sc);
|
||||
|
||||
|
@ -81,7 +81,7 @@
|
||||
sc->debug.sampidx = 0;
|
||||
--- a/drivers/net/wireless/ath/ath9k/main.c
|
||||
+++ b/drivers/net/wireless/ath/ath9k/main.c
|
||||
@@ -1559,7 +1559,7 @@ static void ath9k_disable_ps(struct ath_
|
||||
@@ -1555,7 +1555,7 @@ static void ath9k_disable_ps(struct ath_
|
||||
|
||||
}
|
||||
|
||||
@ -90,7 +90,7 @@
|
||||
{
|
||||
struct ath_softc *sc = hw->priv;
|
||||
struct ath_hw *ah = sc->sc_ah;
|
||||
@@ -1609,9 +1609,11 @@ static int ath9k_config(struct ieee80211
|
||||
@@ -1599,9 +1599,11 @@ static int ath9k_config(struct ieee80211
|
||||
|
||||
if (changed & IEEE80211_CONF_CHANGE_CHANNEL) {
|
||||
struct ieee80211_channel *curchan = hw->conf.channel;
|
||||
@ -102,7 +102,7 @@
|
||||
|
||||
if (ah->curchan)
|
||||
old_pos = ah->curchan - &ah->channels[0];
|
||||
@@ -1659,7 +1661,23 @@ static int ath9k_config(struct ieee80211
|
||||
@@ -1649,7 +1651,23 @@ static int ath9k_config(struct ieee80211
|
||||
memset(&sc->survey[pos], 0, sizeof(struct survey_info));
|
||||
}
|
||||
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- a/net/mac80211/iface.c
|
||||
+++ b/net/mac80211/iface.c
|
||||
@@ -686,6 +686,7 @@ static const struct net_device_ops ieee8
|
||||
@@ -688,6 +688,7 @@ static const struct net_device_ops ieee8
|
||||
static void ieee80211_if_setup(struct net_device *dev)
|
||||
{
|
||||
ether_setup(dev);
|
||||
|
@ -11,7 +11,7 @@
|
||||
u16 listen_interval;
|
||||
--- a/net/mac80211/cfg.c
|
||||
+++ b/net/mac80211/cfg.c
|
||||
@@ -1739,7 +1739,7 @@ static int ieee80211_get_tx_power(struct
|
||||
@@ -1711,7 +1711,7 @@ static int ieee80211_get_tx_power(struct
|
||||
{
|
||||
struct ieee80211_local *local = wiphy_priv(wiphy);
|
||||
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- a/drivers/net/wireless/ath/ath9k/main.c
|
||||
+++ b/drivers/net/wireless/ath/ath9k/main.c
|
||||
@@ -1683,6 +1683,8 @@ int ath9k_config(struct ieee80211_hw *hw
|
||||
@@ -1673,6 +1673,8 @@ int ath9k_config(struct ieee80211_hw *hw
|
||||
return -EINVAL;
|
||||
}
|
||||
|
||||
@ -9,7 +9,7 @@
|
||||
/*
|
||||
* The most recent snapshot of channel->noisefloor for the old
|
||||
* channel is only available after the hardware reset. Copy it to
|
||||
@@ -1697,6 +1699,7 @@ int ath9k_config(struct ieee80211_hw *hw
|
||||
@@ -1687,6 +1689,7 @@ int ath9k_config(struct ieee80211_hw *hw
|
||||
sc->config.txpowlimit = 2 * conf->power_level;
|
||||
ath9k_cmn_update_txpow(ah, sc->curtxpow,
|
||||
sc->config.txpowlimit, &sc->curtxpow);
|
||||
|
@ -78,7 +78,7 @@
|
||||
kfree(sta);
|
||||
--- a/include/net/cfg80211.h
|
||||
+++ b/include/net/cfg80211.h
|
||||
@@ -508,6 +508,8 @@ struct station_parameters {
|
||||
@@ -518,6 +518,8 @@ struct station_parameters {
|
||||
* @STATION_INFO_ASSOC_REQ_IES: @assoc_req_ies filled
|
||||
* @STATION_INFO_STA_FLAGS: @sta_flags filled
|
||||
* @STATION_INFO_BEACON_LOSS_COUNT: @beacon_loss_count filled
|
||||
@ -87,7 +87,7 @@
|
||||
*/
|
||||
enum station_info_flags {
|
||||
STATION_INFO_INACTIVE_TIME = 1<<0,
|
||||
@@ -529,7 +531,9 @@ enum station_info_flags {
|
||||
@@ -539,7 +541,9 @@ enum station_info_flags {
|
||||
STATION_INFO_CONNECTED_TIME = 1<<16,
|
||||
STATION_INFO_ASSOC_REQ_IES = 1<<17,
|
||||
STATION_INFO_STA_FLAGS = 1<<18,
|
||||
@ -98,7 +98,7 @@
|
||||
};
|
||||
|
||||
/**
|
||||
@@ -609,6 +613,9 @@ struct sta_bss_parameters {
|
||||
@@ -619,6 +623,9 @@ struct sta_bss_parameters {
|
||||
* @plink_state: mesh peer link state
|
||||
* @signal: signal strength of last received packet in dBm
|
||||
* @signal_avg: signal strength average in dBm
|
||||
@ -108,7 +108,7 @@
|
||||
* @txrate: current unicast bitrate from this station
|
||||
* @rxrate: current unicast bitrate to this station
|
||||
* @rx_packets: packets received from this station
|
||||
@@ -640,6 +647,11 @@ struct station_info {
|
||||
@@ -650,6 +657,11 @@ struct station_info {
|
||||
u8 plink_state;
|
||||
s8 signal;
|
||||
s8 signal_avg;
|
||||
@ -271,7 +271,7 @@
|
||||
RX_SAMP_DBG(rate) = rs->rs_rate;
|
||||
--- a/include/linux/nl80211.h
|
||||
+++ b/include/linux/nl80211.h
|
||||
@@ -1657,6 +1657,8 @@ enum nl80211_sta_bss_param {
|
||||
@@ -1661,6 +1661,8 @@ enum nl80211_sta_bss_param {
|
||||
* @NL80211_STA_INFO_CONNECTED_TIME: time since the station is last connected
|
||||
* @NL80211_STA_INFO_STA_FLAGS: Contains a struct nl80211_sta_flag_update.
|
||||
* @NL80211_STA_INFO_BEACON_LOSS: count of times beacon loss was detected (u32)
|
||||
@ -280,7 +280,7 @@
|
||||
* @__NL80211_STA_INFO_AFTER_LAST: internal
|
||||
* @NL80211_STA_INFO_MAX: highest possible station info attribute
|
||||
*/
|
||||
@@ -1680,6 +1682,8 @@ enum nl80211_sta_info {
|
||||
@@ -1684,6 +1686,8 @@ enum nl80211_sta_info {
|
||||
NL80211_STA_INFO_CONNECTED_TIME,
|
||||
NL80211_STA_INFO_STA_FLAGS,
|
||||
NL80211_STA_INFO_BEACON_LOSS,
|
||||
@ -291,7 +291,7 @@
|
||||
__NL80211_STA_INFO_AFTER_LAST,
|
||||
--- a/net/wireless/nl80211.c
|
||||
+++ b/net/wireless/nl80211.c
|
||||
@@ -2347,6 +2347,33 @@ nla_put_failure:
|
||||
@@ -2376,6 +2376,33 @@ nla_put_failure:
|
||||
return false;
|
||||
}
|
||||
|
||||
@ -325,7 +325,7 @@
|
||||
static int nl80211_send_station(struct sk_buff *msg, u32 pid, u32 seq,
|
||||
int flags, struct net_device *dev,
|
||||
const u8 *mac_addr, struct station_info *sinfo)
|
||||
@@ -2393,6 +2420,18 @@ static int nl80211_send_station(struct s
|
||||
@@ -2422,6 +2449,18 @@ static int nl80211_send_station(struct s
|
||||
if (sinfo->filled & STATION_INFO_SIGNAL_AVG)
|
||||
NLA_PUT_U8(msg, NL80211_STA_INFO_SIGNAL_AVG,
|
||||
sinfo->signal_avg);
|
||||
|
@ -109,7 +109,7 @@
|
||||
|
||||
/*
|
||||
* Device initialization/deinitialization handlers.
|
||||
@@ -705,6 +706,7 @@ enum rt2x00_capability_flags {
|
||||
@@ -706,6 +707,7 @@ enum rt2x00_capability_flags {
|
||||
REQUIRE_SW_SEQNO,
|
||||
REQUIRE_HT_TX_DESC,
|
||||
REQUIRE_PS_AUTOWAKE,
|
||||
@ -117,7 +117,7 @@
|
||||
|
||||
/*
|
||||
* Capabilities
|
||||
@@ -961,6 +963,11 @@ struct rt2x00_dev {
|
||||
@@ -960,6 +962,11 @@ struct rt2x00_dev {
|
||||
const struct firmware *fw;
|
||||
|
||||
/*
|
||||
@ -239,7 +239,7 @@
|
||||
.get_entry_state = rt2800pci_get_entry_state,
|
||||
--- a/drivers/net/wireless/rt2x00/rt2x00dev.c
|
||||
+++ b/drivers/net/wireless/rt2x00/rt2x00dev.c
|
||||
@@ -1145,6 +1145,10 @@ int rt2x00lib_probe_dev(struct rt2x00_de
|
||||
@@ -1157,6 +1157,10 @@ int rt2x00lib_probe_dev(struct rt2x00_de
|
||||
BIT(NL80211_IFTYPE_MESH_POINT) |
|
||||
BIT(NL80211_IFTYPE_WDS);
|
||||
|
||||
@ -250,10 +250,10 @@
|
||||
/*
|
||||
* Initialize work.
|
||||
*/
|
||||
@@ -1261,6 +1265,11 @@ void rt2x00lib_remove_dev(struct rt2x00_
|
||||
* Free queue structures.
|
||||
@@ -1280,6 +1284,11 @@ void rt2x00lib_remove_dev(struct rt2x00_
|
||||
*/
|
||||
rt2x00queue_free(rt2x00dev);
|
||||
if (rt2x00dev->drv_data)
|
||||
kfree(rt2x00dev->drv_data);
|
||||
+
|
||||
+ /*
|
||||
+ * Free EEPROM image.
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- a/config.mk
|
||||
+++ b/config.mk
|
||||
@@ -611,6 +611,7 @@ CONFIG_RT2X00=y
|
||||
@@ -618,6 +618,7 @@ CONFIG_RT2X00=y
|
||||
CONFIG_RT2X00_LIB=m
|
||||
CONFIG_RT2800_LIB=m
|
||||
CONFIG_RT2X00_LIB_FIRMWARE=y
|
||||
|
@ -37,7 +37,7 @@
|
||||
num_rates += 4;
|
||||
--- a/drivers/net/wireless/rt2x00/rt2x00.h
|
||||
+++ b/drivers/net/wireless/rt2x00/rt2x00.h
|
||||
@@ -420,6 +420,7 @@ struct hw_mode_spec {
|
||||
@@ -419,6 +419,7 @@ struct hw_mode_spec {
|
||||
unsigned int supported_bands;
|
||||
#define SUPPORT_BAND_2GHZ 0x00000001
|
||||
#define SUPPORT_BAND_5GHZ 0x00000002
|
@ -1,12 +0,0 @@
|
||||
--- a/drivers/net/wireless/rt2x00/rt2x00dev.c
|
||||
+++ b/drivers/net/wireless/rt2x00/rt2x00dev.c
|
||||
@@ -1224,7 +1224,8 @@ void rt2x00lib_remove_dev(struct rt2x00_
|
||||
cancel_work_sync(&rt2x00dev->rxdone_work);
|
||||
cancel_work_sync(&rt2x00dev->txdone_work);
|
||||
}
|
||||
- destroy_workqueue(rt2x00dev->workqueue);
|
||||
+ if (rt2x00dev->workqueue)
|
||||
+ destroy_workqueue(rt2x00dev->workqueue);
|
||||
|
||||
/*
|
||||
* Free the tx status fifo.
|
@ -9,7 +9,7 @@
|
||||
antenna = b43_antenna_to_phyctl(antenna);
|
||||
ctl = b43_shm_read16(dev, B43_SHM_SHARED, B43_SHM_SH_BEACPHYCTL);
|
||||
/* We can't send beacons with short preamble. Would get PHY errors. */
|
||||
@@ -3031,8 +3031,8 @@ static int b43_chip_init(struct b43_wlde
|
||||
@@ -3033,8 +3033,8 @@ static int b43_chip_init(struct b43_wlde
|
||||
|
||||
/* Select the antennae */
|
||||
if (phy->ops->set_rx_antenna)
|
||||
@ -20,7 +20,7 @@
|
||||
|
||||
if (phy->type == B43_PHYTYPE_B) {
|
||||
value16 = b43_read16(dev, 0x005E);
|
||||
@@ -3775,7 +3775,6 @@ static int b43_op_config(struct ieee8021
|
||||
@@ -3777,7 +3777,6 @@ static int b43_op_config(struct ieee8021
|
||||
struct b43_wldev *dev;
|
||||
struct b43_phy *phy;
|
||||
struct ieee80211_conf *conf = &hw->conf;
|
||||
@ -28,7 +28,7 @@
|
||||
int err = 0;
|
||||
bool reload_bss = false;
|
||||
|
||||
@@ -3829,11 +3828,9 @@ static int b43_op_config(struct ieee8021
|
||||
@@ -3831,11 +3830,9 @@ static int b43_op_config(struct ieee8021
|
||||
}
|
||||
|
||||
/* Antennas for RX and management frame TX. */
|
||||
@ -42,7 +42,7 @@
|
||||
|
||||
if (wl->radio_enabled != phy->radio_on) {
|
||||
if (wl->radio_enabled) {
|
||||
@@ -4905,6 +4902,47 @@ static int b43_op_get_survey(struct ieee
|
||||
@@ -4907,6 +4904,47 @@ static int b43_op_get_survey(struct ieee
|
||||
return 0;
|
||||
}
|
||||
|
||||
@ -90,7 +90,7 @@
|
||||
static const struct ieee80211_ops b43_hw_ops = {
|
||||
.tx = b43_op_tx,
|
||||
.conf_tx = b43_op_conf_tx,
|
||||
@@ -4926,6 +4964,8 @@ static const struct ieee80211_ops b43_hw
|
||||
@@ -4928,6 +4966,8 @@ static const struct ieee80211_ops b43_hw
|
||||
.sw_scan_complete = b43_op_sw_scan_complete_notifier,
|
||||
.get_survey = b43_op_get_survey,
|
||||
.rfkill_poll = b43_rfkill_poll,
|
||||
@ -99,7 +99,7 @@
|
||||
};
|
||||
|
||||
/* Hard-reset the chip. Do not call this directly.
|
||||
@@ -5172,6 +5212,8 @@ static int b43_one_core_attach(struct b4
|
||||
@@ -5174,6 +5214,8 @@ static int b43_one_core_attach(struct b4
|
||||
if (!wldev)
|
||||
goto out;
|
||||
|
||||
@ -108,7 +108,7 @@
|
||||
wldev->use_pio = b43_modparam_pio;
|
||||
wldev->dev = dev;
|
||||
wldev->wl = wl;
|
||||
@@ -5260,6 +5302,9 @@ static struct b43_wl *b43_wireless_init(
|
||||
@@ -5262,6 +5304,9 @@ static struct b43_wl *b43_wireless_init(
|
||||
BIT(NL80211_IFTYPE_WDS) |
|
||||
BIT(NL80211_IFTYPE_ADHOC);
|
||||
|
||||
|
@ -1,61 +0,0 @@
|
||||
--- a/scripts/admin-clean.sh
|
||||
+++ b/scripts/admin-clean.sh
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!/bin/bash
|
||||
+#!/usr/bin/env bash
|
||||
if [ -d net ] ; then
|
||||
make clean
|
||||
fi
|
||||
--- a/scripts/admin-refresh.sh
|
||||
+++ b/scripts/admin-refresh.sh
|
||||
@@ -1,3 +1,3 @@
|
||||
-#!/bin/bash
|
||||
+#!/usr/bin/env bash
|
||||
./scripts/admin-clean.sh $@
|
||||
./scripts/admin-update.sh $@
|
||||
--- a/scripts/admin-update.sh
|
||||
+++ b/scripts/admin-update.sh
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!/bin/bash
|
||||
+#!/usr/bin/env bash
|
||||
#
|
||||
# Copyright 2007, 2008, 2010 Luis R. Rodriguez <mcgrof@winlab.rutgers.edu>
|
||||
#
|
||||
--- a/scripts/check_config.sh
|
||||
+++ b/scripts/check_config.sh
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!/bin/bash
|
||||
+#!/usr/bin/env bash
|
||||
# This script checks the compat-wireless configuration file and if changes were made
|
||||
# regenerates the compat_autoconf header.
|
||||
|
||||
--- a/scripts/driver-select
|
||||
+++ b/scripts/driver-select
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!/bin/bash
|
||||
+#!/usr/bin/env bash
|
||||
# Copyright 2009 Luis R. Rodriguez <mcgrof@gmail.com>
|
||||
#
|
||||
# This script allows you to select your compat-wireless driver and
|
||||
--- a/scripts/gen-compat-autoconf.sh
|
||||
+++ b/scripts/gen-compat-autoconf.sh
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!/bin/bash
|
||||
+#!/usr/bin/env bash
|
||||
#
|
||||
# Copyright 2007 Luis R. Rodriguez <mcgrof@winlab.rutgers.edu>
|
||||
#
|
||||
--- a/scripts/gen-stable-release.sh
|
||||
+++ b/scripts/gen-stable-release.sh
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!/bin/bash
|
||||
+#!/usr/bin/env bash
|
||||
# Copyright 2009 Luis R. Rodriguez <mcgrof@gmail.com>
|
||||
#
|
||||
# You can use this to make stable compat-wireless releases
|
||||
--- a/scripts/skip-colors
|
||||
+++ b/scripts/skip-colors
|
||||
@@ -1,2 +1,2 @@
|
||||
-#!/bin/bash
|
||||
+#!/usr/bin/env bash
|
||||
perl -pe 's|(\e)\[(\d+)(;*)(\d*)(\w)||g'
|
Loading…
Reference in New Issue
Block a user