Added motion, thanks to Nathan True ! Fixed menuconfig symbol
SVN-Revision: 3395
This commit is contained in:
parent
327e4d0268
commit
e7125b2ef0
@ -31,6 +31,7 @@ source "package/less/Config.in"
|
||||
source "package/lua/Config.in"
|
||||
source "package/microperl/Config.in"
|
||||
source "package/monit/Config.in"
|
||||
source "package/motion/Config.in"
|
||||
source "package/mgetty/Config.in"
|
||||
source "package/mutt/Config.in"
|
||||
source "package/nano/Config.in"
|
||||
|
@ -143,6 +143,7 @@ package-$(BR2_COMPILE_MINI_HTTPD) += mini_httpd
|
||||
package-$(BR2_PACKAGE_MINI_SENDMAIL) += mini_sendmail
|
||||
package-$(BR2_COMPILE_MIREDO) += miredo
|
||||
package-$(BR2_COMPILE_MONIT) += monit
|
||||
package-$(BR2_PACKAGE_MOTION) += motion
|
||||
package-$(BR2_PACKAGE_MPD) += mpd
|
||||
package-$(BR2_PACKAGE_MRD6) += mrd6
|
||||
package-$(BR2_PACKAGE_MT_DAAPD) += mt-daapd
|
||||
@ -437,6 +438,10 @@ ifneq ($(BR2_PACKAGE_MINI_HTTPD_OPENSSL),)
|
||||
mini_httpd-compile: openssl-compile
|
||||
endif
|
||||
|
||||
ifneq ($(BR2_PACKAGE_MOTION),)
|
||||
motion-compile: libjpeg-compile
|
||||
endif
|
||||
|
||||
ifneq ($(BR2_PACKAGE_MPD_MP3),)
|
||||
mpd-compile: libid3tag-compile libmad-compile
|
||||
endif
|
||||
|
9
openwrt/package/motion/Config.in
Normal file
9
openwrt/package/motion/Config.in
Normal file
@ -0,0 +1,9 @@
|
||||
config BR2_PACKAGE_MOTION
|
||||
prompt "motion............................ webcam motion sensing and logging"
|
||||
tristate
|
||||
default m if CONFIG_DEVEL
|
||||
select BR2_PACKAGE_LIBJPEG
|
||||
help
|
||||
Motion is a software motion detector
|
||||
|
||||
http://www.lavrsen.dk/twiki/bin/view/Motion/WebHome
|
51
openwrt/package/motion/Makefile
Normal file
51
openwrt/package/motion/Makefile
Normal file
@ -0,0 +1,51 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=motion
|
||||
PKG_VERSION:=3.2.5.1
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE_URL:=http://superb.dl.sourceforge.net/sourceforge/motion
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_CAT:=zcat
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
|
||||
|
||||
include $(TOPDIR)/package/rules.mk
|
||||
|
||||
$(eval $(call PKG_template,MOTION,motion,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
|
||||
|
||||
$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
|
||||
(cd $(PKG_BUILD_DIR); \
|
||||
$(TARGET_CONFIGURE_OPTS) \
|
||||
CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include" \
|
||||
LDFLAGS="$(TARGET_LDFLAGS) -L$(STAGING_DIR)/usr/lib" \
|
||||
./configure \
|
||||
--target=$(GNU_TARGET_NAME) \
|
||||
--host=$(GNU_TARGET_NAME) \
|
||||
--build=$(GNU_HOST_NAME) \
|
||||
--prefix=/usr \
|
||||
--sysconfdir=/etc \
|
||||
--with-jpeg-mmx="$(STAGING_DIR)/usr" \
|
||||
);
|
||||
touch $@
|
||||
|
||||
$(PKG_BUILD_DIR)/.built:
|
||||
rm -rf $(PKG_INSTALL_DIR)
|
||||
mkdir -p $(PKG_INSTALL_DIR)
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||
$(TARGET_CONFIGURE_OPTS) \
|
||||
install_prefix="$(PKG_INSTALL_DIR)" \
|
||||
all install
|
||||
touch $@
|
||||
|
||||
$(IPKG_FOO):
|
||||
install -d -m0755 $(IDIR_FOO)/usr/sbin
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/sbin/motion $(IDIR_FOO)/usr/sbin
|
||||
$(RSTRIP) $(IDIR_FOO)
|
||||
$(IPKG_BUILD) $(IDIR_FOO) $(PACKAGE_DIR)
|
||||
|
||||
mostlyclean:
|
||||
make -C $(PKG_BUILD_DIR) clean
|
||||
rm $(PKG_BUILD_DIR)/.built
|
||||
|
8
openwrt/package/motion/ipkg/motion.control
Normal file
8
openwrt/package/motion/ipkg/motion.control
Normal file
@ -0,0 +1,8 @@
|
||||
Package: motion
|
||||
Priority: optional
|
||||
Section: multimedia
|
||||
Maintainer: Jeroen Vreeken <pe1rxq@amsat.org>
|
||||
Source: http://www.lavrsen.dk
|
||||
Depends: libjpeg
|
||||
Description: Webcam motion sensing and logging
|
||||
|
38
openwrt/package/motion/patches/01-ffmpeg.patch
Normal file
38
openwrt/package/motion/patches/01-ffmpeg.patch
Normal file
@ -0,0 +1,38 @@
|
||||
diff -ur motion-3.2.5.1-old/motion.c motion-3.2.5.1/motion.c
|
||||
--- motion-3.2.5.1-old/motion.c 2006-03-17 10:05:13.490000000 -0800
|
||||
+++ motion-3.2.5.1/motion.c 2006-03-17 10:03:38.020000000 -0800
|
||||
@@ -1246,10 +1246,10 @@
|
||||
* Note: Negative value means SIGALRM snaps are enabled
|
||||
* httpd-control snaps are always enabled.
|
||||
*/
|
||||
-
|
||||
+#ifdef HAVE_FFMPEG
|
||||
/* time_current_frame is used both for snapshot and timelapse features */
|
||||
time_current_frame = cnt->currenttime;
|
||||
-
|
||||
+
|
||||
if ( (cnt->conf.snapshot_interval > 0 && cnt->shots == 0 &&
|
||||
time_current_frame % cnt->conf.snapshot_interval <= time_last_frame % cnt->conf.snapshot_interval) ||
|
||||
cnt->snapshot) {
|
||||
@@ -1257,7 +1257,7 @@
|
||||
cnt->snapshot = 0;
|
||||
}
|
||||
|
||||
-
|
||||
+#endif /* HAVE_FFMPEG */
|
||||
/***** MOTION LOOP - TIMELAPSE FEATURE SECTION *****/
|
||||
|
||||
#ifdef HAVE_FFMPEG
|
||||
@@ -1331,10 +1331,9 @@
|
||||
event(cnt, EVENT_TIMELAPSEEND, NULL, NULL, NULL, cnt->currenttime_tm);
|
||||
|
||||
|
||||
-#endif /* HAVE_FFMPEG */
|
||||
|
||||
time_last_frame = time_current_frame;
|
||||
-
|
||||
+#endif /* HAVE_FFMPEG */
|
||||
|
||||
/***** MOTION LOOP - VIDEO LOOPBACK SECTION *****/
|
||||
|
||||
Only in motion-3.2.5.1-old/: motion.c.orig
|
@ -39,7 +39,7 @@ config BR2_PACKAGE_OPENSER_MOD_AUTH_RADIUS
|
||||
tristate
|
||||
default m
|
||||
select BR2_PACKAGE_OPENSER
|
||||
select BR2_PACAKGE_LIBRADIUSCLIENT_NG
|
||||
select BR2_PACKAGE_LIBRADIUSCLIENT_NG
|
||||
help
|
||||
Authentication against RADIUS
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user