update to new upstream release (v0.8.0), enabled when DEVELOPER=1
SVN-Revision: 1955
This commit is contained in:
parent
2da441663d
commit
eef5968c96
@ -1,8 +1,7 @@
|
|||||||
config BR2_PACKAGE_GMEDIASERVER
|
config BR2_PACKAGE_GMEDIASERVER
|
||||||
prompt "gmediaserver - An UPnP music media server"
|
prompt "gmediaserver - An UPnP music media server"
|
||||||
tristate
|
tristate
|
||||||
# default m if CONFIG_DEVEL
|
default m if CONFIG_DEVEL
|
||||||
default n
|
|
||||||
select BR2_PACKAGE_ID3LIB
|
select BR2_PACKAGE_ID3LIB
|
||||||
select BR2_PACKAGE_LIBUPNP
|
select BR2_PACKAGE_LIBUPNP
|
||||||
help
|
help
|
||||||
|
@ -3,9 +3,9 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=gmediaserver
|
PKG_NAME:=gmediaserver
|
||||||
PKG_VERSION:=0.7.0
|
PKG_VERSION:=0.8.0
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
PKG_MD5SUM:=08d3d0274ff7b37b135d6f21b47cb3c5
|
PKG_MD5SUM:=fe5d6ab36287999d7acd8aff8dc0819c
|
||||||
|
|
||||||
PKG_SOURCE_URL:=http://savannah.nongnu.org/download/gmediaserver/
|
PKG_SOURCE_URL:=http://savannah.nongnu.org/download/gmediaserver/
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
@ -14,8 +14,6 @@ PKG_CAT:=zcat
|
|||||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||||
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
|
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
|
||||||
|
|
||||||
BR2_PACKAGE_GMEDIASERVER=m
|
|
||||||
|
|
||||||
include $(TOPDIR)/package/rules.mk
|
include $(TOPDIR)/package/rules.mk
|
||||||
|
|
||||||
$(eval $(call PKG_template,GMEDIASERVER,gmediaserver,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
|
$(eval $(call PKG_template,GMEDIASERVER,gmediaserver,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
|
||||||
@ -27,6 +25,7 @@ $(PKG_BUILD_DIR)/.configured:
|
|||||||
CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
|
CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
|
||||||
LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
|
LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
|
||||||
LIBS=" -lixml -lthreadutil -lupnp -luClibc++ -lz" \
|
LIBS=" -lixml -lthreadutil -lupnp -luClibc++ -lz" \
|
||||||
|
am_cv_func_iconv=no \
|
||||||
./configure \
|
./configure \
|
||||||
--target=$(GNU_TARGET_NAME) \
|
--target=$(GNU_TARGET_NAME) \
|
||||||
--host=$(GNU_TARGET_NAME) \
|
--host=$(GNU_TARGET_NAME) \
|
||||||
@ -50,6 +49,7 @@ $(PKG_BUILD_DIR)/.configured:
|
|||||||
--enable-shared \
|
--enable-shared \
|
||||||
--disable-static \
|
--disable-static \
|
||||||
--disable-rpath \
|
--disable-rpath \
|
||||||
|
--with-gnu-ld \
|
||||||
--with-id3lib="$(STAGING_DIR)/usr" \
|
--with-id3lib="$(STAGING_DIR)/usr" \
|
||||||
--with-libupnp="$(STAGING_DIR)/usr" \
|
--with-libupnp="$(STAGING_DIR)/usr" \
|
||||||
)
|
)
|
||||||
|
@ -1,9 +1,10 @@
|
|||||||
--- gmediaserver-0.7.0/src/main.c.orig 2005-08-29 21:15:01.000000000 +0200
|
diff -ruN gmediaserver-0.8.0-old/src/main.c gmediaserver-0.8.0-new/src/main.c
|
||||||
+++ gmediaserver-0.7.0/src/main.c 2005-08-30 12:37:40.000000000 +0200
|
--- gmediaserver-0.8.0-old/src/main.c 2005-09-10 09:26:00.000000000 +0200
|
||||||
@@ -31,8 +31,10 @@
|
+++ gmediaserver-0.8.0-new/src/main.c 2005-09-17 20:48:01.000000000 +0200
|
||||||
#include <stdarg.h> /* C89 */
|
@@ -32,8 +32,10 @@
|
||||||
#include <stdbool.h> /* Gnulib, C99 */
|
#include <stdbool.h> /* Gnulib, C99 */
|
||||||
#include <signal.h> /* ? */
|
#include <signal.h> /* ? */
|
||||||
|
#include <locale.h> /* ? */
|
||||||
+#ifdef HAVE_ICONV
|
+#ifdef HAVE_ICONV
|
||||||
#include <iconv.h> /* Gnulib, POSIX */
|
#include <iconv.h> /* Gnulib, POSIX */
|
||||||
#include "iconvme.h" /* Gnulib */
|
#include "iconvme.h" /* Gnulib */
|
||||||
@ -11,7 +12,7 @@
|
|||||||
#ifdef HAVE_NL_LANGINFO
|
#ifdef HAVE_NL_LANGINFO
|
||||||
#include <langinfo.h>
|
#include <langinfo.h>
|
||||||
#endif
|
#endif
|
||||||
@@ -70,8 +72,10 @@
|
@@ -71,8 +73,10 @@
|
||||||
#ifdef HAVE_ID3LIB
|
#ifdef HAVE_ID3LIB
|
||||||
{ "disable-id3", no_argument, NULL, OPT_DISABLE_ID3 },
|
{ "disable-id3", no_argument, NULL, OPT_DISABLE_ID3 },
|
||||||
#endif
|
#endif
|
||||||
@ -22,7 +23,7 @@
|
|||||||
{ "friendly-name", required_argument, NULL, OPT_FRIENDLY_NAME },
|
{ "friendly-name", required_argument, NULL, OPT_FRIENDLY_NAME },
|
||||||
{ "pid-file", required_argument, NULL, OPT_PIDFILE },
|
{ "pid-file", required_argument, NULL, OPT_PIDFILE },
|
||||||
{ "profile", required_argument, NULL, OPT_PROFILE, },
|
{ "profile", required_argument, NULL, OPT_PROFILE, },
|
||||||
@@ -89,15 +93,21 @@
|
@@ -90,15 +94,21 @@
|
||||||
{ NULL, 0, NULL, 0 }
|
{ NULL, 0, NULL, 0 }
|
||||||
};
|
};
|
||||||
|
|
||||||
@ -44,7 +45,7 @@
|
|||||||
}
|
}
|
||||||
|
|
||||||
static void
|
static void
|
||||||
@@ -139,13 +149,17 @@
|
@@ -140,13 +150,17 @@
|
||||||
char *logfilename = NULL;
|
char *logfilename = NULL;
|
||||||
char *timestamp_format = NULL;
|
char *timestamp_format = NULL;
|
||||||
uint32_t expire_time;
|
uint32_t expire_time;
|
||||||
@ -62,7 +63,7 @@
|
|||||||
#ifdef ENABLE_NLS
|
#ifdef ENABLE_NLS
|
||||||
if (bindtextdomain(PACKAGE, LOCALEDIR) == NULL)
|
if (bindtextdomain(PACKAGE, LOCALEDIR) == NULL)
|
||||||
warn(_("cannot bind message domain: %s\n"), errstr);
|
warn(_("cannot bind message domain: %s\n"), errstr);
|
||||||
@@ -173,12 +187,14 @@
|
@@ -174,12 +188,14 @@
|
||||||
id3_enabled = false;
|
id3_enabled = false;
|
||||||
break;
|
break;
|
||||||
#endif
|
#endif
|
||||||
@ -77,7 +78,7 @@
|
|||||||
case OPT_FRIENDLY_NAME:
|
case OPT_FRIENDLY_NAME:
|
||||||
if (optarg[0] == '\0')
|
if (optarg[0] == '\0')
|
||||||
die(_("friendly name cannot be empty\n"));
|
die(_("friendly name cannot be empty\n"));
|
||||||
@@ -319,6 +335,7 @@
|
@@ -320,6 +336,7 @@
|
||||||
|
|
||||||
init_logging(logfilename, timestamp_format);
|
init_logging(logfilename, timestamp_format);
|
||||||
|
|
||||||
@ -85,7 +86,7 @@
|
|||||||
if (device_charset != NULL) {
|
if (device_charset != NULL) {
|
||||||
if (in_charset == NULL) {
|
if (in_charset == NULL) {
|
||||||
#ifdef HAVE_NL_LANGINFO
|
#ifdef HAVE_NL_LANGINFO
|
||||||
@@ -335,6 +352,7 @@
|
@@ -336,6 +353,7 @@
|
||||||
if (charset_convert == (iconv_t) -1)
|
if (charset_convert == (iconv_t) -1)
|
||||||
die(_("cannot create character set convertor\nTry using another value for --in-charset or --device-charset\n"));
|
die(_("cannot create character set convertor\nTry using another value for --in-charset or --device-charset\n"));
|
||||||
}
|
}
|
||||||
@ -93,7 +94,7 @@
|
|||||||
|
|
||||||
/* We could write pid before initiating logging too.
|
/* We could write pid before initiating logging too.
|
||||||
*/
|
*/
|
||||||
@@ -396,8 +414,10 @@
|
@@ -409,8 +427,10 @@
|
||||||
if (pidfilename != NULL)
|
if (pidfilename != NULL)
|
||||||
unlink(pidfilename); /* ignore errors */
|
unlink(pidfilename); /* ignore errors */
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user