mtd-utils: Disable lzo for mkfs.ubifs
SVN-Revision: 19104
This commit is contained in:
parent
2ee3073b70
commit
f26aa5f82a
79
tools/mtd-utils/patches/101-ubifs-optional_lzo.patch
Normal file
79
tools/mtd-utils/patches/101-ubifs-optional_lzo.patch
Normal file
@ -0,0 +1,79 @@
|
|||||||
|
diff --git a/mkfs.ubifs/Makefile b/mkfs.ubifs/Makefile
|
||||||
|
index a678b0a..919ce89 100644
|
||||||
|
--- a/mkfs.ubifs/Makefile
|
||||||
|
+++ b/mkfs.ubifs/Makefile
|
||||||
|
@@ -5,7 +5,7 @@ ALL_SOURCES=*.[ch] hashtable/*.[ch]
|
||||||
|
|
||||||
|
TARGETS = mkfs.ubifs
|
||||||
|
|
||||||
|
-LDLIBS_mkfs.ubifs = -lz -llzo2 -lm -luuid -L../ubi-utils/ -lubi
|
||||||
|
+LDLIBS_mkfs.ubifs = -lz $(if,$(NO_LZO),,-llzo2) -lm -luuid -L../ubi-utils/ -lubi
|
||||||
|
|
||||||
|
include ../common.mk
|
||||||
|
|
||||||
|
diff --git a/mkfs.ubifs/compr.c b/mkfs.ubifs/compr.c
|
||||||
|
index e378c5d..0208f80 100644
|
||||||
|
--- a/mkfs.ubifs/compr.c
|
||||||
|
+++ b/mkfs.ubifs/compr.c
|
||||||
|
@@ -83,6 +83,17 @@ static int zlib_deflate(void *in_buf, size_t in_len, void *out_buf,
|
||||||
|
return 0;
|
||||||
|
}
|
||||||
|
|
||||||
|
+static int no_compress(void *in_buf, size_t in_len, void *out_buf,
|
||||||
|
+ size_t *out_len)
|
||||||
|
+{
|
||||||
|
+ memcpy(out_buf, in_buf, in_len);
|
||||||
|
+ *out_len = in_len;
|
||||||
|
+ return 0;
|
||||||
|
+}
|
||||||
|
+
|
||||||
|
+
|
||||||
|
+#if CONFIG_UBIFS_LZO
|
||||||
|
+
|
||||||
|
static int lzo_compress(void *in_buf, size_t in_len, void *out_buf,
|
||||||
|
size_t *out_len)
|
||||||
|
{
|
||||||
|
@@ -101,14 +112,16 @@ static int lzo_compress(void *in_buf, size_t in_len, void *out_buf,
|
||||||
|
return 0;
|
||||||
|
}
|
||||||
|
|
||||||
|
-static int no_compress(void *in_buf, size_t in_len, void *out_buf,
|
||||||
|
- size_t *out_len)
|
||||||
|
+#else
|
||||||
|
+
|
||||||
|
+static int lzo_compress(void *in_buf, size_t in_len, void *out_buf,
|
||||||
|
+ size_t *out_len)
|
||||||
|
{
|
||||||
|
- memcpy(out_buf, in_buf, in_len);
|
||||||
|
- *out_len = in_len;
|
||||||
|
- return 0;
|
||||||
|
+ return -1;
|
||||||
|
}
|
||||||
|
|
||||||
|
+#endif
|
||||||
|
+
|
||||||
|
static char *zlib_buf;
|
||||||
|
|
||||||
|
static int favor_lzo_compress(void *in_buf, size_t in_len, void *out_buf,
|
||||||
|
@@ -195,9 +208,11 @@ int compress_data(void *in_buf, size_t in_len, void *out_buf, size_t *out_len,
|
||||||
|
|
||||||
|
int init_compression(void)
|
||||||
|
{
|
||||||
|
+#ifdef CONFIG_UBIFS_LZO
|
||||||
|
lzo_mem = malloc(LZO1X_999_MEM_COMPRESS);
|
||||||
|
if (!lzo_mem)
|
||||||
|
return -1;
|
||||||
|
+#endif
|
||||||
|
|
||||||
|
zlib_buf = malloc(UBIFS_BLOCK_SIZE * WORST_COMPR_FACTOR);
|
||||||
|
if (!zlib_buf) {
|
||||||
|
@@ -211,7 +226,9 @@ int init_compression(void)
|
||||||
|
void destroy_compression(void)
|
||||||
|
{
|
||||||
|
free(zlib_buf);
|
||||||
|
+#ifdef CONFIG_UBIFS_LZO
|
||||||
|
free(lzo_mem);
|
||||||
|
+#endif
|
||||||
|
if (errcnt)
|
||||||
|
fprintf(stderr, "%llu compression errors occurred\n", errcnt);
|
||||||
|
}
|
Loading…
Reference in New Issue
Block a user