libpcap: add -fpic, refresh patches
SVN-Revision: 26999
This commit is contained in:
parent
50d2a84a21
commit
f94411e910
@ -38,6 +38,7 @@ define Package/libpcap/config
|
||||
endef
|
||||
|
||||
TARGET_CFLAGS += \
|
||||
$(FPIC) \
|
||||
-ffunction-sections \
|
||||
-fdata-sections
|
||||
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- a/Makefile.in
|
||||
+++ b/Makefile.in
|
||||
@@ -539,62 +539,12 @@ install: install-shared install-archive
|
||||
@@ -539,62 +539,12 @@ install: install-shared install-archive
|
||||
(mkdir -p $(DESTDIR)$(includedir); chmod 755 $(DESTDIR)$(includedir))
|
||||
[ -d $(DESTDIR)$(includedir)/pcap ] || \
|
||||
(mkdir -p $(DESTDIR)$(includedir)/pcap; chmod 755 $(DESTDIR)$(includedir)/pcap)
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- a/gencode.c
|
||||
+++ b/gencode.c
|
||||
@@ -439,20 +439,6 @@ pcap_compile_nopcap(int snaplen_arg, int
|
||||
@@ -491,20 +491,6 @@ pcap_compile_nopcap(int snaplen_arg, int
|
||||
}
|
||||
|
||||
/*
|
||||
@ -23,7 +23,7 @@
|
||||
* back to another unresolved block (or nil). At least one of the fields
|
||||
--- a/pcap.c
|
||||
+++ b/pcap.c
|
||||
@@ -698,6 +698,59 @@ static const u_char charmap[] = {
|
||||
@@ -748,6 +748,59 @@ static const u_char charmap[] = {
|
||||
(u_char)'\374', (u_char)'\375', (u_char)'\376', (u_char)'\377',
|
||||
};
|
||||
|
||||
@ -85,7 +85,7 @@
|
||||
{
|
||||
--- a/optimize.c
|
||||
+++ b/optimize.c
|
||||
@@ -2278,45 +2278,6 @@ icode_to_fcode(root, lenp)
|
||||
@@ -2292,45 +2292,6 @@ icode_to_fcode(root, lenp)
|
||||
return fp;
|
||||
}
|
||||
|
||||
|
@ -105,11 +105,10 @@
|
||||
return (p);
|
||||
}
|
||||
|
||||
@@ -317,6 +319,15 @@ pcap_set_buffer_size(pcap_t *p, int buff
|
||||
return 0;
|
||||
@@ -318,6 +320,15 @@ pcap_set_buffer_size(pcap_t *p, int buff
|
||||
}
|
||||
|
||||
+int
|
||||
int
|
||||
+pcap_set_protocol(pcap_t *p, unsigned short proto)
|
||||
+{
|
||||
+ if (pcap_check_activated(p))
|
||||
@ -118,9 +117,10 @@
|
||||
+ return 0;
|
||||
+}
|
||||
+
|
||||
int
|
||||
+int
|
||||
pcap_activate(pcap_t *p)
|
||||
{
|
||||
int status;
|
||||
--- a/pcap/pcap.h
|
||||
+++ b/pcap/pcap.h
|
||||
@@ -68,6 +68,7 @@ extern "C" {
|
||||
|
Loading…
Reference in New Issue
Block a user