opkg: add upstream patch fixing the order packages are configured (closes: #7057, #7058), bump release number
SVN-Revision: 20686
This commit is contained in:
parent
34a5f7bcbe
commit
fc72a828f5
@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
|
||||
PKG_NAME:=opkg
|
||||
PKG_REV:=513
|
||||
PKG_VERSION:=$(PKG_REV)
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE_PROTO:=svn
|
||||
PKG_SOURCE_VERSION:=$(PKG_REV)
|
||||
|
15
package/opkg/patches/000-upstream-fix_configure_order.patch
Normal file
15
package/opkg/patches/000-upstream-fix_configure_order.patch
Normal file
@ -0,0 +1,15 @@
|
||||
http://code.google.com/p/opkg/source/detail?r=521
|
||||
|
||||
--- a/libopkg/opkg_cmd.c
|
||||
+++ b/libopkg/opkg_cmd.c
|
||||
@@ -390,8 +390,8 @@ opkg_configure_packages(char *pkg_name)
|
||||
goto error;
|
||||
}
|
||||
|
||||
- for(i = 0; i < all->len; i++) {
|
||||
- pkg = all->pkgs[i];
|
||||
+ for(i = 0; i < ordered->len; i++) {
|
||||
+ pkg = ordered->pkgs[i];
|
||||
|
||||
if (pkg_name && fnmatch(pkg_name, pkg->name, 0))
|
||||
continue;
|
Loading…
Reference in New Issue
Block a user