bcm53xx: backport patch adding ARCH_BCM_53573 symbol
Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
This commit is contained in:
parent
277f85c21a
commit
fcdba8d590
@ -3,6 +3,7 @@ CONFIG_ARCH_BCM=y
|
||||
# CONFIG_ARCH_BCM_21664 is not set
|
||||
# CONFIG_ARCH_BCM_281XX is not set
|
||||
CONFIG_ARCH_BCM_5301X=y
|
||||
CONFIG_ARCH_BCM_53573=y
|
||||
# CONFIG_ARCH_BCM_63XX is not set
|
||||
# CONFIG_ARCH_BCM_CYGNUS is not set
|
||||
CONFIG_ARCH_BCM_IPROC=y
|
||||
|
@ -0,0 +1,61 @@
|
||||
From 4ebd50472899eb07d5dfc24f2015dce6fe3c5cb8 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Rafa=C5=82=20Mi=C5=82ecki?= <rafal@milecki.pl>
|
||||
Date: Sun, 21 Aug 2016 19:01:38 +0200
|
||||
Subject: [PATCH] ARM: BCM53573: Initial support for Broadcom BCM53573 SoCs
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
BCM53573 series is a new family with embedded wireless. By marketing
|
||||
people it's sometimes called Northstar but it uses different CPU and has
|
||||
different architecture so we need a new symbol for it.
|
||||
Fortunately it shares some peripherals with other iProc based SoCs so we
|
||||
will be able to reuse some drivers/bindings.
|
||||
|
||||
Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
|
||||
Acked-by: Jon Mason <jon.mason@broadcom.com>
|
||||
Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
|
||||
---
|
||||
MAINTAINERS | 7 +++++++
|
||||
arch/arm/mach-bcm/Kconfig | 14 ++++++++++++++
|
||||
2 files changed, 21 insertions(+)
|
||||
|
||||
--- a/MAINTAINERS
|
||||
+++ b/MAINTAINERS
|
||||
@@ -2338,6 +2338,13 @@ F: arch/arm/mach-bcm/bcm_5301x.c
|
||||
F: arch/arm/boot/dts/bcm5301x.dtsi
|
||||
F: arch/arm/boot/dts/bcm470*
|
||||
|
||||
+BROADCOM BCM53573 ARM ARCHITECTURE
|
||||
+M: Rafał Miłecki <rafal@milecki.pl>
|
||||
+L: linux-arm-kernel@lists.infradead.org
|
||||
+S: Maintained
|
||||
+F: arch/arm/boot/dts/bcm53573*
|
||||
+F: arch/arm/boot/dts/bcm47189*
|
||||
+
|
||||
BROADCOM BCM63XX ARM ARCHITECTURE
|
||||
M: Florian Fainelli <f.fainelli@gmail.com>
|
||||
L: linux-arm-kernel@lists.infradead.org
|
||||
--- a/arch/arm/mach-bcm/Kconfig
|
||||
+++ b/arch/arm/mach-bcm/Kconfig
|
||||
@@ -141,6 +141,20 @@ config ARCH_BCM2835
|
||||
This enables support for the Broadcom BCM2835 SoC. This SoC is
|
||||
used in the Raspberry Pi and Roku 2 devices.
|
||||
|
||||
+config ARCH_BCM_53573
|
||||
+ bool "Broadcom BCM53573 SoC series support"
|
||||
+ depends on ARCH_MULTI_V7
|
||||
+ select ARCH_BCM_IPROC
|
||||
+ select HAVE_ARM_ARCH_TIMER
|
||||
+ help
|
||||
+ BCM53573 series is set of SoCs using ARM Cortex-A7 CPUs with wireless
|
||||
+ embedded in the chipset.
|
||||
+ This SoC line is mostly used in home routers and is some cheaper
|
||||
+ alternative for Northstar family.
|
||||
+
|
||||
+ The base chip is BCM53573 and there are some packaging modifications
|
||||
+ like BCM47189 and BCM47452.
|
||||
+
|
||||
config ARCH_BCM_63XX
|
||||
bool "Broadcom BCM63xx DSL SoC" if ARCH_MULTI_V7
|
||||
depends on MMU
|
@ -32,8 +32,8 @@ Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
|
||||
+F: arch/arm/boot/dts/bcm53573*
|
||||
+F: arch/arm/boot/dts/bcm47189*
|
||||
|
||||
BROADCOM BCM63XX ARM ARCHITECTURE
|
||||
M: Florian Fainelli <f.fainelli@gmail.com>
|
||||
BROADCOM BCM53573 ARM ARCHITECTURE
|
||||
M: Rafał Miłecki <rafal@milecki.pl>
|
||||
--- a/arch/arm/boot/dts/Makefile
|
||||
+++ b/arch/arm/boot/dts/Makefile
|
||||
@@ -77,6 +77,7 @@ dtb-$(CONFIG_ARCH_BCM_5301X) += \
|
||||
|
Loading…
Reference in New Issue
Block a user