5256bbdc56
Patch-by: Lars Bøgild Thomsen <lth@cow.dk> Patchwork: http://patchwork.openwrt.org/patch/4922/ [juhosg: - use a separate patch for kernel changes, - reorder Kconfig and Makefile entries, - change function and variable names to be lowercase only and fix misaligned tabs in mach-gs-oolite.c, ... ] Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 40032
40 lines
1.5 KiB
Diff
40 lines
1.5 KiB
Diff
--- a/arch/mips/ath79/machtypes.h
|
|
+++ b/arch/mips/ath79/machtypes.h
|
|
@@ -49,6 +49,7 @@ enum ath79_mach_type {
|
|
ATH79_MACH_EW_DORIN, /* embedded wireless Dorin Platform */
|
|
ATH79_MACH_EW_DORIN_ROUTER, /* embedded wireless Dorin Router Platform */
|
|
ATH79_MACH_EAP7660D, /* Senao EAP7660D */
|
|
+ ATH79_MACH_GS_OOLITE, /* GS OOLITE V1.0 */
|
|
ATH79_MACH_JA76PF, /* jjPlus JA76PF */
|
|
ATH79_MACH_JA76PF2, /* jjPlus JA76PF2 */
|
|
ATH79_MACH_JWAP003, /* jjPlus JWAP003 */
|
|
--- a/arch/mips/ath79/Kconfig
|
|
+++ b/arch/mips/ath79/Kconfig
|
|
@@ -337,6 +337,16 @@ config ATH79_MACH_EW_DORIN
|
|
Say 'Y' here if you want your kernel to support the
|
|
Dorin Platform from www.80211.de .
|
|
|
|
+config ATH79_MACH_GS_OOLITE
|
|
+ bool "GS Oolite V1 support"
|
|
+ select SOC_AR933X
|
|
+ select ARH79_DEV_ETH
|
|
+ select ARH79_DEV_GPIO_BUTTONS
|
|
+ select ATH79_DEV_LEDS_GPIO
|
|
+ select ATH79_DEV_M25P80
|
|
+ select ATH79_DEV_USB
|
|
+ select ATH79_DEV_WMAC
|
|
+
|
|
config ATH79_MACH_JA76PF
|
|
bool "jjPlus JA76PF board support"
|
|
select SOC_AR71XX
|
|
--- a/arch/mips/ath79/Makefile
|
|
+++ b/arch/mips/ath79/Makefile
|
|
@@ -62,6 +62,7 @@ obj-$(CONFIG_ATH79_MACH_DIR_825_C1) += m
|
|
obj-$(CONFIG_ATH79_MACH_DRAGINO2) += mach-dragino2.o
|
|
obj-$(CONFIG_ATH79_MACH_EW_DORIN) += mach-ew-dorin.o
|
|
obj-$(CONFIG_ATH79_MACH_EAP7660D) += mach-eap7660d.o
|
|
+obj-$(CONFIG_ATH79_MACH_GS_OOLITE) += mach-gs-oolite.o
|
|
obj-$(CONFIG_ATH79_MACH_JA76PF) += mach-ja76pf.o
|
|
obj-$(CONFIG_ATH79_MACH_JWAP003) += mach-jwap003.o
|
|
obj-$(CONFIG_ATH79_MACH_HORNET_UB) += mach-hornet-ub.o
|