011f2c26f1
As usual these patches were extracted and rebased from the raspberry pi repo: https://github.com/raspberrypi/linux/tree/rpi-4.4.y Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
283 lines
8.4 KiB
Diff
283 lines
8.4 KiB
Diff
From 881ed164c1e17831d21848d8fb2308d966860d82 Mon Sep 17 00:00:00 2001
|
|
From: Daniel Matuschek <info@crazy-audio.com>
|
|
Date: Wed, 15 Jan 2014 21:42:08 +0100
|
|
Subject: [PATCH] ASoC: BCM:Add support for HiFiBerry Digi. Driver is based on
|
|
the patched WM8804 driver.
|
|
|
|
Signed-off-by: Daniel Matuschek <daniel@matuschek.net>
|
|
|
|
Add a parameter to turn off SPDIF output if no audio is playing
|
|
|
|
This patch adds the paramater auto_shutdown_output to the kernel module.
|
|
Default behaviour of the module is the same, but when auto_shutdown_output
|
|
is set to 1, the SPDIF oputput will shutdown if no stream is playing.
|
|
|
|
bugfix for 32kHz sample rate, was missing
|
|
|
|
HiFiBerry Digi: set SPDIF status bits for sample rate
|
|
|
|
The HiFiBerry Digi driver did not signal the sample rate in the SPDIF status bits.
|
|
While this is optional, some DACs and receivers do not accept this signal. This patch
|
|
adds the sample rate bits in the SPDIF status block.
|
|
---
|
|
sound/soc/bcm/Kconfig | 7 ++
|
|
sound/soc/bcm/Makefile | 2 +
|
|
sound/soc/bcm/hifiberry_digi.c | 223 +++++++++++++++++++++++++++++++++++++++++
|
|
3 files changed, 232 insertions(+)
|
|
create mode 100644 sound/soc/bcm/hifiberry_digi.c
|
|
|
|
--- a/sound/soc/bcm/Kconfig
|
|
+++ b/sound/soc/bcm/Kconfig
|
|
@@ -15,6 +15,13 @@ config SND_BCM2708_SOC_HIFIBERRY_DAC
|
|
help
|
|
Say Y or M if you want to add support for HifiBerry DAC.
|
|
|
|
+config SND_BCM2708_SOC_HIFIBERRY_DIGI
|
|
+ tristate "Support for HifiBerry Digi"
|
|
+ depends on SND_BCM2708_SOC_I2S || SND_BCM2835_SOC_I2S
|
|
+ select SND_SOC_WM8804
|
|
+ help
|
|
+ Say Y or M if you want to add support for HifiBerry Digi S/PDIF output board.
|
|
+
|
|
config SND_BCM2708_SOC_RPI_DAC
|
|
tristate "Support for RPi-DAC"
|
|
depends on SND_BCM2708_SOC_I2S || SND_BCM2835_SOC_I2S
|
|
--- a/sound/soc/bcm/Makefile
|
|
+++ b/sound/soc/bcm/Makefile
|
|
@@ -5,7 +5,9 @@ obj-$(CONFIG_SND_BCM2835_SOC_I2S) += snd
|
|
|
|
# BCM2708 Machine Support
|
|
snd-soc-hifiberry-dac-objs := hifiberry_dac.o
|
|
+snd-soc-hifiberry-digi-objs := hifiberry_digi.o
|
|
snd-soc-rpi-dac-objs := rpi-dac.o
|
|
|
|
obj-$(CONFIG_SND_BCM2708_SOC_HIFIBERRY_DAC) += snd-soc-hifiberry-dac.o
|
|
+obj-$(CONFIG_SND_BCM2708_SOC_HIFIBERRY_DIGI) += snd-soc-hifiberry-digi.o
|
|
obj-$(CONFIG_SND_BCM2708_SOC_RPI_DAC) += snd-soc-rpi-dac.o
|
|
--- /dev/null
|
|
+++ b/sound/soc/bcm/hifiberry_digi.c
|
|
@@ -0,0 +1,223 @@
|
|
+/*
|
|
+ * ASoC Driver for HifiBerry Digi
|
|
+ *
|
|
+ * Author: Daniel Matuschek <info@crazy-audio.com>
|
|
+ * based on the HifiBerry DAC driver by Florian Meier <florian.meier@koalo.de>
|
|
+ * Copyright 2013
|
|
+ *
|
|
+ * This program is free software; you can redistribute it and/or
|
|
+ * modify it under the terms of the GNU General Public License
|
|
+ * version 2 as published by the Free Software Foundation.
|
|
+ *
|
|
+ * This program is distributed in the hope that it will be useful, but
|
|
+ * WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ * General Public License for more details.
|
|
+ */
|
|
+
|
|
+#include <linux/module.h>
|
|
+#include <linux/platform_device.h>
|
|
+
|
|
+#include <sound/core.h>
|
|
+#include <sound/pcm.h>
|
|
+#include <sound/pcm_params.h>
|
|
+#include <sound/soc.h>
|
|
+#include <sound/jack.h>
|
|
+
|
|
+#include "../codecs/wm8804.h"
|
|
+
|
|
+static short int auto_shutdown_output = 0;
|
|
+module_param(auto_shutdown_output, short, S_IRUSR | S_IWUSR | S_IRGRP | S_IWGRP);
|
|
+MODULE_PARM_DESC(auto_shutdown_output, "Shutdown SP/DIF output if playback is stopped");
|
|
+
|
|
+
|
|
+static int samplerate=44100;
|
|
+
|
|
+static int snd_rpi_hifiberry_digi_init(struct snd_soc_pcm_runtime *rtd)
|
|
+{
|
|
+ struct snd_soc_codec *codec = rtd->codec;
|
|
+
|
|
+ /* enable TX output */
|
|
+ snd_soc_update_bits(codec, WM8804_PWRDN, 0x4, 0x0);
|
|
+
|
|
+ return 0;
|
|
+}
|
|
+
|
|
+static int snd_rpi_hifiberry_digi_startup(struct snd_pcm_substream *substream) {
|
|
+ /* turn on digital output */
|
|
+ struct snd_soc_pcm_runtime *rtd = substream->private_data;
|
|
+ struct snd_soc_codec *codec = rtd->codec;
|
|
+ snd_soc_update_bits(codec, WM8804_PWRDN, 0x3c, 0x00);
|
|
+ return 0;
|
|
+}
|
|
+
|
|
+static void snd_rpi_hifiberry_digi_shutdown(struct snd_pcm_substream *substream) {
|
|
+ /* turn off output */
|
|
+ if (auto_shutdown_output) {
|
|
+ /* turn off output */
|
|
+ struct snd_soc_pcm_runtime *rtd = substream->private_data;
|
|
+ struct snd_soc_codec *codec = rtd->codec;
|
|
+ snd_soc_update_bits(codec, WM8804_PWRDN, 0x3c, 0x3c);
|
|
+ }
|
|
+}
|
|
+
|
|
+
|
|
+static int snd_rpi_hifiberry_digi_hw_params(struct snd_pcm_substream *substream,
|
|
+ struct snd_pcm_hw_params *params)
|
|
+{
|
|
+ struct snd_soc_pcm_runtime *rtd = substream->private_data;
|
|
+ struct snd_soc_dai *codec_dai = rtd->codec_dai;
|
|
+ struct snd_soc_codec *codec = rtd->codec;
|
|
+ struct snd_soc_dai *cpu_dai = rtd->cpu_dai;
|
|
+
|
|
+ int sysclk = 27000000; /* This is fixed on this board */
|
|
+
|
|
+ long mclk_freq=0;
|
|
+ int mclk_div=1;
|
|
+ int sampling_freq=1;
|
|
+
|
|
+ int ret;
|
|
+
|
|
+ samplerate = params_rate(params);
|
|
+
|
|
+ if (samplerate<=96000) {
|
|
+ mclk_freq=samplerate*256;
|
|
+ mclk_div=WM8804_MCLKDIV_256FS;
|
|
+ } else {
|
|
+ mclk_freq=samplerate*128;
|
|
+ mclk_div=WM8804_MCLKDIV_128FS;
|
|
+ }
|
|
+
|
|
+ switch (samplerate) {
|
|
+ case 32000:
|
|
+ sampling_freq=0x03;
|
|
+ break;
|
|
+ case 44100:
|
|
+ sampling_freq=0x00;
|
|
+ break;
|
|
+ case 48000:
|
|
+ sampling_freq=0x02;
|
|
+ break;
|
|
+ case 88200:
|
|
+ sampling_freq=0x08;
|
|
+ break;
|
|
+ case 96000:
|
|
+ sampling_freq=0x0a;
|
|
+ break;
|
|
+ case 176400:
|
|
+ sampling_freq=0x0c;
|
|
+ break;
|
|
+ case 192000:
|
|
+ sampling_freq=0x0e;
|
|
+ break;
|
|
+ default:
|
|
+ dev_err(codec->dev,
|
|
+ "Failed to set WM8804 SYSCLK, unsupported samplerate %d\n",
|
|
+ samplerate);
|
|
+ }
|
|
+
|
|
+ snd_soc_dai_set_clkdiv(codec_dai, WM8804_MCLK_DIV, mclk_div);
|
|
+ snd_soc_dai_set_pll(codec_dai, 0, 0, sysclk, mclk_freq);
|
|
+
|
|
+ ret = snd_soc_dai_set_sysclk(codec_dai, WM8804_TX_CLKSRC_PLL,
|
|
+ sysclk, SND_SOC_CLOCK_OUT);
|
|
+ if (ret < 0) {
|
|
+ dev_err(codec->dev,
|
|
+ "Failed to set WM8804 SYSCLK: %d\n", ret);
|
|
+ return ret;
|
|
+ }
|
|
+
|
|
+ /* Enable TX output */
|
|
+ snd_soc_update_bits(codec, WM8804_PWRDN, 0x4, 0x0);
|
|
+
|
|
+ /* Power on */
|
|
+ snd_soc_update_bits(codec, WM8804_PWRDN, 0x9, 0);
|
|
+
|
|
+ /* set sampling frequency status bits */
|
|
+ snd_soc_update_bits(codec, WM8804_SPDTX4, 0x0f, sampling_freq);
|
|
+
|
|
+ return snd_soc_dai_set_bclk_ratio(cpu_dai,64);
|
|
+}
|
|
+
|
|
+/* machine stream operations */
|
|
+static struct snd_soc_ops snd_rpi_hifiberry_digi_ops = {
|
|
+ .hw_params = snd_rpi_hifiberry_digi_hw_params,
|
|
+ .startup = snd_rpi_hifiberry_digi_startup,
|
|
+ .shutdown = snd_rpi_hifiberry_digi_shutdown,
|
|
+};
|
|
+
|
|
+static struct snd_soc_dai_link snd_rpi_hifiberry_digi_dai[] = {
|
|
+{
|
|
+ .name = "HifiBerry Digi",
|
|
+ .stream_name = "HifiBerry Digi HiFi",
|
|
+ .cpu_dai_name = "bcm2708-i2s.0",
|
|
+ .codec_dai_name = "wm8804-spdif",
|
|
+ .platform_name = "bcm2708-i2s.0",
|
|
+ .codec_name = "wm8804.1-003b",
|
|
+ .dai_fmt = SND_SOC_DAIFMT_I2S | SND_SOC_DAIFMT_NB_NF |
|
|
+ SND_SOC_DAIFMT_CBM_CFM,
|
|
+ .ops = &snd_rpi_hifiberry_digi_ops,
|
|
+ .init = snd_rpi_hifiberry_digi_init,
|
|
+},
|
|
+};
|
|
+
|
|
+/* audio machine driver */
|
|
+static struct snd_soc_card snd_rpi_hifiberry_digi = {
|
|
+ .name = "snd_rpi_hifiberry_digi",
|
|
+ .dai_link = snd_rpi_hifiberry_digi_dai,
|
|
+ .num_links = ARRAY_SIZE(snd_rpi_hifiberry_digi_dai),
|
|
+};
|
|
+
|
|
+static int snd_rpi_hifiberry_digi_probe(struct platform_device *pdev)
|
|
+{
|
|
+ int ret = 0;
|
|
+
|
|
+ snd_rpi_hifiberry_digi.dev = &pdev->dev;
|
|
+
|
|
+ if (pdev->dev.of_node) {
|
|
+ struct device_node *i2s_node;
|
|
+ struct snd_soc_dai_link *dai = &snd_rpi_hifiberry_digi_dai[0];
|
|
+ i2s_node = of_parse_phandle(pdev->dev.of_node,
|
|
+ "i2s-controller", 0);
|
|
+
|
|
+ if (i2s_node) {
|
|
+ dai->cpu_dai_name = NULL;
|
|
+ dai->cpu_of_node = i2s_node;
|
|
+ dai->platform_name = NULL;
|
|
+ dai->platform_of_node = i2s_node;
|
|
+ }
|
|
+ }
|
|
+
|
|
+ ret = snd_soc_register_card(&snd_rpi_hifiberry_digi);
|
|
+ if (ret)
|
|
+ dev_err(&pdev->dev, "snd_soc_register_card() failed: %d\n", ret);
|
|
+
|
|
+ return ret;
|
|
+}
|
|
+
|
|
+static int snd_rpi_hifiberry_digi_remove(struct platform_device *pdev)
|
|
+{
|
|
+ return snd_soc_unregister_card(&snd_rpi_hifiberry_digi);
|
|
+}
|
|
+
|
|
+static const struct of_device_id snd_rpi_hifiberry_digi_of_match[] = {
|
|
+ { .compatible = "hifiberry,hifiberry-digi", },
|
|
+ {},
|
|
+};
|
|
+MODULE_DEVICE_TABLE(of, snd_rpi_hifiberry_digi_of_match);
|
|
+
|
|
+static struct platform_driver snd_rpi_hifiberry_digi_driver = {
|
|
+ .driver = {
|
|
+ .name = "snd-hifiberry-digi",
|
|
+ .owner = THIS_MODULE,
|
|
+ .of_match_table = snd_rpi_hifiberry_digi_of_match,
|
|
+ },
|
|
+ .probe = snd_rpi_hifiberry_digi_probe,
|
|
+ .remove = snd_rpi_hifiberry_digi_remove,
|
|
+};
|
|
+
|
|
+module_platform_driver(snd_rpi_hifiberry_digi_driver);
|
|
+
|
|
+MODULE_AUTHOR("Daniel Matuschek <info@crazy-audio.com>");
|
|
+MODULE_DESCRIPTION("ASoC Driver for HifiBerry Digi");
|
|
+MODULE_LICENSE("GPL v2");
|