02629d8f87
Targets were build tested and patches are refreshed. Signed-off-by: Luka Perkov <luka@openwrt.org> SVN-Revision: 42463
154 lines
4.8 KiB
Diff
154 lines
4.8 KiB
Diff
From 0b469f3f4c0e6a0e0b1b60a059600e325a03b6f5 Mon Sep 17 00:00:00 2001
|
|
From: Andy Gross <agross@codeaurora.org>
|
|
Date: Thu, 12 Jun 2014 00:52:06 -0500
|
|
Subject: [PATCH 153/182] soc: qcom: tcsr: Add TCSR driver
|
|
|
|
This patch adds support for the TCSR IP block present in Qualcomm processors.
|
|
|
|
Signed-off-by: Andy Gross <agross@codeaurora.org>
|
|
---
|
|
.../devicetree/bindings/soc/qcom/qcom,tcsr.txt | 25 ++++++++
|
|
drivers/soc/qcom/Kconfig | 6 ++
|
|
drivers/soc/qcom/Makefile | 1 +
|
|
drivers/soc/qcom/qcom_tcsr.c | 64 ++++++++++++++++++++
|
|
include/dt-bindings/soc/qcom,tcsr.h | 19 ++++++
|
|
5 files changed, 115 insertions(+)
|
|
create mode 100644 Documentation/devicetree/bindings/soc/qcom/qcom,tcsr.txt
|
|
create mode 100644 drivers/soc/qcom/qcom_tcsr.c
|
|
create mode 100644 include/dt-bindings/soc/qcom,tcsr.h
|
|
|
|
--- /dev/null
|
|
+++ b/Documentation/devicetree/bindings/soc/qcom/qcom,tcsr.txt
|
|
@@ -0,0 +1,25 @@
|
|
+QCOM TCSR (Top Control and Status Register) Driver
|
|
+
|
|
+The TCSR provides miscellaneous control functions and status registers for
|
|
+Qualcomm processors.
|
|
+
|
|
+Required properties:
|
|
+- compatible: must contain "qcom,tcsr" for IPQ806x
|
|
+- reg: Address range for TCSR registers
|
|
+
|
|
+Optional properties:
|
|
+- qcom,usb-ctrl-select : indicates USB port type selection. Please reference
|
|
+ dt-bindings/soc/qcom,tcsr.h for valid USB port selection values.
|
|
+
|
|
+Example for IPQ8064:
|
|
+
|
|
+#include <dt-bindings/soc/qcom,tcsr.h>
|
|
+
|
|
+ tcsr: tcsr@1a400000 {
|
|
+ compatible = "qcom,tcsr";
|
|
+ reg = <0x1a400000 0x100>;
|
|
+
|
|
+ qcom,usb-ctrl-select = <TCSR_USB_SELECT_USB3_DUAL>;
|
|
+ };
|
|
+
|
|
+
|
|
--- a/drivers/soc/qcom/Kconfig
|
|
+++ b/drivers/soc/qcom/Kconfig
|
|
@@ -9,3 +9,9 @@ config QCOM_GSBI
|
|
functions for connecting the underlying serial UART, SPI, and I2C
|
|
devices to the output pins.
|
|
|
|
+config QCOM_TCSR
|
|
+ tristate "QCOM Top Control and Status Registers"
|
|
+ depends on ARCH_QCOM
|
|
+ help
|
|
+ Say y here to enable TCSR support. The TCSR provides control
|
|
+ functions for various peripherals.
|
|
--- a/drivers/soc/qcom/Makefile
|
|
+++ b/drivers/soc/qcom/Makefile
|
|
@@ -1 +1,2 @@
|
|
obj-$(CONFIG_QCOM_GSBI) += qcom_gsbi.o
|
|
+obj-$(CONFIG_QCOM_TCSR) += qcom_tcsr.o
|
|
--- /dev/null
|
|
+++ b/drivers/soc/qcom/qcom_tcsr.c
|
|
@@ -0,0 +1,64 @@
|
|
+/*
|
|
+ * Copyright (c) 2014, The Linux foundation. All rights reserved.
|
|
+ *
|
|
+ * This program is free software; you can redistribute it and/or modify
|
|
+ * it under the terms of the GNU General Public License rev 2 and
|
|
+ * only rev 2 as published by the free Software foundation.
|
|
+ *
|
|
+ * This program is distributed in the hope that it will be useful,
|
|
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ * MERCHANTABILITY or fITNESS fOR A PARTICULAR PURPOSE. See the
|
|
+ * GNU General Public License for more details.
|
|
+ */
|
|
+
|
|
+#include <linux/clk.h>
|
|
+#include <linux/err.h>
|
|
+#include <linux/io.h>
|
|
+#include <linux/module.h>
|
|
+#include <linux/of.h>
|
|
+#include <linux/of_platform.h>
|
|
+#include <linux/platform_device.h>
|
|
+
|
|
+#define TCSR_USB_PORT_SEL 0xb0
|
|
+
|
|
+static int tcsr_probe(struct platform_device *pdev)
|
|
+{
|
|
+ struct resource *res;
|
|
+ const struct device_node *node = pdev->dev.of_node;
|
|
+ void __iomem *base;
|
|
+ u32 val;
|
|
+
|
|
+ res = platform_get_resource(pdev, IORESOURCE_MEM, 0);
|
|
+ base = devm_ioremap_resource(&pdev->dev, res);
|
|
+ if (IS_ERR(base))
|
|
+ return PTR_ERR(base);
|
|
+
|
|
+ if (!of_property_read_u32(node, "qcom,usb-ctrl-select", &val)) {
|
|
+ dev_err(&pdev->dev, "setting usb port select = %d\n", val);
|
|
+ writel(val, base + TCSR_USB_PORT_SEL);
|
|
+ }
|
|
+
|
|
+ return 0;
|
|
+}
|
|
+
|
|
+static const struct of_device_id tcsr_dt_match[] = {
|
|
+ { .compatible = "qcom,tcsr", },
|
|
+ { },
|
|
+};
|
|
+
|
|
+MODULE_DEVICE_TABLE(of, tcsr_dt_match);
|
|
+
|
|
+static struct platform_driver tcsr_driver = {
|
|
+ .driver = {
|
|
+ .name = "tcsr",
|
|
+ .owner = THIS_MODULE,
|
|
+ .of_match_table = tcsr_dt_match,
|
|
+ },
|
|
+ .probe = tcsr_probe,
|
|
+};
|
|
+
|
|
+module_platform_driver(tcsr_driver);
|
|
+
|
|
+MODULE_AUTHOR("Andy Gross <agross@codeaurora.org>");
|
|
+MODULE_DESCRIPTION("QCOM TCSR driver");
|
|
+MODULE_LICENSE("GPL v2");
|
|
--- /dev/null
|
|
+++ b/include/dt-bindings/soc/qcom,tcsr.h
|
|
@@ -0,0 +1,19 @@
|
|
+/* Copyright (c) 2014, The Linux Foundation. All rights reserved.
|
|
+ *
|
|
+ * This program is free software; you can redistribute it and/or modify
|
|
+ * it under the terms of the GNU General Public License version 2 and
|
|
+ * only version 2 as published by the Free Software Foundation.
|
|
+ *
|
|
+ * This program is distributed in the hope that it will be useful,
|
|
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
|
+ * GNU General Public License for more details.
|
|
+ */
|
|
+#ifndef __DT_BINDINGS_QCOM_TCSR_H
|
|
+#define __DT_BINDINGS_QCOM_TCSR_H
|
|
+
|
|
+#define TCSR_USB_SELECT_USB3_P0 0x1
|
|
+#define TCSR_USB_SELECT_USB3_P1 0x2
|
|
+#define TCSR_USB_SELECT_USB3_DUAL 0x3
|
|
+
|
|
+#endif
|